Contents

Welcome to SketchUp................................................................. 21
   SketchUp for Mac OS X ......................................................... 22
   SketchUp Versions ............................................................... 23
   What's New in this Release? .................................................. 24
   Technical Support ............................................................... 27
   Learning SketchUp ............................................................. 28

Concepts Guide ................................................................. 30
   Designing in SketchUp ....................................................... 31
   Drawing Quickly ............................................................... 37
   Viewing Models in 3 Dimensions ........................................ 44
   Adding Detail to Your Models ............................................. 47
   Presenting Your Models ..................................................... 56
   Modeling Terrain and Organic Shapes ................................. 59

Welcome to the SketchUp Getting Started Guide .................. 62
   Introduction to the SketchUp User Interface (Microsoft Windows) 63
   Introduction to the SketchUp User Interface (Mac OS X) ........ 65
   Using the Mouse in SketchUp ............................................. 67
   Working in 3D ................................................................. 69
   Viewing a Model in 3D Space ............................................. 70
   Creating Geometry With the Push/Pull Tool ....................... 73
   Drawing Shapes with the Circle, Arc, and Rectangle Tools .... 77
   Creating Your First Model ................................................ 79
   Next Steps ........................................................................ 97

Welcome to the Dynamic Components Getting Started Guide .... 98
   Dynamic Components ..................................................... 99
   Configuring a Dynamic Component .................................. 105
   Developing a Dynamic Component .................................. 106

Welcome to the SketchUp User's Guide ................................. 107
   Deleting 2D Person Component ....................................... 108
   Detaching Toolbars (Microsoft Windows) ......................... 109
   Using the Layers Toolbar (Microsoft Windows) ................. 110
   Viewing Tool Tips (Microsoft Windows) ............................ 111
Splitting a Face ...................................................................................................... 151
Splitting a Line ....................................................................................................... 152
Editing a Line Entity ............................................................................................... 153
Drawing an Arc....................................................................................................... 154
Drawing a Half-Circle ............................................................................................. 155
Creating Precise Arcs ........................................................................................... 156
Drawing Tangent Arcs ........................................................................................... 157
Editing an Arc Entity............................................................................................... 158
Editing an Extruded Arc ......................................................................................... 159
Drawing Curves...................................................................................................... 160
Drawing 3D Polyline Entities.................................................................................. 161
Editing a Curve Entity ........................................................................................... 162
Drawing a Rectangle.............................................................................................. 163
Drawing Rectangles by Inference .......................................................................... 164
Locking a Rectangle to the Current Inference Direction ....................................... 165
Creating Precise Rectangles .................................................................................. 166
Drawing a Square .................................................................................................. 167
Drawing a Circle..................................................................................................... 168
Locking a Circle to its Current Orientation .......................................................... 169
Creating Precise Circles ....................................................................................... 170
Editing an Extruded Circle ..................................................................................... 171
Drawing a Polygon................................................................................................. 172
Locking a Polygon to its Current Orientation ...................................................... 173
Drawing Precise Polygons .................................................................................... 174
Editing a Polygon Entity ....................................................................................... 175
Editing an Extruded Polygon.................................................................................. 176

Modification Tools ................................................................................................... 177
Creating Multiple Copies (Linear Arrays) .............................................................. 178
Moving/Stretching With Autofold ........................................................................... 180
Making Copies ........................................................................................................ 181
Moving Groups and Components ......................................................................... 182
Moving by Inference .............................................................................................. 183
Moving Precisely .................................................................................................... 184
Moving Several Entities ......................................................................................... 186
Moving a Single Entity ........................................................................................... 187
Wrapping Material Around a Cylinder ............................................................... 230
Projecting a Material .......................................................................................... 231
Repositioning a Material .................................................................................... 232
Reorienting Materials .......................................................................................... 233

**Construction Tools** ..................................................................................... 234
Creating Guide Lines and Guide Points ............................................................... 235
Locking a Line to a Specific Inference Direction ................................................. 237
Measuring Distance .............................................................................................. 238
Placing Precise Guide Lines and Guide Points .................................................... 239
Scaling an Entire Model ..................................................................................... 240
Scaling Entities..................................................................................................... 241
Creating Angled Guide Lines .............................................................................. 242
Locking the Protractor Tool to its Current Orientation ........................................ 244
Measuring an Angle ............................................................................................. 245
Creating Precise Angles ..................................................................................... 247
Moving the Drawing Axes ................................................................................... 248
Resetting the Drawing Axes .............................................................................. 249
Placing Diameter Dimensions .......................................................................... 250
Placing Linear Dimensions ................................................................................ 251
Placing Radius Dimensions ................................................................................ 253
Toggling Dimension Type .................................................................................... 254
Configuring Text Settings ................................................................................... 255
Editing Text .......................................................................................................... 256
Attaching Text Directly to a Face ....................................................................... 257
Creating and Placing Leader Text ...................................................................... 258
Creating and Placing Screen Text ...................................................................... 260
Creating 3D Text ................................................................................................. 261
Place 3D Text Dialog Box ................................................................................... 262
Aligning Your View ............................................................................................. 263
Animating Section Cut Effects .......................................................................... 264
Creating Section Cut Effects .............................................................................. 265
Creating Grouped Section Slices ....................................................................... 266
Exporting Sections .............................................................................................. 267
Hiding Section Plane Entities and Section Cuts .................................................. 268
Sandbox Tools ......................................................................................................... 308
   Enabling the Sandbox Tools .............................................................................. 309
 Creating a Sandbox From Contour Lines ............................................................ 310
 Creating a New TIN ............................................................................................... 311
 Drawing a Flat TIN by Inference ........................................................................ 312
 Creating Precise TINs .......................................................................................... 313
 Specifying an Offset Value .................................................................................. 314
 Sculpting a Terrain ............................................................................................... 315
 Specifying Sculpting Radius Values ..................................................................... 317
 Creating Impressions of Geometry in a TIN ....................................................... 318
 Painting Draped Terrain ...................................................................................... 319
 Draping Edges Onto a TIN .................................................................................. 320
 Creating Smooth Areas ....................................................................................... 321
 Detailing a TIN ...................................................................................................... 322
 Specifying an Offset Value .................................................................................. 324
 Modifying TIN Triangulations ............................................................................. 325
 Improving Sandbox Tool Performance .............................................................. 326
 Adding Strokes to a Style ..................................................................................... 329
 Deleting Libraries of Strokes (Mac OS X) .......................................................... 330
 Deleting Library of Strokes (Microsoft Windows) .............................................. 331
 Deleting Strokes ................................................................................................. 332

Google Toolbar .................................................................................................... 333
   Configuring Google Earth ................................................................................... 334
   Using SketchUp With Google Earth ................................................................. 335
   Getting the Current View From Google Earth .................................................. 336
   Toggling Terrain .............................................................................................. 337
   Placing Your Model in Google Earth .............................................................. 338
   Deleting Models from Google Earth ............................................................... 339
   Optimizing Models for Google Earth ............................................................. 340
   Hiding Google Earth Terrain .......................................................................... 342
   Storing Models for Use in Google Earth ......................................................... 343
   Specifying a Model's Location in the World .................................................... 344
   Stitching Together Terrain Images From Google Earth .................................. 345

Model Settings and Managers ............................................................................. 346
   Applying Materials ......................................................................................... 347
Loading and Selecting Colors from Images (Mac OS X) ............................................... 389
Adding Materials From Image Files (Mac OS X) .......................................................... 390
Selecting Color with the Screen Picker (Mac OS X) ..................................................... 391
Setting the North Angle ............................................................................................... 392

**Entities** ................................................................................................................ 393
Applying Materials to Groups ..................................................................................... 394
Creating a Group ......................................................................................................... 395
Editing a Group ........................................................................................................... 396
Exploding (Ungrouping) a Group ................................................................................. 397
Inserting Image Entities ............................................................................................... 398
Creating an Arc Surface .............................................................................................. 399
Creating a Cylindrical Surface .................................................................................... 400
Creating a Polyface Surface ....................................................................................... 401

**Input and Output** .................................................................................................. 402
Preparing a 3DS File for Export ................................................................................ 403
Exporting 3DS Files ..................................................................................................... 404
Exporting 3DDWG or DXF Files ................................................................................ 405
Exporting KMZ Files ..................................................................................................... 406
Exporting DAE Files ..................................................................................................... 407
Exporting FBX Files ..................................................................................................... 408
Exporting OBJ Files ..................................................................................................... 409
Exporting XSI Files ...................................................................................................... 410
Exporting PDF or EPS Files ......................................................................................... 411
Exporting a Raster Image ............................................................................................. 412
Exporting VRML Files ................................................................................................ 413
Exporting Epix Files ..................................................................................................... 414
Exporting 2D DWG or DXF Files ................................................................................ 415
Importing Large Images ............................................................................................... 416
Preparing a CAD File for Import and Use in SketchUp ............................................... 417
Importing CAD Files at the Correct Scale ................................................................. 418
Dialog Boxes .......................................................................................................... 585
Context Menu Items for Entities .................................................................................. 586
Context Menus ........................................................................................................... 594
Welcome to SketchUp Dialog Box ............................................................................. 595

**Principal Tools** .................................................................................................... 596

- Select Tool ........................................................................................................... 597
- Eraser Tool............................................................................................................. 598
- Paint Bucket Tool ................................................................................................. 599
Fill Options .............................................................................................................. 600
Face Painting Rules .................................................................................................. 602

**Drawing Tools** .................................................................................................... 603

- Line Tool .............................................................................................................. 604
  Line Entities ............................................................................................................ 605
- Arc Tool .................................................................................................................. 606
  Arc Entities ............................................................................................................. 607
- Freehand Tool ....................................................................................................... 608
  3D Polyline Entities ............................................................................................... 609
  Curve Entities ........................................................................................................ 610
- Rectangle Tool ...................................................................................................... 611
  Face Entities ........................................................................................................... 612
- Circle Tool .............................................................................................................. 613
  Circle Entities ......................................................................................................... 614
- Polygon Tool .......................................................................................................... 615
  Polygon Entities ..................................................................................................... 616

**Modification Tools** .............................................................................................. 617

- Move Tool .............................................................................................................. 618
- Rotate Tool ............................................................................................................. 619
- Scale Tool ............................................................................................................... 620
  Scale Grip Types ................................................................................................... 621
Push/Pull Tool ................................................................................................ 622
Offset Tool ..................................................................................................... 623
Follow Me Tool ............................................................................................... 624
Intersect With Model Tool ............................................................................. 625
Position Texture Tool ....................................................................................... 626
Material Positioning Pins ................................................................................ 627
Fixed Pin and Free Pin Mode Context Commands ......................................... 628

Construction Tools .......................................................................................... 629
Tape Measure Tool ........................................................................................ 630
Guide Line Entities ........................................................................................... 631
Guide Point Entities ........................................................................................ 632
Protractor Tool ................................................................................................ 633
Axes Tool ........................................................................................................ 634
Dimension Tool ............................................................................................... 635
Dimension Entities ........................................................................................... 636
Text Tool ......................................................................................................... 637
Text Entities ..................................................................................................... 638
3D Text Tool ................................................................................................... 639
Section Plane Tool ......................................................................................... 640
Section Plane Entities ...................................................................................... 641

Camera Tools ................................................................................................... 642
Next ............................................................................................................... 643
Previous ........................................................................................................ 644
Standard Views ............................................................................................... 645
Match New Photo ........................................................................................... 646
Match Controls and Context-Menu Items ....................................................... 647
Sketch-Over-Image Session Controls and Context-Menu Items ..................... 650
Orbit Tool ....................................................................................................... 651
Pan Tool ......................................................................................................... 652
Zoom Tool .................................................................................................... 653
Zoom Window Tool ....................................................................................... 654
Zoom Extents Tool ....................................................................................... 655
Zoom to Photo Tool ...................................................................................... 656
Walkthrough Tools ....................................................................................... 657
Position Camera Tool .................................................................................. 658
Walk Tool .................................................................................................... 659
Look Around Tool ....................................................................................... 660
Sandbox Tools ............................................................................................ 661
Sandbox From Contours Tool ...................................................................... 662
Sandbox From Scratch Tool ....................................................................... 663
Smoove Tool .............................................................................................. 664
Stamp Tool .................................................................................................. 665
Drape Tool .................................................................................................. 666
Add Detail Tool ........................................................................................... 667
Flip Edge Tool ........................................................................................... 668
Google Toolbar .......................................................................................... 670
Google Earth and SketchUp Workflow ....................................................... 671
Get Current View Button .......................................................................... 672
Toggle Terrain Button ............................................................................... 673
Place Model Button .................................................................................... 674
Get Models Button ..................................................................................... 675
Share Model Button ................................................................................... 676
Model Settings and Managers .................................................................... 677
Model Info Dialog Box ................................................................. 678
Entity Info .......................................................................................... 693
Entity Info Dialog Box ................................................................. 697
Details Arrow .................................................................................. 698
Materials Browser ........................................................................... 699
Materials Browser Controls .......................................................... 700
Material Browser Context Menu Items (Mac OS X) ....................... 701
Material Browser Context Menu Items (Microsoft Windows) ......... 702
Materials Browser Details Menu .................................................. 703
Materials Browser Edit Panel ....................................................... 704
Components Browser ..................................................................... 706
Component Definitions and Instances ........................................... 708
The Create Component Dialog Box .............................................. 709
Component Entities .......................................................................... 712
Components Browser Context Menus .......................................... 713
Components Browser Controls ..................................................... 714
Styles Browser ................................................................................. 717
The Styles Browser Background Panel ......................................... 719
Styles Browser Controls ............................................................... 720
Styles Browser Details Menu ........................................................ 722
The Styles Browser Edge Panel ..................................................... 723
The Styles Browser Face Panel ...................................................... 728
The Styles Browser Modeling Panel .............................................. 731
The Styles Browser Watermark Panel ........................................... 733
Watermark ....................................................................................... 734
Watermark Panel ............................................................................ 735
Watermark Settings ......................................................................... 736
Layers Manager ............................................................................... 737
Details Menu .................................................................................. 738
Layers Manager Options ................................................................. 739
Outliner ............................................................................................ 740
Details Menu .................................................................................. 741
Scenes Manager .............................................................................. 742
Details Arrow .................................................................................. 744
Scenes Manager Options ................................................................. 745
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shadows Settings Dialog Box</td>
<td>747</td>
</tr>
<tr>
<td>Details Arrow</td>
<td>748</td>
</tr>
<tr>
<td>Shadow Options</td>
<td>749</td>
</tr>
<tr>
<td>Fog Dialog Box</td>
<td>750</td>
</tr>
<tr>
<td>Fog Options</td>
<td>751</td>
</tr>
<tr>
<td>Match Photo Dialog Box</td>
<td>752</td>
</tr>
<tr>
<td>Soften Edges Dialog Box</td>
<td>754</td>
</tr>
<tr>
<td>Soften Edges Options</td>
<td>756</td>
</tr>
<tr>
<td>Instructor</td>
<td>757</td>
</tr>
<tr>
<td>Application Preferences Dialog Box (Microsoft Windows)</td>
<td>758</td>
</tr>
<tr>
<td>Application Preferences Dialog Box (Mac OS X)</td>
<td>764</td>
</tr>
<tr>
<td>Color Pickers (OS X)</td>
<td>769</td>
</tr>
<tr>
<td>Color Pickers (Microsoft Windows)</td>
<td>775</td>
</tr>
<tr>
<td>Entities</td>
<td>777</td>
</tr>
<tr>
<td>Group Entities</td>
<td>778</td>
</tr>
<tr>
<td>Image Entities</td>
<td>779</td>
</tr>
<tr>
<td>Image Proportions</td>
<td>780</td>
</tr>
<tr>
<td>Surface Entities</td>
<td>781</td>
</tr>
<tr>
<td>Input and Output</td>
<td>782</td>
</tr>
<tr>
<td>3D Model (3DS) Export</td>
<td>783</td>
</tr>
<tr>
<td>Known Issues and Limitations</td>
<td>784</td>
</tr>
<tr>
<td>3DS Export Options Dialog Box</td>
<td>786</td>
</tr>
<tr>
<td>3D Model (DWG/DXF) Export</td>
<td>789</td>
</tr>
<tr>
<td>3D DWG/DXF Export Details</td>
<td>790</td>
</tr>
<tr>
<td>AutoCAD Export Options Dialog Box (Microsoft Windows)</td>
<td>791</td>
</tr>
<tr>
<td>AutoCAD Export Options Dialog Box (Mac OS X)</td>
<td>792</td>
</tr>
<tr>
<td>3D Model (KMZ) Export</td>
<td>793</td>
</tr>
<tr>
<td>3D Model (DAE) Export</td>
<td>794</td>
</tr>
<tr>
<td>The DAE Export Options Dialog Box</td>
<td>795</td>
</tr>
<tr>
<td>3D Model (FBX) Export</td>
<td>796</td>
</tr>
</tbody>
</table>
Welcome to SketchUp

Developed for the conceptual stages of design, SketchUp is powerful yet easy-to-learn 3D software. We think of it as the pencil of digital design. This award-winning software combines a simple, yet robust tool-set that streamlines and simplifies 3D design inside your computer. SketchUp is being used by anyone with the desire to Dream, Design and Communicate in 3D!

From the entire SketchUp team, thank you for trying SketchUp, and welcome to the SketchUp user community.
SketchUp for Mac OS X

SketchUp for Mac OS X has been designed and developed as a native Macintosh OS X application. SketchUp provides features and performance exclusive to MacOS X by taking advantage of the Macintosh Aqua user interface and dynamic, object-oriented, Cocoa Application Programmer's Interface (API). Below are some examples of the SketchUp and MacOS X integration.

Fast OpenGL 3D Rendering

Mac OS X is a state-of-the-art operating system designed to support intensive 2D and 3D graphics. Every Macintosh computer shipping today comes with incredibly powerful 3D graphics hardware providing you with the best possible user experience. SketchUp uses these features of your Macintosh by automatically running in accelerated OpenGL mode.

Document Icons

Your SketchUp documents can be saved in such a way that they contain a thumbnail view of their contents. This feature can help you quickly organize and locate your files in the Finder.

Portable Document Format (PDF)

SketchUp leverages Mac OS X built-in support for Adobe® Portable Document Format (PDF) which is the worldwide standard for electronic document distribution.

Drag and Drop

SketchUp leverages the Macintosh drag and drop feature. For example, you can drag image files, such as scans or digital photos, from the Finder, directly into your SketchUp drawing window. You can also drag SketchUp files (.skp) into the drawing window. These .skp files will be placed in your model as components.

Apple Color System

SketchUp for MacOS X has a completely redesigned color and materials management system based on Apple Computer's System Color Picker. SketchUp modifies this color picker to enable texture image management and to easily keep track of materials specified in your model.

One Button Mouse

Macintosh computers traditionally ship with a one-button mouse. SketchUp has been designed to allow you to be effective using a one-button mouse through the use of keyboard shortcuts as follows:

**Orbit**

Hold down the Control and Command keys, while clicking the mouse button, to orbit using a one-button mouse. This key combination temporarily invokes the Orbit Tool.

**Pan**

Hold down the Shift key along with Control and Command, while clicking the mouse button, to pan using a one-button mouse. This key combination temporarily invokes the Pan Tool.
SketchUp Versions

SketchUp is available in personal and professional versions. Google SketchUp is available for free on sketchup.google.com.

Google SketchUp Pro is available to purchase at http://sketchup.google.com/gsu6/buy.html. You need Google SketchUp Pro if you want to:

- Export models in 3DS, DWG, DXF, OBJ, XSI, VRML, and FBX file formats
- Use the LayOut tools to create page and screen-based presentations of your models.
- Receive free email technical support for two years after purchase

Google SketchUp and Google SketchUp Pro 7 Documentation

This documentation represents all of the functionality in both Google SketchUp and Google SketchUp Pro 7. Functionality that is specific to Google SketchUp Pro 7 is identified with the pro icon ( ) in this documentation.
What's New in this Release?

Google listens to your requests and attempts to implement many into SketchUp enhancements and new features. Google SketchUp and Google SketchUp Pro 7 contain the following enhancements and new features:

Dynamic Components

*Dynamic components* are components that have parametric behaviors, such as a stair component that, when resized, automatically adds more steps, or a cabinet component whose doors can open and close.

All SketchUp users can use Dynamic Component available in SketchUp's Component Browser or in the Google 3D Warehouse. These components are identified by a small icon (◮) indicating that the component has parametric behaviors. Insert a Dynamic Component, context-click on the component, and select "Dynamic Components > Component Options" to view configurable behavior. Click on the Dynamic Component with the Interact Tool (◮) to see if parts animate or change. Or, attempt to scale the Dynamic Component using the Scale Tool to see if it has special scaling attributes.

Google SketchUp Pro 7 users have the ability to create dynamic components using the new Component Attributes dialog box. This dialog box is similar to a two-column spreadsheet in appearance and functionality. Context-click on any component and select "Dynamic Components > Component Attributes" to author a Dynamic Component.

Google SketchUp Pro 7 users have the ability to create attribute reports for Dynamic Components. Select "File > Generate Report" to create an attribute report.

Components Browser Enhancements

You can search and download models from the Google 3D Warehouse directly to your modeling space with the SketchUp 7 enhanced Component Browser. The new Google 3D Warehouse search feature allows you to save and bookmark your searches or 3D Warehouse collections as “Favorites” for faster access to the items you need. You can even download a Google 3D Warehouse collection or the results of a search to a local collection on your hard drive for easy access. When you have a big project and you want to take advantage of the wealth of models in the 3D Warehouse, the new Component Browser lets you do it without losing focus on your design. The Components Browser is available by selecting "Window > Components."

Save Custom Templates

SketchUp 7's "Save As Template" menu item allows you to configure a file with units, style, initial view, and so on, and save it as a reusable Template (containing thumbnail view and description). Select "File > Save As Template" to save your current file as a template.

Improved GEO-referencing Workflow

SketchUp 7 has an improved the user interface for managing geo-location in the model, including a new status bar icon (See following VCB and Status Bar Improvements section) and a new "Use georeferencing checkbox" in the Location panel of the Model Info dialog box (Window > Model Info).
Credits
SketchUp 7 Credits feature allows you to take credit for the models you create and for model contributions. As with the Google 3D Warehouse, Credits require you to log in to a Google account. Credits are available from the status bar or by selecting the "Credits" tab from the Model Info dialog box (Window > Model Info).

VCB and Status Bar Improvements
The Value Control Box (VCB) has been renamed to the "Measurements Toolbar" and can now be repositioned on the screen. Additional buttons have also been added to the status prompt to provide access to and status for the following features: Georeferencing, Credits, Google account login, and the Instructor.

Help Center Integration
All of the SketchUp 7 learning resources are consolidated in the Help Center which is accessible through the Welcome Dialog and the Help menu. Select "Help > Help Center" to access all SketchUp learning resources.

Welcome to SketchUp
The Welcome to SketchUp dialog box provides you with an opportunity to choose essential first-run options and prepares you for success in your first experience with SketchUp. The Welcome to SketchUp dialog box is divided into three sections: Learn, License, and Template.

- The Learn section contains links to all learning resources into the Help Center.
- The License section displays license status, simplifies license entry for Google SketchUp Pro users, displays remaining demo time, and warns of impending demo expiration.
- The Template section contains a list, with thumbnail views and descriptions, of all available templates.

Texture Handling Enhancements
Google SketchUp 7 contains incremental improvements to texture handling, including improvements in Match Photo and the Position Texture Tool. These changes are:

Make Unique Texture
The Make Unique Texture menu item makes the selected texture image unique and crops it to fit the selected face. This feature works with texture images as well as with plain colors. Context-click on a face with a texture and select "Make Unique Texture." Selecting "Make Unique Texture" on a face without a texture displays a Texture Size dialog box. A new, unique, texture the color of the face is created.

Edit Texture
The Edit Texture Image button sends the selected texture image to the user's default image editor for modification. Context click on a texture in the Materials Browser and select "Edit Texture Image." Or, context-click on a textured face and select "Texture > Edit Texture Image."

The default image editing program used with this feature can be configured in the Applications tab of SketchUp Preferences.

Project Texture
Textures are now projected only onto visible faces and faces within grouped entities.
**Combine Textures**
The Combine Textures menu item combines separate textures on adjacent co-planar faces into a single larger texture. This feature also, optionally, removes edges between co-planar faces to reduce the polygon count for the model as a whole. Context-click on multiple selected parallel faces, with at least one face having a texture, and select "Combine Textures" to create a texture which is unique to that set of faces.

**Maximum Texture Size**
Check the "Use maximum texture size" checkbox to use the maximum texture size supported by your graphics card. This option might result in a slowing of SketchUp unless your graphics card and computer can handle what is advertised. The Use maximum texture size checkbox is in the OpenGL panel of the Preferences dialog box (Window > Preferences on Microsoft Windows or SketchUp > Preferences on Mac OS X).

**Use Anti-Aliased Textures**
SketchUp has a Use Anti-Aliased Textures option in Model Info's Rendering tab. This option, also known as mipmapping, takes a texture at full size and creates smaller versions of the texture which are swapped out for the appropriate view size. The result is smoother looking textures and faster display because less memory must be used when smaller texture images are swapped out.

**Edge Merging Behavior**
Two lines crossing in a single plane will now break into four segments at their point of intersection. Previously, crossing lines would have to be explicitly broken. This is true for all drawing and modification operations.

**New Inference Icons**
Google SketchUp 7 has new, easier to distinguish, inference icons. These icons are also consistent with the inference icons in LayOut 2.

**Ruby API Changes**
New Ruby APIs have been added. Refer to code.google.com for information about the SketchUp Ruby API.

**Style Builder 1**
SketchUp 7 contains the first official release of the Style Builder application for creating custom sketchy edge styles for SketchUp. Style Builder is accessible through a desktop shortcut (Microsoft Windows) or within the Applications folder (Mac OS X).

**LayOut 2**
Google SketchUp 7 Pro contains the first official release of LayOut, titled LayOut 2. LayOut 2 contains numerous improvements over LayOut 1 (beta). Refer to the What's New section in the LayOut documentation for further information. LayOut 2 is accessible through a desktop shortcut (Microsoft Windows) or within the Applications folder (Mac OS X).
Technical Support

Google SketchUp (Free) and Google SketchUp Pro users have different levels of technical support. Review the following technical support explanation for your product.

Google SketchUp Free

SketchUp Free is a self-supporting product. There are several options available to find answers to SketchUp issues:

- Use the online user's guide index to find a topic.
- Search the knowledge base to find a topic.
- Post a question in our user forum.

Visit the Online Help Center by clicking on the Online Help Center menu item in the Help menu (Help > Online Help Center). You must be connected to the Internet to access the user forums.

Google SketchUp Pro

In addition to the self-supporting options for Google SketchUp Free, Google SketchUp Pro users can request installation and configuration help using email through the Online Help Center (your serial number will be required).

Please include the following with your email:

- A list of your computer system's resources (CPU type, RAM, video card details, and the exact release of your operating system, such as OS X 10.3.9 or Windows XP Professional with Service Pack 2)
- A detailed description of your question or issue
Learning SketchUp

As with any software tool, there is a minimum level of learning you must do to attain proficiency with SketchUp. The following information can help you learn how to use SketchUp.

Help Center

You can find answers to many questions in this Google SketchUp Help Center, just search on a common term or phrase in your question, or browse through the categories. Select "Help > Help Center" to visit the SketchUp Help Center. You must be connected to the Internet to access the help center.

The Help Center contains SketchUp documentation, video tutorials, quick reference card, and a Google SketchUp Group.

SketchUp Documentation

There are several written guides covering the use of SketchUp. These guides differ in their intended audience.

Getting Started Guide: Read the Getting Started Guide if you are new to SketchUp and want to try introductory operations.

Concepts Guide: Read the Concepts Guide if you are new to SketchUp and want to understand common SketchUp terms and concepts. This guide will help you better understand information presented in the User's Guide and Reference Guide.


Video Tutorials

Google has created several video tutorials to facilitate learning of the SketchUp tools and drawing procedures. View these tutorials through the View Tutorials menu item in the Help menu (Help > Help Center). You must be connected to the Internet to access these tutorials.
Quick Reference Card
The SketchUp Quick Reference Card (in the Help Center) contains a list of all of Toolbar tools and their modifier keys. Examine the SketchUp Quick Reference Card to become familiar with using SketchUp's tools.

Proceed to the Quick Reference Card

Google SketchUp Group
The Google SketchUp Group is an excellent place to find answers, ask questions, and share your expertise. Visit the SketchUp user group through the SketchUp Help Center (Help > Help Center) or by tying the following URL in your browser: http://groups.google.com/group/sketchup-Pro-Groups/topics. You must be connected to the Internet to access SketchUp user group.

Proceed to the Google SketchUp Group

SketchUp Training
Google provides training courses for users who want extra assistance with SketchUp from the experts at Google. Visit the Help Center for further information on SketchUp training classes in your area.

The SketchUp User Interface
Following are three additional options for learning SketchUp built into the SketchUp user interface.

Menus
Most SketchUp commands are accessible using both tool buttons and drop-down menus. Examine SketchUp's menus to become familiar with the breadth of features.

Instructor
Enable the Instructor (Window > Instructor) to display information related to the currently selected tool.

The Status Bar
The Status Bar, located at the bottom of the SketchUp Drawing Area, displays tips for the active tool, including special functions accessible using keyboard shortcuts. Watch the status bar while you are working in SketchUp to discover advanced capabilities of each of the SketchUp tools.
Concepts Guide

This guide covers the numerous 3D design and SketchUp concepts found within the product and in the user community. This section was primarily written for users who are new to 3D modeling or SketchUp.

Note - This section does not cover how to do something in SketchUp, but covers important concepts necessary to model in 3D.

This section is organized into the following topics:

- Designing in SketchUp - Introduces you to the basic concepts behind drawing accurately in SketchUp.
- Drawing Quickly - Introduces you to SketchUp tools and concepts necessary to draw quickly.
- Viewing Models in 3D - Presents the concept of the camera and manipulation of a model in 3D space.
- Adding Detail to Your Models - Introduces you to mechanisms to quickly add realism to your SketchUp models.
- Presenting Your Models - Presents concepts related to the presentation of your models to clients.
- Modeling Terrain and Organic Shapes - Presents concepts related to working with mesh tools to create both terrain and organic shapes.
Designing in SketchUp

SketchUp models are fundamentally created by joining lines as the edges of the model. Faces are automatically created when any three or more lines or edges are in the same plane (an infinite flat 2D space), or coplanar, and form a closed loop. These edge and face combinations are combined to create 3D models. The following image shows three unconnected coplanar lines. These lines were drawn with the Line Tool (this tool looks like a pencil).

The following image shows four connected coplanar lines and the subsequently created flat, 2 dimensional, face.

Note - Everything you draw in SketchUp is generically referred to as geometry.

To create a 3D model, simply draw up or down in the blue direction (parallel to the blue axes). The coordinate system (axes) is covered later in this section. The following image shows the first line created in 3D space.
As you continue to draw lines, following the colored axes, faces are created. The following image shows four faces created simply by drawing lines parallel to the three axes directions (red, green, and blue).

There is one line left to draw to finish a 3 dimensional box. Notice that when this one line is drawn in, two faces are created (the top and front faces).
You can do a lot in SketchUp simply by drawing lines to form faces using the Line Tool. And, you can draw lines starting anywhere (on another line, on a face, at a point, and so on). Can you recognize the previous 3D box within the model of the following house?

Look around the room you are in. Notice how everything you look at has faces. Some faces might be rounded, some might be flat. Additionally, everything has edges that bound the face, such as the edge of a shelf in a bookshelf.

**Note** - SketchUp is not the same as Computer Assisted Design or CAD. CAD applications are designed specifically for representing concrete information, while SketchUp is for exploration and design of concepts and ideas (though you are not prohibited from designing models that are as concrete or accurate as those designed in CAD).

SketchUp files can be imported into several different CAD applications for further processing and several different CAD files can be imported into SketchUp to quickly create 3D models.
Introduction to Entities

As mentioned previously, lines are combined to create faces in SketchUp. Lines (also called edges) and faces, are just two of the many building blocks (called entities) used for creating models in SketchUp. A full list of SketchUp entities follows.

<table>
<thead>
<tr>
<th>Name</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>Lines in SketchUp are straight. Lines, also referred to as edges, are the most basic building block for all SketchUp models.</td>
</tr>
<tr>
<td>Face</td>
<td>Faces are created automatically when three or more coplanar edges form a closed loop. Faces have a front side and a back side. SketchUp attempts to put the front side of all faces on the outside (facing out) of all of your models, though sometime you might have to tell SketchUp the direction for your faces.</td>
</tr>
<tr>
<td>Circle</td>
<td>Circle, arcs, and curves are comprised of several lines or edges.</td>
</tr>
<tr>
<td>Arc</td>
<td></td>
</tr>
<tr>
<td>Polygon</td>
<td></td>
</tr>
<tr>
<td>Curve</td>
<td></td>
</tr>
<tr>
<td>Polyline</td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td>Group entities are used to combine two or more entities in your model for quick operations such as a copy.</td>
</tr>
<tr>
<td>Component</td>
<td>Component entities are like groups but can be reused in all of your SketchUp models. Components are just SketchUp models used within other SketchUp models.</td>
</tr>
<tr>
<td>Guide Line</td>
<td>A Guide Line entity is a temporary line used as a drawing guide.</td>
</tr>
<tr>
<td>Dimension</td>
<td>A notation indicating length of an edge or a radius.</td>
</tr>
<tr>
<td>Surface</td>
<td>Surface entities are the result of combining a number of faces to give the impression of smoothness.</td>
</tr>
<tr>
<td>Section Plane</td>
<td></td>
</tr>
<tr>
<td>Image</td>
<td>An imported raster, or pixel-based, image.</td>
</tr>
<tr>
<td>Text</td>
<td>Text can be unattached (floating) or attached to a specific entity using a leader line.</td>
</tr>
</tbody>
</table>

The SketchUp Coordinate Systems

SketchUp uses a 3D coordinate system whereby points in space are identified by position along three drawing axes: plus or minus X, Y, and Z (above ground/below ground) values. In SketchUp, plus or minus X is represented by solid red and dotted red lines respectively; plus or minus Y are represented by a solid green and dotted green axis lines respectively; plus or minus Z (above and below the ground plane) are represented by solid blue and dotted blue lines respectively. The plane where the red and green axes lines lie is called the ground plane. Finally, the term origin is used to define the place where all of axes lines start or originate.
The following image shows the drawing axes in SketchUp (the lines have been thickened to make the axes easier to read). The black circle represents the origin.

Understanding SketchUp's coordinate system is important because SketchUp's inference engine (explained next) provides you help with drawing accurately.

**Following the Inference Engine**

SketchUp has an invisible *inference engine* to help you draw accurate and realistic models. The inference engine locates or infers points from other points in your model, such as the center of a circle, the midpoint of a line, a line that is perpendicular to the ground plane, a point on a face, a point on an edge, and so on.

SketchUp notifies you of these points by using both color indicators and tool tips, which are on-screen messages indicating the location of the cursor as you draw an entity. For example, SketchUp displays the string "On Face" when the cursor is touching a face. The following image contains five common inference tool tips.

Additional information on the inference engine, including inference types, is in the User Interface section of this guide.

The first step to drawing in SketchUp is to learn how to draw accurately by following the cues of the inference engine. Simply select the Line Tool (it looks like a pencil in the Toolbar or tool pallet) and start drawing. Pay attention to the on-screen tool tips from the inference
engine as you draw. Most everything you will create in SketchUp can be created by inference using the Line Tool.

You can move on to learning how to draw quickly after you master using the inference engine.

= Functionality only available in SketchUp Pro
Drawing Quickly

As mentioned in the Design in SketchUp topic, you can use the Line Tool and the inference engine, to draw just about anything in SketchUp. It is recommended that you use the Line Tool and inference engine to create your initial models.

💡 **Tip** - Learn to draw accurately before you learn to draw quickly and you will master SketchUp in a shorter amount of time.

SketchUp implements several concepts which you will use to help you draw quickly. These are dividing and healing, pushing and pulling, sticky geometry, autofold, and intersections.

### Dividing and Healing Geometry

Some tools speed up design dramatically by allowing you to perform modifications on existing geometry. For example, the Line Tool allows you to split faces and edges to create additional independent faces and edges. Simply divide the face or edge with another edge. This concept is similar to cutting a piece of paper in half and having two separate remaining pieces. The following image shows how two faces are created when dividing the face with a line. Notice the image on the left has one solid top face, while the image on the right has two independent faces when split with a line. Note that the dividing line does not cut through the model from top to bottom, but just cuts the top face in half.

![Diagram of dividing and healing geometry](image)

The following image shows how the edges at each end of the face have been split to create additional edges. Note four edges bounding the face in the left image, while four edges bounding each of two faces in the image on the right (the middle edge being common to both top faces).
If you remove the line that shared by the two faces in the image on the right, the two faces will be glued back together or healed back into one face. It is common in SketchUp to perform these dividing and healing operations to your model.

**Pushing and Pulling**

The Push/Pull Tool allows you to take any non-curved face in SketchUp and push it away or pull it toward a starting point (these operations are also referred to as extrusions). Pushing is the process of reshaping a portion of your model by shrinking the portion away from its starting point and along a single axis. The following image shows the right-most face of the split face (shown earlier) pushed down toward the ground plane.

In the previous image, there are eight faces that can be pushed, can you find them (some are hidden out of view)?

Pulling is the process of expanding a portion of your model away from the starting point along a single axis. The following image shows the same face having been pulled up toward the sky. Any face in SketchUp can be pushed and pulled (with some minor limitations).
In both of the images, the left side of the cube remained the same size, while the right side was pushed and pulled (shrunk and expanded) independently. The Push/Pull Tool is one of the most commonly used tools in SketchUp to add the sense of volume to your model.

**Manipulating Connected Faces**

Geometry in SketchUp is *sticky* meaning that it can be manipulated (skewed, distorted, or folded) by selecting an edge or face and moving the edge or face with the Move Tool (causing all entities attached or "stuck" to the edge or face to move too). Following are three examples of sticky geometry in SketchUp:

1. The following image shows a line dividing the top face of a box being moved up with a Move Tool. The faces that were connected to the middle line followed the line as it was moved to create a roof-like effect.

2. The following image shows the left-most top face being moved down in the blue direction. This action causes the right-most top face to angle to create a slant on one side.
3. Finally, the following image shows the left-most top-edge being moved to the left. The model is skewed into a trapazoid-like shape.

Be sure to use the Move Tool to grab and move edges and faces while you begin to experiment with modeling in SketchUp.

💡 **Tip** - Experimentation and play is highly important in learning how to draw in SketchUp! Learn how to draw accurately first, then learn how to draw quickly using the concepts in this portion of the user's guide.

**Autofold**

Faces must remain planar at all times in SketchUp. Therefore, SketchUp will Autofold, or *score*, faces as necessary to accommodate any operation that will result in warped faces.

In the left-most image above, a six-sided polygon volume's top face (created with the Polygon Tool followed by the Push/Pull Tool) was rotated using Rotate Tool. Because of SketchUp's sticky nature, the sides of the shape, which share common edges with the top face, twisted and folded with the rotate operation (right-most image).
What you are not seeing is that SketchUp has created *hidden geometry* when performing this Autofold operation. The following image shows the 3 dimensional shape with the hidden geometry shown (dotted lines). Notice that each twisted faces are actually comprised of two triangular faces.

Intersections (Boolean Operations)

SketchUp allows you to easily create complex geometry by intersecting two geometrical forms, such as a box and a tube, creating new edges where the elements intersect, merging the geometry, and subtracting parts of the combined geometry.

In the left-most image above, a cylinder shape was moved into a cube shape. Notice, that no lines appear where the two shapes intersect, indicating that the shapes have not truly merged. A special tool, called the Intersect with Model Tool, is used to create intersection lines (the middle image), merging the two shapes together to form one new shape. Finally, the cylinder shape is deleted (using the eraser tool on the cylinder's edges) and because the intersection lines were created, the resulting curved face is left within the cube creating a new complex geometrical shape (right image).
SketchUp Tools

Most entities in SketchUp, including arcs and circles, are actually just a combination of small lines or edges. Thankfully, you do not have to use only the Line Tool to sketch your models. Instead, SketchUp provides many other tools to help you draw quickly. Some of these tools are for creating common entities such as a circle, arc, polygon, or freehand line. Other tools allow you to quickly draw complex models by modifying your models (splitting, skewing, and even merging geometry together).

Tools in SketchUp are divided into five categories: principal tools (tools that are used a lot to select and modify geometry), drawing tools (tools used to create geometry), modification tools (tools used to modify existing geometry), construction tools (tools used to create construction lines or points, and document your model), camera tools (tools used to view geometry; discussed later), and walkthrough tools (tools to explore your model). The following table lists all of the Drawing and Modification tools:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Type</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>Drawing</td>
<td>Can be used to create, intersect, or divide a face or other line (edge)</td>
</tr>
<tr>
<td>Arc</td>
<td>Drawing</td>
<td>Can be used to create, intersect, or divide a face or other line (edge)</td>
</tr>
<tr>
<td>Freehand</td>
<td>Drawing</td>
<td>Can be used to create, intersect, or divide a face or other line (edge)</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Drawing</td>
<td>Can be used to create, intersect, or divide a face or other line (edge)</td>
</tr>
<tr>
<td>Circle</td>
<td>Drawing</td>
<td>Can be used to create, intersect, or divide a face or other line (edge)</td>
</tr>
<tr>
<td>Polygon</td>
<td>Drawing</td>
<td>Can be used to create, intersect, or divide a face or other line (edge)</td>
</tr>
<tr>
<td>Select</td>
<td>Principal</td>
<td>Used to select entities</td>
</tr>
<tr>
<td>Eraser</td>
<td>Principal</td>
<td>Used to delete geometry and heal faces</td>
</tr>
<tr>
<td>Paint Bucket</td>
<td>Principal</td>
<td>Used to apply materials (combinations of color and texture)</td>
</tr>
<tr>
<td>Position Texture*</td>
<td>Modification</td>
<td>Used to manipulate materials painted on a surface.</td>
</tr>
<tr>
<td>Move</td>
<td>Modification</td>
<td>Used to move, distort (autofold), and copy entities</td>
</tr>
<tr>
<td>Rotate</td>
<td>Modification</td>
<td></td>
</tr>
<tr>
<td>Scale</td>
<td>Modification</td>
<td></td>
</tr>
<tr>
<td>Push/Pull</td>
<td>Modification</td>
<td>Used to expand and shrink geometry</td>
</tr>
<tr>
<td>Follow Me</td>
<td>Modification</td>
<td>Used to duplicate a profile along a path</td>
</tr>
<tr>
<td>Intersect With Model*</td>
<td>Modification</td>
<td>Used to create complex geometry by piecing together separate geometry</td>
</tr>
<tr>
<td>Offset</td>
<td>Modification</td>
<td></td>
</tr>
<tr>
<td>3D Text Modificati</td>
<td>Modification</td>
<td>Used to draw 3 dimensional text geometry</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>-------------------</td>
<td>--------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Tape MeasureGuide</td>
<td>Used to get a measurement and create construction line entities</td>
<td></td>
</tr>
<tr>
<td>ProtractorGuide</td>
<td>Used to set angles</td>
<td></td>
</tr>
<tr>
<td>AxesGuide</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DimensionsGuide</td>
<td>Used to calculate and display a dimension</td>
<td></td>
</tr>
<tr>
<td>TextGuide</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Section PlaneGuide</td>
<td>Used to create section cut effects</td>
<td></td>
</tr>
</tbody>
</table>

*These menu items are available in menus, not from the Toolbar (Microsoft Windows) or tool palette (Mac OS X), and are discussed in the tools sections of this user's guide.

Each of these tools is discussed further in this guide. As a recommendation, however, learn the Line Tool and Eraser Tool first, followed by the Orbit Tool (discussed in the next section), Push/Pull, and Move Tools.

**Note** - Most drawing tools can perform modifications as well, such as the Line Tool being used to draw a line to divide a face.
Viewing Models in 3 Dimensions

SketchUp implements the concept of a camera to represent your point of view of the model. Simply, you (the user) are treated as though you were a camera looking at your model as you work. This concept is particularly important when your model is something that you want to tour, such as a house, as though you were walking through it in the real world. In this case, SketchUp allows you to change your point of view to a specific height and angle to the model and walk through the model as though it were real.

Manipulating the Camera

You can manipulate the camera (your view) in a number of ways to aid you in your designing. The first, called an orbit,

Camera Tools

There are other ways to manipulate the camera (your point of view) in SketchUp, including zooming in and out and panning. The following table lists all of the camera tools in SketchUp:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Orbit</td>
<td>Camera</td>
</tr>
<tr>
<td>Pan</td>
<td>Camera</td>
</tr>
<tr>
<td>Zoom</td>
<td>Camera</td>
</tr>
<tr>
<td>Zoom Window</td>
<td>Camera</td>
</tr>
<tr>
<td>Zoom Extents</td>
<td>Camera</td>
</tr>
<tr>
<td>Position Camera</td>
<td>Walkthrough</td>
</tr>
<tr>
<td>Walk</td>
<td>Walkthrough</td>
</tr>
<tr>
<td>Look Around</td>
<td>Walkthrough</td>
</tr>
</tbody>
</table>

Perspective and Paraline Projections

In addition to your point of view, you can view items in SketchUp in a paraline (also called axonometric) projection or in a perspective projection. Axonometric means “measurable from the axes” and an axonometric projection is a view of a model in which lines appear parallel in both 3 dimensional and 2 dimensional space. Also, lines have a length that is to some scale in an axonometric projection when printed (for example 4’ in SketchUp = 1” on paper). The following image shows a axonometric or paraline projection, notice how the roof, and wall lines appear parallel.
Perspective, however, distorts the view such that it represents the model as though the lines were vanishing to a horizon (certain items appear closer while other items appear to be far away; entities are not to scale). The following image shows a perspective projection.

SketchUp defaults to a perspective view, but can be toggled into a paraline view for those who prefer a point of view that is similar to what you would see when drawing 3D objects in a 2D space (such as when drawing a cube on flat paper).

*Note* - The iso camera view in SketchUp is not the same as an isometric projection in which anything along the x, y or z axis are in proportion. This view simply shows you ¾ of your model and is a standard camera angle for viewing models in a 3D space.

**Layers**

SketchUp *layers* are used to control the visibility of geometry within large models. A SketchUp layer is an attribute with a name, such as "Layer0," "Layer9," or "Chairs." Elements can be assigned different layers. For example, all Component entities that are chairs can be assigned to the "Chairs" layer. This layer can be then be hidden temporarily to hide everything on the layer from view.

*Note* - Geometry on one layer is not separated from geometry on another layer. For example, faces sharing a common edge will both be affected by a modification to that edge regardless of what layer the faces are on.
**Default "Layer0"**

There is one Layer, Layer0, in SketchUp, by default. All entities are automatically placed on this layer unless you create another layer, designate the new layer as the active layer, and create entities on the new layer.
Adding Detail to Your Models

You will likely want to create progressively more detailed models as you become more proficient with SketchUp. SketchUp contains several features allowing you to quickly create detailed or life-like models. These features include components, materials, shadows, and styles.

Materials

SketchUp allows you to paint materials on faces to add detail and realism to your models. Materials are essentially paints that have a color and optional texture (defined within an image file). For example, a siding material with the color of grey and an appearance or texture simulating real overlapped composite siding. Following is a building painted with grey composite siding and grey shingle roofing materials. A grass material is also used on the ground.

As with components, SketchUp comes with a library of materials. You can paint these materials on your models using the Paint Bucket Tool. Additionally, you can create your own materials within SketchUp (using the color wheel), or by importing texture-like images (such as the image of a wood flooring). In fact, you can import an entire image of a real-world object (such as a picture of a car), and manipulate it over your 3D model to give your model a truly realistic appearance.

Default Material

Geometry in SketchUp is assigned a default material as it is created. The default material can be changed by painting the geometry with a material.
**Material Transparency**

Materials also have an opacity property (a number between 0 and 100%) allowing you to create materials that behave like glass. Paint these materials on faces to create windows.

![Material Transparency Image](image)

Faces have two sides. SketchUp materials are normally applied to a single side of a face at a time. Painting a default colored side with transparent material will result in both sides of that face being treated as transparent allowing the surface to be transparent when viewed from both sides. If the back side of a face has already been painted with some non-transparent material, applying a transparent material to the front side will not cause the back side to also display as transparent. Likewise, if you paint the back side of a face with a different transparent material, it will not effect the front side. Thus, by specifically applying a material to both sides, it is possible to have transparent faces that can have different colors and levels of transparency on each side.

**Groups and Components**

*Groups* and *components* are entities that can hold other entities. Groups are commonly used to combine several entities into a single entity for the purposes of performing a quick operation on the group (such as a copy or move). For example, you might draw a model, group the entities that compose model and move the entire model. The characteristics of groups are:

- **Quick selection.** When you select a Group, all elements within that group are selected as well.
- **Isolation of geometry.** Entities within groups are protected from the rest of the model. Geometry outside of the group does not affect the geometry within the group.
- **Model organization.** Groups can be nested within other groups resulting in hierarchical collection of subgroups.
- **Group material.** The group as a whole can be assigned a material of its own, which is separate from the materials painted on individual entities within the group. See the Materials section within this topic for further information.
- **Drawing Axes.** Groups maintain their own internal drawing axes.
- **Alignment and Hole Cutting.** Groups have a special behavior that allows them to properly align themselves and stick to faces on which they are placed (as well as cut holes in those faces).
Components are just a group with special behaviors, namely behaviors allowing them to be inserted in other models. For example, you might create a model of a car that you want to bring into other SketchUp models, such as the model of a house. Any models you create can be a component.

Components have the following characteristics, in addition to the characteristics of groups:

- **Instancing Behavior.** Each copy of a component that you insert into a model is considered an *instance* of a *component definition*. The component definition is the blueprint that defines the appearance and behavior of all component instances (created when you insert the component in the model). Editing a component instance edits the definition and all instances accordingly. However, some actions, such as scaling an instance, only affects the instance itself.

- **Improved Performance.** Components allow SketchUp to more efficiently use your computer's resources because the information necessary to describe a component is only stored once, in the component definition, and then referenced for every component instance.

- **Drawing Axes.** Components display their own internal drawing axes when you are editing the component.

- **Alignment and Hole Cutting.** You can define alignment and hole cutting behavior when creating components (it is automatically defined for groups).

  **Note** - You can define the characteristics of the component during component creation.

**Group and Component Context**

Entities within a group or component are said to exist within the group or component's scope or *context*. You can modify a group or component as a whole (affecting all of the entities within the group or component) or edit the group or component's individual entities (within the group or component's context). Additionally, you can nest components within other components, groups within components, components within groups and so on. The following image shows a shelf component has been selected (as indicated by the yellow selection color) using the Select Tool. This shelf is composed of several subcomponents, such as slats.
The following image shows the shelf component being edited. Notice that it has a dashed bounding box to indicate you are in the component's context. In this case, a subcomponent, one of the slats in the shelf, has been selected. That slat is within the context of the shelf. Also notice that the component's axes are displayed in the lower left-hand corner.

Finally, the following image shows the slate component being edited. Notice now that there is a dashed bounding box around the component, and around the slat being edited. The entities, such as the lines and face, that compose that individual slat are said to be in the context of the slat.
Component Collections

Component collections have been created and included with SketchUp to allow you to easily add detail to your models. These components range from standard architectural components (doors, windows, and so on) to people, cars, trees, and geometric shapes. You can also create your own collections of components from pre-existing components or components you create yourself.

Note - Individual components and collections of components are available on the Google 3D Warehouse.

Component Axes

Components have their own axes which, by default, are aligned to the global axes in the drawing area. These axes can be moved affecting component placement in the model.

Cutting and Gluing Behavior

Components, such as doors and windows, can be designed such that they can be placed on specifically-oriented surfaces such as vertical wall surfaces. This behavior is referred to as the gluing behavior of a component.

Additionally, components can be designed to automatically cut holes in surfaces, such as in the case of a window component being able to cut a hole in a wall. This behavior is referred to as the cutting behavior of a component.

Layers, Groups and Components

Layers are a mechanism for controlling the visibility of entities within a model. Entities can be assigned to different layers in a model and those layers, and their contents, can be displayed independently. Groups and Components are used to isolate geometry as sub-models within an overall model, such as a component of a chair within a model of a room.

Note - Entities within a group or component can be on several different layers.
Styles
A style is a predefined set of display settings that can be applied to a model, and the drawing area, to give it a specific look-and-feel. A style can consist of a specific edge type; face type, sky and background color, watermark, and other drawing area effects (such as the color used to represent selected geometry). SketchUp has multiple styles, some best used while drawing a model (because they don’t use any intensive rendering effects), others are best suited for printing or presenting a model (because they use rendering effects to give a model a hand-drawn appearance). For example, a pre-defined style might have an edge type of jitter edges, a face type of hidden line mode, a background color of white, a sky color of blue, a ground color of brown, and so on.

Sketchy Edges
SketchUp allows you to apply various edge types, including hand-drawn sketchy edges, to your model. Sketchy edges are edges that can be unique from any other edge style in SketchUp because, unlike other pre-defined edge types, you can create your own sketchy edge using a drawing program like Photoshop. Sketchy edges are simply a collection of different hand-drawn strokes that, when combined and applied to model, give the a model a unique hand-drawn appearance.

Watermarks
Watermarks are images placed in the background or foreground of the drawing area and span the entire area just as sky and ground. Watermarks are great for creating backgrounds, such as simulating paper textures beneath a model. Watermarks can also be used to place logos and other graphics directly on the screen.
Shadows

SketchUp allows you to cast shadows on your model as though the model were in a real-world environment. These shadows can be cast based on time of day and virtual location of the model in the real-world. For example, you can set shadows to see exactly what a model of a house would look like at 10:20 am, December 10, in Boulder, Colorado, which is the default location. Finally, SketchUp's shadows are designed to provide dynamic feedback as you change geometry and your camera viewpoint. The shadow casting feature in SketchUp is a great way to give your models a better sense of depth and realism.

Note - While SketchUp's projected shadow angles are accurate, the rendering effect is not intended to be photo-realistic. Fortunately, SketchUp can export models to other many other applications that excel at photo-realistic renderings.
Ground Shadows

*Ground shadows* use the faces in your model to create a flattened set of faces on the ground plane. These faces are colored and positioned based on the background color and the angle of the sun. Although faster than face shadows, the illusion that ground shadows provide only works on the ground plane. The following figure shows a model whose geometry all lies on or above the ground plane.

![Model example](image)

**Note** - Ground shadows create unexpected geometry, called *artifacts*, when your model contains geometry beneath the ground plane. Ground shadows work well for models with solid color backgrounds and in which all geometry is above the ground plane.

Face Shadows

*Face shadows* use the sun angle to project shadows based on the location of faces relative to other faces. For example, a shadow is cast on the stairs in the following figure, based on the face of the vertical 3d rectangle. The calculation used to create face shadows is processor-intensive, however, and will slow down performance with large models.

![Model example](image)

**Note** - Faces with less than 70 percent opacity are considered transparent, and do not cast shadows. Faces with 70 percent opacity or greater cast shadows. Transparent faces cannot receive shadows. The following image shows a transparent (less than 70% opacity) rectangle that does not cast a shadow (left) and a opaque (70% or greater opacity) rectangle that does cast a shadow (right).
The two shadow systems are designed to be complimentary, and you may often wish to have both types enabled simultaneously.
Presenting Your Models

There are several things you can do after you create a model. For example:

- You can add dimensions, section cut effects, and other entities to your model for use in documenting the actual physical item.
- You can present the model within SketchUp as an animation.
- You can print your model
- You can export all or portions (such as a section slice) of the model for post processing in another application

Section Cut Effects

SketchUp allows you to create *section cut effects* which are the result of slicing through your model to see and work inside its interior. The following image shows a model of a building with a section cut affect active allowing the designer to work inside the model or present interior detail to a client.
The following model shows the section cut effect resulting from slicing through the model of a cup.

**Section Planes**

Section cut effects are created by *section planes* which are special entities used to control the selection, placement, orientation, direction, of the *section slice*. Section planes are generated using the Section Plane Tool.

The previous image shows a section plane entity intersecting the cup and creating a section slice through the cup.
**Section Slices**

The term section slice refers to the edges that are highlighted after intersecting geometry with a section plane. The following image shows a section slice in red.

These edges act as dynamic virtual edges in that they continually change as you move the section plane through your model with the Move Tool. You can create a group from these edges, such as when slicing horizontally through a house, to create a wire frame of the model (such the outline of a floor plan). Then, export this section slice for use in a CAD program to add additional detail (such as wall construction detail).

**Animations**

SketchUp allows you to create different scenes, similar to slides in traditional presentation software, each containing different settings for your model (point of view, section cut effects, and so on). These scenes can be combined and executed sequentially as an animation. The animation engine can be set to gradually transition between effects on different scenes for a truly dynamic presentation.
Modeling Terrain and Organic Shapes

SketchUp implements the concept of a sandbox which refers to a surface that can be generated and manipulated using sandbox tools. A sandbox in SketchUp (and in other 3D modeling tools) is commonly referred to as a \textit{triangulated irregular network} or TIN in terrain modeling terminology. The following image shows a TIN (sandbox) in SketchUp.

![TIN in SketchUp](image)

**Note** - This documentation uses the term TIN, sandbox, and terrain interchangeably. A TIN is like a sandbox because it has a boundary and contains a sculpted surface (sand). Sandbox tools are those tools that are included in SketchUp for creating and manipulating TINs.

The following image shows a TIN in SketchUp with hidden geometry displayed (so you can see the triangles that are the foundation of the TIN).

![TIN with hidden geometry](image)

There is nothing special about a TIN, it is simply several connected triangular faces that, when smoothed, appear like one continuous smooth surface. Note that you are not limited to creating terrain with the sandbox tools, you can create other \textit{organic shapes} (shapes that appear to be crafted by hand) using these tools. For example, you might create a person's face, a bowl, or a swimming pool using the sandbox tools.

Another type of TIN-like surface, which the sandbox tools can work with, is called a \textit{polygon mesh}. A polygon mesh is similar to a TIN, but contains faces with more than three vertices.

**Note** - SketchUp's Sandbox From Scratch Tool and Sandbox From Contours Tool only create TINs, but you can import a polygon mesh or create a polygon mesh (manually) using other SketchUp tools.
Triangulation

Triangles in a TIN can be oriented in different directions. The orientation of triangles is referred to as triangulation. Notice in the previous image that some triangles are oriented vertically while others are oriented horizontally. This concept is important because some sandbox tools allow you to change the direction of the triangles as a way to further smooth TINs.

Creating a TIN

There are several ways to obtain a starting TIN as the foundation of your model. These are:

- Create or import contour lines and use the Sandbox From Contours Tool to create a TIN.
- Import an image of a site plan or contour map and trace its contours with the Freehand Tool. Then, adjust the contours to their proper elevation and use the Sandbox From Contours Tool to create a TIN.
- Import a TIN using the SketchUp ArcGIS Plug-in available at www.http://www.sketchup.com/markets/gis.php. ArcGIS is an industry standard application suite or Geographic Information System for working with geographical information such as the location of buildings within a world-wide global coordinate system.
- Import a digital terrain model (DTM) file.
- Create sandbox (TIN) using the Sandbox From Scratch Tool.

Modifying a TIN

SketchUp contains several tools for modifying TINs. The following table lists all of the sandbox tools in SketchUp.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Type</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sandbox From Scratch</td>
<td>Create TIN</td>
<td>Creates a flat, rectangular shaped, TIN or sandbox that can be modified by other sandbox tools.</td>
</tr>
<tr>
<td>Sandbox From Contours</td>
<td>Create TIN</td>
<td>Creates TIN or a sandbox from contour lines at various elevations.</td>
</tr>
<tr>
<td>Smoove</td>
<td>Large Modifications</td>
<td>Allows you sculpt or make large modifications to a TIN by moving groupings of vertices to create hills, berms, or other features.</td>
</tr>
<tr>
<td>Stamp</td>
<td>Large Modifications</td>
<td>Allows you to sculpt or make large modifications to a TIN by stamping footprints into the TIN, such as the footprint of a building.</td>
</tr>
<tr>
<td>Drape</td>
<td>Large Modifications</td>
<td>Allows you to drape the outlines of roads, paths and buildings, drawn on a flat plane, onto a TIN.</td>
</tr>
<tr>
<td>Add Detail</td>
<td>Small, Detailed,</td>
<td>Allows you to sculpt or make small, detailed, modifications to the a TIN by adding additional triangles to a TIN.</td>
</tr>
<tr>
<td>Flip Edge</td>
<td>Small, Detailed,</td>
<td>Allows you to sculpt or make small, detailed, modifications to the TIN.</td>
</tr>
</tbody>
</table>
Modifications

TIN by adjusting the triangulation of a TIN.

Note - The sandbox tools can also be used to create organic geometry or geometry that appears to be hand-crafted.

Functional Terrain

The term functional terrain is used to describe terrain that has no portion bending back upon itself creating overhangs, underhangs, or caves. If you draw a vertical line through your terrain at any point and the line only touches the terrain at one point, your terrain is functional.

This concept is important because certain tools, such as the Smoove Tool, can create unexpected results when working on nonfunctional terrain (the neighboring points included in the sculpting operation by the Smoove Tool are often undesirable).
Welcome to the SketchUp Getting Started Guide

Introduction to the SketchUp User Interface (Microsoft Windows)

The main parts of the SketchUp user interface are the title bar, menus, Toolbars, drawing area, status bar, and the Measurements Toolbar. The following image shows the SketchUp user interface.

Title Bar
The title bar contains the standard Microsoft Windows controls (close, minimize, and maximize) on the right, and the name of the currently opened file.

A blank drawing area appears when you start SketchUp. The title bar displays the name of the blank file as "Untitled," indicating that you have not yet saved your work.

Menus
Menus appear below the title bar. The majority of SketchUp tools, commands, and settings are available within these menus. The menus are: File, Edit, View, Camera, Draw, Tools, Window, and Help.

Toolbars
The Toolbars appear below the menus and along the left side of the application, contain a user-defined set of tools and controls.
Note - SketchUp starts with the Getting Started Toolbar. Additional Toolbars can be displayed by selecting the Toolbars under the View > Toolbars menu item.

Drawing Area
The drawing area is where you create your model. The 3D space of the drawing area is identified visually by the drawing axes. The drawing axes are three colored lines, perpendicular to each other. These axes are helpful in providing a sense of direction in 3D space while you work.

The drawing area also contains a simple model of a person to give you a sense of 3D space.

Status Bar
The status bar is the long gray rectangular area below drawing area.

The left side of the status bar displays tips for the currently used drawing tools, including special functions accessible using keyboard shortcuts. Watch the status bar to discover advanced capabilities of each of the SketchUp tools.

Note - Use the resize handle to make the drawing area larger so you can see the entire message in the status bar.

Measurements Toolbar
The Measurements Toolbar is located on the right side of the status bar. The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate currently selected entities, such as creating a line of a specific length.

Window Resize Handle
To the right of the Measurements Toolbar is the window resize handle which is used to change the size of the application window.

Video - Watch the following video to learn a bit more about the SketchUp user interface.
Introduction to the SketchUp User Interface (Mac OS X)

The SketchUp user interface is designed to be simple and easy to use. The main parts of the SketchUp user interface are the title bar, menus, Toolbars and tool palettes, drawing area, status bar, and the Measurements Toolbar.

Note - The previous image contains a screenshot of the Google SketchUp Pro application. The Google SketchUp application looks the same.

Title Bar
The title bar (at the top of SketchUp) contains the standard Macintosh OS X window controls (close, minimize, and maximize) on the left, and a title bar collapse/expand button on the right. In the middle of the title bar is the name of the currently opened file. A blank drawing area appears when you start SketchUp and the name of the currently opened file is "Untitled" in the title bar, indicating that you have not yet saved your work.

Menus
Menus appear below the title bar. The majority of SketchUp tools, commands, and settings are available within these menus. The menus that appear by default are: SketchUp, File, Edit, View, Camera, Draw, Tools, Window, and Help.

Toolbars and tool palettes
The Toolbar, appearing below the menus, contains a set of user-defined controls. By default, the Toolbar contains the basic set of SketchUp tools, referred to as the getting started tools.

Additional tool palettes are found in the View > Tool Palettes submenu.
Drawing Area
The *drawing area* is where you create your model. The 3D space of the drawing area is identified visually by the *drawing axes*. The drawing axes are three colored lines, perpendicular to each other. These axes are helpful in providing a sense of direction in 3D space while you work.

The drawing area also contains a simple model of a person to give you a sense of 3D space.

Status Bar
The status bar is the long gray rectangular area at the bottom of the drawing area.

The left side of the status bar displays tips for the currently used drawing tools, including special functions accessible using keyboard shortcuts. Watch the status bar to discover advanced capabilities of each of the SketchUp tools.

- **Note** - Use the resize handle to make the drawing area larger so you can see the entire message in the status bar.

Measurements Toolbar
The Measurements Toolbar is located on the right side of the status bar. The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate currently selected entities, such as creating a line of a specific length.

Window Resize Handle
To the right of the Measurements Toolbar is the window resize handle which is used to change the size of the drawing area.

- **Video** - Watch the following video to learn a bit more about the SketchUp user interface.
Using the Mouse in SketchUp

SketchUp can work with both 3-button and 1-button (commonly found on Mac computers) mice. A 3-button mouse is preferred as it will greatly increase your efficiency with SketchUp. You must learn different mouse operations before you can begin drawing in SketchUp.

Using a 3-Button Mouse

A three-button mouse consists of a left mouse button, a middle-mouse button (also called the scroll wheel) and a right-mouse button. The following is an overview of the different mouse operations commonly performed in SketchUp with a three-button mouse:

- Click - A click refers to the user quickly pressing the releasing the left-mouse button.
- Click and hold - A click and hold refers to the user pressing and holding down the left-mouse button.
- Click, hold, drag - A click, hold, and drag operation refers to the user pressing and holding down the left-mouse button and then moving the cursor.
- Middle click, hold, drag - A middle click, hold, drag operation refers to the user pressing and holding down the middle-mouse button and then moving the cursor.
- Scroll - A scroll refers to a user spinning the middle mouse wheel.
- Context-click - A context-click refers to pressing and holding the right-mouse button. Context-clicks are usually used to display context menus. Context menus are menus whose contents vary depending on the context in which they are invoked (usually on one or more entities in the drawing area or within a user interface component, such as a dialog box). The following image shows a context menu for a Face entity.
Using a 1-Button Mouse

The following is an overview of the different mouse operations commonly performed in SketchUp with a one-button mouse:

- Click - A click refers to the user quickly pressing the releasing the mouse button.
- Click and hold - A click and hold refers to the user pressing and holding down the mouse button.
- Click, hold, drag - A click, hold, and drag operation refers to the user pressing and holding down the mouse button and then moving the cursor.
- Scroll - A scroll refers to a user spinning the mouse ball (found on some Mac computers).
- Context-click - A context-click refers to pressing and holding the control key while simultaneously pressing clicking the mouse button. Context-clicks are usually used to display context menus. Context menus are menus whose contents vary depending on the context in which they are invoked (usually on one or more entities in the drawing area or within a user interface component, such as a dialog box). The following image shows a context menu for a Face entity.

![Context Menu](image)

**Video** - Watch the following video to learn a bit more about using the mouse in SketchUp.
Working in 3D

Creating models in SketchUp primarily consists of two operations:

- Viewing models in 3D space using the camera tools (rotate, zoom in, zoom out, and pan)
- Creating 2D faces or shapes and transforming 2D faces, using the Push/Pull Tool, into a 3D geometry.

**Video** - Watch the following video covering these two operations.
Viewing a Model in 3D Space

SketchUp implements the concept of a camera to represent your point of view of the model. Simply, you (the user) are treated as though you were a camera looking at your model as you work.

There are several tools in SketchUp for viewing your model in 3D space. The most commonly used camera tools are the Orbit tool, Pan tool, Zoom tool, and Zoom extents tool.

Preparing to Use the Viewing Tools

You must have a model in the drawing area before we can practice viewing. By default, SketchUp contains a model of a person at the origin of the axes. You can use that model for the purposes of these exercises. Or, follow these steps to place one of SketchUp’s pre-built models into the drawing area:

1. Click on "Window > Components." The Component Browser is displayed.
2. Click on the "Collections and Searches" drop-down list identified by a downward arrow.
3. Click on the Architecture collection. Architectural components are listed.
4. Click on one of the pre-built architectural models, such as the bed.
5. Move your cursor into the drawing area. The model you choose will follow the cursor.
6. Click anywhere in the drawing area to place the model. The model will be positioned in the drawing area.

Using the Orbit Tool

Use the Orbit Tool to rotate the camera about the model and is often used while drawing to quickly change your view in between drawing operations. Activate the Orbit Tool from either the Camera Toolbar or the Camera menu. To orbit your model:

1. Click on the "Orbit Tool" in the Toolbar. The cursor changes to two interconnected perpendicular ovals.
2. Click anywhere in the drawing area.
3. Move your cursor in any direction to rotate around the center of the drawing area.

Using the Orbit Tool (3-Button Mouse)

A 3-button mouse allows you to orbit a model without exiting the current drawing tool, speeding up your drawing. To orbit with a 3-button mouse:

1. Click on the "Pencil Tool" in the Toolbar. The cursor changes to a pencil.
2. Click and hold the middle-mouse button. The cursor changes to the Orbit Tool cursor.
3. Move your cursor in any direction to rotate around the center of the drawing area (continue to keep your finger pressed on the middle mouse button).
4. Release the middle-mouse button to return to the Pencil Tool. The cursor changes back to a pencil (-pencil).

Using the Pan Tool
Use the Pan Tool to move the camera (your view) vertically and horizontally. Activate the Pan Tool from either the Camera Toolbar or the Camera menu. To pan using the Pan Tool:

1. Click on the "Pan Tool" (Pan Tool). The cursor changes to a hand (hand).
2. Click anywhere in the drawing area.
3. Move the cursor in any direction to pan.

Using the Pan Tool (3-Button Mouse)
A 3-button mouse allows you to pan your view without exiting the current drawing tool, speeding up your drawing. To orbit with a 3-button mouse:

1. Click on the "Pencil Tool" (Pencil Tool) in the Toolbar. The cursor changes to a pencil (pencil).
2. Press and hold the "Shift" key.
3. Press and hold the middle-mouse button. The cursor changes to the Pan Tool cursor (hand).
4. (optionally) Press and hold the left mouse button while pressing and holding the middle mouse button (scroll wheel) to activate the Pan Tool.

Using the Zoom Tool
Use the Zoom Tool to move the camera (your view) in or out. Activate the Zoom Tool from either the Camera Toolbar or the Camera menu.

1. Click on the "Zoom Tool" (Zoom Tool) in the Toolbar. The cursor changes to a magnifying glass (magnifying glass).
2. Click and hold anywhere in the drawing area.
3. Drag the cursor up to zoom in (closer to the model) and down to zoom out (farther from the model).

Using the Zoom Tool (3-Button Mouse)
A 3-button mouse allows you to zoom in or out without exiting the current drawing tool, speeding up your drawing. To zoom with a 3-button mouse:

1. Click on the "Pencil Tool" (Pencil Tool) in the Toolbar. The cursor changes to a pencil (pencil).
2. Roll the scroll wheel (middle-mouse button) forward to zoom in on your model.
3. Roll the scroll wheel (middle-mouse button) back to zoom out from your model.
Using the Zoom Extents Tool

Use the Zoom Extents Tool to zoom your view to a distance where the whole model is visible and centered in the drawing area. Activate the Zoom Extents Tool from either the Camera Toolbar or the Camera menu. The Zoom Extents Tool is often used when your model goes off screen or you find yourself confused about the view of your model. Click on the "Zoom Extents Tool" ( ) in the Toolbar. Your model is centered in the drawing area.
Creating Geometry With the Push/Pull Tool

Use the Push/Pull Tool to push and pull faces to add volume to or subtract volume from your models. You can use push/pull to create volume out of any face type, including circular, rectangular, and abstract faces. Activate the Push/Pull Tool from either the Toolbar or the Tools menu.

Preparing to Use the Push/Pull Tool

Start a new file before continuing with the next exercise. To start a new file:

1. Select "File > New." A dialog box is displayed asking if you want to save your changes.
2. Click on the No button. A new, blank, drawing area appears.
3. Click on the "Rectangle Tool" ( ). The cursor changes to a pencil with a rectangle ( ).
4. Click anywhere in the drawing area to set the first corner point of the rectangle.
5. Move the cursor diagonally. A rectangle will expand out from the first corner point.
6. Click again to set the second corner of the rectangle. A rectangular face is created bordered by four edges.

Using the Push/Pull Tool

To push or pull a face:

1. Click on the "Push/Pull Tool" ( ). The cursor will change to a 3D rectangle with an up arrow ( ).
2. Click on the rectangular face created in the previous exercise.

4. Move the cursor to create (or decrease) volume.

Note - Press the "Esc" key at any point during the operation to start over.

5. Click when the volume has reached the desired size.

Note - You can also press and hold the mouse button, drag the mouse, and release the mouse button to create a volume.

You can use the Push/Pull Tool to create volume from any shape, whether it be an abstract shape drawn using the Freehand Tool or a shape drawn on another piece of 3D geometry. Following are some examples of Push/Pull operations.
Pushing and Pulling a Curved Face

You can use the Push/Pull Tool on faces that have an arc as an edge similarly to using the Push/Pull Tool on regular faces. The curved face that results from the push/pull operation is called a Surface entity. Surfaces can be adjusted as a whole, but are comprised of a number of faces or a curved face set.
Creating Voids with Push/Pull

You can create a void, or empty space, simply by drawing a 2D shape on 3D geometry and using the Push/Pull Tool to push the 2D face until it meets the back face of the 3D geometry. The following three images demonstrate how to push/pull a 2D face that is drawn on 3D geometry to create a void.

Video - Watch the following video for a little more on using the Push/Pull tool.
Drawing Shapes with the Circle, Arc, and Rectangle Tools

The majority of drawing tools in SketchUp, such as the Circle, Arc, and Rectangle Tool, are designed to speed up what can be drawn using the Pencil Tool.

Drawing Circles

Use the Circle Tool to draw circle entities. Activate the Circle Tool from the Toolbar or the Draw menu. To draw a circle:

1. Select the "Circle Tool" ( ). The cursor changes to a pencil with a circle.
2. Click to place the center point of the circle.
3. Move the cursor out from the center point to define the radius of your circle. As you move the cursor, the radius value is displayed dynamically in the Measurements Toolbar and can be specified by typing in a length value followed by pressing the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. You can also specify the segmentation for the circle in the Measurements Toolbar.
4. Click to finish the circle.

Tip - You can also click and hold the mouse button to set the center of the circle, and drag outward without releasing the button to set the radius. Release the mouse button to complete the circle.

Drawing Arcs

Use the Arc Tool to draw Arc entities, comprised of multiple line segments (which can be edited as a single arc). Activate the Arc Tool from the Toolbar or from the Draw menu.

Arc entities consist of three parts: the starting point, the ending point and the bulge distance. The distance between the starting point and the ending point is also known as the chord length. To draw an arc:

1. Select the "Arc Tool" ( ). The cursor changes to a pencil with an arc.
2. Click to place the starting point of your arc.
3. Move the cursor to the ending point of your chord.
4. Click to place the ending point of your arc. A straight line is created.
5. Move your cursor perpendicular to the straight line to adjust the bulge distance. A straight line will extend perpendicular from the straight line.

![Diagram showing a line with a bulge distance adjustment](image)

**Note** - Press the "Esc" key at any point during the operation to start over.

6. Click to set the bulge distance.

**Drawing Rectangles**

Use the Rectangle Tool to draw rectangular Face entities, specified by clicking at two opposite corners of the desired shape. Activate the Rectangle Tool from either the Toolbar or Draw menu.

Rectangles can be placed on existing faces or separate from existing geometry (aligned to an axes plane). To draw a rectangle:

1. Select the "Rectangle Tool" ( ). The cursor changes to a pencil with a rectangle.
2. Click to set the first corner point of the rectangle.
3. Move the cursor diagonally.

**Note** - Press the "Esc" key at any point during the operation to start over.

4. Click again to set the second corner point of the rectangle.
Creating Your First Model

It will take some time to master SketchUp as with any new software. However, following is a project to help you learn the tools and concepts covered in this document.

Creating a Chair in SketchUp: The Subtractive Approach

You will create a chair by subtracting volume from a 3D form in this exercise. This exercise is accomplished by creating the profile of a chair on a 3D form and then using the Push/Pull tool to remove the pieces of the form that will not be in the final model. To create a chair using a subtractive approach:

1. Select the "Rectangle Tool" ( ). The cursor changes to a pencil with a rectangle ( ).
2. Click to set the first corner point of the rectangle.
3. Move the cursor diagonally.
4. Type "18,18" and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. Your dimensions appear in the Measurements Toolbar and the rectangle will snap to 18 by 18 inches.

5. Zoom, orbit, and pan to such that your rectangle is large enough to push/pull with the Push/Pull Tool. Refer to Viewing a Model in 3D Space for further information.
6. Select the "Push/Pull Tool" ( ). The cursor will change to a 3D rectangle with an up arrow ( ).

7. Click on the rectangular face.

8. Move the cursor to create (or decrease) volume.

9. Type "4" and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. Your dimensions appear in the Measurements Toolbar and the rectangle will expand up and snap to 4 feet.

10. Select the "Line Tool" ( ) in the Toolbar. The cursor changes to a pencil tip ( ).
11. Draw a line from a top, horizontal, edge, (vertically) about half-way down your model.

12. Draw a line from the ending point of the last line horizontally until you meet a vertical edge.
13. Select the "Rectangle Tool" ( ). The cursor changes to a pencil with a rectangle ( ).

14. Draw a rectangle to represent the space between the legs of the chair. The profile of a chair is now drawn on one side of your model.

15. Select the "Push/Pull Tool" ( ). The cursor will change to a 3D rectangle with an up arrow ( ).
16. Click on the rectangular face you just drew between the legs.

17. Push the rectangular face until it meets the back of the model. The tool tip should say "on face" when the cursor has met the back face of the model.
18. Click to remove the area below the seat of your chair. The area below the seat of your chair should disappear.

19. Remove the area above the seat and against the back by repeating the process you just used to remove the area below the seat. Your model should now closely resemble a 3D chair (without individual legs).
20. Zoom, orbit, and pan under the chair so that you are facing the back legs.
21. Use the "Rectangle Tool" to draw a rectangle that represents the space between the two back legs.
22. Use the "Push/Pull Tool" to remove the area between the back legs.

23. Repeat the three previous steps with the front legs.

24. Draw an arc across the top of the back starting just below the left side of the back of the chair. A separate face will be created at each corner of the top of the chair.
24. Use the "Push/Pull Tool" to remove the two areas at the top of the chair and create a rounded chair back.

25. Zoom, orbit, and pan to such that you can view the chair in its normal, upright, position. Refer to Viewing a Model in 3D Space for further information.

Video - Watch the following video to learn a bit more about the steps in this project.

Creating a Chair in SketchUp: The Additive Approach

You will create a chair by starting with a chair seat and adding the legs and back. To create a chair using an additive approach:

1. Select the "Rectangle Tool" ( ). The cursor changes to a pencil with a rectangle ( )
2. Click to set the first corner point of the rectangle.
3. Move the cursor diagonally.
4. Type "18,18" and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. Your dimensions appear in the Measurements Toolbar and the rectangle will snap to 18 by 18 inches. You are creating a chair seat.
5. Zoom, orbit, and pan to such that your rectangle is large enough to push/pull with the Push/Pull Tool. Refer to Viewing a Model in 3D Space for further information.

6. Select the "Push/Pull Tool" ( ). The cursor will change to a 3D rectangle with an up arrow ( ).

7. Click on the rectangular face.

8. Move the cursor to create the seat thickness.

9. Draw a line toward the back of the seat to represent the profile of the seat back.
10. Use the "Push/Pull Tool" on this rectangle to create the seat back.

11. Draw an arc across the top of the back starting just below the left side of the back of the chair. Two separate faces will be created at each corner of the top of the chair.
12. Use the "Push/Pull Tool" to remove the two areas at the top of the chair and create a rounded chair back.

![Push/Pull Tool](image)

13. Zoom, orbit, and pan to such that you can view the bottom of the chair seat. Refer to Viewing a Model in 3D Space for further information.

14. Select the "Tape Measure Tool" ( ). The cursor changes to a tape measure with a plus sign (+).

15. Click on one edge of the chair bottom.

16. Move the cursor to away from the edge. A guide line will be drawn perpendicular to the line. Guide lines help you draw geometry to a specific dimension.
17. Type "2" and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. Your dimensions appear in the Measurements Toolbar and a guide will be created 2" away from the edge.

18. Repeat steps 15-17 to create three more guides. Your model should look like the following:
19. Use the "Rectangle Tool" to create the profiles of each chair leg within each corner of the chair bottom. The Rectangle Tool will snap to each guide in the corner to make accurate 2" x 2" legs. The following picture shows the resulting four rectangular faces in each corner of the chair bottom.
20. Use the "Push/Pull Tool" to create the legs from the four faces created in the previous step. You can use inference to align length of the second through fourth leg to the length of the first leg.
21. Use the "Eraser Tool" to erase all of your guide lines.
22. Zoom, orbit, and pan to such that you can view the chair in its normal, upright, position. Refer to Viewing a Model in 3D Space for further information.

Video - Watch the following video to learn a bit more about the steps in this project.
**Next Steps**

All of the principles used in creating the chair are also used to creating models of houses, people, cars, and anything else in SketchUp. For Further Help:

- Watch Video Tutorials
- Read the User's Guide and Reference Guide
- Participate in the Google SketchUp Online Group
Welcome to the Dynamic Components Getting Started Guide

The Dynamic Components Getting Started Guide contains an overview of dynamic components from both end-user (someone who uses these components in their scenes) and developer (someone who develops these components) perspectives.
Dynamic Components

Components are pre-built models that you can reuse within your SketchUp models and scenes. Pre-built components are available from the Component Browser (Window > Component Browser). Any model you create can be a component.

Dynamic components are components that have parametrics, such as a stair component that, when resized, automatically adds more steps, or a cabinet component whose doors can open and close.

Components are made "dynamic" by attaching attributes to the component. Attributes are items such as the component's name, description, size, location, and number of copies. Some attributes, such as those mentioned previously, are predefined attributes, meaning they are automatically available for every dynamic component. Conversely, custom attributes are unique attributes defined by the developer of the dynamic component. Refer to Dynamic Components Predefined Attributes for further information.

Every component attribute has a value which can be a textual string, a number, or the result of a formula (which is usually a number or text). For example, the attribute called "Name" might have the value of "Fence," or the attribute called "LenX" might have the value of "4," or the attribute "TotalCost" might have the value equal to the result of "SquareFeet * CostPerFoot). Each attribute and associated value is called an attribute name/value pair.

Formulas can consist of predefined functions, mathematical operators (*, -, +, /, <, >, and so on), or the values of other attributes. Functions are shortcuts that perform some operation, such as calculating the square root of a number. Refer to Dynamic Components Supported Functions and Dynamic Components Supported Operators for further information.

Note - All SketchUp users can use dynamic components. However, only SketchUp Pro users can develop dynamic components.

Note - A component is only dynamic when it has parametric data. Dynamic Components will display a special badge when it contains parametric data. Refer to Identifying Dynamic Components for further information.

Tip - Experience with spreadsheet formulas will be helpful in developing dynamic components.

Common Features of Dynamic Components

Following are six common features of dynamic components. Most dynamic components will implement one or more of these features..
Constrained
Dynamic components can have values (such as size values) that are constrained, yielding a component whose parts might not be scalable (using the Scale Tool), or only scalable in a certain direction. For example, a dynamic cabinet door component might have a frame of a set size (such as 3 inches). The following image shows a cabinet door with a 3" thick frame:
The following picture shows the same cabinet door after it has been scaled larger. Notice that the frame around the door has maintained its size (it is constrained to 3 inches).

Constraints are usually placed on components that represent manufactured products that come in a series of pre-defined sizes (such as doors, cabinets, appliances, mattresses, windows, or even bicycle frames).
Repetitive
A dynamic component can have sub-components that repeat when the component is scaled, such as a stair component that automatically adds steps when scaled. Following is an image of a repeating stair component before it has been scaled:

Following is the repeating stair component after it has been scaled using the Scale Tool. Notice that additional stairs have automatically been added as the size increased.
Repetition might be used in a variety of dynamic components such as stairs (number of steps), couches (number of cushions), fences (number of pickets), construction framing (number of studs), and so on.

**Configurable**
A dynamic component can have a pre-defined set of values that are configurable by the user, such as lengths for a couch or amount of spacing between pickets in a fence component. The following is an example of the Component Options dialog box that is displayed for a dynamic component that is configurable.

![Component Options dialog box](image)
Animated
A dynamic component can have animated sub-components that move when the user clicks on the component with the Interaction Tool. The following image shows a door frame and door.

The following image shows the door opened after it has been clicked on with the Interaction Tool.

Animations can be found in components that represent real-world objects that have moving parts. These objects include doors, windows, and appliances.
Configuring a Dynamic Component

Some dynamic components are configurable by users through the Component Options dialog box. To configure a component:

1. Context-click on the component. The component's context menu is displayed.
2. Select the "Dynamic Components > Component Options" menu item. The Component Options dialog box is displayed. The following is an image of the Component Options dialog box for a Fence dynamic component:

![Component Options Dialog Box for Fence](image)

This picket fence component is a good example of using the copy attribute to create repeating parts as something changes overall size. Configurable options like board sizes are presented to the end user in the form of questions. Overall length of the fence is adjusted with the scale tool. Notice that most scale grips are hidden to prevent scaling in prohibited directions.

3. Type values in fields or select options from drop-down menus as applicable. For example, the Fence component has a Slat Spacing drop-down list. Select one of the four options from this list.
4. Click the Apply button to apply your configuration changes to the component. The component's geometry should reflect changes in the Component Options dialog box.
Developing a Dynamic Component

Google SketchUp Pro users can develop dynamic components for use by any SketchUp user. Developing a dynamic component consists of the following high-level steps:

1. Create a new component that is comprised entirely from groups or sub-component instances, each with a unique name.
2. Context-click on the component. The component's context menu is displayed.
3. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed. This dialog box is a two-column spreadsheet of attribute name and value pairs. This spreadsheet follows general spreadsheet rules:
   1. Use the Tab key to tab between fields or to accept a value.
   2. Use the equals sign (=) to assign a value or formula to a variable
   3. Use an exclamation point (!) to refer to a value outside of the current sub-component. For example, Fence!spacing refers to the value of the spacing variable in the Fence component.
4. Add variables and values to your component to make it dynamic.
5. Test your component to ensure it works correctly.
6. Save your component to a component file.

This concludes the Dynamic Component Getting Started Guide.
Welcome to the SketchUp User's Guide

The SketchUp User's Guide contains step-by-step instructions on how to perform most all basic SketchUp tasks. The content in this guide answers the "How Do I..." questions of end-users.
Deleting 2D Person Component

SketchUp opens with a 2D person standing at the origin of the axes. To delete this 2D person component:

1. Click on the "Select Tool." The icon turns to an arrow.
2. Click on the 2D person component. The component is highlighted.
3. Press the "Delete" key on your keyboard. The 2D person component is deleted.
Detaching Toolbars (Microsoft Windows)

These Toolbars can be detached by clicking and dragging the move handle (thin line at the top) of the Toolbar, resized by dragging the corners, and reattached or docked to the edge of the drawing area to suit your preferences.
Using the Layers Toolbar (Microsoft Windows)

The Layers Toolbar provides quick access to several often used layer operations.

Display the Current Layer
When nothing is selected, the current layer name is displayed in the Toolbar and has a check mark next to it. Any new entities you draw will be assigned to the current layer.

Change the Current Layer
Select a layer from the Layers Toolbar, when nothing is selected, to change the current layer.

View Entity's Layer
Select an entity. The layer for the entity will be displayed, with a check mark, in the Layers Toolbar.

Change the Layer Assignment of Entities
Select an entity and then a layer from the Layer Toolbar to change the layer of an entity.

Display the Layers Manager
The button on the right hand side displays the Layers Manager allowing you to create new layers, control their visibility, and more.
Viewing Tool Tips (Microsoft Windows)

Hover over a tool to display a tool tip with the name of the tool. A longer tip will appear in the Status Bar when you activate a tool.
Customizing the Toolbar (Mac OS X)

You can modify the Toolbar by adding, removing, and repositioning controls within the Toolbar. To customize your Toolbar:

1. Select "View > Customize Toolbar," or Context-click on the Toolbar and select "Customize Toolbar" from the context menu, to customize the controls that are visible in the Toolbar. The Customize Toolbar dialog box appears.

2. Perform one of the following Toolbar customizations:
   - Drag the controls from the Customize Toolbar dialog box, to the desired position in the Toolbar, to add a control to the Toolbar.
   - Drag a control from the Toolbar and drop it anywhere outside of the Toolbar to delete a control. A smoke cloud will appear indicating that the control has been removed.
   - Drag a control left or right, within the Toolbar, to reposition the control.

3. Click the "Done" button in the Customize Toolbar dialog box when you have finished customizing your Toolbar.

   **Note** - Remove all of the controls from your Toolbar and drag the default set of controls to your Toolbar to reset the Toolbar controls to its original state.
Showing and Hiding Tool Palettes (Mac OS X)

SketchUp displays the Getting Started tool palettes by default. To show or hide other tool palettes:

1. Select "View > Tool Palettes." The Tool Palettes sub-menu displays.

2. Select any Toolbar to show or hide. Toolbars with a checkmark are currently displayed. Toolbars without a checkmark are not currently displayed.
Viewing Tool Tips (Mac OS X)

Hover the mouse cursor over a tool to display the name of the tool. A longer help tip will appear in the Status Bar when you activate a tool.
Aligning the Point of View to the Current View

You can align SketchUp's point of view to be perfectly aligned with the current view. To align the point of view to the current view:

1. Context-click on the drawing axes. The drawing axes context menu is displayed.
2. Select "Align View" from the context menu.
Determining Axis Relationship to Real-World 3D Space

Each axis has a solid line on one side of the origin and a dotted line on the other side of the origin. Following is an explanation for each line that make up the origin:

- The solid blue line leads up from the origin up.
- The dotted blue line leads down from the origin.
- The solid red line leads east from the origin.
- The dotted red line leads west from the origin.
- The solid green line leads north from the origin.
- The dotted green line leads south from the origin.

A Real-World 3D understanding of the axis is important when you placing models in Google Earth or casting realistic shadows.
Hiding the Drawing Axes

You can display or hide the drawing axes from the View menu. You can also hide the drawing axes from the drawing axes's context menu (when the drawing axes are visible).
Moving and Rotating the Drawing Axes Relative to Current Position

You can quickly and accurately move and rotate the drawing axes relative to their current position using the Move Sketching Context dialog box. To move and rotate the drawing axes:

1. Context-click on the drawing axes. The drawing axes context menu is displayed.
2. Select "Move" from the context menu. The Move Sketching Context (Microsoft Windows) or Move Axes (Mac OS X) dialog box is displayed. The following image shows the Move Sketching Context dialog box on Microsoft Windows:

![Move Sketching Context Dialog Box](image1)

3. Specify displacement and rotation values in the units specified under the Units panel of the Model Info dialog box.
4. Click the "OK" button.
Moving the Drawing Axes

The drawing axes can be manipulated (moved, moved and rotated, and hidden) through their context menu. To move the drawing axes:

1. Context-click on the Drawing Axes and select "Place" from the context menu. The cursor changes to a collection of axes.

2. Move your cursor to the point in your model to be the new coordinate origin. You will see the axes snap to inferred alignments and points as you move around your model.

3. Click to accept the new coordinate origin.

4. Drag your cursor away from the origin to set an alignment for the red axis. Use the inference tool tips to make sure you are aligned precisely.

5. Click to accept the alignment.

6. Move your cursor away from the origin to set an alignment for the green axis. Use inference tool tips again to make sure you are aligned precisely.

7. Click again to accept the alignment.
Invoking a Context Menu

Context menus are invoked on entities by selecting one or more entities, holding down the Control key, and clicking the mouse button (single button mouse). Users with three-button or scroll-wheel mice can select one or more entities and click the right mouse button to invoke a context menu. This operation is referred to as a context-click.

Context menus are invoked on user interface components, such as a dialog box, by clicking the right mouse button while the cursor is on the component (three button mouse) or holding down the Control key and clicking the mouse button (single button mouse).
Encouraging an Inference

At times, the inference you need may not come up immediately or SketchUp might choose alignments with the wrong geometry. In these cases, you can increase the chances of a particular alignment by pausing your mouse cursor over the particular location that you want SketchUp to infer from. When the visual cue appears, SketchUp will briefly prioritize that alignment as you continue drawing. For example, to encourage SketchUp to create a line to match another, parallel, line (such as when drawing the third line of a rectangle):

1. Create the first two edges of a rectangle with the first edge being parallel to the red axes.

2. Click on the start point of the third edge and move the line tool as though you were creating the third line parallel to first line. As you begin to move the Line Tool, the line should appear in red.

3. Mid-line creation, move the Line Tool over the start point of the start point of the first line you created for the rectangle. Your line will extend diagonally to this point.

4. Leave the tool over this point until the Endpoint visual cue displays.

5. Move the Line Tool to the approximate location where the end of the third line should appear. A dotted line, with the color of the corresponding axes (green) will follow the Line Tool to indicate you are directly inline with the start point of the first line.

6. Click when the line you are drawing is indicated by an axes color (red) and is directly perpendicular to the green dotted line.
Locking an Inference

At times, geometry might interfere with your ability to infer points from other points, making it difficult to draw accurately. Use an inference lock, which tells SketchUp not to waver from the direction it is currently inferring from, to solve this problem. To use the inference lock, press and hold the “Shift” key when SketchUp infers the desired alignment (the inference line will bold). The alignment will remain locked, even as you move the mouse and/or pick a secondary inference point. The following image shows the inference locked in the blue direction to ensure that a new line is exactly perpendicular to the face.

Any of the inference conditions may be locked; along an axis direction, along an edge direction, on a face, from a point, parallel or perpendicular to an edge, and so on.
Manipulating Dialog Boxes in a Dialog Box Stack

A dialog box stack refers to a series of dialog boxes snapped together at their bottom and top edges such that they form a stack. The following image contains a dialog box stack with the Shadow Settings dialog box opened in the middle. The following is an image of a dialog stack on Microsoft Windows:

![Screen shot of a dialog stack on Microsoft Windows](image)

The following is an image of a dialog stack on Mac OS X:

![Screen shot of a dialog stack on Mac OS X](image)

You can manipulate the dialog boxes in a dialog box stack in the following ways:

- Move the entire dialog box stack by clicking, holding, and moving the top-most dialog box's title bar.
- Click on any dialog box's title bar to minimize or maximize a dialog box within the stack.
- Move a dialog box, residing in the middle of the stack, to the right or left to break it from the stack. Move a dialog box, residing at the bottom of the stack, down to break it from the stack.
- Reinsert the dialog box at the beginning or end of the stack by snapping the dialog box to the bottom or top edge of the stack, respectively.
- Reinsert the dialog box in the middle of the stack by moving sideways into a middle position.
- Snap the entire dialog box stack to the application window or screen by moving it to the outer edge of the application window or screen.
Minimizing Dialog Boxes

Click on any dialog box's title bar to minimize or maximize the dialog box (even those that can not be placed in a dialog box stack).
Resizing Dialog Boxes

Some SketchUp dialog boxes, such as the Components Browser dialog box, can be resized. Move the cursor around the dialog box's edges to display a resize cursor (two arrows). Click on the edge and move the edge to resize the dialog box.
Snapping Dialog Boxes to Other User Interface Components

Some dialog boxes, such as the Styles Browser dialog box, automatically snap to the outside edges of the application window, the outer edge of the screen, with the top and bottom of other dialog boxes to create a *dialog stack*. To snap a dialog box to another user interface component:

1. Display a dialog box, such as the "Window > Styles" dialog box.
2. Click and hold on the dialog box's title bar.
3. Move the dialog box to the outside edge of the application window, outside edge of the screen, or top or bottom edge of another dialog box (such as the Shadow Settings dialog box). The dialog box will snap to and align with the edge.

**Note** - Dialog boxes that have been snapped to the application window do not move when the application window is moved (they are not stuck to the window).

**Tip** - Snap several dialog boxes together at their top and bottom edges to form a dialog box stack. Dialog boxes in a dialog box stack move with the stack when the top-most dialog box's title bar is moved.
Creating Models to Scale

You can create models that are not based on any scale, useful for drafting quick concepts, or are based on some scale, useful for creating a final produced product. Models that are not created based on some scale can be rescaled when accuracy becomes important.

- Use the Measure Tape Tool to rescale an entire model to a specific scale. See Scaling an Entire Model for further information.
- Use the Measurements Toolbar to provide specific dimensions as you draw. The values accepted by Measurements Toolbar depend on the tool you are using. See the Measurements Toolbar for further information.
Sharing Files Between SketchUp 7 and Other Versions of SketchUp

You can save SketchUp 7 files as SketchUp 6, 5, 4, or 3. To save a SketchUp file in a format compatible with earlier SketchUp versions:

1. Open the file in SketchUp 7. The file appears in the drawing area.
2. Select "File > Save As." The Save As dialog box appears.
3. Navigate to the directory where you want to save your file.
4. Select the file type from the Save as type drop-down list.
5. Click on the "Save" button. The file is saved.
Principal Tools

This section of the user's guide covers the principal tools within SketchUp. Principal tools are those tools that tend to be used most often in SketchUp.

Tools in this section are covered in the order they appear within the Tools menu.
Adding and Subtracting From a Selection Set

The Select Tool can be used with one or more keyboard modifiers to add or remove entities from a selection set.

Adding to the Selection Set

Press and hold the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key (the cursor will change to an arrow with a plus sign) while clicking on additional entities to add entities, one-by-one, to the selection set. Or, press and hold the "Shift" key (the cursor will change to an arrow with a plus and minus signs) while clicking on additional entities to add entities, one-by-one, to the selection set.

Changing Selection Status for an Entity (Shift)

Press and hold the "Shift" key (The cursor will change to an arrow with plus and minus signs) while clicking on entities to invert the selection status of the entity (currently selected entities will become unselected, unselected entities will be come selected).

Subtracting from the Selection Set

Press and hold the "Shift" and "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) keys simultaneously (the cursor will change to an arrow with a minus sign) while clicking on currently selected entities to remove entities from the selection set. Or, press and hold the "Shift" key (the cursor will change to a plus sign and minus sign) while clicking on currently selected entities to remove the entities, one-by-one, from the selection set.

Tip - Use the Group entity to group items within a selection set as a temporary way of quickly reselecting the same group of items. See the Group entity for additional information.
Expanding the Selection Set Using the Mouse

You can automatically add to a selection set by clicking the mouse button (while in the Select tool) multiple times in rapid succession. Click once on an entity to select that entity. Click rapidly twice (double-click) on an entity, namely an edge or face, to select corresponding faces or edges respectively. Click three times (triple-click) on an entity, namely an edge or face, to select the edge or face and all entities physically connected to that edge or face. The following image shows this click/selection sequence.

Tip - Use a context-click to invoke the context menu for an entity. Many context menus have a Select submenu allowing you to expand a selection using one of the following commands: Bounding Edges, Connected Faces, All Connected, All on same layer, and All with same material.
Selecting Multiple Entities

There are multiple ways to select multiple entities in SketchUp. These ways are:

- Selecting multiple entities with a selection box
- Selecting connected entities using rapid mouse clicking
- Selecting connected entities using the Select context-menu item

Selecting Multiple Entities With a Selection Box

A selection box is an expandable temporary box used to select multiple entities. Selection box selections are useful when you want to perform a single operation on several connected or disconnected entities (the selection set). To select multiple entities:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.
3. Drag the mouse to expand the selection box over the elements you want to select.
   - Clicking to the right-side and dragging to the left, called a crossing selection, selects any elements within the selection rectangle, including those that are only partially contained in the rectangle. The following images show a right-to-left selection selecting two components, though none are completely within the bounds of the selection box.
Clicking to the left-side of the entities and dragging right, called a window selection, selects only those elements completely within the selection rectangle. The following image shows a left-to-right selection selecting one component because only one component (the left speaker) is completely within the bounds of the selection box.

4. Release the mouse button when all of the elements are either partially included (right-to-left selection) or fully included (left-to-right selection) in the selection box.

Selecting Connected Entities Using Rapid Mouse Clicking
Rapidly clicking the mouse button will select one or more additional connected entities. To select a face and its bounding edges:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Double-click on a face to select the face and all of its bounding edges. The selected entities are highlighted yellow.

To select just a face and an edge:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Double-click on an edge to select the connected face. The selected entities are highlighted yellow.
To select all entities connected to a single entity:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Triple-click rapidly on any entity, in a set of connected entities, to select all of the connected entities. For example, if you triple-click a face in a cube, the entire cube is selected. Selected entities are highlighted in yellow.

Selecting Connected Entities Using the Select Context-Menu Item

Use the Select context-menu item to select entities based on their specific relationship to the currently selected entity. To use the Select menu item:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Context-click on a single entity, such as an edge or face. The entity's context-menu appears.
3. Select the "Select" menu item. A sub-menu appears.
4. Select one of the Select sub-menu items:
   - Select "Bounding Edges" if you want to select all the bounding edges of a selected face.
   - Select "Connected Faces" to select all of the faces connected to the selected entity.
   - Select All "Connected" to select all entities connected to the selected entity (this is identical to performing a triple-click on the entity).
   - Select "All on same Layer" to select all the entities on the same layer as the selected entity.
   - Select "All with same Material" to select all the entities on with the same material as the selected entity.
Selecting or Unselecting All Geometry

Select "Edit > Deselect All," press "Ctrl+T" (Microsoft Windows) or "Shift+Command+A" (Mac OS X) or click on any empty space in the drawing area to deselect all currently selected entities.
Selecting a Single Entity

SketchUp allows you to make both single-entity and multiple-entity selections. To select a single entity:

1. Select the "Select Tool" ( ). The cursor changes to an arrow.
2. Click on an entity. The selected entity is highlighted in yellow.
Erasing Entities

As mentioned previously, the Eraser Tool is used to erase entities in the drawing area. Note, the Eraser Tool does not allow you to erase faces (faces are erased after their bounding edges are erased). To erase entities:

1. Select the "Eraser Tool" ( ). The cursor changes to an eraser with a small box.
2. Click on an entity to erase it. Alternatively, erase several entities at once by holding down the mouse button and dragging it over several entities to be erased. All selected geometry will be erased once you release the mouse button.

If you accidentally select geometry you do not wish to delete, press the Esc key to cancel the erase operation before it deletes your selection.

💡 Tip - Try erasing entities slowly if you continuously skip over entities you want to erase.

💡 Tip - It is usually faster to erase a large number of entities by selecting the entities with the Select Tool and pressing the Delete key on your keyboard. You can also delete selected items by selecting Erase from the Edit menu.

Hiding Lines

Press and hold the "Shift" key and use the Eraser Tool to hide lines (instead of erasing lines).
Softening/Unsoftening Edges

Press and hold the "Ctrl" (Microsoft Windows) or "Option" key (Mac OS X) key to soften/smooth edges (instead of erasing entities). Press and hold the "Shift" and "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) keys simultaneously to unsoften/unsmooth edges.
Applying Materials and Color

Ensure you are using either the Shaded or Shaded with Textures style so that you can see materials as they are applied to your model. To apply materials:

1. Select the "Paint Bucket Tool" ( ). The cursor will change to a paint bucket and the Material Browser is activated. The Materials Browser contains libraries of materials you can paint on faces in your model.

2. Select a materials library using the drop down list in the Materials Browser. SketchUp contains several default materials libraries, including landscape, roofing, and transparent materials.

3. Select a material from the materials library.

4. Click on the faces to paint. The material is assigned to the face.

Alternatively:

- (Mac OS X) Click and drag a material swatch from the Texture Pallet Picker and drop it on a single entity you want to color.
- (Mac OS X) Select several entities with the Select Tool and then click and drag a swatch from the library and drop it on one of the selected entities.
- Select the material you want to use and then select the Paint Bucket Tool. Click the Paint Bucket Tool's cursor over the entity or selection set you wish to color.

Note - Ensure that the Shaded with Textures display style is selected to see the materials that you have applied to entities.
Painting Groups and Components

Materials can be painted on entire Group entities or Component entities or to the individual entities within the group or component. To assign materials to an entire group or component:

1. Select the "Paint Bucket Tool." The cursor will change to a paint bucket and the Material Browser is activated. The Materials Browser contains libraries of materials you can paint on faces in your model.

2. Select a materials library using the drop down list box. SketchUp contains several default materials libraries, including landscape, roofing, and transparent materials.

3. Select a material from the library of materials.

4. Click on the group or component you want to paint. The faces will receive the material.

5. If you select multiple groups or components using the Select Tool, clicking on the selection with the Paint Tool will paint all of them with a single click.

⚠️ **Note** - If a face within a group or component is already painted with a material (other than the default material), before applying a material to the entire group or component, the face will not adopt the new material. For example, the windshields, bumpers, and tires in the following image were already painted before a material was applied to these components. Therefore, the windshields, bumpers, and tires maintained their original material.

⚠️ **Note** - Exploding a group or component assigns the object materials to any elements assigned the default material, thus making the material override permanent.
Face Painting Rules

There are several face painting rules that apply when painting multiple faces or edges at the same time. These rules follow:

- The side of the faces that will be painted depends on the side initially painted when more than one face is selected. For example, if all faces are selected and you paint the front of one face, the front of all faces will be painted. Conversely, if all faces are selected and you paint the back of one face, all back faces will be painted.

- All selected edges will be painted when you select a face and all edges and paint the front of the face. No edges are painted when you select a face and all edges and paint the back of one face. Ensure you have the color set to the "By material" style setting to see the painted effect applied to edges.
Sampling a Material

Press and hold the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key to change from the Paint Bucket Tool to a Sample Tool for sampling materials within your model. The cursor will change to an eye dropper. Click on the face whose material you want to sample. Release the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key to return to the Paint Bucket Tool. Paint the sampled material on a face.

Note - The sampled material is placed in the Active Color Well of the Color Picker, where it can be painted on new entities, modified, or used as the basis of a new material (Mac OS X).
Drawing Tools

This section of the user's guide covers the drawing tools within SketchUp. Drawing tools are those tools used to create new geometry. These tools include the Line Tool, Rectangle Tool, and Freehand Tool.

Tools in this section are covered in the order they appear within the Draw menu.
**Drawing a Line**

Lines can be placed on existing faces or separate from existing geometry. To draw a Line:

1. Select the "Line Tool" ( ). The cursor changes to a pencil.
2. Click to set the starting point of your line.

   **Note** - Press the "Esc" key at any point during the operation to start over.

3. Move the cursor to the ending point of your line. As you draw a line, the length is displayed dynamically in the Measurements Toolbar.

4. Click to draw your line. This ending point can also be the starting point of another line.

The line length can be specified precisely using the Measurements Toolbar either before clicking the second point or immediately after the line has been drawn. See Creating Precise Lines for further information on using the Measurements Toolbar with Line entities.

   **Tip** - Alternately, you can click and hold the mouse button to set the starting point of the line, and drag outward without releasing the button to set the length. Release the mouse button to complete the line. See the Drawing panel of the Preferences dialog box for further information on setting drawing behavior.
Creating a Face

The Line Tool will remain at the ending point of every line you create. This end point is automatically treated as a starting point for another line. You can create another line by moving the cursor and clicking again from this new starting point. These two lines are said to be coplanar, intersecting lines (intersecting at starting and ending points).

Three or more coplanar lines, intersecting at their ending and starting points (forming a loop), generate a Face entity. Ensure that the Endpoint inference tool tip is visible whenever you close a Face entity to ensure that any lines you draw are continuous. The Line Tool is released but is still active after a face has been created.
Drawing Lines by Inference

The Line Tool uses SketchUp's sophisticated geometric inference engine to help you place your lines in 3D space. The inference decisions, made by the inference engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between the line you are drawing and the geometry of your model. Refer to the inference engine topic for additional information.

Locking a Line to the Current Inference Direction

Press and hold the "Shift" key, while the line you are drawing is the specific color of an axis, to lock drawing operation to that axis.

Locking a Line to a Specific Inference Direction

Press and hold either the up arrow, left arrow, or right arrow keys, where the up arrow equals blue, left arrow equals green, right arrow equals red, while drawing a line to lock the line to a specific axis.
Creating Precise Lines

The Measurements Toolbar displays the length of your line while you are drawing lines. You can also specify a line length value using the Measurements Toolbar.

Entering a Length Value

The Measurements Toolbar label indicates "Length" after you place the starting point of a line. The following image shows the length value in the Measurements Toolbar.

![Length](image)

Type the length into the Measurements Toolbar, after placing the starting point of the line, and press the "Enter" (Microsoft Windows) or "Return" (Mac OSX) key. SketchUp will use the current document units setting if you only type in a numerical value. You can also specify either Imperial (1'6") or Metric (3.652m) units at any time, regardless the model units setting.

**Note** - The Line Tool will snap to any previously entered length within the Measurements Toolbar.

Entering a 3D Coordinate

The Measurements Toolbar can also be used to place the end of the line at an exact coordinate in space.

**Entering an Absolute Coordinate**

Type in the coordinates of a point in 3D space enclosed by brackets, such as [x, y, z], to get absolute coordinates relative to the current axes.

![Length](image)

**Entering a Relative Coordinate**

Type the coordinate points enclosed by angle brackets, in the format <x, y, z>, where x, y, and z values are relative distances from the starting point of your line.

![Length](image)

**Note** - The exact format for Measurements Toolbar entries will vary depending on your computer's Regional Settings. For European users, the list separator symbol may be a semi-colon instead of a comma, so the format would be [x;y;z].
Dividing a Line into Equal Segments

Line segments can be divided into any number of equal line segments. To divide a line into equal segments:

1. Context-click on a line.
2. Select "Divide" from the context menu. SketchUp will place points on the line to show where the line will be divided.
3. Move the cursor toward the center of the line to reduce the number of segments. Move cursor toward either end of the line to increase the number of segments.
4. Click on the line when the number of segments you would like is shown. The line will be divided into an equal number of joined line segments.
Splitting a Face

Draw a line with starting and ending points on the face's edges to split a face. The following image shows a rectangle being split when a line is drawn from one edge of a face to another opposite edge.

Integrating Lines

Occasionally, overlapping lines will not be split or integrate with a face. Any lines that are not part of a face perimeter will be displayed with a thicker line (left-most image below). The Profile Edge rendering style must be enabled in the style to see this behavior.

Use the "Line Tool" to trace along an existing line to attempt to split overlapping lines. SketchUp will re-analyze your geometry and attempt to reintegrate the line. The following images show a bold line that did not effectively split a face (left-most image). The line was traced (middle-image) and the line became thin indicating that the line was reintegrated.
Splitting a Line

SketchUp automatically splits line segments when new lines are drawn perpendicular to a line. For example, draw a new line to the midpoint (identified by a cyan square) of another line to split a line in half. The following example shows one line being intersected at the midpoint, resulting in two lines.

Select the original line to verify that the line has been split into two equal segments.
Editing a Line Entity

You can edit the length of a Line entity, that does not yet bound a face, by using the Move Tool. To edit an Line entity:

1. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.
2. Move over the Line entity to locate an endpoint of the Line entity.
3. Click and hold on the endpoint of the Line entity.
4. Move the cursor to adjust the length of the Line entity.

You can also adjust the length using the Line entity's Entity Info dialog box.
Drawing an Arc

Arc entities consist of three parts: the starting point, the ending point and the bulge distance. The distance between the starting point and the ending point is also known as the *chord length*. To draw an arc:

1. Select the "Arc Tool" ( vẽ ). The cursor changes to a pencil with an arc.
2. Click to place the starting point of your arc.
3. Move the cursor to the ending point of your chord.
4. Click to place the ending point of your arc. A straight line is created.
5. Move your cursor perpendicular to the straight line to adjust the bulge distance. A straight line will extend perpendicular from the straight line.

![A diagram of an arc being drawn with the starting and ending points marked.](image)

**Note** - Press the "Esc" key at any point during the operation to start over.

6. Click to set the bulge distance.

Chord length can be specified after you place the ending point of your arc. Bulge distance, radius, and number of segments can be specified using the Measurements Toolbar immediately after a arc is drawn. See Creating Precise Arcs for more information on manipulating arcs using the Measurements Toolbar.
Drawing a Half-Circle

The arc temporarily snaps to a half-circle as you pull out a bulge distance. Watch for the half-circle inference tool tip indicating when your arc is a half-circle.
Creating Precise Arcs

The Measurements Toolbar displays the chord length of the arc (after setting the starting point), then the bulge distance (after setting the ending point). Use the Measurements Toolbar to enter exact lengths for the chord length, bulge distance, radius value, and number of segments.

Note - SketchUp will use the current file units setting if you only type in a numerical value. You can also specify either Imperial (1'6") or Metric (3.652m) units at any time, regardless the file's units setting. Units are set within the Units panel of the Model Info dialog box.

Entering a Chord Length

The Measurements Toolbar's label indicates "Length" after you place the starting point of an arc. Type the chord length into the Measurements Toolbar, after placing the starting point of the arc, and press the "Enter" (Microsoft Windows) or Return (Mac OS X) key. Specify a negative value, such as -6.5", to indicate that you want the length to apply in an opposite direction to the current drawing direction.

Specifying a Bulge Distance

The Measurements Toolbar's label indicates "Bulge" after you place the ending point of an arc. Type the bulge length in the Measurements Toolbar, after placing an ending point, and press the Enter (Microsoft Windows) or Return (Mac OS X) key. You can also enter the bulge distance after the creation of the arc as long as "Bulge" is displayed as the Measurements Toolbar label. Negative bulge values can also be used to create an arc in an opposite direction to the current drawing direction.

Specifying a Radius

You can specify an arc radius instead of a bulge distance. Type the desired radius in the Measurements Toolbar, followed by the letter 'r' and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) Key. You can perform this action either during or immediately following the creation of the arc. For example: 24r or 3'6"r or 5mr.

Specifying the Number of Segments

You can also specify the number of segments in an arc. Type the number of segments in the Measurements Toolbar, followed by the letter 's', and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. You can perform this action either during or immediately following the creation of the arc. For example: 20s.
Drawing Tangent Arcs

The Arc Tool displays a cyan tangent arc while you are drawing from an unconnected end or start point of an existing arc.
Editing an Arc Entity

You can edit the radius of an Arc entity by using the Move Tool. To edit an Arc entity:

1. Select the "Move Tool" ( ). The cursor will change to an four-way arrow.
2. Move over the Arc entity to locate the midpoint of the Arc entity.
3. Click and hold on the midpoint of the Arc entity.
4. Move the cursor to adjust the bulge of the Arc entity.

5. Click and hold on the starting or ending point of the Arc.
6. Move the mouse to adjust the radius and length of the arc entity. The radius attempts to stay proportional to the base chord length.

You can also adjust the radius and number of segments using the Arc entity's Entity Info dialog box.
Editing an Extruded Arc

When you use the Push/Pull Tool to extrude a 2D face that includes an arc, it extrudes a special arc Surface entity which can also have its radius edited. Use the Move Tool to reposition the midpoint edge, and the arc curved face set (as well as the midpoints of the two arc entities that define it) will move accordingly.
Drawing Curves

Curves can be placed on existing faces or separate from existing geometry (aligned to an axes plane). To draw a curve:

1. Select the "Freehand Tool" (-pencil). The cursor will change to a pencil with a curve.
2. Click and hold to place the starting point of your curve.
3. Drag the cursor to draw.
4. Release the mouse button to stop drawing.

5. (optional) End your curve at point where you started drawing to draw a closed shape.
Drawing 3D Polyline Entities

3D polylines do not generate inference snaps or affect geometry in any way. 3D polylines are usually used for tracing imported drawings, 2D sketching, or for decorating your model. Press and hold the "Shift" key, before you begin drawing, to draw a 3D polyline.

⚠️ **Note** - Select Explode from the 3D polyline's context menu to convert a Freehand Sketch into regular edge geometry.
Editing a Curve Entity

You can change the length of a Curve entity, that does not yet bound a face, by using the Move Tool. To edit a curve:

1. Select the "Move Tool" ( ). The cursor will change to an four-way arrow.
2. Move over the Curve entity to locate an endpoint of the Curve entity.
3. Click and hold on the endpoint of the Curve entity.
4. Move the cursor to adjust the length of the Curve entity.
Drawing a Rectangle

Rectangles can be placed on existing faces or separate from existing geometry (aligned to an axes plane). To draw a rectangle:

1. Select the "Rectangle Tool". The cursor changes to a pencil with a rectangle.
2. Click to set the first corner point of the rectangle.
3. Move the cursor diagonally.

\[\text{Note} \quad \text{Press the "Esc" key at any point during the operation to start over.}\]
4. Click again to set the second corner point of the rectangle.
Drawing Rectangles by Inference

The Rectangle Tool uses SketchUp's geometric inference engine to help you place your rectangles in 3D space. The inference decisions, made by the inference engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between the rectangle you are drawing and the geometry of your model.

For example, if you move your mouse over an endpoint of an existing edge and then move away in the direction of an axis, a dotted inference line with a From Point tool tip will appear.

This tool tip indicates that you are aligned to that end point. You can also use a From Point inference to draw rectangles vertically or at non-orthogonal planes.
Locking a Rectangle to the Current Inference Direction

Press and hold the "Shift" key, while the rectangle you are drawing is the specific color of an axis, to lock drawing operation to that axis.
Creating Precise Rectangles

A rectangle's dimensions dynamically appear in the Measurements Toolbar as you draw. Specify exact length and width dimensions by typing them in the Measurements Toolbar, and pressing "Enter" (Microsoft Windows) or "Return," Mac OS X) either after the first corner is clicked or immediately after the rectangle is drawn.

![Dimensions 23,35]

SketchUp will use the current document units setting if you only type in a numerical value. You can also specify either Imperial (such as 1'6") or Metric (such as 3.652m) units at any time, regardless the document units setting.

You can also type one dimension at a time in the Measurements Toolbar. If you enter a value and a comma (3',), the new value will be applied to the first dimension, and the second dimension will be retained from before. Similarly, if you type a comma and then a value (,3'), only the second dimension will be changed.

💡 Tip - If you enter a negative value (-24, -24), SketchUp will apply that value in a direction opposite to the one you indicated while drawing and accept any new values in the new direction.
Drawing a Square

Squares are created with the rectangle tool in conjunction with the Square tool tip. To draw a Square:

1. Select the "Rectangle Tool" ( ), The cursor changes to a pencil with a rectangle.
2. Click to set the first corner point of the rectangle.
3. Move your mouse to the opposite corner. A diagonal dotted line will appear, along with a Square tool tip, when you are in a position that will create a square.

   **Note** - Press the "Esc" key at any point during the operation to start over.

3. Click to finish.

   **Tip** - A dotted line and Golden Section tool tip appears when you are in a position to create a Golden Section.

Alternately, you can press your mouse button on the first corner of your rectangle, drag to the opposite corner, and release the mouse button.

   **Tip** - Use the Axes tool to re-align the axes, prior to drawing your rectangle, if you want to draw a rectangle that is not aligned with the default drawing axes orientation.
Drawing a Circle

Circles can be placed on existing faces or separate from existing geometry. To draw a circle:

1. Select the "Circle Tool" ( ). The cursor changes to a pencil with a circle.
2. Click to place the center point of the circle.
3. Move the cursor out from the center point to define the radius of your circle. As you move the cursor, the radius value is displayed dynamically in the Measurements Toolbar and can be specified by typing in a length value followed by the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. You can also specify the segmentation for the circle in the Measurements Toolbar.

Note - Press the "Esc" key at any point during the operation to start over.

4. Click to finish the circle.

Tip - You can also click and hold the mouse button to set the center of the circle, and drag outward without releasing the button to set the radius. Release the mouse button to complete the circle.

Radius and segment values can be specified using the Measurements Toolbar immediately after a circle is drawn. See Specifying Precise Circle Values for more information on setting the radius and segment values with the Measurements Toolbar.
Locking a Circle to its Current Orientation

Press and hold the "Shift" key, before you begin drawing a circle, to lock drawing operation to that orientation.
Creating Precise Circles

The Measurements Toolbar displays the radius after setting the center point of a circle. Use the Measurements Toolbar to enter an exact radius and number of segments.

Specifying a Radius

The Measurements Toolbar's label indicates "Radius" after you place the center point of the circle. Type the radius size in the Measurements Toolbar, after placing the center point, and press the "Enter" (Mac OS X) or "Return" (Mac OS X) key. You can perform this action either during or immediately following the creation of the circle. For example: 24r or 3'6"r or 5mr.

Note - The Circle Tool will snap to any previously entered radius within the Measurements Toolbar.

Specifying the Number of Sides

The Measurements Toolbar's label indicates "Sides" when the Circle Tool is initially activated. Specify the number of sides in the Measurements Toolbar, and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key, before clicking to set the center point of the circle. For example: 100.

You can also specify the number of sides in a circle immediately after the creation of the circle. Type the number of sides in the Measurements Toolbar, followed by the letter 's', and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. For example: 20s. This number will be applied to any future circles.

Note - The default number of segments for a circle is 24.
Editing an Extruded Circle

When you use the Push/Pull Tool to extrude a 2D circle, a special cylindrical Surface entity is created. To change the size of the extruded circle:

1. Select the "Move" Tool ( ). The cursor will change to a four-way arrow.
2. Click on one of the four cardinal points (indicated by a vertical dashed line) on the side of the extruded circle.

3. Move the cursor inward to decrease the size of the extruded circle or outward to increase the size of the extruded circle.

Circle Segmentation

Circles with more line segments appear to have smoother curvature than circles with fewer line segments. However, more line segments increases the size of your model and degrades performance. You can often achieve acceptable results by indicating small segmentation and using smoothing and edge softening to create the impression of smoothness.

Circle Deformation

If an Arc is deformed in a way that destroys its radial definition, such as with a non-uniform scale operation, it will become a non-parametric Curve entity. Polyline curves can no longer be edited as arcs.
Drawing a Polygon

Polygons can be placed on existing faces or separate from existing geometry. To draw a polygon:

1. Select the "Polygon Tool" ( ). The cursor changes to a pencil with a polygon.
2. Click to place the center point of the polygon.
3. Move the cursor out from the center point to define the radius of your polygon. As you move the cursor, the radius value is displayed dynamically in the Measurements Toolbar and can be specified by typing in a length value followed by the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key.

Note - Press the "Esc" key at any point during the operation to start over.

4. Click a second time to finish the polygon. (Alternately, you can click once to set the center of the polygon, and drag outward without releasing the button to set the radius. Release the mouse button to complete the polygon.)

Radius and segment values can be specified using the Measurements Toolbar immediately after a polygon is drawn. See Creating Precise Polygons for more information on setting the radius and segment values with the Measurements Toolbar.
Locking a Polygon to its Current Orientation

Press and hold the "Shift" key, before you begin drawing a polygon, to lock drawing operation to that orientation.
Drawing Precise Polygons

The Measurements Toolbar displays the radius after setting the center point of a polygon. Use the Measurements Toolbar to enter an exact radius and number of segments.

Specifying a Radius

The Measurements Toolbar's label indicates "Radius" after you place the center point of the polygon. Type the radius size in the Measurements Toolbar, after placing the center point, and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. You can perform this action either during or immediately following the creation of the polygon. For example: 24r or 36"r or 5mr.

Note - The Polygon Tool will snap to any previously entered radius within the Measurements Toolbar.

Specifying the Number of Sides

The Measurements Toolbar's label indicates "Sides" when the Polygon Tool is initially activated. Specify the number of sides in the Measurements Toolbar, and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key, before clicking to set the center point of the polygon. For example: 10.

You can also specify the number of sides in a polygon immediately after the creation of the polygon. Type the number of sides in the Measurements Toolbar, followed by the letter 's', and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. For example: 6s. This number will be applied to any future polygons.
Editing a Polygon Entity

You can edit the radius of a circle in which the polygon is inscribed, that does not yet bound a face, by using the Move Tool. To edit a Polygon entity:

1. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.
2. Move over the Polygon entity to locate the midpoint of a side. At least one midpoint of the polygon will allow you to resize the entity.
3. Click and hold on the midpoint of the Polygon entity.
4. Move the cursor to adjust the radius of the Polygon entity. Click and hold on another midpoint if the polygon does not resize. Try each midpoint until you find the midpoint that will resize the entity.

You can also adjust the radius and number of segments using the Polygon entity's Entity Info dialog box.
Editing an Extruded Polygon

When you use the Push/Pull Tool to extrude a 2D face that includes a polygon, it extrudes a special polygonal curved face set which can also have its radius edited. Use the Move Tool to reposition one of the control edges, and the polygonal curved face set radius (as well as the radii of the two polygon entities that define it) will be adjusted accordingly.

Polygon Deformation

If a polygon is deformed in a way that destroys its radial definition, such as with a non-uniform scale operation, it will become a non-parametric polyline curve. Polyline curves can no longer be edited as polygons.
Modification Tools

This section of the user's guide covers the modification tools within SketchUp. Modification tools are those tools used to modify existing geometry. These tools include the Push/Pull Tool, Eraser Tool, and Select Tool.

Tools in this section are covered in the order they appear within the Tools menu.
Creating Multiple Copies (Linear Arrays)

The Move Tool can also be used to create arrays, or a series of copies of geometry. To create multiple copies of one or more entities:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the entities to be copied.
3. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.
4. Press and release the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key on your keyboard. The cursor will change to an arrow with a plus sign. This action informs SketchUp that you want to duplicate the selected entities.
5. Click on the selected entities to copy.
6. Move your mouse to copy the entities. A copy of the selected entities will follow as you move your mouse.
7. Click at the destination point to finish your copy operation. The copied entities are now selected and the original entities are deselected.
8. Type a multiplier value to create additional multiple copies. For example, typing in 2x (or *2) will create one additional copy (or 2 copies total, the one you manually copied plus one you automatically copied using this step) instead of just one.
Creating Copies at an Equal Distance Apart

You can divide the distance between the copy and the original by typing in a divisor value. For example, typing 5/ (or /5) will create five copies evenly distributed between the original and the first copy. You can keep typing in distances and multipliers until you perform another operation.

Tip - This feature is particularly useful in creating models of items such as fences, bridges, and decks, where you might want several posts or beams an equal distance apart.
Moving/Stretching With Autofold

SketchUp will Autofold faces automatically when a move or stretch operation will create non-planar faces. For example, clicking on the corner of a box with the Move Tool and move down in the blue direction causes SketchUp to create a fold line along the box's top face.

Forcing Autofold Behavior

There are times when SketchUp constrains an operation in favor of keeping all faces planar and not creating additional fold lines. For example, clicking on the edge of a box with the Move Tool only allows you to move the edge in a horizontal direction (red and green), but not vertically (blue).

You can override this behavior by pressing and releasing the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key before performing the move operation. This key sequence enables Autofold allowing geometry to move freely in any direction.
Making Copies

As mentioned previously, the Move Tool can be used to make copies of entities within your model. To make copies of an entity using the Move Tool:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the entities to be copied.
3. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.
4. Press and release the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key on your keyboard. The cursor will change to a four-way arrow with a plus sign. This action informs SketchUp that you want to duplicate the selected entities.
5. Click on the selected entities to copy.
6. Move the cursor to copy the entities. A copy of the selected entities will follow as you move your mouse.
7. Click at the destination point to finish your copy operation. The copied entities are now selected and the original entities are deselected.

Note - You can press and release the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key on your keyboard at any time during a move operation to perform a copy (not just at the start).
Moving Groups and Components

If a component is glued to a face, the component will stay in the plane of that face when moved unless it is unglued. Copies of a glued component will also be glued to the originating plane.
Moving by Inference

The Move Tool uses SketchUp's sophisticated geometric inference engine to help you place entities in 3D space. The inference decisions, made by the inference engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between the move operation and the geometry of your model. Refer to the inference engine topic for additional information.

Locking a Move to the Current Inference Direction

Press and hold the "Shift" key, while the move you are performing is the specific color of an axis, to lock move operation to that axis.

Locking a Line to a Specific Inference Direction

Press and hold the up arrow, left arrow, or right arrow keys, where up arrow equals blue, left arrow equals green, and right arrow equals red, while moving to lock the move to a specific axis.
Moving Precisely

The Measurements Toolbar at the bottom right corner of the SketchUp window displays the length of the move operation (displacement) in the default units, as specified under the Units panel of the Model Info dialog box, while moving, copying, or stretching entities. In addition to creating arrays, you can also specify an exact displacement or a relative or absolute 3D coordinate for the finishing point during, or immediately after, a move operation.

Entering a Displacement Value

You can specify a new displacement length during or directly following a move operation. To enter a displacement value during a move operation:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the entities to be moved.
3. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.
4. Click once to select the start point of the move operation.
5. Move your mouse to begin moving the entities in the correct direction. The selected entities will follow as you move your mouse. Also, an inference line will appear between the start and ending points of the move, and the distance of the move is displayed dynamically in the Measurements Toolbar.
6. Type the positive or negative displacement value (such as 20' or -35mm) in the Measurements Toolbar and press the Enter (Microsoft Windows) or "Return" (Mac OS X) key.

Note - You can type values in the Measurements Toolbar using an alternate measuring system than the default system. SketchUp will convert the value to the default system. For example, you can type in 3' 6" even if you are using metric system as your default.

Entering a 3D Coordinate

SketchUp can move your entities to exact (using []) or relative (using <> ) coordinates in 3D space. To enter a 3D coordinate during a move operation:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the entities to be moved.
3. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.
4. Click once to select the start point of the move operation.
5. Move your mouse to begin moving the entities in the correct direction. The selected entities will follow as you move your mouse. Also, an inference line will appear between the start and ending points of the move, and the distance of the move is displayed dynamically in the Measurements Toolbar.
6. Type the exact or relative coordinate.
   
   Global Coordinates: [x, y, z] of the current Sketch Axes:
Relative Coordinates: $<x, y, z>$ relative to the start point:

Note - You can define only one or two values as part of your 3D coordinate. For example, to move geometry to 2 feet in the $z$ or blue direction enter the following in the Measurements Toolbar: $[,,2']$

Note - The exact format for values typed in the Measurements Toolbar will vary depending on your computer’s regional settings. For some European users, the list separator symbol is a semi-colon instead of a comma. For example, $[x;y;z]$
Moving Several Entities

You can preselect several entities to move prior to performing a move operation. To preselect and move entities:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the entities to be moved.
3. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.
4. Click once on an entity to begin the move operation. The point where you click on the entity is called the move point.
5. Move your mouse to move the entities. The selected entities will follow as you move your mouse. Also, an inference line will appear between the start and ending points of the move, and the distance of the move is displayed dynamically in the Measurements Toolbar. You can also type in a specific distance as described below. The following image shows a component being moved:

![Image of component being moved](image)

**Tip** - Follow inference lines to easily align items in 3D space. Select corners of components as your move point and align to corners of other components when aligning components side-by-side (such as when aligning kitchen cabinet components).

6. Click at the destination point to finish your move operation.

**Note** - Press the "Esc" key at any point during the operation to start over.
Moving a Single Entity

You can activate the Move Tool when nothing is selected to select a single entity to move. The selection click point becomes the base point for the move operation. To select and move a single entity:

1. Select the "Move" Tool ( ). The cursor will change to a four-way arrow.
2. Click on an entity to begin the move operation.
3. Move the cursor to move the entity. The selected entity will follow as you move the cursor.
4. Click at the destination point to finish your move operation.

Note - If the entity you are moving is connected to other entities, the other entities will be moved or modified accordingly. See the Stretching Geometry section for further information on this behavior.
Stretching Geometry

When you move an element that is interconnected with others, SketchUp will stretch geometry as necessary. You can move points, edges, and faces in this manner. For example, the following Face entity can be moved back in the negative red direction or up in the positive blue direction:

You can also move single line segments to stretch an object. In the following example, a line is selected and moved up in the blue direction to form a sloped roof.
Creating Multiple Rotated Copies (Radial Arrays)

The Rotate Tool can also be used to create radial arrays, or a series of copies around a rotate point. To create a radial array:

1. Select the "Rotate Tool" ( ). The cursor will change to a protractor with a circular arrow.
2. Click on the entity to rotate.
3. Press and release the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key on your keyboard. The cursor will change to a protractor with a plus sign. This action informs SketchUp that you want to duplicate the entity.
4. Move the cursor in a circle until it is at the starting point of the rotation.
5. Click to set the starting point of the rotation. Use the inference tool tips to help you to find the center of the rotation.
6. Move the cursor until it is at the ending point of the rotation. A copy of the entity appears and is rotated about the starting point. If the Enable angle snapping checkbox is checked in the Units Panel of the Model Info dialog box, movements close to the protractor result in angle snaps, while those further away from the protractor allow free rotation.
7. Click to complete the rotation.
8. Type a multiplier value to create additional multiple copies. For example, typing in 2x (or *2) will create one additional copy (or 2 copies total, the one you manually copied plus one you automatically copied using this step) instead of just one.

Note - Press and hold the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key at any time during a rotate operation to perform a copy (not just at the start).

Creating Copies at an Equal Distance Apart

You can divide the distance between the copy and the original by typing in a divisor value in the Measurements Toolbar. For example, typing 5/ (or /5) will create five copies evenly distributed between the original and the first copy. You can enter distances and multipliers until you perform another operation.
Making Rotated Copies

The Rotate Tool can be used to make rotated copies of entities within your model. To make copies of an entity using the Rotate Tool:

1. Select the "Rotate Tool." The cursor will change to a protractor with a circular arrow.
2. Click on the entity to rotate.
3. Press and release the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key on your keyboard. The cursor will change to a protractor with a plus sign. This action informs SketchUp that you want to duplicate the entity.
4. Move the cursor in a circle until it is at the starting point of the rotation.
5. Click to set the starting point of the rotation. Use the inference tool tips to help you to find the center of the rotation.
6. Move the cursor until it is at the ending point of the rotation. A copy of the entity appears and is rotated about the starting point. If the Enable angle snapping checkbox is checked in the Units Panel of the Model Info dialog box, movements close to the protractor result in angle snaps, while those further away from the protractor allow free rotation.
7. Click to complete the rotation.

Note - Press and hold the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key at any time during a move operation to perform a copy (not just at the start).
Folding Along an Axis of Rotation

You can fold geometry by setting the protractor along an edge that will act like a fold line and then folding geometry at that line. To fold geometry along an axis of rotation:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the geometry to rotate. The bottom of the triangle will act as a fold line.

3. Select the "Rotate Tool" ( ). The cursor will change to a protractor with a circular arrow.
4. Click and hold on one end of the fold line or edge where the fold will appear in your geometry.
5. Drag the cursor along the fold line to align the protractor to the fold line (the bottom of the triangle).
6. Release the mouse button to set the rotation point or the point upon which the geometry will rotate.
7. Click the mouse again to set the starting point of the rotation.

8. Move the mouse to rotate. If angle snaps are active under preferences, you'll notice that as you move the mouse, movements close to the protractor will result in angle snaps, while those further away from the protractor will allow free rotation.

9. Click a third time at the ending point of the rotation (to complete the rotation).
Locking the Rotate Tool to its Current Orientation

Press and hold the "Shift" key, before you click on an entity, to lock the operation to that orientation.
Rotating Precisely

The degree of rotation you have indicated appears in angular degrees in the Measurements Toolbar while rotating. You can also manually enter in angular rotation or slope values directly into the Measurements Toolbar while rotating geometry.

Entering an Angular Rotation Value

To specify an exact angle in degrees, type a decimal value into the Measurements Toolbar while rotating the cursor around the protractor. For example, typing in "34.1" will give you an exact 34.1 degree angle. Negative values will move angle in a counter-clockwise direction. You can specify an exact angular value either during or immediately after your rotation operation.

Entering a Slope Value

To specify a new angle as a slope, type in the two values separated by a colon in the Measurements Toolbar, such as "8:12." Negative values will move angle in a counter-clockwise direction. You can specify an exact angular value either during or immediately after your rotation operation.
Rotating Geometry

You can rotate geometry in three different planes in a 3D environment. To rotate geometry using the Rotate Tool:

1. Select the "Rotate Tool" ( ). The cursor will change to a protractor with a circular arrow.
2. Click on the entity to rotate.
3. Move the cursor in a circle until it is at the starting point of the rotation.
4. Click to set the starting point of the rotation. Use the inference tool tips to help you to find the center of the rotation.
5. Move the cursor until it is at the ending point of the rotation. If the Enable angle snapping checkbox is checked in the Units Panel of the Model Info dialog box, movements close to the protractor result in angle snaps, while those further away from the protractor allow free rotation.

Note - Press the "Esc" key at any point during the operation to start over.

6. Click to complete the rotation.
Rotational Stretching with Auto-Fold

The Rotate Tool can also be used to stretch geometry by selecting and rotating a portion of the geometry. Any rotational movement that would cause a face to twist in on itself or otherwise become non-planar will activate SketchUp's Auto-Fold feature.
Scaling 2D Surfaces or Image Entities

Two-dimensional surfaces and Image entities can be scaled just as easily as three-dimensional geometry. The Scale Tool's bounding box contains nine scaling grips when scaling a 2D face. These operate in a similar manner to the grips in a 3D bounding box, and also work with the Ctrl (Microsoft Windows) or Option (Mac OS X) and Shift modifiers.

The bounding box is a 2D rectangle when scaling a single 2D surface that lies in the red-green plane. The bounding box will be a 3D volume if the surface to be scaled is out of plane with the current red-green plane. You can ensure a 2D scale by aligning the Drawing Axes to a surface prior to scaling.
Scaling About the Geometry Center

The Scale Tool allows you to scale outward from geometry's center point. Press and hold the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key at any time during a scale operation to display the geometry's center point, click on any of the other scaling grips, and drag outward or inward to scale accordingly.
Scaling Components

Scaling a Component entity scales the individual instance. All other instances of the component will retain their individual scales. This feature allows you to have many differently scaled versions of the same component in your model.

Scale operations within a component's context (such as scaling a Line entity within a component) affect the component definition and, therefore, all instances of the component are scaled to match (all instances of the same Line entity in all component instances).
Controlling Scaling Direction With The Axis Tool

You can precisely control the direction of scaling by first repositioning the drawing axes with the Axes Tool. The Scale Tool will use the new red, green, and blue directions to orient itself, and control grip direction, after the axes are repositioned.
Scaling Precisely

The Measurements Toolbar at the bottom right corner of the SketchUp window displays the axis dimensions that are being scaled, and the value of the scale itself, in the default units (as specified under the Units panel of the Model Info dialog box) during a scaling operation. Type a scale value into the Measurements Toolbar to directly scale geometry during or immediately after a scaling operation.

Entering a Scale Multiplier Value

You can specify a new dimensional length value during or directly following a scaling operation. To enter a dimensional length value during a scaling operation:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the geometry to scale.
3. Select the "Scale Tool" ( ). The cursor will change to a box within another box. Scaling grips will appear around the selected geometry.
4. Click on a scaling grip to select the grip. The selected grip and the opposite scaling grip will highlight in red. Each scaling grip provides a different scaling operation. See Scaling Options section for further information.
5. Move the mouse to scale the geometry. The Measurements Toolbar displays relative size of the item as you scale the item. You can enter the desired scale dimensions after the scale operation is complete.
6. Type the dimensional length value (such as 2’ 6" for two feet and six inches or 2m for two meters) in the Measurements Toolbar and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key.

Mirroring Geometry using the Scale Tool

The Scale Tool can also be used to mirror geometry by pulling a grip towards and then beyond the point about which you are scaling. This operation allows you to pull geometry inside out. Note that the grips snap to certain negative values (such as -1, -1.5, and -2) just as they do in the positive direction. You can force a mirror by typing in a negative value or dimension.

Entering Multiple Scale Values

The Measurements Toolbar always indicates the scaling factors associated with a particular operation. A 1D scaling operation requires one value. A 2D scaling operation requires two values, separated by a comma. A Uniform 3D scaling operation requires only one value whereas a Non Uniform 3D scaling operation requires three values, each separated by a comma.

You'll notice that during the scale operation, a dashed line appears between the scaling point and the grip you've selected. Entering a single value or distance in the Measurements Toolbar tells SketchUp adjust the anchor to grip distance to be that scale value or distance, regardless of which mode (1D, 2D, 3D) is active.

When scaling in multiple directions, typing in multiple values separated by commas will resize the object(s) based on the entire bounding box dimension(s), not the objects individually. (To scale objects based on a particular edge or known distance, you can use the Tape Measure Tool.)
Scaling Geometry

To scale geometry:

1. Select the "Scale Tool" ( ). The cursor will change to a box within another box.
2. Click on the entity. Scaling grips will appear around the selected geometry.

3. Click on a scaling grip. The selected grip and the opposite scaling grip will highlight in red. Each scaling grip provides a different scaling operation. See Scaling Options section for further information.

4. Move the cursor to scale the entity. The Measurements Toolbar displays relative size of the item as you scale the item. You can enter the desired scale dimensions after the scale operation is complete.

Note - Press the "Esc" key at any point during the operation to start over.

5. Click to finish scale operation.

Scaling Auto-Folding Geometry

SketchUp's Auto-fold feature works automatically with all Scale operations. SketchUp will create folding lines as necessary to maintain planar faces.
Scaling Uniformly

You might need to maintain the uniformity of geometry as it is being scaled, despite performing nonuniform scaling. The Shift key toggles to uniform scaling operation (from a nonuniform scaling operation) and to nonuniform scaling operation (from a uniform scaling operation).

![Note - Use the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) and "Shift" keys to allow uniform and non-uniform scaling from the center of the selected geometry.](image)
Pushing and Pulling a Curved Face

You can use the Push/Pull Tool on faces that have an arc as an edge similarly to using the Push/Pull Tool on regular faces. The curved face that results from the push/pull operation is called a Surface entity. Surfaces can be adjusted as a whole, but are comprised of a number of faces or a curved face set.

Tip - Select View > Hidden Geometry to view and manipulate the individual faces in the surface.
Creating a New Push/Pull Starting Face

Push/pull a face (click on the face, move, and then click again) and then press and release "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) (the cursor will contain a plus sign) and push/pull again. The lines that represent the edges of the top-most face will remain as the starting point for a new push/pull operation. This mechanism is useful for creating quick multilevel buildings. The following image shows a face that was pulled up (left), then the user pressed and released Ctrl (Microsoft Windows) or Option (Mac OS X) and pulled again (middle) and then the user pressed and released Ctrl (Microsoft Windows) or Option (Mac OS X) and pulled again (right).

This operation is particularly useful for creating quick space planning diagrams (such as for an office building). Simply use a combination of push/pull and push/pull with Ctrl to create offices, halls, break rooms, meeting rooms and so on (with walls created when Ctrl is pressed).
Pushing and Pulling Precisely

The displacement of a push/pull operation is displayed in the Measurements Toolbar. You can specify an exact push/pull value either during or immediately after your push/pull operation. Negative values will perform the push/pull in the opposite direction.
Repeating a Push/Pull Operation

Double-clicking on another face immediately after a push/pull operation will automatically apply another push/pull operation, of the same amount, to the other face.

Note - The side of the face that you double-click on affects the direction of the repeated push/pull operation. If your last push/pull was on a front face, and you double-click on the back side face, the push/pull will occur in the opposite direction.
Creating Voids

Push/pull will implode the shape into the volume and toward the back face of the volume when you use push/pull on a shape that is part of another volume. SketchUp will subtract the shape and create a 3D void if the shape is pushed completely out of the back of the volume as in the following example.

Note - This operation only works when the front and back faces are parallel. Such as when you have two parallel walls in a house and you want to create a void for a door or window.
Creating a Volume

Push/Pull Tool is used to expand or decrease the volume of geometry in your models. To push or pull faces:

1. Select the "Push/Pull Tool" ( ). The cursor will change to a 3D rectangle with an up arrow.
2. Click on the face that you want to expand or decrease.
3. Move the cursor to create (or decrease) volume.

**Note** - Press the "Esc" key at any point during the operation to start over.

4. Click when the volume has reached the desired size.

**Note** - You can also press and hold the mouse button, drag the mouse, and release the mouse button to create a volume.

**Note** - When you create a single face, as shown previously in step 4, on the ground plane (the red/green plane), SketchUp assumes you are going to be using that face as the floor of a structure. The front of the face (gray) points down and the back of the face (purple) points up. When you use the Push/Pull Tool on this single face (in the blue direction), you are really pulling up from the back of the face. The positive blue direction temporarily acts as the "below ground" or negative blue direction. A double-click, after performing the initial push/pull, applies a positive amount and returns the entity to the single face you started with.
**Offsetting a Face**

The most common use of the Offset Tool is to offset the edges that bound a face. To perform a face offset:

1. Select the "Offset Tool" ( ). The cursor will change to two offset corners.
2. Click on the face to be offset.
3. Move the mouse cursor to define the offset dimension. The offset distance is displayed in the Measurements Toolbar. You can offset inside or outside of the edges; on rectangular face or circular face.

   ![Offset Tool](image)

   ![Measurements Toolbar](image)

   **Note** - Press the "Esc" key at any point during the operation to start over.

4. Click to finish the offset operation.
Offsetting Lines

You can also select and offset connected, co-planar, lines (and arcs) for an offset. To offset lines:

1. Select the "Select Tool" ( ). The cursor will change to an arrow.
2. Select the lines to be offset. You must select two or more connected lines, and all your lines must be coplanar.

3. Select the "Offset Tool" ( ). The cursor will change to two offset corners.
4. Click on one of your selected line segments. The cursor will automatically snap to the nearest line segment.
5. Move the cursor to define the offset dimension.

6. Click to finish the offset operation.

Tip - You can click once on the selected line segments, drag to set the offset while holding down the mouse button, and release the button to accept.

Note - Offseting an Arc entity will create a Curve entity that cannot be edited. The original Arc, however, can still be edited after this operation.
Offsetting Precisely

The Measurements Toolbar at the bottom right corner of the SketchUp window displays the length of the offset in the units as specified under the Units panel of the Model Info dialog box, while offsetting entities. You can also specify an exact offset during, or immediately after, an offset operation.

**Note** - You can type values in the Measurements Toolbar using an alternate measuring system than the default system. SketchUp will convert the value to the default system. For example, you can type in 3’ 6” even if you are using metric system as your default.

Entering an Offset Value

You can specify a new offset length during or directly following an offset operation. To enter an offset value during an offset operation:

1. Select the "Select Tool." The cursor will change to an arrow.
2. Select the lines to be offset. You must select two or more connected lines, and all your lines must be coplanar. Use the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) and/or "Shift" key to change your selection.
3. Select the "Offset Tool."
4. Click on one of your selected line segments. The cursor will automatically snap to the nearest line segment.
5. Move the mouse to define the offset dimension.
6. Click your mouse to accept the offset lines.
7. Type the positive or negative offset value (such as 20' or -35mm) in the Measurements Toolbar and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X).
Repeating an Offset Operation

Double-clicking on another face immediately after a offset operation will automatically apply another offset operation, of the same amount, to the face.
Automatically Extruding a Face Along a Single Surface Path

The simplest and most accurate way to extrude a face along a path is to have the Follow Me Tool automatically select and follow a path on a single coplanar surface. To automatically extrude a face along a path on a single surface using the Follow Me Tool:

1. Identify the edge of the geometry you want to modify. This edge will be your path.
2. Draw a profile of the face that you want to follow the path. Make sure that this profile is approximately perpendicular to the path.
3. Select the "Tools > Follow Me."
4. Press and hold the "Alt" (Microsoft Windows) or "Command" (Mac OS X) Key.
5. Click on the profile that you created.
6. Move the cursor off the profile surface onto the surface around which you wish to sweep. The path will automatically close.

Note - If your path consists of the edges around a single surface, you can select the surface and then the Follow Me Tool to automatically follow the edges around the surface.
7. Click to commit the follow-me operation.
Creating a Lathed Shape

You can use the Follow Me Tool to create full lathed shapes using circular paths. To create a lathed shape:

1. Draw a circle whose edge will represent the path.
2. Draw a face perpendicular to the circle. The face does not have to be on or even touch the circle's path.
3. Select "Follow Me Tool". The cursor will change to a slanted box with an arrow.
4. Follow the edge of the circle with the face using one of the methods above.
Manually Extruding a Face Along a Path

The manual method for extruding a face along a path allows you to control the direction the face will travel while performing the extrusion. To manually extrude a face along a path using the Follow Me Tool:

1. Identify the edge of the geometry you want to modify. This edge will be your path.
2. Draw a face that you want to follow the path. Make sure that this profile is approximately perpendicular to the path.
3. Select the "Follow Me Tool" ( ). The cursor will change to a slanted cylinder with an arrow.
4. Click on the face that you created.
5. Drag the cursor along the path. SketchUp will highlight the path, in red, you are following as you drag your cursor around the model. You must touch the segment of the path immediately adjacent to the profile for the Follow Me to start in the correct location. If you select an edge, as your starting edge, that is not touching the profile, Follow Me will start extruding at that edge, not from the profile to that edge.

Note - Press the "Esc" key at any point during the operation to start over.
6. Click to complete the Follow Me operation when you reach the end of the path.
Preselecting the Path

You can preselect the path using the Select Tool to help the Follow Me Tool follow the correct path. To extrude a face along a pre-selected path:

1. Draw a profile of the face that you want to follow the path. Make sure that this profile is approximately perpendicular to the path.

2. Select the continuous set of edges that represent the path.

3. Select the "Follow Me Tool" (.setImageResource(9999999)) (the edges should still be selected). The cursor will change to a slanted box with an arrow.

4. Click on the profile that you created. The surface will be extruded continuously along your pre-selected path.
Creating Complex Geometry

To create complex geometry using the Intersect With Model Tool:

1. Create two distinct geometries, such as a box and a tube.

2. Select the "Select Tool" ( ). The cursor changes to an arrow.

3. Triple-click on the tube to select all of the entities of the tube.

4. Select the "Move Tool" ( ). The cursor will change to a four-way arrow.

5. Move the tube such that it intersects the box completely in any way you like. Notice that no edges exist where the tube meets the faces of the box on the box's top face. The tube should remain selected although it is within the box.


7. Select Intersect With Model from the context commands menu. The tool creates edges where the tube intersects the box.
8. Delete or move the portions of the tube that you do not want to keep. Notice that SketchUp will have created new subdivided faces where the tube intersected the box.
Using Intersect With Model with Groups and Components

Edges created by the Intersect With Model Tool are drawn in the current context. For example, if one of your intersecting entities is a group, and you perform the Intersect with Model while editing that group (such as while editing the tube), the intersection lines will be applied within the group (right-most image below).
Manipulating a Material Using Fixed Pin Mode

Fixed pin mode allows you to scale, skew, shear and distort a texture, while constraining or "fixing" one or more pins. Fixed pin mode is best for materials that tile like brick or roofing textures. To manipulate a material using Fixed Pin Mode:

1. Context-click on the material to display its context menu.
2. Select "Texture > Position." A matrix of dotted lines is displayed on the material to indicate the materials individual tiles. The cursor also changes to a hand and four pins are displayed.
3. Context-click on the material
4. Select the Fixed Pins menu item if there is not a check mark next to the item. Colored icons appear next to each pin, each icon representing a specific position texture operation.
5. Manipulate the material by clicking, holding, and dragging on one of the pins. See Fixed Pin Mode Options in this topic for additional information.

   ![Diagram of material with pins]

   **Note** - Single-clicking on a pin grabs the pin allowing you to move the pin to a different location on the texture. This new position will be the starting point for any of the fixed pin mode operations. This action works in both Fixed Pin and Free Pin modes.
6. When you are finished modifying the texture, context-click and select "Done," or just click outside the texture to exit the Position Texture Tool.

Fixed Pin Mode Options

- **Move Icon and Pin:** Drag (click and hold) the Move icon or pin to reposition the texture. When you are finished modifying the texture, context-click and select Done, or just click outside the texture to close it. Or you can simply press the Enter (Microsoft Windows) or Return (Mac OS X) key when finished.
**Scale / Rotate Icon and Pin:** The Scale/Rotate icon or pin is used to scale and rotate the material to any angle, based on the fixed pin location of the move pin. Dragging the cursor closer to, or farther from, the base pin will scale the material. Dragging the pin icon around the base pin causes SketchUp to rotate the material. A dashed arc is created in the direction that you rotate the material. If you hold the cursor over the dashed arc, the material will rotate, but not scale.

Notice that the dots along the dashed lines and arcs show you the current size and the original size of the texture for reference. You can change back to the original size by moving the cursor to the original arc and line. Or you can select Reset from the Context menu. Be forewarned that selecting Reset also resets the rotation as well as the scale.

**Scale / Shear Icon and Pin:** The Scale/Shear icon or pin is used to simultaneously slant or shear and resize the material. Notice that the two bottom pins are fixed during this operation.

**Distort Icon and Pin:** The Distort icon or pin is used to perform a perspective correction on the material. This feature is useful for applying image photos to geometry.
Manipulating a Material Using Free Pin Mode

Pins are not constrained to other pins in Free Pin Mode allowing you to drag pins anywhere to distort the material just as you might distort a material as you stretch it over a drum. Free pin mode is best for positioning and removing the distortion from photographs. To manipulate a material using Free Pin Mode:

1. Context-click on the material to display its context menu.
2. Select "Texture > Position." A matrix of dotted lines is displayed on the material to indicate the materials individual tiles. The cursor also changes to a hand and four pins are displayed.
3. Context-click on the material.
4. Select the "Fixed Pins" menu item if there is a check mark next to the item. Four pins appear.
5. Manipulate the material by clicking, holding, and dragging on one of the pins.

   ![Note - Single-clicking on a pin grabs the pin allowing you to move the pin to a different location on the texture. This new position will be the starting point for any of the fixed pin mode operations. This action works in both Fixed Pin and Free Pin modes.](image)

6. When you are finished modifying the texture, context-click and select "Done," or just click outside the texture to exit the Position Texture Tool.
Repositioning a Material on Hidden Geometry

You can adjust textures on a face, such as the faces of a cylinder, and then repaint the adjust texture across the entire curved surface of the cylinder. For example, to adjust a texture on a cylinder:

1. Create a cylinder.
2. Select the "File > Import" menu item to insert an image.
3. Select an image format from the Files of type drop-down list.
4. Select the image file.
5. Click the "Open" button. The cursor changes to the Select Tool with the image.
6. Click in the drawing area to place the starting point of the image.
7. Drag the cursor away from the starting point so that the image is resized.
8. Click again to place the image.
9. Context-click on the image. The Image entity's context menu appears.
10. Select "Use as Material." The image appears in the Colors In Model material library within the Materials Browser.
11. Click on the material in the Materials Browser. The cursor changes to the Paint Bucket Tool.
12. Paint the Material on the cylinder. The material will automatically wrap around the cylinder, repeating itself as necessary to wrap the entire model.
13. Select the "Display > Hidden Geometry" menu item.
14. Select one of the faces of the cylinder
15. Context-click on the selected face. The Face entity's context menu appears.
16. Select the "Texture > Position" menu item.
17. Reposition the texture on the face.
18. Sample the repositioned texture using the eyedropper button on the material browser, or using the "Alt" key with the Paint Bucket Tool.
19. Click on "Display > Hidden Geometry" to turn off Hidden Geometry.
20. Paint the sampled, repositioned, texture on the remainder of the cylinder. Your texture now appears as though it has been repositioned on the entire cylinder.
Manipulating an Image as Material Using Free Pin Mode

Free pin mode is especially useful when using an image as the foundation for geometry. For example, you can use a picture containing a door as the foundation for a photo-realistic door in a SketchUp model. To manipulate an image using Free Pin Mode:

1. Create a rectangular face.
2. Select the "File > Import" to insert an image, such as the image of a real door. The Open dialog box is displayed.
3. Select an image format from the Files of type drop-down list.
4. Click on the "Use as texture" radio button.
5. Select the image file.
6. Click on the "Open" button.
7. The cursor changes to the Paint Bucket Tool with the image.
8. Click on one corner of the face to place the starting point of the texture.
9. Drag the cursor away from the starting point so that the texture is resized over the rectangular face.
10. Click again to place the texture on the rectangular face.
11. Context-click on the material to display its context menu.
12. Select "Texture > Position." A matrix of dotted lines is displayed on the material to indicate the materials individual tiles. The cursor also changes to a hand and four pins are displayed.
14. Select the "Fixed Pins" menu item if there is a check mark next to the item.
15. Manipulate the material by clicking, holding, and dragging on one of the pins.

Note - Single-clicking on a pin grabs the pin allowing you to move the pin to a different location on the texture. This new position will be the starting point for any of the fixed pin mode operations. This action works in both Fixed Pin and Free Pin modes.

11. When you are finished modifying the texture, context-click and select "Done," or just click outside the texture to exit the Position Texture Tool.
Wrapping Material Around Corners

The texture can be wrapped around a corner, just as you might wrap a package with wrapping paper. To wrap textures around corners:

1. Create a three-dimensional cube.
2. Select "File > Import" to insert an image.
3. Select an image format from the Files of type drop-down list.
4. Select the image file.
5. Click the "Open" button. The cursor changes to the Select Tool with the image.
6. Click in the drawing area to place the starting point of the image.
7. Drag the cursor away from the starting point so that the image is resized.
8. Click again to place the image.
9. Context-click on the image. The Image entity's context menu appears.
10. Select "Use as Material." The image appears in the In Model (Microsoft Windows) or Colors in Model (Mac OS X) materials library within the Materials Browser.
11. Select the "Paint Bucket Tool". The cursor will change to a paint bucket and the Materials Browser is activated.
12. Click and hold the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key while using the Paint Bucket Tool to change to the eye dropper.
13. Click on the thumbnail of your image in the In Model (Microsoft Windows) or Colors in Model (Mac OS X) material library within the Materials Browser.
14. Release the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key.
15. Click on a face of your model and paint the material.
16. Context-click on the material to display its context menu.
17. Select "Texture > Position." Don't position anything!
18. Context-click again.
19. Select "Position Texture Tool > Done.".
20. Click and hold the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key while using the Paint Bucket Tool to change to the eye dropper.
21. Click on the painted material using the eye dropper to sample the material.
22. Release the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key.
23. Paint the sampled texture on the remainder of the model. The texture is wrapped around corners.
Wrapping Material Around a Cylinder

A texture can also be wrapped around a cylinder. To wrap a texture, such as an image texture, around a cylinder:

1. Create a cylinder.
2. Select "File > Import" to insert an image.
3. Select an image format from the Files of type drop-down list.
4. Select the image file.
5. Click the "Open" button. The cursor changes to the Select Tool with the image.
6. Click in the drawing area to place the starting point of the image.
7. Drag the cursor away from the starting point so that the image is resized.
8. Click again to place the image.
9. Context-click on the image. The Image entity's context menu appears.
10. Select "Use as Material." The image appears in the In Model (Microsoft Windows) or Colors in Model (Mac OS X) material library within the Materials Browser.
11. Click on the material in the Materials Browser. The cursor changes to the Paint Bucket Tool.
12. Paint the Material on the cylinder. The material will automatically wrap around the cylinder, repeating itself as necessary to wrap the entire model.
Projecting a Material

SketchUp's Texturing Positioning feature also lets you project materials or images onto faces as though projected using a slide projector. This feature is particularly useful if you wish to project a topographic image over a site model, or an image of a building onto a model representing the building. To project an image over a model:

1. Create a model, such as a cone, topography, or building front. This model will receive the projected image.
2. Select "File > Import." The cursor changes to the Select Tool with the image.
3. Place the image in front of the model that will receive the projection.
4. Size the image so it is large enough to cover the entire model.
5. Context-click on the image and select "Explode" to turn the image into a projected texture.

Note - Turn on x-ray display mode for the image to ensure the image is positioned such that it will cover the entire model.

6. Select the "Sample Paint Tool" (eyedropper) from the Materials Browser. Notice, when you drag the Sample Paint Tool over the image, a square appears on the tip of the tool. This square indicates that you are in projected texture mode (Microsoft Windows).
7. Sample the projected texture with the Sample Paint Tool.
8. Paint the texture onto the faces of the model. The image will appear as though it were projected directly on the faces, adjusting to the contours of model.
Repositioning a Material

Repositioning the material is the easiest of position texture operations. To reposition a material:

1. Context-click on the material to display its context menu.
2. Select "Texture > Position." A matrix of dotted lines is displayed on the material to indicate the material's individual tiles. The cursor also changes to a hand and four pins are displayed.
3. Drag the cursor on the surface to reposition the texture on that surface. If you want to rotate the tiled image, context-click on the surface again and select Rotate or Flip.
4. When you are finished modifying the texture, context-click and select "Done," or just click outside the texture to exit the Position Texture Tool.

Tip - Press the "Esc" key anytime during editing to reset the material's position to its previous position. Press Esc twice to cancel the entire texture positioning operation. While positioning a texture, you can back up a step at anytime by context-clicking and selecting Undo from the context menu.
Reorienting Materials

You can reorient materials (skew, rotate, resize, and so on) using the Position Texture Tool. See Position Texture Tool for more information.
Construction Tools

This section of the user's guide covers the construction tools within SketchUp. Guide tools are those tools used to create construction geometry and prepare physical documentation. These tools include the Measure Tool, Text Tool, and Dimension Tool.

Tools in this section are covered in the order they appear within the Tools menu.
Creating Guide Lines and Guide Points

Guide Line entities and Guide Point entities are useful for drawing precisely. To create an infinite parallel guide line using the Tape Measure Tool:

1. Select the "Tape Measure Tool" ( ). The cursor changes to a tape measure.

2. Click on a line that will be parallel to the guide line, to set the starting point of your measurement. You must click on an "On Edge" or "Midpoint" point between the start and end points in the line segment.

   **Note** - Start from an "On Edge" point inference and move across a face to generate an infinite parallel guide line. Start from an "Endpoint" to create a finite guide line with a guide point at the end.

3. Press and release the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key.

4. Move the cursor the direction you want to measure. A temporary measuring tape line and a guide line will stretch out from your starting point.

4. Click again at the point where you want to set your guide line. The final distance is displayed in the Measurements Toolbar.

   **Tip** - Starting from an endpoint or midpoint results in a Guide Point.
Locking a Line to a Specific Inference Direction

Press and hold the up arrow, left arrow, or right arrow keys, where up arrow equals blue, left arrow equals green, and right arrow equals red, while measuring to lock a specific axis.
Measuring Distance

The Tape Measure Tool is primarily used to measure distances between two points. To measure a distance between two points:

1. Select the "Tape Measure Tool" ( ). The cursor changes to a tape measure.
2. Click at the starting point of your measurement. Use the inference tool tip to make sure you click on the exact point.
3. Move the cursor in the direction you want to measure. A temporary measuring tape line, with arrows at each end, will stretch out from your starting point as you move the mouse. The Tape Measure Tool’s measuring tape line functions like an inference line and will change color to match axes colors when it is parallel to any axes. The Measurements Toolbar dynamically displays the length of your measuring tape as you move the mouse around your model.

Note - Press the "Esc" key at any point during the operation to start over.

4. Click at the ending point of your measurement. The final distance is displayed.

Tip - You can also click and hold on the starting point of the distance you wish to measure, drag the mouse to the endpoint of the measurement, and release the mouse to obtain a measurement.
Placing Precise Guide Lines and Guide Points

The Measurements Toolbar displays the distance that a guide line is from the starting point. Specify a different distance simply by typing it in the Measurements Toolbar. Specify a negative length to draw the line in the direction opposite the one indicated.
Scaling an Entire Model

You can rescale your model to a more precise dimension during the modeling process by specifying the desired dimension between two points using the Tape Measure Tool. This line is referred to as the reference line. To scale an entire model:

1. Select the "Tape Measure Tool" ( ). The cursor changes to a tape measure.
2. Click one end of a line segment to set the starting point of a measurement. Use the inference tool tip to make sure you click on the exact point.
3. Move the mouse to the end point of the same line segment. A temporary measuring tape line, with arrows at each end, will stretch out from your starting point as you move the mouse.
4. Click again at the other end of the line segment. The final distance is displayed in the Measurements Toolbar.
5. Enter a new size for the line in the Measurements Toolbar and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. This size will be used as the basis for a proportional rescale of your model. The following dialog box appears.

6. Click the "Yes" button. The model will be rescaled proportionally.

**Note** - Only components that are created within the current model (not dragged from the Components Browser and loaded from an external component file) can be resized.
Scaling Entities

You can rescale one or more entities using the Tape Measure Tool. To scale an one or more entities:

1. Select the "Select Tool" ( ). The cursor changes to an arrow.
2. Select the entities you want to scale.
3. Context-click while the cursor is over one of the selected entities. The selection set context menu is displayed.
4. Select "Make Group." The entities are grouped.

   Note - This process also works with components.

5. Double-click on the group to enter the group's context.

6. Select the "Tape Measure Tool" ( ). The cursor changes to a tape measure.
7. Click one end of a line segment to set the starting point of a measurement. Use the inference tool tip to make sure you click on the exact point.
8. Move the mouse to the end point of the same line segment. A temporary measuring tape line, with arrows at each end, will stretch out from your starting point as you move the mouse.
9. Click again at the other end of the line segment. The final distance is displayed in the Measurements Toolbar.
10. Enter a new size for the line in the Measurements Toolbar and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. This size will be used as the basis for a proportional rescale of your model. The following dialog box appears.

11. Click the "Yes" button. The model will be rescaled proportionally.

   Note - Only components that are created within the current model (not dragged from the Components Browser and loaded from an external component file) can be resized.
Creating Angled Guide Lines

Angled guide lines are useful to draw angled geometry such as a roof slope. To create an angled guide line:

1. Select the "Protractor Tool" ( ). The cursor will change to a protractor, aligned to the red/green plane and with its center point fixed to the cursor.
2. Place protractor's center at a vertex of the angle.
3. Click to set the vertex of the angle you will measure. The following image shows the protractor being placed at the angle's vertex.

4. Move the cursor in a circle until it is touching the start of the angle (one of the lines). The following image shows the first line in the angle (from the vertex out along to the red square).

5. Click to set the start of the angle.
6. Press and release the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key.
7. Move the cursor in a circle until the guide line is at the desired angle. Notice that the protractor has marks, indicating 15 degree increments, on its edge. The angle will snap to these tick marks when the cursor is close to the protractor while moving around the protractor. Conversely, angle will move in more precise (smaller) increments when your cursor is farther from the center of the protractor while moving around the protractor.

Note - Press the "Esc" key at any point during the operation to start over.

8. Click to create the guide line. The following image shows a guide line created at a 45 degree angle so that a profile of a roof can be drawn.
Locking the Protractor Tool to its Current Orientation

Press and hold the "Shift" key, before you click on an entity, to lock the operation to that orientation.
Measuring an Angle

Measure an angle when you want to duplicate that angle elsewhere in your model or create plans, such as for a woodworking project. To measure an angle:

1. Select the "Protractor Tool" ( ). The cursor will change to a protractor, aligned to the red/green plane and with its center point fixed to the cursor.
2. Place protractor's center at a vertex of the angle (where two lines meet).
3. Click to set the vertex of the angle you will measure. The following image shows the protractor being placed at the angle's vertex.

4. Move the cursor in a circle until it is touching the start of the angle (one of the lines). The following image shows the first line in the angle (from the vertex out along to the red square).

5. Click to set the start of the angle.
6. Move the cursor in a circle until it is touching the end of the angle (other line). Notice that the protractor has marks, indicating 15 degree increments, on its edge. The angle will snap to these tick marks when the cursor is close to the protractor while moving around the protractor. Conversely, angle will move in more precise (smaller) increments when your cursor is farther from the center of the protractor while moving around the protractor.

Note - Press the "Esc" key at any point during the operation to start over.
7. Click to measure angle. The angle's measurement will appear in the Measurements Toolbar. The value displayed in the Measurements Toolbar is referred to as the *angular rotation value*. The following image shows the second line in the angle (from the vertex out along to the red square). The angle measures 120 degrees.

![Diagram of angle measurement](image)

**Note** - Set the angle manually by entering a value in the Measurements Toolbar, and pressing "Enter" (Microsoft Windows) or "Return" (Mac OS X). The value can either be in decimal degrees, such as 34.1, or slope, such as 1:6. This value can be changed any number of times before proceeding to the next command.
Creating Precise Angles

The degree of rotation you have indicated appears in angular degrees in the Measurements Toolbar while creating guide lines using the Protractor Tool. You can also manually enter in angular rotation or slope values directly into the Measurements Toolbar while measuring an angle and setting a guide line.

Entering an Angular Rotation Value

To specify an exact angle in degrees, type a decimal value into the Measurements Toolbar while rotating the cursor around the protractor. For example, typing in "34.1" will give you an exact 34.1 degree angle. Negative values will move angle in a counter-clockwise direction. You can specify an exact angular value either during or immediately after your rotation operation.

Entering a Slope Value

To specify a new angle as a slope, type in the two values separated by a colon in the Measurements Toolbar, such as 8:12. Negative values will move angle in a counter-clockwise direction. You can specify an exact angular value either during or immediately after your rotation operation.

Note - SketchUp can handle up to 0.1 of a degree of angular precision.
Moving the Drawing Axes

To move the Drawing Axes:

1. Select the "Axes Tool" (📸). The cursor changes to a collection of axes.

2. Move your cursor to a point in your model that you want to be the new origin. You will see the axes snap to inferred alignments and points as you move near them around your model. Use the inference tool tips to make sure your cursor is located exactly where you want it to be.

3. Click to establish the origin.

4. Move cursor away from the origin to set the direction for the red axis. Use the inference tool tips to make sure you are aligned precisely.

5. Click to accept the direction.

6. Move your cursor away from the origin to set the direction of the green axis. Use inference tool tips again to make sure you are aligned precisely.

   **Note** - Press the "Esc" key at any point during the operation to start over.

7. Click again to accept the direction.

You have moved your axes. The blue axis will appear perpendicular to the new red/green plane.

**Note** - Moving the drawing axes does not change the true ground plane for shadows and ground/sky display.
Resetting the Drawing Axes

Context-click on the drawing axes and select “Reset” from the context menu to restore the axes to the default position.
Placing Diameter Dimensions

To place a diameter dimension on a Circle entity:

1. Activate the "Dimension Tool" (phase). The cursor changes to an arrow.
2. Click on a Circle entity.
3. Move the cursor to pull a dimension string out from the model.
4. Click the mouse again time to fix the position of the dimension string.
Placing Linear Dimensions

Dimensions in SketchUp are based on a 3D model. Edges and points can be used to take dimensions. Suitable points include: end points, midpoints, on edge points, intersections, and arc and circle centers. Dimension leaders can be adjusted to span between non-linear points in a model so that your dimensions are as useful as possible in 3D. To take a dimension between two points in your model:

1. Select the "Dimension Tool" ( ). The cursor changes to an arrow.
2. Click at starting point of your dimension.
3. Move the cursor toward the endpoint of your dimension.
4. Click on the endpoint of your dimension.
5. Move the cursor perpendicular to create a dimension string.
6. Click the mouse to fix the position of the dimension string.

Note - Press the "Esc" key at any point during the operation to start over.

Tip - You can take a dimension of a single line simply by clicking on the line and moving the cursor.
Tip - You might need to occasionally rotate your model, as you dimension, to position the dimension to the proper plane.

Tip - Type "\n" followed by a space to start a new line of text (Microsoft Windows)

The appearance of all Dimensions are set and controlled from the Dimension panel of the Model Info dialog box. These settings affect all dimensions already in the model.

Dimension Plane

You can take dimensions in one of several planes. These include the current axial planes (red/green, red/blue, red/green) or the plane aligned to the edge you are measuring. Radius and Diameter dimensions are limited to the plane defined by the arc or circle. Once a dimension is taken and placed within a plane, it can only be moved within that plane.
Placing Radius Dimensions

To place a radius dimension on an Arc entity:

1. Activate the "Dimension Tool" ( ). The cursor changes to an arrow.
2. Click on an Arc entity.
3. Move the cursor to pull a dimension string out from the model.
4. Click the mouse again to fix the position the dimension string.
Toggling Dimension Type

Context-click on the dimension and choose "Type > Radius" or "Diameter," to change a radius dimension to a diameter dimension (or a diameter dimension to a radius dimension).
Configuring Text Settings

Text entities are created using the settings found in the Text panel of the Model Info dialog box. Refer to the Text entity topic for further information.

Note - Text entities can have different attributes (font, size, and so on) while dimension settings are global.
Editing Text

Double-click on text, with the Text Tool or Select Tool active, to edit the text. You can also context-click on a Text entity and select the "Edit Text" menu item from the Text entity's context menu.
Attaching Text Directly to a Face

Double-click on a face with the Text Tool to attach text, without leader, to the face.
Creating and Placing Leader Text

Leader Text contains characters and a leader line that points (refers) to an entity. To create and place leader text:

1. Select the "Text Tool" ( ). The cursor changes to an arrow with a text prompt.
2. Click on any entity to indicate the ending point of the leader line (the location where the leader should point).
3. Move the cursor to position the text. The leader line will grow and shrink as you move the cursor around the screen.
4. Click to position the text. A text entry box appears with default text, such as the name of a component (if the ending point of the leader line is attached to a component), or the square footage of a square (if the ending point of the leader line is attached to the face of a square).

5. (optional) Click in text box.
6. (optional) Enter text in the text box.

Note - Press the "Esc" key at any point during the operation to start over.
7. Click outside of the text box, or press the “Enter” (Microsoft Windows) or “Return” (Mac OS X) key twice, to complete text entry.

💡 Tip - Press the Esc at any time to cancel creation of the Text entity.

📝 Note - There are two styles of leaders: View Based and Pushpin. A View Based leader will always retain its 2D screen orientation. A Pushpin leader is aligned in 3D space, and rotates with your model as you change your view. You can specify which type of leader is used from the Text panel of the Model Info dialog box.

💡 Tip - Double-click on any face, while in the Text Tool, to display the area of the face as a Text entity.

💡 Tip - Type "\n" followed by a space to start a new line of text (Microsoft Windows)
Creating and Placing Screen Text

Screen Text contains characters and is not associated with an entity and is fixed to the screen regardless of how you manipulate or orbit the model. To create and place screen text:

1. Select the “Text Tool” ( ). The cursor changes to an arrow with a text prompt.
2. Move your mouse to a blank area on the screen where you want the screen text to appear.
3. Click to position the text. A text entry box appears.
4. Enter text in the text entry box.
5. Click outside of the text box, or press the “Enter” (Microsoft Windows) or “Return” (Mac OS X) key twice, to complete text entry. Screen text will stay fixed on the screen regardless of how you manipulate and orbit the model.

Tip - Type “\n” followed by a space to start a new line of text (Microsoft Windows)
Creating 3D Text

3D text is text that has been extruded (push/pulled). To create 3D text:

1. Select the "3D Text Tool" ( ). The 3D Text dialog box appears.
2. Type text in the text field.
3. (optional) Modify settings in the Place 3D Text dialog box. See The 3D Text Dialog Box for further information.
4. Click on the "Place" button. You are placed in a move operation with the 3D text and the Move Tool.
5. Move the 3D text to the desired location. Refer to the Move Tool for further information.

Note - Press the "Esc" key at any point during the operation to start over.
Place 3D Text Dialog Box

Use the options in the Place 3D Text dialog box to enter and configure 3D text.

Font
Select a Font from the drop-down list to change font. Select Regular or Bold from the drop-down menu to create regular (non-bold) or bold text, respectively.

Height
Type the height, in current units, in the Height text entry box.

Align
Select Left, Center, or Right, from the drop-down list to align two or more lines text to the left, center, or right respectively.

Filled
The 3D Text dialog box allows you to create 2D text with just outlines (edges) or faces, or 3D extruded text. Check the Filled checkbox to create faces for 3D text. Uncheck the Filled checkbox to create 2D text outlines (just edges).

Note - The Filled checkbox must be checked to create 3D text.

Extruded
Check the Extruded checkbox to create extruded (push/pull) 3D text. Uncheck the Extruded checkbox to create 2D text.

Note - The extruded checkbox must be checked to create 3D text.
Aligning Your View

Use the "Align View" command from the Section Plane Context menu to re-orient the model view to a view perpendicular to the section plane. Use this command, in conjunction with Paraline mode, to quickly generate sectional elevation or 1-point perspective views of your model.
Animating Section Cut Effects

SketchUp allows you to animate section cut effects such that transitions are automatically inserted when you move between active section cuts. To animate a section cut effect:

1. Add two or more section slices to your model.
2. Create two or more scenes
3. Activate one section cut in the first scene. The section cut effect is displayed.
4. Activate the second section cut in the second scene. The section cut effect is displayed.
5. Context-click on the first scene. The scene context menu is displayed.
6. Select the play animation menu item. SketchUp will cycle through each scene transitioning seamlessly between section cut effects.
Creating Section Cut Effects

To add a section plane entity:

1. Select the "Section Plane Tool" (أخر). The cursor changes to a pointer with a section plane.

   Note - Press the "Esc" key at any point during the operation to start over.

2. Click on a face to create a Section Plane entity and resulting section cut effect.

   Note - A section plane will not work on a selection set (you cannot preselect only those items you want to slice). Instead, the section plane will create a section slice in all entities in the current context and, therefore, the slice will expand to cover all entities in the context.
Creating Grouped Section Slices

To create grouped section slices, context-click on a Section Plane entity, then select "Create Group from Slice" from the context menu. New edges, encapsulated within a group, are generated (wherever the section plane intersects with faces).

This group may be moved off to the side as a section outline, or it may be immediately exploded, making the edges merge with the geometry from which they were generated. This technique allows you to quickly make slices through any complex shape.
Exporting Sections

SketchUp allows you to export section cut effects (your model with a section slice) and section slices.

Exporting Models with Section Cut Effects

Exporting models with section cut effects is the equivalent of exporting any model as a bitmap image file. Section planes and section cuts will appear in the exported file depending on the visibility of the section plane and section cut.

Section Slice

SketchUp can also export section slices using the Section Slice export feature. 2D vector sections can be accurately scaled and measured similarly to other 2D vector exports.
Hiding Section Plane Entities and Section Cuts

Use the Toggle Section Cuts Toolbar item in the Section Planes Toolbar (Microsoft Windows) or Customize Toolbar screen (Mac OS X) to hide and unhide section cuts. Additionally, you can use the Toggle Section Plane Display in the Section Planes Toolbar (Microsoft Windows) or Customize Toolbar screen (Mac OS X) to hide and unhide Section Plane entities. These controls are helpful in keeping your model uncluttered.
Manipulating Section Planes

You can use the Move Tool and Rotate Tool to reposition section planes just as you reposition other entities. Additional methods for manipulating section planes follow.

Reverse Cutting Direction

The direction of a section plane can be reversed by context-clicking on the section plane and selecting reverse from context menu.

Changing the Active Section Plane

Newly placed section planes are active until another entity, such as another section plane, is selected.

There are two ways to activate a section plane: double-click on the section plane while in the Select Tool or context-click on the section plane and select "Activate" from the context menu.

Note - One section plane can be active for each context in your model. Therefore a section plane within a group or component can be active at the same time, because they are in separate contexts, as a section plane outside of any group or component. A model that has a group that also contains two other groups has four different contexts (one context outside of any group, one context inside the top level group, and one context each for the groups contained within the top-level group), and can have four active sections at once.
Simultaneously Activating Multiple Section Planes

SketchUp only allows you to have one section plane active per context. That means, you must place additional section planes within a group or component to have simultaneous multiple section planes active.
Using Sections with Scenes

Active Section Plane may be saved to a scene. Section cut effects will animate during animations.
Camera Tools

This section of the user's guide covers the camera tools within SketchUp. Camera tools are those tools used to manipulate your point of view of the model. These tools include the Orbit Tool, Pan Tool, and Zoom Tool.

Tools in this section are covered in the order they appear within the Camera menu.

Camera Tools Context Menu

Context-clicking while using any camera tool launches the camera tools context menu. This menu enables you to switch between camera tools.
Using the Isometric (Iso) View

SketchUp will move your view to the true Isometric view closest to your current view angle when you activate the Isometric View. Use the "Orbit" Tool to orient the camera approximately where you want the view to be to change to a different Isometric view. Finally, activate the Isometric view to lock into an actual Isometric view. (Remember that true Isometric views require Paraline mode.)
Printing Standard Views in Perspective Mode

Traditional rules of perspective apply when you are in Perspective mode and want to print or export your model as a 2D vector drawing, (the output will not be to scale as it is in the SketchUp drawing area). For example, the Top and Isometric views will reorient your view in a similar way, but cannot create a true plan or isometric drawing unless SketchUp is in Paraline mode.

Note - You are in a perspective projection when the Perspective menu item in the Camera menu item has a checkmark.
Match New Photo

Use the Match New Photo and Edit Matched Photo menu items to create a 3D model to match a photo or to match an existing 3D model to a photo's context. Activate the Match New Photo and Edit Matched Photo menu items from the Camera menu.

SketchUp is commonly used to create designs of buildings or structures. SketchUp allows you to create these designs using the actual real-world scale (a scale of 1:1 where a unit of measurement in SketchUp represents that actual unit of measurement in the real world). However, digital pictures are not at a 1:1 scale. Therefore, to create a 3D model that matches a photo (or to match an existing SketchUp model to a scale in a photo), you must calibrate SketchUp's camera to match the position and focal length of the digital camera used to take the picture.

High-Level Steps for Using Photo Match

Photo matching consists of 4 high-level steps:


2. Start matching. Matching involves loading a digital picture and calibrating SketchUp's camera to the position and focal length of the camera used to take the actual photo (you are setting up the exact criteria used to take your picture so you can draw on the picture). You can also set the scale of the actual building or structure while matching, or just resize the entire model after it has been drawn.

3. Start sketching. Once you have duplicated the position and focal length of the camera used to take the picture, you can draw over the image in SketchUp. SketchUp moves into a 2D sketching mode from matching (it is 2D because you are drawing on a 2D photo that needs to be oriented at a specific camera angle to you).

4. Repeat Step 2 and 3 with any other photos that make up the building or structure.
Creating a 3D Model to Match a Photo

Use the matching process to create a 3D model to match one or more photos of a building or structure. This process is best suited for making models of images that have parallel lines, such as the top and bottom of a square window. To create a 3D model to match a real-world building or structure:

2. Select the "Camera > Match New Photo." The Select background image file dialog box is displayed.
3. Navigate to the first photo in the series of photos for your building or structure.
4. Click on the first photo in the series of photos for your building or structure. The photo is selected.
5. Click the "Open" button. The photo will appear in the drawing area on its own scene in SketchUp. You are also placed in a matching mode where you will calibrate SketchUp's camera to duplicate the position and focal length of the camera used to take the actual photo. The words "Match Photo" appear in the upper-left of the drawing area. Finally, the Match Photo dialog box appears. Refer to Matching Controls and Context-Menu Items for further information.
6. Click and hold the cursor on the origin. The cursor changes to a hand.
7. Move the cursor to a distinct origin-like point on photo (where three axes might intersect, such as bottom corner of building). The origin you use depends on the photo:
   - For photos that are usually taken indoors where walls, ceiling, and floor of a room meet at a corner, the origin is usually at the bottom corner where the walls, ceiling, and floor meet.
   - For photos that are taken from a vantage point where you are looking down on the building or structure, the origin would be at the top corner of the building where roof and walls meet.
   - For photos that are taken from a vantage point where you are standing on the ground, the origin would be the bottom corner where the walls and ground meet.
8. Release the mouse button. The origin is established.
9. Click on a red axis bar grip. The cursor changes to a hand.
10. Move the cursor to the starting point of a position on the photo representing a line parallel to the red axis.
11. Release the mouse button.
12. Click on the other red axis bar grip. The cursor changes to a hand.
13. Move the cursor to the ending point of a position on the photo representing a line parallel to the red axis.
14. Release the mouse button. The first axis bar is aligned to the red axis.
15. Repeat steps 9 through 14 for the remaining three (one red and two green) axis bars.
16. Context-click to invoke the matching context-menu.
17. Select "Done." You are placed in a sketching mode. This mode, unlike normal SketchUp drawing mode, is a 2D drawing mode. The words "Sketch Over" appear in the upper-left of the drawing area. Refer to Sketch-Over-Image Controls and Context-Menu Items for further information.

18. Sketch on photo using the SketchUp drawing tools.

**Caution** - Tools that manipulate your point of view force you out of Sketch-Over-Image mode into normal SketchUp drawing mode. These POV tools are the Orbit Tool, Position Camera Tool, Walk Tool, and Look Around Tool.

19. Repeat steps 2-12 with other sides (photos) of the building until building or structure is done.
Matching an Existing 3D Model to a Photo's Context

Use the matching process to match an existing 3D model to a photo's context. To match an existing 3D model to a photo's context:

1. Take a digital picture of the location where you will place your building. This photo might or might not have an existing building where the model will be located.
2. Select "File > Open." The Open dialog box appears.
3. Navigate to your model.
4. Select the model.
5. Click "Open." The model appears in the drawing area.
6. Select "Camera > Match New Photo." The Select background image file dialog box is displayed.
7. Navigate to the photo where you want to place your building or structure.
8. Click on the photo. The photo is selected.
9. Click "Open." The photo will appear in the drawing area on its own scene in SketchUp. You are also placed in a matching mode where you will calibrate SketchUp's camera to duplicate the position and focal length of the camera used to take the actual photo. The words "Match Photo" appear in the upper-left of the drawing area. Finally, the Match Photo dialog box appears. Refer to Matching Controls and Context-Menu Items for further information.
10. Click and hold the cursor on the origin. The cursor changes to a hand.
11. Move the cursor to a distinct origin-like point on photo (where three axes might intersect, such as bottom corner of building).
12. Release the mouse button. The origin is established.
13. Uncheck the "Model" checkbox in the Match Photo dialog box. The model will be hidden.
14. Click on an red axis bar grip. The cursor changes to a hand.
15. Move the cursor to the starting point of a position on the photo representing a line parallel to the red axis.
16. Release the mouse button.
17. Click on the other red axis bar grip. The cursor changes to a hand.
18. Move the cursor to the ending point of a position on the photo representing a line parallel to the red axis.
19. Release the mouse button. The first axis bar is aligned to the red axis.
20. Repeat steps 9 through 14 for the remaining three (one red and two green) axis bars.
21. Check the "Model" checkbox in the Match Photo dialog box. The model will reappear, oriented correctly to the photo (but likely not-to-scale with the photo).
22. Click and hold on any of the axes. The cursor will change to two opposing arrows.
23. Move the cursor up or down the axis to scale your model. Your model will scale to fit the photo.

24. (optional) If your photo contains an existing building that is now represented by your model, click the "Project textures" from photo button in the Match Photo dialog box to project.

25. Context-click to invoke the matching context-menu.

26. Select "Done." You are placed in a sketch-over-image mode. This mode, unlike normal SketchUp drawing mode, is a 2D drawing mode. The words "Sketch Over" appear in the upper-left of the drawing area. See Sketch-Over-Image Controls and Context-Menu Items for further information.

⚠️ Caution - Tools that manipulate your point of view force you out of Sketch-Over-Image mode into normal SketchUp drawing mode. These POV tools are the Orbit Tool, Position Camera Tool, Walk Tool, and Look Around Tool.
Taking Digital Photos for Use When Matching

Your success with matching depends highly on the quality of photographs taken of your building or structure. Following are a few tips regarding matching photographs.

- Sketch Over Image works best on pictures of structures composed of predominantly right angles and taken at a roughly a 45 degree angle from a corner.
- The images should not be distorted and should be of a "reasonable" resolution.
- Barrel distortion typically comes from wide angle lens cameras, and users should use a third party product to eliminate it from images prior to using them within SketchUp. All cameras have a little bit of this distortion, typically worse around the edges of the image, and we have a simple tool for compensating for this visually.
- There are many other kinds of subtle lens distortions which I won't go into. Ultimately, we assume that perfectly straight lines in the original object are shown as perfectly straight lines in the photograph.
- Cropped (or expanded) images. A cropped image, or one which has been expanded to have extra white space around it, will not have the 'center of projection' in the center of the image. Sketch Over Image currently requires that the point you aimed the camera at is located in the center of the image. Although it may seem possible to use an image like this, typically, vertical lines will not align well across the image and the results will be unsatisfactory.
- Warped images. Images which have been manually warped via an image processing program, or specialized camera are not supported. For example, some cameras used for architectural photographs adjust for vertical perspective distortion, by tilting the camera plane. The resulting photo is an image similar to our "Two Point Perspective" mode.
- Stitched images (for example panoramic images). These images are typically excessively warped and will have multiple vanishing points for each axis.
- Non right angle models. Sketch Over Image relies on SketchUp's red/green/blue axes and limits most drawing to the axis planes. The more right angled reference lines in the original image, the better results you will get. Sketch Over Image will also struggle with: Vanishing points which are at infinity. This happens in two common situations. A one point perspective, for example, an image which is looking down a hall way, will be difficult to align because you only adjust one vanishing point and the other two are far away. Likewise, an image taken with a very long tele-photo lens (or say a satellite or aerial image) will not have very useful vanishing points and will be difficult to align.
- Extremely high resolution images. Images are currently embedded within the skp file and duplicated when made into a material. This makes for large model sizes. There is also no resolution control over the export process and this may be a problem when exporting to GE (for example).
- Excessive foreground. If there are trees and other foreground objects blocking the view of the building, it may be difficult to Sketch Over top of the image.
Resuming a Sketch-Over-Image Mode

Click on the scene tab that represents the photo to return to sketching over the image.
Editing a Previously Matched Photo

There are two options to resume matching. These options are:

- Select the photo you were matching from the Camera > Edit Matched Photo sub-menu.
- Context-click on the Scene tab for the photo you were matching and select "Edit Matched Photo."
Deleting a Matched Photo

To delete a matched photo:

1. Select the "Window > Scenes." The Scenes Manager is displayed.
2. Click on the scene with the same name of the matched photo. The photo is selected.
3. Click on the "Remove Scene" button. A dialog box appears asking if you want to delete the scene.
4. Click the "Yes" button. The scene and its matched photo are removed.
Suspending the Gravity Setting (Microsoft Windows)

The Orbit Tool is designed to maintain a sense of gravity by keeping vertical edges pointed up and down. Press and hold the "Ctrl" key during orbit to suspend this gravity setting and to roll the camera on its side.
Orbiting With a Three Button Mouse

The Orbit Tool is used heavily when creating and editing models. SketchUp contains a few mouse enhancements and modifier keys to allow easy access to the Orbit Tool.

Activating the Orbit Tool While in Another Tool

Click and hold middle mouse button (scroll wheel) on a three-button mouse to temporarily activate the Orbit Tool while in any other tool (except the Walk Tool).

Tip - Click and hold the Control and Command keys simultaneously while clicking and holding the left mouse button to temporarily activate the Orbit Tool (if you have only one mouse button) (Microsoft Windows).

Tip - You will also be put in pan temporarily if you click on the middle-mouse wheel and then click and hold the left mouse button or press and hold the "Shift" key.
Orbiting the View

The Orbit Tool performs a 3D orbit. To orbit using the Orbit Tool:

1. Select the "Orbit Tool" ( ). The cursor changes to two interconnected perpendicular ovals.
2. Click anywhere in the drawing area.
3. Move your cursor in any direction to rotate around the center of the drawing area.

Tip - Double-click the left mouse button on your model to center to the model in the drawing area.
Panning While in Other Tools (1-Button Mouse)

Click and hold the "Control," "Command," and "Shift" keys simultaneously while clicking and holding the left mouse button to temporarily activate the Pan Tool (if you have only one mouse button).
Panning While in the Orbit Tool (3-Button Mouse)

Press and hold the "Shift" key while in the Orbit Tool to temporarily activate the Pan Tool. Or, press and hold the left mouse button while pressing and holding the middle mouse button (scroll wheel) to activate the Pan Tool.
Panning the View

The Pan Tool performs a pan operation. To pan using the Pan Tool:

1. Select the "Pan Tool" ( ). The cursor changes to a hand.
2. Click anywhere in the drawing area.
3. Move the cursor in any direction to pan.
Centering the Point of View

Double-click the left mouse button on your model to center the model in the drawing area.
Changing Focal Length With the Zoom Tool

Focal length, expressed in millimeters, affects the amount you can see of a model. A shorter focal length allows you to see a larger (wide) portion of a model, while a longer focal length allows you to see a smaller portion of a model. To change the focal length:

1. Select the "Zoom Tool" (🔍). The cursor changes to a magnifying glass.
2. Type a focal length in millimeters, such as "300mm." The value appears in the Measurements Toolbar and the focal length changes to 300mm.

Note - Focal length can range from 10 to 2063 millimeters.
Changing Field of View and Focal Length

Field of view, expressed in degrees, refers to the amount you can see of a model or scene. A narrow field of view only allows you to see a small portion of a scene, while a wider field of view allows you to see more of a scene. Wider fields of view are useful when working inside a room where you might want to see more of the room while you draw.

Focal length, expressed in millimeters, refers to a camera lens size. Short or wide angle focal lengths yield a greater field of view, while longer, or telephoto, focal lengths yield a smaller field of view.

Field of view and focal length are inversely related (when you increase one, the other decreases). You must be in perspective mode (Camera > Perspective) to change field of view and focal length.

Changing Field of View Using the Zoom Tool

The Zoom Tool simulates what is known as a dolly in movie-making terms. That is, when you zoom in on your model, picture yourself standing on a moving platform looking into a camera, while the platform moves closer to or farther from the model. To change field of view using the Zoom Tool:

1. Select the "Zoom Tool" ( ). The cursor changes to a magnifying glass.
2. Hold the shift key and click and hold the mouse button while moving the cursor up or down. The field of view increases when the cursor goes up (focal length decreases). The field of view decreases when the cursor goes down (focal length increases).

Note - The Measurements Toolbar will display field of view in degrees when using the Zoom Tool in the field of view mode.

Note - As you increase or decrease the field of view beyond the normal setting of 35 degrees, the perspective angles will look increasingly distorted. As you approach zero, the focal point moves off into infinity and you lose perspective (as if perspective mode is turned off). As you approach 120 degrees, which is the maximum field of view, the focal point is very short and perspective angles become overly pronounced.

Changing Field of View Using the Field of View Tool

To change field of view using the Field of View Tool:

1. Select "Camera > Field of View." The cursor changes to a magnifying glass.
2. Click and hold the mouse button while moving the cursor up or down. The field of view increases when the cursor goes up. The field of view decreases when the cursor goes down.

Precisely Changing Field of View and Focal Length

You can precisely change field of view by typing a value (from 1.0 to 120.00), followed by "deg." in the Measurements Toolbar. For example, to change the focal length to 110, type "110deg."

You can precisely change the focal length by typing a value (10 to 2063), followed by "mm" in the Measurements Toolbar. For example, to change the focal length to 30, type "30mm."
Adjusting Perspective (Field of View)

Adjust the screen to an exact perspective or camera lens by typing an exact value in the Measurements Toolbar while the Zoom Tool is active. For example, "45 deg" sets a 45 degree field of view and "35 mm" sets the equivalent focal length of a 35mm camera. Press and hold the "Shift" key while in the Zoom Tool to visually adjust the camera lens or field of view. Remember, changing the FOV keeps the camera in the same location in 3D space.
Zooming With a Scroll Wheel Mouse

Rolling wheel forward on a scroll wheel mouse zooms in on your model. Rolling the wheel backward on a scroll wheel mouse zooms out from your model.

Note - The cursor position determines the center of zoom when using the scroll wheel whereas the center of the screen determines the center of zoom when zooming using the left mouse button.
Zooming In and Zooming Out of Your Model

The Zoom Tool simulates what is known as a *dolly* in movie-making terms. That is, when you zoom in on your model, picture yourself standing on a moving platform looking into a camera, while the platform moves closer to or farther from the model. To zoom in and out using the Zoom Tool:

1. Select the "Zoom Tool" (Zoom Tool Image). The cursor changes to a magnifying glass with a plus and minus sign.
2. Click and hold anywhere in the drawing area.
3. Drag the cursor up to zoom in (closer to the model) and down to zoom out (farther from the model).
Zooming in on a Portion of Your Model

The Zoom Window Tool allows you to draw a rectangular zoom window around a portion of your model. The Zoom Window Tool will then zoom in on the content within the zoom window. To zoom in on a portion of your model:

1. Select the "Zoom Window Tool" ( ). The cursor changes to a magnifying glass with small square.
2. Click and hold a short distance away from the entities you want to appear in the zoom window. This is the zoom window starting point.
3. Move cursor diagonally.
4. Release the mouse button when all of the entities are enclosed within the zoom window. These entities will fill the screen.
Walkthrough Tools

This section of the user's guide covers the walkthrough tools within SketchUp. Walkthrough tools are those tools used to view your model as through walking around and in your model. These tools are the Position Camera Tool, Look Around Tool, and Walk Tool.

Tools in this section are covered in the order they appear within the Camera menu.
Positioning the Camera

The camera is positioned using one of two methods. The first method places the camera at eye-level above a specific point (5’ 6” above that point by default). The second method requires placing the camera at a specific point, facing a specific direction.

Positioning the Camera at an Eye-Level View

The first position camera method allows you to position the camera at a specific eye-height above a specific point that you choose. The camera does not point at anything in particular. However, you are placed in the Look Around Tool allowing you to move the camera around the point to look at items in your model.

1. Select the "Position Camera Tool" ( ). The cursor changes to a small person with a red X. Notice that the Measurements Toolbar indicates that the eye height above the ground plane is set to 5 feet, 6 inches. You can override this height at this time by typing in a desired value.

2. Click on a point in your model. SketchUp places the camera's point of view at an average eye-height over the point you click on. You are also placed in the Look Around Tool. The following image shows a point in the middle of a room. The camera will be positioned directly above this point (5’ 6”) facing the television set if you click at this point.

Note - The viewing direction defaults to the top of screen, which is due north, if you place the camera from a plan view.
Positioning the Camera Using Specific Target Points

The second position camera method allows you to position the camera at a specific point, facing a specific direction.

1. Select the "Position Camera Tool" ( ). The cursor changes to a small person with a red X. Notice that the Measurements Toolbar indicates that the eye height above the ground plane is set to 5 feet, 6 inches. You can override this height at this time by typing in a desired value.

   Tip - Use the Tape Measure Tool and the Measurements Toolbar to drag parallel construction lines off of edges as a method to provide accurate camera placements.

2. Click and hold mouse button on a point in your model.

3. Drag the cursor to the portion of the model that you want to look at. A dotted line is extended from the point selected in step 2 to the portion of the model you want to look at.

4. Release the mouse button. The camera is repositioned at a height of 0 at the point selected in step 2. The camera faces the item you dragged the cursor to in step 3. The following image shows a point in the middle of a room with a dotted line to the window on the left wall of the room. The camera will be positioned directly at the first point (at 0 height) facing up at the window if you release the mouse button on the window.
5. (optional) Type a new eye height into the Measurements Toolbar to reposition the camera at eye height above the point selected in step 2.

💡 **Tip** - Position the camera directly horizontal to the model to achieve a 2 Point Perspective.

💡 **Tip** - Hold the "Shift" key while clicking on a surface to position the camera directly on the surface.
Ascending and Descending

The Walk Tool automatically walks up and down inclines or steps while maintaining eye height.
Looking Around While in the Walk Tool

Click and hold the middle mouse button, while using the Walk Tool, to use the Look Around Tool.
Toggling Collision Detection

Press the "Alt" (Microsoft Windows) or "Command" (Mac OS X) key while walking around to temporarily turn off collision detection. This option is useful when examining models such as mechanical devices or furniture (anything other than the interior of a building).
Touring Your Model

The Walk Tool is primarily used to take an interactive walk through or around your model. To use the Walk Tool to tour your model:

1. Select the "Walk Tool" ( ). The icon changes to a pair of shoes. Notice that the Measurements Toolbar indicates that the eye height above the ground plane is set to 2 feet, 10 1/2 inches. You can override this height at this time by typing in a desired value.

2. Click and hold anywhere in the drawing area. A small plus sign (cross hair) is placed at the location where you clicked.

3. Move the cursor up (forward), down (backward), left (to go left) or right (to go right) to walk through or around your model. The further you are from the cross hair, the faster you walk.

   **Note** - Press and hold the "Shift" key while moving the cursor up and down allows you to move up or down instead of forward or backward. Press and hold the "Ctrl" (Microsoft Windows) or "Option" (Mac OS X) key to run instead of walk. Press and hold the "Alt" key to avoid collision detection (walk through walls).

   **Tip** - It is often desirable to tour a model with a wide field of view. Activate the Zoom Tool, press and hold the "Shift" key, and press and drag up and down to widen your field of view prior to walking through a model.
Activating the Look Around Tool While in the Walk Tool

Click the middle mouse button to activate the Look Around Tool while in the Walk Tool.
Looking Around

The Look Around Tool performs tilt and pan operations. To tilt and pan using the Look Around Tool:

1. Select the "Look Around Tool" ( ). The cursor changes to a pair of eyes.
2. Click to start pivot.
3. Move the cursor up or down to tilt; right or left to pan.
Specifying an Eye Height

Type the eye height for the camera in the Measurements Toolbar and press the "Enter" (Microsoft Windows) or "Return"(Mac OS X) key to change the height above the ground plane for the camera.
Sandbox Tools

This section of the user's guide covers the sandbox tools within SketchUp. Sandbox tools are those tools used to create and manipulate large surfaces (TINs) in your models. These tools include the Sandbox From Scratch Tool, Sandbox From Contours Tool, Smoove Tool, Stamp Tool, and Drape Tool.

Sandbox tools are not just for modeling terrain; they can also be used to model other organic shapes such as the curved portions of a hand-built wooden chair or a wooden bowl. Organic shapes are those that have a hand-made or custom appearance.

Tools in this section are covered in the order they appear within the Draw > Sandbox and Tools > Sandbox sub-menus.
Enabling the Sandbox Tools

To enable the sandbox tools:

1. Open the Extensions Manager ("Window > Preferences > "Extensions" on Microsoft Windows or "SketchUp > Preferences > Extensions" on Mac OS X).
2. Click the check box next to the extension that you want to enable.
3. Click "OK."
Creating a Sandbox From Contour Lines

To create a sandbox from contour lines:

1. Import or draw several contour lines. Ensure that the contour lines are offset in their height from the ground plane.
2. Select all of your contour lines.
3. Select "Draw > Sandbox > From Contours." Terrain will be filled in using the contour lines as a guide.
Creating a New TIN

To create a new TIN:

1. Select the "Sandbox From Scratch Tool" ( ). The cursor changes to a pencil with a grid.
   
   **Note** - The Sandbox from Scratch Tool defaults to 10’ square grid sizes. You might want to zoom out or change the grid size (Grid Spacing) in the Measurements Toolbar to before creating your sandbox.

   **Tip** - You can optionally enter a value in the Measurements Toolbar for the size of each square in your grid at this time (Grid Spacing).

2. Click to set the starting point of your TIN.

3. Move the mouse in the direction you want to be the length of the TIN. As you move your mouse a line appears with tick marks at a specific spacing. The length value is displayed dynamically in the Measurements Toolbar.

4. Click a second time to establish the length of your TIN.

5. Drag the mouse perpendicular to the length line to establish the width of your TIN.

6. Click a third time to establish the width of your TIN. The following image shows the flat TIN created with the Sandbox From Scratch Tool.

   ![Flat TIN created with Sandbox From Scratch Tool](image)

   **Note** - The terrain will be placed inside of a Group entity. You must edit or explode the group to perform other operations, such as smoothing with the Smoove Tool, on the TIN.
Drawing a Flat TIN by Inference

The Sandbox From Scratch Tool uses SketchUp's sophisticated geometric inference engine to help you place your terrain in 3D space. The inference decisions, made by the inference engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between the line you are drawing and the geometry of your model. Refer to the inference engine topic for additional information.
Creating Precise TINs

The Measurements Toolbar displays the length and width of your TIN while you are drawing a flat TIN. You can also specify a line length and width value using the Measurements Toolbar.

Entering a Length Value

Specify a length and width in the Measurements Toolbar by typing in the desired length after placing the starting point of the flat TIN. SketchUp will use the current document units setting if you only type in a numerical value. You can also specify either Imperial (1'6") or Metric (3.652m) units at any time, regardless the model units setting.

Entering a Width Value

Specify a width and width in the Measurements Toolbar by typing in the desired length after setting the length of the flat TIN. SketchUp will use the current document units setting if you only type in a numerical value. You can also specify either Imperial (1'6") or Metric (3.652m) units at any time, regardless the model units setting.
Specifying an Offset Value

The Measurements Toolbar also specifies an offset while you are sculpting. You can also specify an offset value, such as “10,” using the Measurements Toolbar.
Sculpting a Terrain

To sculpt a terrain:

1. Create, such as with the Sandbox From Scratch Tool, or import a TIN. The following image shows a flat terrain created with the Sandbox From Scratch Tool.

2. Select the "Smoove Tool" ( ). The cursor changes to an arrow.

   **Tip** - Alternatively, you can preselect a series of points, edges, and faces and then click on the Smoove Tool to begin a smoove operation.

3. Click on a point, edge, or face within the TIN. SketchUp highlights all neighboring vertices to be included in the sculpting operation within the radius specified in the Measurements Toolbar. The following image shows the point that was selected (the largest square in the middle) and neighboring vertices.

   **Note** - Remember to ungroup a terrain created with the Sandbox From Scratch Tool prior to using the Smoove Tool.
4. Move the mouse up or down in the vertical (blue) direction to sculpt the TIN. The TIN will expand or contract accordingly. You can also type offset value in the Measurements Toolbar, such as 10'. The following image shows the terrain resulting from moving the point and neighboring vertices up.

![Terrain Sculpting](image)

**Note** - You can sculpt in a direction other than vertical by holding down the Shift key while moving the mouse. However, this operation can result in a non-functional terrain or terrain that can no longer be manipulated in a known way. This operation can only be performed while in active selection (not after preselection).

5. Smooth and soften the TIN to get your final model.

**Tip** - Double-click to repeat the last smooth operation.
Specifying Sculpting Radius Values

SketchUp determines the number of vertices included in the sculpting operation based on a radius value. The larger the radius the more vertices included in the sculpt. The Measurements Toolbar displays this radius while you are sculpting a TIN. You can also specify a radius value while sculpting, such as “10’r,” using the Measurements Toolbar.

💡 Tip - Preselect a series of points, faces, and edges within your TIN to sculpt more specific shapes such as ridges and berms.
Creating Impressions of Geometry in a TIN

To create an impression of geometry in a TIN:

1. Create your TIN, such as the terrain where a building might exist
2. Create the faces to be used as the stamp, such as the bottom faces of the building.
3. Move the stamp over the location in the TIN where you want to create an impression.

Note - The stamp can be an individual face, selection set of faces, a group, or a component.

4. Select the "Stamp Tool" ( ). The cursor changes to an arrow.
5. Click on the stamp. SketchUp will create an offset around the stamp.
6. (optionally) Adjust the offset size by typing in a new value in the Measurements Toolbar.
7. Click on the TIN.
8. A copy of the stamp will be indented into the TIN. The cursor will be on the copy of the stamp allowing you to move the stamp, and connected TIN, up or down.
9. Move the mouse to adjust the stamp within the TIN.
10. Click when you are done adjusting the stamp.
11. Smooth and soften the TIN to get your final model.

Note - The Stamp tool will not work on a group or component that is open for editing.
Painting Draped Terrain

Terrain is typically contained within a group. Paint the draped section without editing the group will paint the entire terrain instead of just a section of the terrain. You must edit the group to paint individual sections of the terrain.
Draping Edges Onto a TIN

To drape edges onto a TIN:

1. Create, such as with the Sandbox From Scratch Tool, or import a terrain.

2. Create the edges you want to drape over the TIN. The edges can be in a single plane (flat) and must be positioned above a TIN. The following image shows a 2D road positioned above a terrain.

![Image of 2D road on terrain]

**Note** - The Drape Tool will only drape the edges surrounding a face if you attempt to drape a face or series of faces over the TIN.

3. Select the edges that you want to drape over the TIN.

4. Select the "Drape Tool" ( ). The cursor changes to an arrow.

5. Click on the TIN to drape the selected edges on the TIN. The following image shows the edges draped over the terrain.

![Image of draped edges on terrain]

**Note** - The draped edges will be outside of a group or component context if the TIN is encapsulated within a group or component.

**Tip** - This tool also works in active selection mode to select the drape edges if nothing is preselected.
Creating Smooth Areas

You can preselect a series of triangles in your model using the Select Tool and then use the detailer to divide those triangles to create a smoother area. The following image shows a flat TIN with a selection set that was detailed two times (creating several tiny triangles). This area of the model will appear very smooth when sculpted, using a tool such as the Smoove Tool.
Detailing a TIN

To detail a terrain:

1. Create a TIN. The following image shows a flat TIN or sandbox created with the Sandbox From Scratch Tool.

2. Select the "Add Detail Tool" ( ). The cursor changes to an arrow.

3. Click on a point, edge, or face within the TIN. SketchUp creates a new vertex where you clicked with new triangles spanning out from the new vertex. The following image shows two additional triangles created when the midpoint of a line was selected.
4. Move your mouse up or down to adjust the height of the vertex and surrounding triangles. The following image shows the resulting TIN when the new vertex was lifted.

![TIN Image]

**Note** - You can also type in an offset distance to adjust the height of the vertex after clicking on a point, edge, or face within the terrain. For example, 10' will raise the new vertex 10' above the starting terrain.

**Note** - You can sculpt in a direction other than vertical by holding down the Shift key while moving the mouse. However, this operation can result in non-functional terrain or terrain that can no longer be manipulated in a known way.

5. Continue clicking on points, edges, or faces (either on the TIN you created in step 3, or on other portions of the TIN) to create additional triangles for manipulation.

6. Smooth and soften the TIN to get your final surface.
Specifying an Offset Value

The Measurements Toolbar also specifies an offset while you are detailing a TIN. You can also specify an offset value, such as "10'", using the Measurements Toolbar.
Modifying TIN Triangulations

To modify TIN triangulations:

1. Create a TIN using a tool such as the Sandbox From Contours Tool.

2. Select the "Flip Edge Tool".

3. Move the mouse over the TIN to highlight edges that can be flipped.

4. Click on any edge to flip the edge to an opposite triangulation. SketchUp analyzes the two adjacent triangles that share the edge, removes the selected edge, and replaces it with a perpendicular edge.
Improving Sandbox Tool Performance

The more complex your model (the more faces), the slower SketchUp. Some Sandbox tools are capable of creating a lot of faces, thus slowing performance. Following are some tips for improving performance using the Sandbox tools.

Depending on the complexity of the model, it can take SketchUp several minutes to several hours to calculate the geometry created by the Sandbox tools. SketchUp may even appear to have stopped responding. Once you have started a Sandbox operation, you should not make any more changes to the model until after SketchUp has finished the operation. If you make any changes before that, you'll interrupt the calculations.

Sandbox From Contours Tool

Simplify contours so that they have fewer lines and end points (when the complexity of the contours is not important for your overall model). Use the Simplify Contours script to reduce the number of line segments and endpoints. This script evaluates each pair of segments in a contour. If a pair forms an angle that is less than the simplify angle, which defaults to 10 degrees, they are merged into one segment, eliminating one endpoint. You can change the simplify angle when running the script.

You can reduce the endpoints by 50% or more when using the 10 degree setting, while maintaining contours that are smooth enough for modeling. To use the Simplify Contours Ruby script:

2. Uncompress the Simplify Contours script to create a SimplifyContours.rb file.
3. Place the Simplify Contours script into your Plugin The Plugins folder on Microsoft Windows is at: C:\Program Files\Google\Google SketchUp 6\Plugins
   The Plugins folder on Mac OS X is at: <username>/Library/Application Support/Google SketchUp 6/SketchUp/Plugins
5. Open your model with the contoured terrain.
6. Select all of the contours. The contours are highlighted.
7. Select the "Plugins > Simplify Contours."
8. (optional) Set the Simplify Angle.
9. Click the "OK" button. The contours are simplified.

Sandbox From Scratch Tool

Reduce grid complexity, by adjusting grid spacing to be larger, when creating a sandbox from scratch.
Stamp and Drape Tool

The Stamp Tool and Drape Tool create additional faces from existing terrain. Simplify your existing terrain to yield simpler results with these tools by:

- Simplifying your contours if your existing terrain was created from contours.
- Adjusting grid spacing to be larger if your existing terrain was created from scratch.
- Crop existing terrain to essential area needed for your model (removing all unneeded geometry).

The following image shows the additional polygons created when using the Stamp Tool on a complex terrain (rectangles that compose the house foundation):

The following image shows the additional polygons created when using the Stamp Tool on a simple terrain (rectangles that compose the house foundation):
The following image shows the additional polygons created when using the Drape Tool on complex terrain (shaded below the house foundation):

Add Details Tool
Minimize use of this tool unless you truly need to add detail to your model because this tool adds additional faces to your terrain.

The following image shows the additional polygons created when using the Drape Tool on a simple terrain (shaded below the house foundation):
Adding Strokes to a Style

You can drag and drop strokes from the Strokes tab directly into empty grey boxes in the Sets Pane (if they exist). You can also drag and drop strokes from the Strokes tab, above or below current strokes in the Sets Pane. Keep in mind, however, that all sets in the Sets Pane, must have the same number of strokes. So, if all sets in the Sets Pane have 1 stroke, and you add another stroke to one of the sets, the Style Builder will automatically create a blank stroke in the remaining sets to even out the sets. The following image shows the Sets Pane with four sets, each with a single stroke.

The following image shows the Sets Pane after a second stroke has been added to the first set (the set whose stroke size is 32). Notice that all of the other sets (64, 129, and 256) have been expanded to accommodate the same number of strokes as the first set. This expansion is accomplished by adding empty grey boxes, or blank strokes, in the remaining sets.

Note - You will want to have the same number of strokes per set before you save your style, otherwise the empty gray boxes will appear in SketchUp as part of your style. You can fill in the blanks by adding duplicate strokes as in the previous image where two of the same 32 pixel strokes were used.
Deleting Libraries of Strokes (Mac OS X)

Highlight a stroke library name in the Strokes tab and then select the "Strokes > Remove Stroke" menu item to remove the stroke library from the Strokes tab.
Deleting Library of Strokes (Microsoft Windows)

Click on the "X" (×), next to library of strokes in the Strokes tab, to remove the library.
Deleting Strokes

Click on the eraser icon (eraser) next to any stroke, in the Sets Pane, to replace the stroke with an empty gray box.
Google Toolbar

This section of the user's guide covers the Google Toolbar within SketchUp. Buttons on the Google Toolbar are used to interact with other Google technologies, such as Google Earth.

Items in this section are covered in the order they appear within the Google menu.
Configuring Google Earth

There are a few configuration options you should set before using the Google Toolbar buttons. These are as follows:

- Install Google Earth 3.0.640 or higher.
- Turn Elevation Exaggeration to 1 in Google Earth ("Tools > Options > View")
- Turn terrain on in Google Earth. Click on the Terrain check box toward the bottom middle of Google Earth to turn on terrain.
- Change your image resolution in Google Earth to the largest available setting ("Tools > Options > View" > "Detail Area") to ensure the best images captures in SketchUp.
Using SketchUp With Google Earth

You can use SketchUp with Google Earth to create 3D structures within the Google Earth environment. Refer to the Configuring Google Earth and Google Earth and SketchUp Workflow sections for further information.
Getting the Current View From Google Earth

To get the current view:

1. (Google Earth) Find the location where you want your 3D model to appear. For example, type street and city where a new building will be built.

2. (Google Earth) Zoom in on this location until you have a fairly detailed view of a building that you want to model.

   **Note** - Ensure terrain is turned on in Google Earth. Click on the Terrain check box toward the bottom middle of Google Earth to turn on terrain.

3. (SketchUp) Click on the "Get Current View" button to capture an image of the current Google Earth view. A 2D image of the current view in Google Earth is placed in SketchUp. This image is locked so that you cannot delete it.

4. (optional) Click on "Undo" if the image is not satisfactory and you need to reposition the view in Google Earth and repeat this process.

   **Note** - If your snapshot appears solid black in SketchUp, adjust your graphics mode option in Google Earth. Go to "Tools" > "Options" > "View" and change your graphics mode setting from Open GL to Direct X. Exit and restart Google Earth for this setting to take effect.

   **Note** - The snapshot of the Google Earth view is locked in SketchUp so that it is not mistakenly deleted. You cannot delete this snapshot, but you can use the Materials Browser to change the opacity of the image to 0, making the image 100% transparent.
Toggling Terrain

To toggle a terrain:

1. Get the current view from Google Earth using the Get Current View button. A 2D Google Earth image will appear by default.

2. Click on the "Toggle Terrain" button. The 2D Google Earth image will toggle to a 3D Google Earth image (with terrain).

Note - The Get Current View button actually captures two images from Google Earth, one with terrain and one without terrain. Each image is assigned to a different layer in SketchUp whose visibility is toggled using the Toggle Terrain button.

Tip - Develop your model on the 2D image then toggle to the 3D image and adjust the model's location to the contours of the terrain.
Placing Your Model in Google Earth

To place your model in Google Earth:

1. Use the Snapshot, Toggle Terrain, and SketchUp Tools to create and place your model on a Google Earth snapshot image.

2. Ensure Google Earth is running.

3. Click the "Place Model" button to send your model to Google Earth. SketchUp creates a temporary file of your model and places the model in Google Earth at the proper location.

Note - Reverse the faces in your model (within SketchUp) if your model appears black in Google Earth. Select the faces to reverse and then context-click and select Reverse Faces from the context menu.

4. Repeat this process until your model appears as you would like it in Google Earth.

Note - Use the KMZ export option to export the final model for use in Google Earth. See the Input and Output section of this guide for further information.
Deleting Models from Google Earth

You can delete models in your local version of Google Earth when you no longer need them. To delete a model from Google Earth:

1. Context-click on the model in either the Places or Temporarv Places folder in Google Earth.

2. Select the "Delete" menu item. The SketchUp model will be deleted.

Note - Uncheck checkboxes in front of SketchUp models to hide models in Google Earth. This method will help you locate the model you want to delete.
Optimizing Models for Google Earth

Complex models (models with a lot of faces) are rendered slowly in Google Earth. The following tips will help to reduce the complexity, and therefore size, of your model in Google Earth.

Use Image Textures On Simplified Structures

Draw the basic form of a structure and cover the structure with image textures of the actual structure. For example, instead of modeling all of the details of each side of the Eiffel Tower, which could contain thousands of faces, model the general shape of each side and then project an image texture of the Eiffel Tower’s side, containing all of the detail, on to the model. The following image shows a SketchUp model of the Eiffel Tower with minimal faces:
The following image shows the SketchUp model of the Eiffel Tower with a projected photo image (Google Earth on the left and SketchUp on the right).

Note - Use PNG or JPG Format to preserve transparency. (If your image does contain transparency, don't colorize the image; a colorized image with transparency won't display correctly in Google Earth.) Make sure you optimize both the image dimensions and resolution. Since this is for on-screen display, a resolution of 72 ppi is adequate, and your image dimension should be 640 x 480 or smaller. Your goal is to keep the image size as light as possible so it doesn't add unnecessary weight to the model.

Reduce Face Count by Simplifying Geometry
Large buildings might have a lot of detail that is simply not necessary in Google Earth. For example, specific detailing on windows might not be as important as the placement and number of windows.

Reduce face count by reducing the number of sides of curves. For example, the tapered steel crown of the Chrysler Building is made up multiple, half-circle arcs. A default half-circle arc has 12 sides, but you can easily reduce the number of sides to five, eliminating 168 faces, while still preserving the feel of the building.
Hiding Google Earth Terrain

SketchUp imports two terrain images, one 3D and one 2D when the Get Current View feature is used in SketchUp. Each image is locked on its own unique layer. The 3D image’s layer is named Google Earth Snapshot. The 3D image’s layer is Google Earth Terrain. Only one of these snapshots (layers) is visible at a time. To hide all Google Earth terrain:

1. Select "Window > Layers." The Layer Manager is displayed.
2. Uncheck the checkboxes under the Visible column for the Google Earth Snapshot and Google Earth Terrain layers. All Google Earth terrain will be hidden.
Storing Models for Use in Google Earth

You can store models either in your local version of Google Earth (so they are not available to others) or share them using the 3D Warehouse.

Storing a Model Locally in Google Earth

To store a model locally in Google Earth:

1. Locate the model in the Temporary Places folder within Places panel on the left-hand side of Google Earth. Models placed in Google Earth are named SUPreview#, such as SUPreview2.
2. Context-click on the model name. A context menu appears.
3. Select the "Move to My Places" menu item. The model is moved to the My Places folder within the Places panel.
   
   **Note** - Only one SketchUp model can exist in Temporary Places at one time. You must store your models in the My Places folder if you want to view more than one of your models simultaneously in Google Earth.

Sharing a Model Using the 3D Warehouse

To share a model using the 3D Warehouse:

1. Open the model in SketchUp. The model appears in the drawing area.
2. Click on the "Share Model" button in the Google toolbar. The 3D Warehouse appears.
3. Log in to the 3D Warehouse. You will need a Google account if you do not have one.
4. Follow the steps to post your model in the 3D Warehouse.
Specifying a Model's Location in the World

You can set the location of your model in all versions of SketchUp. However, the mechanism for setting location is different between SketchUp Pro and Google SketchUp.

Setting Location in SketchUp Pro

Use the Location panel in the Model Info dialog box ("Window > Model Info > Location") to set the location for your model.

⚠️ Caution - Do not use the Location panel in the Model Info dialog box to change the location of a model after importing the current view from Google Earth (using the Google Plugin). Using the Location panel to position models in Google Earth will likely result in an incorrectly located model.

Setting Location in Google SketchUp

Load Google Earth and navigate to the location where you model will exist (the town is sufficient). Use SketchUp's Get Current View button to import the current view, as well as the location, from Google Earth. You can hide or delete the Google Earth snapshots if you want to work without them (such as when doing a shadow study).
Stitching Together Terrain Images From Google Earth

You can often get better quality images by flying in close on a location in Google Earth, but this can prevent you from seeing the entire area you want to use. However, you can easily stitch together multiple terrain images from Google Earth in SketchUp. To stitch together multiple terrain images from Google Earth:

1. (Google Earth) Fly in close so you are looking straight down at a location.
2. (SketchUp) Click the "Get Current View" button.
3. (Google Earth) Move the earth so you are looking straight down at a slightly different location than the location in step one.
4. (SketchUp) Click the "Get Current View" button again. The new image is aligned properly with the image already in SketchUp.

Note - It is important to get the images from Google Earth at the same elevation to ensure images align properly.
Model Settings and Managers

This section of the user's guide covers the various model settings and manager dialog boxes within SketchUp. These dialog boxes include the Components Browser, Application Preferences, Material Browser, and Styles Browser dialog boxes.

Each dialog box in this section is covered in the order they appear within the Window (Microsoft Windows) and SketchUp (Mac OS X) menus.
Applying Materials

There are multiple methods to apply a material to entities in your model. To apply materials using the Paint Bucket Tool:

1. Select the "Paint Bucket Tool." The cursor will change to a paint bucket. The Materials Browser will open.
2. Click on the "Select" tab.
3. Locate and click on a material library within the drop-down list.
4. Click on the material you want to use.
5. Click on a entity to apply the color or material to the entity.

Note - Ensure that the Shaded with Textures display style is selected to see materials containing textures that you have applied to entities.
Editing Materials

Changes made a material will automatically apply to the entities in the model painted with that material. This behavior allows you to interactively experiment with color variations in your model. To edit a material:

1. Select "Window > Materials.". The Materials Browser is displayed.
2. Click on the "Select" tab.
3. Click on the "In Model" library drop-down list.
4. Click on one of the materials. The material appears in the material thumbnail.
5. Click on the "Edit" tab.
7. (optional) Save your changes to the edited material:
   a. Click on the "In Model" button. The In Model library is displayed.
   b. Context-click on the edited material. The In Model context-menu is displayed.
   c. Select the "Save As" menu item.
   d. Navigate to a directory (folder) where you want to save the style.
   e. Type a name in the File name field and click the "Save" button. The file is saved.
      Refer to the Open or create a library context-menu item for information on how to retrieve this material for use in other SketchUp files.

Note - Select "Edit > Undo" to revert back to a previous material if you make a mistake while you are editing a material
Deleting Materials

Materials added to your model are stored within the model's .skp file. A material with only color information is very small, but materials with textures can get fairly large, depending on the file size of your texture. Therefore, it is suggested you delete unused materials from the In Model tab to minimize the size of your model file. To delete a material:

1. Select the "In Model" button of the Materials Browser. This button displays all materials defined in your model. Materials that are used in your model have a small triangle in the bottom right corner.

2. Right click on the material you want to delete to display the material's context menu.

3. Select "Delete" (Microsoft Windows) or "Remove" (Mac OS X) from the context menu. A dialog box will appear if you are deleting a material that is currently used in your model.
   a. Click "Yes" (Microsoft Windows) or "Remove" (Mac OS X) to delete the material and replace it with the default material.
   b. Click "No" (Microsoft Windows) or "Cancel" (Mac OS X) to retain the material.
Creating a Component

Components are useful for creating reusable models to be placed within other models. The most important issue to consider when creating components is how you want them to be placed when inserted into the model from the Components Browser. The component axes will dictate both component orientation on insert and cutting plane (for components that are to automatically cut holes in faces, such as windows). To create a component:

1. Draw your component in the orientation where it will be used. For example, if you are creating a couch component, draw it on the ground plane. If you are creating a window or door, draw it on a wall that is vertically aligned to the blue axis.

2. Select the "Select Tool." The will change to an arrow.

3. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.

4. Drag the mouse to the opposite corner of the selection starting point.

5. Release the mouse button when all of the elements are either partially included (left-to-right selection) or fully included (right-to-left selection) in the selection box.

5. Select "Edit > Make Component." Alternatively, context-click on the currently selected entities and select "Make Component" from the context menu. The Create Component dialog box is displayed. The following image shows the Create Component dialog box on Microsoft Windows:
6. Fill out the fields in the dialog box. Ensure you make all of the appropriate selections and check all of the appropriate boxes before continuing. Specifically, decide whether the component should glue to faces in a specific orientation and cut openings.
7. Click the "Create" button. SketchUp adds the newly created component to the In Model components.

⚠️ **Caution** - Components that are created in their appropriate "glue to" orientation are created with the blue and green axis swapped. This is only of importance when creating dynamic components as the LENZ will have a value for length along the green axis and the LENY will have a value for the length along the blue axis.

📝 **Note** - The Make Component operation disconnects any geometry that was connected to selected geometry prior to placing the selected geometry in the component. The disconnected geometry is maintained outside of the component's context.

📝 **Note** - You can make component hierarchies by grouping other Component entities within a component. Additionally, you can mix your hierarchies by including components and groups within other components and groups.

💡 **Tip** - Create components that can be attached or glued to a surface in context (on a surface) to ensure that the cutting plane is established correctly.
Setting the Gluing and Cutting Plane of a Component

The Set gluing plane button is used to specify a different origin for the Component and to modify the orientation of the component when it is placed. To set the origin and plane of a component:

1. Select "Show Component Axes" in the Components Panel of Model Info dialog box to see the existing axes on a Component before using the Set gluing plane button to move the axes.

2. Draw your component in the orientation where it will be used. For example, if you are creating a couch component, draw it on the ground plane. If you are creating a window or door, draw it on a wall that is vertically aligned to the blue axis.

3. Select the "Select Tool." The will change to an arrow.

4. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.

5. Drag the mouse to the opposite corner of the selection starting point.

6. Release the mouse button when all of the elements are either partially included (left-to-right selection) or fully included (right-to-left selection) in the selection box.
7. Select "Edit > Make Component." Alternatively, context-click on the currently selected entities and select "Make Component" from the context menu. The Create Component dialog box is displayed. The following image shows the Create Component dialog box on Microsoft Windows:

![Create Component dialog box](image)

The following image shows the Create Component dialog box on Mac OS X:

![Create Component dialog box](image)

8. Click on the "Set gluing plane" button. The cursor changes to an arrow with axes attached to it.
9. Click on a location of the component to set the origin of the component's axes. The origin and insertion point is now set to this location.

**Note** - When you change the axes you change the orientation of the component when dragged from the Components Browser and also the component's cutting plane. By default, the component's axes are placed as though the component will be inserted from the Components Browser in the exact orientation as the component is in while you create the component. Generally, you will not want to change this orientation unless, for example, you are creating a window component independent of other geometry and in the vertical plane (blue). In this case, the bottom of the window will be on the red/green plane. The red/green plane is the gluing and cutting plane. As such, this window's bottom will therefore want to align and cut into a face when placed in the model from the Component browser. As mentioned previously, however, it is best to create window and door components within the context of a surface type where they will ultimately be placed, such as a wall, so you do not have to reorient the axes. Follow the last two steps in this list if you need to reorient the component axes.

10. (optional) Move the mouse around the origin to redefine the orientation of the component. The axes of the component will rotate suggesting a new orientation for the component. The cut plane will also move to represent where the component will cut into a face when placed vertically or horizontally. For example, if you rotate the axes such that red is up and green is to the left, the component will be inserted horizontally to its orientation when created. The following image shows a window component during component creation. The component's axes have been reoriented such that the cutting plane is now parallel to the front of the window.

11. (optional) Click to set the new orientation.
Editing a Component Instance as a Whole

You can edit the component as a whole or edit individual entities within a component. Editing or modifying the component instance as a whole affects only the component instance, not the component definition or other instances.

Scaling a Component

Scaling a component as a whole scales the individual component instance, not the component definition, allowing you to have many differently scaled instances of the same component in your model.

A component can become skewed when you scale the component in multiple directions. You can reset both a components scale and skew using the Reset Scale and Reset Skew context menu items.

Flipping a Component

You can flip (or mirror) a component along its axes using the Flip Along component context menu item. Choose Component's Red, Component's Blue, or Component's Green depending on the direction to flip the component.

Rotating a Component Using the Move Tool

Components can be rotated using either using the Move Tool or Rotate Tool. The first rotation method rotates the component about its center of mass and in the planes of the component bounding box. The second rotation method allows you to specify precise rotate planes and center of rotation. See the Rotate Tool for further information on this second rotation method. To rotate a component using the Move Tool:

1. Select the "Move Tool." The cursor will change to a four-way arrow.
2. Move the cursor over a face that is perpendicular to the desired axis of rotation. Four rotation handles and a protractor appear on the face.
3. Click on a rotation handle
4. Rotate the component.
Editing Entities Within a Component Instance

Editing the entities within a component requires you to enter the component's context. Editing or modifying the entities within a component instance affects the component definition and other instances of the component. To edit the entities within a component:

1. Select the "Edit > Component Instance > Edit Component" to edit the component. Alternatively, context-click on the currently selected component and select "Edit Component" from the context menu. An edit bounding box will surround the component and entities exterior to the component will turn grey.

   Tip - Double-click on the component to edit the component.

2. Make changes to entities within the component. Any changes while in the context of the component affects each component instance and the component definition. You can also perform inference alignments to geometry outside of the component while you are editing the component.

3. Select the "Edit > Close Group / Component" to end the edit session. Alternatively, context-click on the component's bounding box and select Close component from the context menu.

   Tip - Click outside of the component to close the component.
Exploding a Component

You can explode a Component entity to break it back into its original entities. To explode a component:

1. Select the "Select Tool." The will change to an arrow.
2. Select the component you want to explode.
3. Select "Edit > Component Instance > Explode." Alternatively, context-click on the currently selected group and select "Explode" from the context menu. The component will be split back into its entities.

Elements within components that were placed adjacent to other geometry might become joined to elements exterior to the component when the component is exploded.
Inserting Components

There are a variety of different ways to insert component instances in SketchUp.

Inserting Components from Components Browser

Pre-defined Components are most often inserted from the Components Browser into a model. See the Components Browser for further information.

Insert a Component From an External SketchUp (.skp) File

You can also insert a component from an external SketchUp file. To insert a component from an external SketchUp file:

1. Select the "File > Import" menu item. The Open file dialog box appears.
2. Select the type of file to import from the Files of Type (Microsoft Windows) or Format (Mac OS X) drop-down list (.skp).
3. Click the "Open" button. The cursor changes to the Move Tool anchored to the component's insertion point.

   Tip - The component axes origin is the default insertion point for a Component. Change the location of the component's axes before you insert the component to change the default insertion point.

4. Move the mouse to the location in the drawing area where you want to place the component.
5. Click the mouse button again to release the component.

Insert a Component From the File Explorer (Microsoft Windows) or the Finder (Mac OS X).

Finally, you can also insert a component from the File Explorer (Microsoft Windows) or the Finder (Mac OS X). To insert a component from the File Explorer (Microsoft Windows) or the Finder (Mac OS X):

1. Locate the icon representing the file you want to insert.
2. Click and hold the mouse button on the icon.
3. Drag the icon into the drawing area. The cursor changes to the Move Tool anchored to the component's insertion point.

   Tip - The component axes origin is the default insertion point for a Component. Change the location of the component's axes before you insert the component to change the default insertion point.

4. Release the mouse button to place the component into your model.
Applying Materials to Components

Any geometry inside a component that is painted with the default material will be painted when you paint the instance as a whole. Therefore, you can have entities within a component painted individually while other elements painted using the material assigned to the entire component. The following image contains four cars all enclosed in components. The tires, bumper, and windshield have been painted black when editing the component.

Each entire component instance was then painted after being edited, turning each of the faces with the default material to the color applied on the group (green, blue, red, and yellow from left to right):
Moving the Insertion Point

The Components Browser switches the insertion point from the origin of the component’s axes to another point on the component when you use the Move Tool to select a component, that is already in your model, using a different (non-origin) point. For example, if you have a 3d rectangle component, the origin and insertion point will be the lower left-hand corner. However, if you insert this component and then move it by a midpoint, the insertion point changes to the mid point (while the origin remains at the lower left hand corner).

This feature is useful when aligning components, such as cabinet components in a kitchen. Consider the following:

1. Insert one kitchen cabinet component with the insertion point at the lower left corner of the component.
2. Insert a second instance of the same cabinet to the left of the previously inserted cabinet (so that the two cabinets touch). Notice that it is hard to accurately place the second cabinet because the insertion point is at the origin at the lower left corner of the component (away from where the two cabinets will touch).
3. Reposition the second kitchen cabinet away from the first.
4. Select the "Move Tool" and click the lower-right corner of the second kitchen cabinet component.
5. Now move the second kitchen cabinet such that it is aligned on the left-side of the first cabinet. This process should be easier now that the insertion point has been moved to the lower-right corner of the component. If you drag a third instance of the same cabinet into the model, the insertion point will now be at the lower-right corner (making it easier to place more cabinets to the left of each other).

Resetting Component Axes

Context-click on the component in the Components Browser and select "Reset Insert Point" to reset the insertion point to the origin of the component’s axes.
Inserting a Component

To insert a component in your drawing area:

1. Navigate to a component in the Components Browser.
2. Click on the component.
3. Move the mouse to the location in the drawing area where you want to place the component. The cursor changes to the Move Tool.

   **Note** - The Move Tool will usually be anchored to the origin of the component's axes (also called the insert point). To see the origin of the component, select Window > Model Info > Components > Show component axes.

   **Tip** - The component axes is the default insertion point (the point where the cursor grabs the component) for a component the first time you place the component in the model from the Components Browser. The insertion point will change to the point where the Move Tool selects a component if you place a component and then reposition the component using the Move Tool.

3. Click the mouse button again to release the component.

   **Note** - You can also insert components from an external SketchUp (.skp) file or by dragging and dropping a file from the Explorer (Microsoft Windows) or the Finder (Mac OS X) into your model. See the Component entity for further information.
Changing Component Thumbnail

Creating a component creates a thumbnail image of the component in the Component Browser. This image is based on the view of the component unless the component has a gluing plane. The following rules apply for components that have gluing planes:

- Thumbnails for components whose gluing plane is vertical, such as windows and doors, is of a front view of the component.
- Thumbnails for components whose gluing plane is horizontal, any, or sloped, is a top-down view of the component (which is appropriate for a rug component, but not for a lamp, vehicle, or person, for example).

You must save the individual component to a file to change its thumbnail. To change the component thumbnail:

1. Context-click on the component. The component's context menu appears.
2. Select the "Save As" menu item. The Save As dialog box appears.
3. Navigate to the components directory. The components directory on Microsoft Windows is: \Program Files\Google\Google SketchUp 6\Components The components directory on Mac OS X is: Macintosh HD/Library/Application Support/Google SketchUp 6/Components
4. Type a file name in the File name field.
5. Click the "Save" button. The component is saved in the specified directory.
7. (Microsoft Windows) Select the "File" item from the left-hand side of the dialog box. The File panel is displayed.
8. (Microsoft Windows) Check the "Redefine thumbnail on save" checkbox. This option ensures your thumbnail will be saved based on current view.
9. Open the component file. The component appears in the drawing area.
10. Use the camera tools to find a view of the component acceptable for a thumbnail.
11. Save the component file.
Applying Styles

Select one of many pre-defined styles from the Styles Browser and apply it to your model. Each pre-defined style represents a collection of specific settings that can be applied to your model and the drawing area. To select and apply a pre-defined style:

1. Select "Window > Styles." The Styles Browser is displayed.
2. Click on the "Select" tab.
3. Click on the styles library drop-down list.
4. Select the "Styles" library. All of the pre-defined styles in the library are displayed in thumbnail form.
5. Click on one of the pre-defined styles. The style is applied to your model and the drawing area.
Editing Styles

Styles are comprised of several different settings found under the Edit tab. To Edit a style:

1. Select "Window > Styles." The Styles Browser is displayed.
2. Click on the "Select" tab.
3. Click on the "Styles" library drop-down list.
4. Select the "Styles" library. All of the pre-defined styles in the library are displayed in thumbnail form.
5. Click on one of the pre-defined styles. The style is applied to your model and the drawing area. A copy of the style appears in the In Model library.
6. Click on the "Edit" tab. One of five panels is displayed (Edge, Face, Background, Watermark, and Modeling).
7. Modify settings in any of the edit panels. Refer to Edge Panel, Face Panel, Background Panel, Watermark Panel, or Modeling Panel for further information.
8. Click on the "Update Style" button. The copy of the style in the In Model library is updated with your changes.
9. (optional) Save your changes to the edited style:
   a. Click on the "In Model" button. The In Model library is displayed.
   b. Context-click on the edited style. The In Model context-menu is displayed.
   c. Select the "Save As" menu item.
   d. Navigate to a directory (folder) where you want to save the style.
   e. Type a name in the File name field and click the "Save" button. The file is saved. Refer to the Open or create a library context-menu item for information on how to retrieve this style for use in other SketchUp files.
Aligning Edges to Axes

One method for aligning edges to axes is to enable an option to display all edges in the color of their respective axis direction. For example, edges drawn in the up or down direction will be colored blue. To enable edge color by axis:

1. Select "Window > Styles." The Styles Browser is displayed.
2. Select "In Model" from the drop-down list of edge types. Thumbnails of all of the current edge styles used are displayed.
3. Click on the "Edit" tab. The Edit panel is displayed.
4. Click on the "Edge Settings" icon (the first icon on the left). The Edge rendering panel is displayed.
5. Select the "By axis" item from the "Color" drop-down list (at the bottom of the Edge rendering panel). All edges in your model will now be colored with the color of their respective axis direction.
Sharing Styles

Styles are shared in .style files that can be opened by any copy of SketchUp 6 or above. You must create a .style file to share a style with others. To share a style:

1. Create a new folder/directory on your computer to contain your shared styles.
2. Select "Window > Styles." The Styles Browser is displayed.
3. Select the "In Model" style library from the drop-down list. The In Model style library is displayed.
4. Context-click on the style name you would like to share. The style context menu is displayed.
5. Select the "Save As" menu item. The Save As dialog box appears.
6. Navigate to the folder/directory you created in step 1.
7. Type the name of the style in the File name field.
8. Click the "Save" button. The style file is saved to your newly created folder/directory.

You can now share this style file with others.
Adding a Watermark to the Drawing Area

To add a watermark to the drawing area:

1. Select "Window > Styles." The Styles Browser is displayed.
2. Click on the "Edit" tab.
3. Click on the "Watermark" panel button. The Watermark panel is displayed.
4. Click on the "Add" button. The Choose Watermark dialog box is displayed.
5. Navigate to an image you will use as a watermark.
6. Click the "Open" button. The image will appear as a watermark in the background of the drawing area. The Create Watermark dialog box is displayed.
7. Click either the "Background" button to have the image appear behind your model as a background watermark, or the "Overlay" button to have the image appear in front of your model as an overlay.
8. Click on the "Next" button.
9. (optional) Check the "Create Mask" checkbox. Refer to Watermark Settings for further information.
10. (optional) Move the "Blend" slider to the left to fade the watermark. Or, move the "Blend" slider to the right to fade the model.
11. Click on the "Next" button.
12. Check the radio button that reflects where you want the watermark to appear on the screen. Refer to Watermark Settings for further information.
13. Click on the "Finish" button.
Moving Geometry Between Layers

To move geometry from one layer to another:

1. Select the "Select Tool." The cursor changes to an arrow.
2. Select one or more entities. The selected entities are highlighted in yellow.
3. Activate the context menu for the selected entities.
4. Select the "Entity Info" menu item. The Entity Info dialog box appears.
5. Select the layer for the entities from the "Layers" drop-down list.
Filtering Groups and Components in the Hierarchical View

The Outliner contains a Filter field for displaying only those groups or components containing a specific filter string. This feature helps you to locate only like components or groups. To filter items within the Outliner:

1. Select "Window > Outliner." The Outliner dialog box opens with a hierarchical view of your model. The Group and Component entities at the root (top-most) level of the hierarchy are displayed. An icon with a plus sign will appear next to any components or groups when additional levels in the hierarchy exist (additional groups or components within the top-level groups or components).

2. Type a string in the "Filter" field.

3. Click on the plus (+) icon to list groups or components within other groups or components. Or, optionally, click on the Details Menu and select the "Expand All" menu item to expand the hierarchy so all levels are displayed. Items containing the filter string will be listed, in red, in the hierarchical view.
Identifying Entries in the Outliner Hierarchy

The Outliner uses a combination of icons and text to identify groups and component status in a hierarchy.

- **Component** - Four black squares
- **Group** - One solid square
- **Locked Component** - Four grey squares with small lock in lower right corner
- **Locked Group** - One grey square with small lock in lower right corner
- **Open Component** - Four hollow squares
- **Open Group** - One hollow square
- **Hidden Component or Group** - Name of component or group is in italics
Moving Items Within the Outliner

Use the Outliner to reorganize groups and components in the hierarchy. For example, you can move a group, buried deep within the hierarchy, to the top of the hierarchy for easy editing. To move items within the outline:

1. Select "Window > Outliner." The Outliner dialog box opens with a hierarchical view of your model. The Group and Component entities at the root (top-most) level of the hierarchy are displayed. An icon with a plus sign will appear next to any components or groups when additional levels in the hierarchy exist (additional groups or components within the top-level groups or components).

2. Click on the plus (+) icon to list groups or components within other groups or components. Or, optionally, click on the Details Menu and select the "Expand All" menu item to expand the hierarchy so all levels are displayed.

3. Click and hold on the group or component you want to move in the hierarchy.

4. Move the group or component to a new position in the hierarchy.
Naming Groups and Components Within the Outliner

The Outliner displays groups by their group names and components by a combination of the definition and specific instance name.

Naming a Component Definition

As mentioned in the previous paragraph, components are identified in the outliner by a combination of their instance and definition names (the definition name is enclosed in less-than and greater-than symbols). For example, Jim's Office <Cubicle Style 1>. Where you may have several Cubicle Style 1 components in your model, but only one instance represents Jim's Office.

The component definition name generally refers to type of component, such as a certain type of cubicle (Cubicle Style 1) or certain type of video camera (VideoX 8mm camera). This name can either be established when the component is first created, or you can accept the default (Component#X, X being some number) and rename the component definition using the outliner. To rename the component definition:

1. Context-click on the component in the Outliner. The context menu for the Component entity is displayed. Notice that this is the same context menu as the context menu displayed when you context-click on an entity in the drawing area (except this context menu has a Rename menu item).
2. Click on the "Entity Info" menu item. The Entity Info dialog box is displayed.
3. Click on the "Definition" tab to display information about this component's definition.
4. Type a new name in the definition's name field.
5. Click outside of the Entity Info dialog box to save your change.

Naming a Component Instance

A component instance name is useful when you want to differentiate different component instances from each other in the Outliner (the default name for all component instances is "Component"). For example, you might want to have different instance names if several chairs are all from the same definition in your model. To rename the component instance:

1. Context-click on the component in the Outliner. The context menu for the Component entity is displayed. Notice that this is the same context menu as the context menu displayed when you context-click on an entity in the drawing area (except this context menu has a Rename menu item).
2. Select the "Rename" menu item
3. Type the new component instance name in the Outliner.
4. Press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key to save your change.

Note - You can also use the Name field at the top of a component's Entity Info dialog box to rename component instances.

Tip - Use instance names to differentiate different instances of the same definition in your model. This tip is particularly useful if you want to easily locate a specific component instance in the outliner.
Naming a Group

You can also name your groups for easy identification in the Outliner. To rename a group:

1. Context-click on the group in the Outliner. The context menu for the Component entity is displayed. Notice that this is the same context menu as the context menu displayed when you context-click on an entity in the drawing area (except this context menu has a Rename menu item).

2. Select the "Rename" menu item

3. Type the new component instance name in the Outliner.

4. Press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key to save your change.
Traversing Component and Group Hierarchies

The outliner contains a hierarchy view that reflects your hierarchy of components and groups in your model. To navigate a component or group hierarchy using the hierarchical view:

1. Select "Window > Component." The Outliner dialog box opens with a hierarchical view of your model. The Group and Component entities at the root (top-most) level of the hierarchy are displayed. An icon with a plus sign will appear next to any components or groups when additional levels in the hierarchy exist (additional groups or components within the top-level groups or components).

2. Click on the plus (+) icon to list groups or components within other groups or components. Or, optionally, click on the Outliner's Details Menu and select the "Expand All" menu item to expand the hierarchy so all levels are displayed.

3. Click on any group or component name in the hierarchical view to select the group or component in your model.

4. (optional) Double-click on the group or component name in the hierarchical view to edit the group or component in your model.
Assigning Styles to Scenes

Select a style before creating a scene. Active style is automatically assigned to scenes you create in your SketchUp models. To select a Style and create a new scene, please follow these steps:

1. Select "Window > Styles." The Styles Manager is displayed.
2. Select a styles library from the drop-down list, such as "Assorted Styles." The In Model library simply displays styles currently used in the model.
3. Click on a style in the library. The style is selected.
4. Select "Window > Scenes." The Scenes Manager is displayed.
5. Click the "Add Scene" button. A scene is added to the list.

Changing a Style Assigned to a Scene

To change a style already assigned to a scene:

1. Select "Window > "Styles." The Styles Manager is displayed.
2. Select the "In Model" library from the drop-down list. The In Model styles library is displayed.
3. Select the "Edit" tab. The Edit panel is displayed.
4. Adjust the display settings as necessary.
5. Click the "Update Style with changes" button. The style is updated in all scenes.
Changing Scene Settings

Display settings are now part of the Styles Manager feature in SketchUp 6. To change scene settings:

1. Select "Window > Styles." The Styles Manager is displayed.
2. Select the "Edit" tab. The Edit panel is displayed.
3. Edit the style as desired.
Enabling Shadows

The SketchUp Shadows feature is designed to give you a general idea of how the sun and shadows affect your model during the course of a day and throughout the year. The calculations are based on the location (latitude and longitude, directional orientation of the model, and an associated time zone. The time is not adjusted for Daylight Saving Time. To enable shadows:

Enabling Shadows Using Location Data from Google Earth

Use Google Earth to set location and directional orientation for models that represent real-world structures. To enable shadows using location data from Google Earth:

1. (Google Earth) Find the location where you want your 3D model to appear. For example, type street and city where a new building will be built.
2. (Google Earth) Zoom in on this location until you have a fairly detailed, top-down, view of a building that you want to model.

   Note - Ensure terrain is turned on in Google Earth. Click on the Terrain check box toward the bottom middle of Google Earth to turn on terrain.

3. (SketchUp) Click on the "Get Current View" button to capture an image of the current Google Earth view. The following occurs when you perform this step:
   • A 2D image of the current view in Google Earth is placed in SketchUp. The 2D image is locked so that you cannot delete it.
   • SketchUp is calibrated to the same latitude, longitude, and time zone as the location in Google Earth. These coordinates appear in SketchUp's Set Custom Location dialog box within Model Info > Custom Location...
   • The imported image is aligned with the axes in SketchUp (the solid green axis points north and the solid red axis points east).
   • The time zone in SketchUp is set based on the coordinates of the image. Because some time zones lines zigzag rather dramatically, the time zone for some locations may inaccurate by up to one hour (sometimes longer).
4. (SketchUp) Select "Window > Shadows." The Shadows Settings dialog box appears.
5. (SketchUp) Click on "display shadows" to display shadows for your model.
6. (SketchUp) Manipulate shadows using the controls in the Shadows Settings dialog box.

Enabling Shadows Using Manually Input Data

Use the Location section of the Model Info dialog box to manually input location information. To enable shadows using manual input data:

2. Select "Location" on the left-hand side of the Model Info dialog box. The Location Panel appears.
3. (optional) Select or enter a country using the "Country" drop-down list box.
4. (optional) Select or enter a location (city) using the "Location" drop-down list box.
5. (optional) Enter a North angle in the "North angle" field if the true north is at an angle (instead of the default 0.0) to your model.
6. Click on the "Custom" location button. The Set Custom Location dialog box appears.
7. Enter the latitude in the Latitude field.
8. Enter the longitude in the Longitude field.
9. Select a time zone using the "Timezone" drop-down list box.
10. Click the "OK" button. The Shadow Settings dialog box disappears
11. (SketchUp) Select "Window > Shadows." The Shadows Settings dialog box appears.
12. (SketchUp) Click on "display shadows" to display shadows for your model.
13. (SketchUp) Manipulate shadows using the controls in the "Shadows Settings" dialog box.

Note - You cannot change the color of shadows.
Setting Fog

Use the Fog dialog box to apply Fog-like effects to your model. To apply Fog:

2. Check the "Enable Fog" checkbox. Fog might appear around your model (depending on your view of the model and the settings of the fog sliders).
3. Adjust the sliders.

Note - Fog sliders will move automatically when you change your point of view, such as when you zoom in or zoom out. As with real fog, the geometry will become clearer as you zoom closer to it, and less clear as you move away.
Automatically Loading a Template

You can load a template SketchUp file manually using File > Open every time you want to create a model. Or, you can identify a file as a template using the Template section of the Preferences dialog box to load the template automatically when you run SketchUp:

1. Select "Window > Preferences" (Microsoft Windows) or "SketchUp" > Preferences" (Mac OS X). The Preferences dialog box is displayed.
2. Click on the "Templates" item on the left-hand side of the Preferences dialog box. The Template panel is displayed.
3. Select a drawing template from the drop-down list to select one of the SketchUp default templates. Or, optionally, click the "Browse" button to find a template that you have created.
4. Click the "OK" button to close the Preferences dialog box. The selected template is used after you close and restart SketchUp.
Changing Your Template

To change your template:

1. Select "Window > Preferences" (Microsoft Windows) or "SketchUp > Preferences" (Mac OS X). The Preferences dialog box is displayed.

2. Click on the "Template" item on the left-hand side of the Preferences dialog box. The Template panel is displayed.

3. Select a drawing template from the drop-down list to select one of the SketchUp default templates. Or, optionally, click the "Browse" button to find a template that you have created.

4. Click the "OK" button to close the Preferences dialog box. The selected template is sued after you close and restart SketchUp.
Creating a Template

A template file contains default settings from the Model Info dialog box and base geometry. To create a template:

1. Select "File > New" to start a new SketchUp file.
2. Modify the Model Info settings to fit your particular needs. For example, you might want to set default units and snaps, activate a ground plane, and set a geographic location.
3. Modify the Preference settings to fit your particular needs.
4. (optionally) Draw any geometry that you want to share among all of your models. For example, you might want all of your models of houses to be created within the same starting terrain (such as when you are creating models of houses within a housing development).
5. Select "File > Save As Template" to save the SketchUp file.
6. Enter the template name, description, and filename.
7. (optional) Click the "Set as default template" checkbox to save this template as the default template (to load every time you load SketchUp).

Note - The template will appear in the Template panel of the Preferences dialog box (Window > Preferences on Microsoft Windows or SketchUp > Preferences on Mac OS X)
Assigning Keyboard Shortcuts
(Microsoft Windows)

Keyboard shortcuts can dramatically speed up your drawing by allowing you to change tools while keeping the mouse cursor near the drawing area. To assign a keyboard shortcut:

1. Select "Window > Preferences." The Preferences dialog box is displayed.
2. Click on the "Shortcuts" item on the left-hand side of the Preferences dialog box. The Shortcuts panel is displayed.
3. Select the command to which you will assign a keyboard shortcut (within the Function list). Existing keyboard shortcuts for this command will display in the Assigned list.

Note - The list of commands available in the Shortcuts panel is dynamically generated and includes all menu items and active context menu items. Some context menu items become active only after performing another task. For example, select a face to activate the Reverse Faces command and then open Preferences > Shortcuts to set a keyboard shortcut for Reverse Faces.

2. Type the keyboard shortcut key sequence in the "Add Shortcut" field. Shortcut keys can consist of any keyboard key, except number keys, with a few exceptions. Any key that can be used as a shortcut can also be assigned a modifier key like Shift, Control, or Alt. SketchUp will indicate when a key or key combination cannot be used or is already assigned.

3. Click the plus (+) button.

You can have multiple keyboard shortcut combinations for each command. SketchUp will prompt you before allowing you to assign a keyboard shortcut that is already assigned to another command. Some keys are reserved for use by Microsoft Windows and cannot be assigned as a keyboard shortcut.

Note - You can save your shortcuts to a .dat file for copying to other computers. See the Files panel in this topic for more information.

The Measurements Toolbar and Keyboard Shortcuts

Temporary focus is given to the Measurements Toolbar when you type a number while in the drawing area. Therefore, numbers cannot be used as shortcut keys. The letters S, R, X, and the symbols / and * can be used within keyboard shortcuts and as you enter values in the Measurements Toolbar. Prepend any of these letters with a number in the Measurements Toolbar to ensure that a command with a corresponding keyboard shortcut letter is not invoked. For example, 7s would be the correct entry to redefine a segmentation in the Measurements Toolbar. However, s7 will activate whatever command is invoked with the letter S as a keyboard shortcut.

Tip - Do not use the spacebar or backspace keys as keyboard shortcuts to avoid conflict with values entered in the Measurements Toolbar.
Assigning Keyboard Shortcuts (Mac OS X)

Keyboard shortcuts can dramatically speed up your drawing by allowing you to change tools while keeping the mouse cursor near the drawing area. To assign a keyboard shortcut:

1. Select "SketchUp > Preferences." The Preferences dialog box is displayed.
2. Click on the "Shortcuts" item on the left-hand side of the Preferences dialog box. The Shortcuts panel is displayed.
3. Select the command to which you will assign a keyboard shortcut (within the Function list). Existing keyboard shortcuts for this command will display in the Key column next to each function.

   **Note** - The list of commands available in the Shortcuts panel is dynamically generated and includes all menu items and active context menu items. Some context menu items become active only after performing another task. For example, select a face to activate the Reverse Faces command and then open Preferences > Shortcuts to set a keyboard shortcut for Reverse Faces.

2. Type the keyboard shortcut key sequence in the field below the function list. Shortcut keys can consist of any keyboard key, except number keys, with a few exceptions. Any key that can be used as a shortcut can also be assigned a modifier key like Shift, Control, or Option, or Command. SketchUp will indicate when a key or key combination cannot be used or is already assigned.

You can have multiple keyboard shortcut combinations for each command. SketchUp will prompt you before allowing you to assign a keyboard shortcut that is already assigned to another command. Some keys are reserved for use by Microsoft Windows and can not be assigned as a keyboard shortcut.

   **Note** - You can save your shortcuts to a .dat file for copying to other computers. See the Files panel in this topic for more information.

**The Measurements Toolbar and Keyboard Shortcuts**

Temporary focus is given to the Measurements Toolbar when you type a number while in the drawing area. Therefore, numbers cannot be used as shortcut keys. The letters S, R, X, and the symbols / and * can be used within keyboard shortcuts and as you enter values in the Measurements Toolbar. Prepend any of these letters with a number in the Measurements Toolbar to ensure that a command with a corresponding keyboard shortcut letter is not invoked. For example, 7s would be the correct entry to redefine a segmentation in the Measurements Toolbar. However, s7 will activate whatever command is invoked with the letter S as a keyboard shortcut.

   **Tip** - Do not use the spacebar or backspace keys as keyboard shortcuts to avoid conflict with values entered in the Measurements Toolbar.
Exporting Preferences, Including Keyboard Shortcuts (Microsoft Windows)

System preferences are automatically saved as you make the changes to items like keyboard shortcuts. However, you can export preferences, including keyboard shortcuts, for sharing between other copies of SketchUp. To export your preferences:

1. Select the "Window > Preferences." The Preferences dialog box appears.
2. Select the "Files" item from the left-hand of the Preferences dialog box. The Files panel is displayed.
3. Click the "Export" button. The Export Preferences dialog box is displayed.
4. Navigate to the folder where you want to save the file.
5. Type the name of the file in the File name field (Preferences.dat by default).
6. Click on the "Options" button. The Export Preferences Options dialog box appears.
7. Check Shortcuts checkboxes if you do not want to save either shortcuts or File locations respectively.
8. Click the "OK" button.
9. Click the "Export" button. The preferences are saved to your predefined location.
Importing Preferences, Including Keyboard Shortcuts (Microsoft Windows)

You can import preferences, including keyboard shortcuts, that are exported from another copy of SketchUp. To import preferences:

1. Select "Window > Preferences." The Preferences dialog box appears.
2. Select the "Files" item from the left-hand of the Preferences dialog box. The Files panel is displayed.
3. Click the "Import" button. The Import Preferences dialog box is displayed.
4. Navigate to the folder containing the preferences file.
5. Select the preferences file.
6. Click on the "Options" button. The Import Preferences Options dialog box appears.
7. Check Shortcuts checkboxes if you do not want to save either shortcuts or File locations respectively.
8. Click the "OK" button.
9. Click the "Import" button. The preferences are imported into SketchUp.
Resetting Keyboard Shortcuts

To reset keyboard shortcuts:

1. Select the Preferences menu item from the Window (Microsoft Windows) or SketchUp (Mac OS X) menu. The Preferences dialog box is displayed.

2. Click on the Shortcuts item on the left-hand side of the dialog box. The Shortcuts panel is displayed.

3. Click the "Reset All" button. Keyboard shortcuts are reset.
Loading and Selecting Colors from Images (Mac OS X)

The Image Palettes Picker allows you to load an image file into the Color Picker and select colors from anywhere in that image. The Image Palettes Picker has a spectrum image loaded as a default. To load and select a color from an image:

1. Select "New From File" from the pop-up menu at the bottom of the image well.
2. Locate your image in the New Color Palette dialog box.
3. Click "Open."
4. Click and Drag your cursor around the Image Well until the color you want is in the Color Well.

Note - To switch from image to image, use the pop-up list at the top of the Image Well.

Note - You can also load an image you have copied to the OS X clipboard by selecting New From Pasteboard from the pop-up menu at the bottom of the image well. Additionally, you can drag an image file from the Finder and drop it on the Image Well.
Adding Materials From Image Files (Mac OS X)

You can create realistic materials from image files (such as .jpg pictures taken with a digital camera) using the materials browser. To add materials from image files:

1. Create a folder for your image files.
2. Place your image files into the new folder.

   **Note** - You must create a new materials library if you wish to add materials to SketchUp from image files. You cannot add materials to the materials libraries that are included with SketchUp.

3. Launch SketchUp.
4. Select Window > Colors. The Color Picker dialog box is displayed.
5. Click on the Texture Palette Picker.
6. Click on the List drop-down menu.
7. Select New.
8. Enter a name for the new materials library that will contain your image-based materials.
9. Click OK. A new materials library is saved at ~/Library/Application Support/SketchUp/Materials/<libraryname>.skm
10. Click on the Color drop-down menu.
12. Locate the image-based material to add to the library.
13. Click Open. The image-based material will be added to your new materials library.
Selecting Color with the Screen Picker (Mac OS X)

The Screen Picker, represented as a magnifying glass, is used to choose a color from any element currently visible on your Apple Macintosh screen. To select a color using the Screen Picker:

1. Click on the magnifying glass icon to activate the Screen Picker. The cursor changes into a large magnifying glass.
2. Move the cursor around the screen until you are magnifying the color you want to use.
3. Click the mouse button to place the color in the Active Color Well.
Setting the North Angle

The North angle establishes the path of the sun. To set the North angle:

1. Click on the Select button. The cursor changes to a cross within a circle.
2. Place the center of the cross at the origin of the North angle (usually the axes origin).
3. Click the left mouse button.
4. Drag the cursor away from the origin in the north direction.
5. Click again to establish the new north angle.
Entities

This section of the user's guide covers the various entities used to construct a model in SketchUp. These entities include faces, arcs, dimensions, and lines.

Entities are covered in alphabetical order.
Applying Materials to Groups

Any geometry inside a group that is painted with the default material will be painted when you paint an unexploded group. Therefore, you can have entities within a group painted individually while other elements painted using the material assigned to the entire group. The following image contains four cars all enclosed in groups. The tires, bumper, and windshield have been painted black when editing the group.

![Image of cars enclosed in groups with different materials applied](image)

Each entire Group entity was then painted after being edited, turning each of the faces with the default material to the color applied on the group (green, blue, red, and yellow from left to right):
Creating a Group

Groups are useful for combining entities to perform a quick operation such as copy or move operations. To create a group:

1. Select the "Select Tool." The will change to an arrow.
2. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.
3. Drag the mouse to the opposite corner of the selection starting point.
4. Release the mouse button when all of the elements are either partially included (left-to-right selection) or fully included (right-to-left selection) in the selection box.
5. Select the "Edit > Make Group." Alternatively, context-click on the currently selected entities and select "Make Group" from the context menu. The geometry you selected appears grouped within a highlighted bounding box.

Note - The Make Group operation disconnects any geometry that was connected to the grouped geometry prior to placing the geometry in the group. The disconnected geometry is maintained outside of the group's context.

Note - You can make group hierarchies by grouping other Group entities within a group. Additionally, you can mix your hierarchies by including components and groups within other components and groups.
Editing a Group

Groups can be opened for editing, placing you in the Group's context. To edit a group:

1. Select the "Edit > Group > Edit Group" to edit the group. Alternatively, context-click on the currently selected group and select "Edit Group" from the context menu. An edit bounding box will surround the group and entities exterior to the group will turn grey.

   Tip - Double-click on the group to edit the group.

2. Make changes to entities within the group. Any changes while in the group's context only affects the Group entity. You can, however, perform inference alignments to geometry outside of the group while you are editing the group.

3. Select the "Edit > Close Group / Component" to end the edit session. Alternatively, context-click on the currently selected group's bounding box and select "Close Group" from the context menu.

   Tip - Click outside of the group to close the Group.
Exploding (Ungrouping) a Group

You can explode (ungroup) a Group entity to break it back into its original entities. To explode a group:

1. Select the "Select Tool." The will change to an arrow.
2. Select the group you want to explode.
3. Select the "Edit > Group > Explode." Alternatively, context-click on the currently selected group and select "Explode" from the context menu. The Group will be split back into its entities.

Elements within groups that were placed adjacent to other geometry might become joined to elements exterior to the group when the group is exploded.
Inserting Image Entities

Images can be added to SketchUp models in one of two ways. First, you can use the "File > Import", which will open a File Open dialog allowing you to navigate to the file you want. Alternately, you can simply drag and drop from the File Explorer (Microsoft Windows) or Finder (Mac OS X) directly into your drawing area.

Note - Image Objects can also be inserted as textures ("File > Import"). For additional information on using images as textures, see the Texture Positioning topic.
Creating an Arc Surface

As mentioned previously, arc surfaces are extruded faces with one or more arc edges. To draw an arc surface:

1. Select the "Arc Tool." The cursor changes to a pencil with an arc.
2. Click to place the starting point of your arc.
3. Click again to place the ending point of your arc.
4. Move your mouse to adjust the bulge distance. Or, optionally type in values for the chord length, bulge distance, radius, and number of segments in the Measurements Toolbar.
5. Click again to set the bulge distance.
6. Select the "Line Tool." The cursor changes to a pencil.
7. Click at one end of the arc set the starting point of your line.
8. Click at the other end of the arc to set the ending point of your line. This step completes a face consisting of an arc and a straight line.
9. Select the "Push/Pull Tool." The cursor will change to a 3D rectangle with an up arrow.
10. Click on the face.
11. Move the cursor up to create an arc curve in the positive direction or move the cursor down to expand the arc curve in the negative direction.
12. Click again when the arc curve has reached the desired size. The vertical curved surface is an arc surface.
Creating a Cylindrical Surface

As mentioned previously, cylindrical surfaces are extruded circles. To draw a cylindrical surface:

1. Select the "Circle Tool." The cursor changes to a pencil with a circle.
2. Click to place the center point of the circle.
3. Move the mouse out from the center point to define the radius of your circle. As you do so, the radius value is displayed dynamically in the Measurements Toolbar and can be specified by typing in a length value followed by pressing the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. You can also specify the segmentation for the circle in the Measurements Toolbar.

4. Click a second time to finish the circle.
5. Select the "Push/Pull Tool." The cursor will change to a 3D rectangle with an up arrow.
6. Click on the face
7. Move the cursor up to create cylinder in the positive direction or move the cursor down to expand the cylinder in the negative direction.
8. Click again when the cylinder has reached the desired size. The vertical surface is a cylindrical surface.
Creating a Polyface Surface

As mentioned previously, polyface surfaces are extruded faces with one or more polyline curve edges. To draw a polyface surface:

1. Select the "Freehand Tool." The cursor will change to a pencil with a polyline curve.
2. Click and hold to place the starting point of your polyline curve.
3. Drag the cursor to draw a polyline curve. Do not close the curve.
4. Release the mouse button to stop drawing.
5. Select the "Line Tool." The cursor changes to a pencil.
6. Click at one end of the polyline curve to set the starting point of your line.
7. Click at the other end of the polyline curve to set the ending point of your line. This step completes a face consisting of an arc and a straight line.
8. Select the "Push/Pull Tool." The cursor will change to a 3D rectangle with an up arrow.
9. Click on the face
10. Move the cursor up to create the polyface surface in the positive direction or move the cursor down to expand the polyface surface in the negative direction.
11. Click again when the polyface surface has reached the desired size. The vertical curved surface is an polyface surface.
Input and Output

This section of the user's guide covers the various mechanisms for inputting items, such as graphic images, into your SketchUp file and outputting or presenting your model once it is finished.

The items in this section are divided into the following categories:

- Importers and Exporters
- Presentations
- Printing

The majority of the items in this section are found in the File menu.
Preparing a 3DS File for Export

Ever face in SketchUp has a front and back side. Ensure the front of each face is facing out before exporting a model to the 3DS format.

1. Select the "Window > Styles." The Styles Browser is displayed.
2. Click the "Edit" tab. The Edit panel is displayed.
3. Click the "Face" settings button. The face settings portion of the Edit panel is displayed.
4. Note the Front color. You will want to turn all of the faces in your model so that the front of the face is showing.
5. Select "View > Face Style."
6. Select the "Monochrome" face style.
7. Select all of the back faces that are displayed.
8. Context-click on one of the selected faces. The context menu for a Face entity is displayed.
9. Select the "Reverse Faces" menu item. All of the selected faces are reversed.
10. Save the file as a 3DS file.
Exporting 3DS Files

To export a 3DS file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).

2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.

3. Select the "3DS" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.

4. (optional) Click on the "Options" button. The 3DS Export Options dialog box is displayed.

5. (optional) Adjust the options in the 3DS Export Options dialog box.

6. (optional) Click the "OK" button.

7. Click the "Export" button.

= Functionality only available in Google SketchUp Pro 7
Exporting 3DDWG or DXF Files

To export a 3D DWG or DXF file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).

2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.

3. Select the export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.

4. (optional) Click on the "Options" button. The AutoCAD Export Options dialog box is displayed.

5. (optional) Adjust the options in the AutoCAD Export Options dialog box.

6. (optional) Click the "OK" button.

7. Click the "Export" button.

= Functionality only available in Google SketchUp Pro 7
Exporting KMZ Files

To export a KMZ file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).
2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.
3. Select the "KMZ" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.
4. Click the "Export" button.
Exporting DAE Files

To export a DAE file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).
2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.
3. Select the "DAE" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.
4. (optional) Click on the "Options" button. The DAE Export Options dialog box is displayed.
5. (optional) Adjust the options in the DAE Export Options dialog box.
6. (optional) Click the "OK" button.
7. Click the "Export" button.
Exporting FBX Files

To export a FBX model file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).
2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.
3. Select the "FBX" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.
4. (optional) Click on the "Options" button. The FBX Export Options dialog box is displayed.
5. (optional) Adjust the options in the FBX Export Options dialog box.
6. (optional) Click the "OK" button.
7. Click the "Export" button.

= Functionality only available in Google SketchUp Pro 7
Exporting OBJ Files

To export an OBJ file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).

2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.

3. Select the "OBJ" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.

4. (optional) Click on the "Options" button. The OBJ Export Options dialog box is displayed.

5. (optional) Adjust the options in the OBJ Export Options dialog box.

6. (optional) Click the "OK" button.

7. Click the "Export" button.

= Functionality only available in Google SketchUp Pro 7
Exporting XSI Files

To export a XSI model file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).

2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.

3. Select the "XSI" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.

4. (optional) Click on the "Options" button. The XSI Export Options dialog box is displayed.

5. (optional) Adjust the options in the XSI Export Options dialog box.

6. (optional) Click the "OK" button.

7. Click the "Export" button.

= Functionality only available in Google SketchUp Pro 7
Exporting PDF or EPS Files

To export a 2D PDF or EPS graphic file:

1. Manipulate the view of the model so that it appears as you would like it to appear in the exported file.
2. Select "File > Export > 2D Graphic." The Export 2D Graphic dialog box is displayed (Microsoft Windows).
3. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.
4. Select the "PDF" or "EPS" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.
5. (optional) Click on the "Options" button. The PDF/EPS Hidden Options dialog box is displayed.
6. (optional) Adjust the options in the PDF/EPS Hidden Options dialog box.
7. (optional) Click the "OK" button.
8. Click the "Export" button.

Note - SketchUp exports the model using the current point of view with the exception of unsupported features such as textures and shadows.

= Functionality only available in Google SketchUp Pro 7
Exporting a Raster Image

To export a 2D graphic file:

1. Manipulate the view of the model so that it appears as you would like it to appear in the exported file. SketchUp will export the model view as it is currently displayed, including display style, edge rendering, shadows, and point of view.

2. Select "File > Export > 2D Graphic." The Export 2D Graphic dialog box is displayed (Microsoft Windows).

3. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.

4. Select the export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.

5. Click the "Export" button.

6. (optional) Click the "Options" button. The Export Image Options dialog box is displayed.

7. (optional) Adjust the options in the Export Image Options dialog box.

8. (optional) Click the "OK" button.

9. Click the "OK" button.
Exporting VRML Files

To export a VRML file:

1. Select "File > Export > 3D Model." The Export Model dialog box is displayed (Microsoft Windows).

2. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.

3. Select the "VRML" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.

4. (optional) Click on the "Options" button. The VRML Export Options dialog box is displayed.

5. (optional) Adjust the options in the VRML Export Options dialog box.

6. (optional) Click the "OK" button.

7. Click the "Export" button.

= Functionality only available in Google SketchUp Pro 7
Exporting Epix Files

To export an Epix file:

1. Manipulate the view of the model so that it appears as you would like it to appear in the exported file.
2. Select "File > Export > 2D Graphic." The Export 2D Graphic dialog box is displayed (Microsoft Windows).
3. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.
4. Select the "Epix" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.
5. (optional) Click on the "Options" button. The Export Options dialog box is displayed.
6. (optional) Adjust the options in the Export Options dialog box dialog box.
7. (optional) Click the "OK" button.
8. Click the "Export" button.

Note - SketchUp exports the model using the current point of view with the exception of unsupported features such as textures and shadows.

Note - Your display must be set to 32-bit color in order to correctly export Epix files (Microsoft Windows).

= Functionality only available in Google SketchUp Pro 7
Exporting 2D DWG or DXF Files

To export a 2D DWG or DXF graphic file:

1. Manipulate the view of the model so that it appears as you would like it to appear in the exported file.
2. Select "File > Export > 2D Graphic." The Export 2D Graphic dialog box is displayed (Microsoft Windows).
3. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.
4. Select the "DWG" or "DXF" export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.
5. (optional) Click on the "Options" button. The DWG/DXF Hidden Line Options dialog box is displayed.
6. (optional) Adjust the options in the DWG/DXF Hidden Line Options (Microsoft Windows) or Export Options (Mac OS X) dialog box.
7. (optional) Click the "OK" button.
8. Click the "Export" button.

Note - SketchUp exports the model using the current point of view with the exception of unsupported features such as textures and shadows.

= Functionality only available in Google SketchUp Pro 7
Importing Large Images

The maximum size of an image that can be imported into SketchUp is 1024 pixels wide by 1024 pixels high. SketchUp will automatically downsize files larger than the 1024 pixels by 1024 pixels using a medium quality sampling mechanism. For better quality results, downsize a larger image before import into SketchUp using a photo editing program like Adobe Photoshop (one that supports bicubic resampling) and save the file as a high-quality JPEG file.

Additionally, crop any images to include only the portion of the image to be used if the image will be used as a texture in SketchUp (to minimize impact on file size in SketchUp).
Preparing a CAD File for Import and Use in SketchUp

You should prepare your CAD files before importing them for use in SketchUp. Additionally, there are a few things you should do to your CAD files once they are imported into SketchUp.

Preparing a CAD File for Import

The following tasks should be done before your CAD files are imported into SketchUp:

1. Delete layers from the CAD file containing text, dimensioning, hatching, logos and other entities that have no 3D relevance. You can also delete these Layers in SketchUp using the Purge command menu.

2. Move all graphics, such as civil site plan, far from the origin, toward the origin in your CAD program.

3. Explode objects in AutoCAD to create block entities which are imported into SketchUp as components.

Handling CAD Files in SketchUp

The following tasks should be done before you begin working with your CAD file in SketchUp:

1. Create a single component from all entities imported into SketchUp that will not be extruded, such as property lines and parking lot markers to improve performance in SketchUp. You might want to move these entities into their own Layer to make this task easier to accomplish. Also, check the Replace Selection With Component option when you make your component.

2. Trace edges from end point to end point that are part of a 2D surface that will be extruded. SketchUp's face finder will create faces as edges are traced.
Importing CAD Files at the Correct Scale

Apply the appropriate scale when importing a CAD file, such as an AutoCAD Drawing (.dwg) or AutoCAD Interchange File (.dxf). To import a CAD file at the correct scale:

1. Select the "File > Import." The Open dialog box appears.
2. Select the type of file to open from the Files of type (Microsoft Windows) or Format (Mac OS X) drop-down list.
3. Click the "Options" button. The import options for the specific CAD file type appears.
4. Select the appropriate scale from the Units drop-down list.
5. Click the "OK" button.
6. Click the "Open" button. The CAD file is imported.
Importing an Adobe Illustrator File

Export the Adobe Illustrator drawing using either the AutoCAD Drawing (.dwg) or AutoCAD Interchange File (.dxf) format for use in SketchUp.

Note - When exporting Illustrator drawings that include curved line segments (splines), you may want to reduce the number of anchor points that define the curve to reduce the number of segments that are created from the curves when the file is imported into SketchUp. If your imported geometry contains a lot of segments, the file size can increase dramatically, especially if you extrude the faces formed by the segments. Try to balance how many anchor points you think you must include in curved lines by taking into consideration the distance at which the curved lines will be viewed in the model.
Importing 3D DWG or DXF Files

To import a 3D DWG or DXF model file:

1. Select the "File > Import." The Open dialog box is displayed.

2. Select the type of file to import from the Files of Type (Microsoft Windows) or Format (Mac OS X) drop-down list.

3. (optional) Click on the "Options" button to modify the import options, such as units, for the incoming file. See the following Import Options section for further information.

4. Click "OK" to import the file. The Import Results dialog box will appear containing details of the imported model.

   Note - It can take several minutes to import a large file because SketchUp's native geometry is very different from most CAD software and the conversion process is calculation-intensive.

5. Click "OK" in the Import Results dialog box. The model will appear in the drawing area at the origin.

   Note - The imported model's entities will be enclosed within a group if geometry existed in the drawing area prior to importing the model.

6. (optional) Click on the "Zoom Extents" Tool to locate the imported model if it is not currently displayed in your drawing area.
Reducing DWG or DXF Import File Size

Try to keep the size of imported files to a minimum. Importing very large CAD files can take a long time because each CAD element must be analyzed and converted into a SketchUp entity. Also, once imported, a complex CAD file can slow SketchUp's performance because lines and faces in SketchUp have a lot more "intelligence" than their CAD equivalents.

Strategies for Minimizing CAD File Size

SketchUp models can be designed to be as accurate as models in CAD. However, SketchUp is not designed for the same type of line-intensive drawings done in CAD software. Therefore, it is a good idea to clean up and import only the CAD content that is absolutely necessary into SketchUp.

Another strategy is to keep different levels of detail in separate CAD files. For example, one imported CAD file can contain site plan information, another can have a floor plan, and a final file can have a specific detail.
Importing 3DS Files

To import a 3DS model file:

1. Select the "File > Import" menu item from the File menu. The Open dialog box is displayed.

2. Select the type of file to import from the Files of Type (Microsoft Windows) or Format (Mac OS X) drop-down list.

3. (optional) Click on the "Options" button to modify the import options for the incoming file. See the following Import Options section for further information.

4. Click "OK" to import the file.

   **Note** - It can take several minutes to import a large file because SketchUp's native geometry is very different from most CAD software and the conversion process is calculation-intensive.

5. Click "OK" in the Import Results dialog box. The model will appear in the drawing area at the origin.

6. (optional) Click on the "Zoom Extents" Tool to locate the imported model if it is not currently displayed in your drawing area.
Importing DAE Files

To import a DAE file:

1. Select the "File > Import." The Open dialog box is displayed.
2. Select the type of file to import from the Files of Type (Microsoft Windows) or Format (Mac OS X) drop-down list.
3. Locate the file you want to import.
4. Click "OK" in the Import Results dialog box. The model will appear in the drawing area at the origin.
5. (optional) Click on the "Zoom Extents" Tool to locate the imported model if it is not currently displayed in your drawing area.
Importing DEM Files

To import a DEM file:

1. Select the "File > Import." The Open dialog box is displayed.

2. Select the type of file to import from the Files of Type (Microsoft Windows) or Format (Mac OS X) drop-down list.

   Caution - You must add the .dem file extension to your DEM files to open these files. Additionally, you can select any file with the .ddf extension from your directory to open DDF files.

3. (optional) Click on the "Options" button to modify the import options, such as points, for the incoming file. See the following Import Options section for further information.

4. Click "OK" to import the file. The Import Results dialog box will appear containing details of the imported model.

   Note - The file import time corresponds to the number of maximum points defined in the Import Options dialog box: the greater number of maximum points, the longer it takes the file to load.

5. Click "OK" in the Import Results dialog box. The model will appear in the drawing area at the origin.

   Note - The imported model's entities will be enclosed within a component.

6. (optional) Click on the "Zoom Extents" Tool to locate the imported model if it is not currently displayed in your drawing area.
Importing Large Images

The maximum size of an image that can be imported into SketchUp is 1024 pixels wide by 1024 pixels high. SketchUp will automatically downsize files larger than the 1024 pixels by 1024 pixels using a medium quality sampling mechanism. For better quality results, downsize a larger image before import into SketchUp using a photo editing program like Adobe Photoshop (one that supports bicubic resampling) and save the file as a high-quality JPEG file.

Additionally, crop any images to include only the portion of the image to be used if the image will be used as a texture in SketchUp (to minimize impact on file size in SketchUp).
Importing 2D Graphic Files

To import a 2D graphic file:

1. Select the "File > Import." The Open dialog box is displayed.
2. Select the type of file to import from the Files of Type (Microsoft Windows) or Format (Mac OS X) drop-down list.
3. Locate the file you want to import
4. Click "OK" to import the file. The image will appear in the drawing area. Your cursor, which will be an arrow, will be anchored to one of the image's corners.
5. Click anywhere in the drawing area to anchor the point of the image held by the cursor.
6. Drag your mouse away from the anchor point to increase the size of the image.
7. Click again to finish placing your image.
Importing 2D Graphics as Textures

To import a 2D graphic file as a texture:

1. Select the "File > Import." The Import dialog box is displayed.

2. Select the type of file to import from the Files of Type (Microsoft Windows) Format (Mac OS X) drop-down list.

3. Locate the file you want to import.

4. Click the "Use As Texture" check box if you want your image to be used as a texture upon import (this will require you to paint the image on an existing surface). See the following Importing 2D Graphics as Textures section for additional information.

5. Click "OK" to import the file. The image will appear in the drawing area. Your cursor, which will be the paint bucket, will be anchored to one of the image's corners. The paint bucket cursor only appears when the image is over a surface where it can be painted.

6. Click on a surface to anchor the point of the image held by the cursor.

7. Drag your mouse away from the anchor point to increase the size of the image on the face.

8. Click again to paint your image on the face. The image will repeat, if necessary, to fill the entire face. A thumbnail of the image appears in the Materials Browser's Colors (Microsoft Windows or In Model (Mac OS X) section to indicate that the image is a texture. Refer to the Paint Bucket Tool for additional information on working with textures.
Exporting Section Slices

To export a section slice:

1. Double-click on the Section Plane entity whose section slice you want to export.
2. Select "File > Export > Section Slice." The Export 2D Section Slice dialog box is displayed (Microsoft Windows).
3. Enter a file name for the exported file in the File name (Microsoft Windows) or Save As (Mac OS X) field.
4. Select the export type from the Export type (Microsoft Windows) or Format (Mac OS X) drop-down list.
5. (optional) Click on the "Options" button. The Section Slice Export Options dialog box is displayed.
6. (optional) Adjust the options in the Section Slice Export Options dialog box.
7. (optional) Click the "OK" button.
8. Click the "Export" button.

= Functionality only available in Google SketchUp Pro 7
Exporting an Animation

Animation files can be used to present your model without the need for SketchUp. Or, you import your files into another presentation or animation product to further enhance your animations. To Export an animation as an animation file (or series of image files):

1. Select the "File > Export > Animation" menu item. The Export Animation Dialog box is displayed.
2. Select the export type from the Export type drop-down list.
3. Enter the name for the exported file or series of files. The animation exporter will combine this name with a sequencing number for each image file that is created as part of a multiple image file animation. For example, if you export a 1 minute presentation called mypres.jpg, at 10 frames per-second, you will get 600 files, each named mypres0001.jpg, mypres0002.jpg, mypress0003.jpg all the way to mypress0600.jpg.
4. Click on the "Options" button. The Animation Export Options dialog box is displayed. The following image contains the Animation Export Options dialog box on Microsoft Windows:

![Animation Export Options dialog box on Microsoft Windows](image)

The following image contains the Animation Export Options dialog box on Mac OS X:

![Animation Export Options dialog box on Mac OS X](image)
5. Modify animation export options as necessary. See Animation Export Options in this topic for further information.

6. Click on the "Export" button to export the presentation as an animation.

= Functionality only available in Google SketchUp Pro 7
Running an Animation

SketchUp contains controls for starting, stopping, and pausing an animation. To run an animation:

1. Select the "View > Animation > Play" menu item. The animation controls are displayed and the animation starts to cycle through your scenes.

2. Press the "Pause" button to pause the animation.

3. Press the "Stop" button to stop the animation.

Note - You can also context-click on a scene tab and select Play Animation to begin an animation.
Saving Animations

SketchUp animations can be exported as a video animation, or series of progressive raster images, using the "File > Export > Animation" menu item. Refer to Animation Export Options for further information.

= Functionality only available in SketchUp Pro
Printing (Microsoft Windows)

SketchUp allows you to print your designs using any Windows-compatible printing device. You can also Print to Scale and span a print across multiple sheets, allowing you to output a large drawing from a standard printer. Printing is a three-step process:

1. Select the paper size for your printer using "File > Print Setup."
2. Configure the output size and preview your output using "File > Print Preview."
3. Print your model using "File > Print."
Printing (Mac OS X)

SketchUp allows you to print your designs using any Mac OS X-compatible printing device. Printing is a four-step process:

1. Select the paper size for your printer using "File > Page Setup."
2. Configure your model size printing using "File > Document Setup."
3. Preview your output using "File > Print > Preview."
4. Print your model using "File > Print."

💡 Tip - Select the "File > Print" menu item to print using paper size and model size defaults.
Printing To Scale (Microsoft Windows)

To print to scale:

1. Select the Perspective menu item from the Camera menu. The check mark next to the Perspective menu item should disappear and SketchUp will enter paraline mode.

2. Select the "Camera > Standard Views." The Standard views submenu is displayed.

3. Select a view. The drawing area changes to the view.

4. Select the "File > Print." The Print dialog box appears.

5. Uncheck the "Fit to page" checkbox (if it is not already checked). The Page size fields appear active.

6. Set the scale using the Page size fields.

7. Click the "OK" button. The model prints to scale.
Printing To Scale (Mac OS X)

To print to scale:

1. Select "Camera > Perspective." The check mark next to the Perspective menu item should disappear and SketchUp will enter paraline mode.
2. Select "Camera > Standard Views." The Standard views submenu is displayed.
3. Select a view. The drawing area changes to the view.
5. Uncheck the "Fit View to Page" checkbox. The Print Scale fields appear active.
6. Set the scale using the Print Scale fields.
7. Click the "OK" button.
8. Select "File > Print." The Print dialog box appears.
9. Click the "Print" button. The model prints.
Technical Info

This section of the documentation contains additional detailed information about various aspects of SketchUp.
Loading An Offline Crash Report (Microsoft Windows)

If a crash occurs when you are not connected to the Internet, BugSplat displays a dialog box indicating that a zip file has been created on your local hard drive. This dialog box will also indicate the name and location of the zip file (normally AtLastCrashMMDDYY_HHMMS.zip in your Windows temporary directory). Go to http://www.bugsplatsoftware.com/post/post_form.php and follow the instructions on the Web page to send this file to BugSplat Software when you reconnect to the Internet. Or email the zip file to Google directly by contacting technical support at http://sketchup.google.com/support/bin/request.py.
Uninstalling SketchUp on Windows XP, Windows NT, and Windows 2000

Uninstalling SketchUp is as simple as using the Add or Remove programs control panel of your operating system. Follow these steps to uninstall SketchUp on Windows XP, Windows NT, and Windows 2000:

1. Click on the "Start" menu.
2. Select the "Programs" folder.
3. Select the "Google SketchUp 6" subfolder.
4. Select the "Uninstall or Repair" menu item.
5. Follow the instructions to remove the application.
Uninstalling SketchUp on Mac OS X

Uninstalling SketchUp is as simple as dragging three folders and two files to the trash. Follow these steps to uninstall SketchUp on Mac OS X:

1. Navigate to the Applications folder (or wherever you installed SketchUp. For example, navigate to /Macintosh HD/Applications/.
2. Drag the Google SketchUp 6 folder to the Trash.
3. Navigate to the system-level Application Support folder. For example, navigate to /Macintosh HD/Library/Application Support/.
4. Drag the Google SketchUp 6 folder to the Trash.
5. Navigate to the user-level Application Support folder. For example, navigate to Jon/Library/Application Support/.
6. Drag the Google SketchUp 6 folder to the Trash.
7. Navigate to the user-level Preferences folder. For example, navigate to Jon/Library/Preferences/.
9. Empty the Trash.
Welcome to the Dynamic Components Developer's Guide

The Dynamic Components Developer's Guide contains step-by-step instructions on how to perform specific dynamic component creation tasks. The content in this guide answers the "How Do I..." questions of end-users.
**Constraining Attributes of a Dynamic Component**

A constrained dynamic component is a component that has elements (sub-components or sub-groups) that, when scaled with the Scale Tool, will not change size or orientation to the axes. To constrain entities of a dynamic component:

1. Create a new component that is comprised entirely from groups or sub-component instances, each with a unique name. Following is an image of the fence component used in this example. This component contains 4 sub-components: post, top rail, bottom rail, and picket sub-components. The parent component and each sub-component have a unique name. For example, the parent component is called Fence and it contains Post, TopRail, BottomRail, and Picket sub-components.

![Image of fence component](image.png)

**Note** - Configuring a dynamic component is easier when the component is placed at the origin of the axes in SketchUp.

2. Context-click on the component. The component's context menu is displayed.

3. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed.
4. Click the plus (+) button next to the Fence component. An empty list of attributes appears for the component.

5. Click on the "add attribute" button in the last row of the Fence component. A list of predefined attributes is displayed. The field is opened for editing.

6. Click on "Position" in the list of predefined attributes. All of the position attributes are displayed for the component.

7. Click on the "add attribute" button in the last row of the Fence component. A list of predefined attributes is displayed. The field is opened for editing.
8. Click on "Size" in the list of predefined attributes. All of the size attributes are displayed for the component. The following image shows these attributes within the Fence component.

![Fence Attributes](image)

9. Examine the parent component's default attributes:
   - X (red), Y (green), and Z (blue) refer to the location of the parent component's axes relative to the SketchUp axis. So, for example, if the parent component's Z is 2", the component is 2" above the origin. Remember, all components have their own axes. So, every sub-component will have the X, Y, and Z axes. However, sub-component X, Y, and Z values are relative not to the SketchUp Axes, but to their parent component's axes.
   - LenX, LenY, and LenZ refer to the length of the component in either the X, Y, or Z direction.
   - All of the attributes are faded gray color to indicate they are not constrained to a specific value.

10. Double-click in the field next to the LenY attribute in the Fence component. The field is opened for editing.

11. Erase the current value.

12. Type "=4" in the LenY field to constrain the length of the Fence component in the Y direction (the fence cannot be scaled in the Y direction).

13. Press the "Tab" key to accept the formula. The value for LenY (4) is displayed in black to indicate it is constrained (the fence cannot be resized using the Scale Tool).

14. Click on the plus sign "+" next to the TopRail sub-component to display its attributes.

15. Click on the "add attribute" button in the last row of the TopRail component. A list of predefined attributes is displayed. The field is opened for editing.

16. Click on "Position" in the list of predefined attributes. All of the position attributes are displayed for the component.

17. Click on the "add attribute" button in the last row of the TopRail component. A list of predefined attributes is displayed. The field is opened for editing.

18. Click on "Size" in the list of predefined attributes. All of the size attributes are displayed for the component.

19. Double-click in the field next to the X attribute in the TopRail sub-component. The field is opened for editing.
20. Erase the current value.

21. Type ",=4" in the X field of the TopRail to constrain the TopRail to 4" along the X axis from the Fence's origin (to accommodate the 4" width of the Pole). Generally, you want all of your sub-component's values constrained. Some of the parent's values might be constrained depending on the type of component you are creating. For example, the Fence's thickness (LenY) is constrained to 4". But all other values, including Fence's location to SketchUp's axes (X, Y, and Z) are unconstrained so it can be moved anywhere and scaled in the X and Z directions (LenX and LenZ).

![Note - Constrained values appear in solid black text. Unconstrained values (values that could be altered when scaling a component) are in light gray.]

22. Press the "Tab" key to accept the formula.

23. Double-click in the field next to the Y attribute. The field is opened for editing.

24. Erase the current value.

25. Type ",=1.25" in the Y field of the TopRail to constrain the TopRail to 1.25" along the Y axis from the Fence's origin (the middle of the Pole).

26. Press the "Tab" key to accept the formula.

27. Double-click in the field next to the Z attribute. The field is opened for editing.

28. Type ",=Fence!LenZ-9" in the Z field of the TopRail to constrain the Pole's Z value using a formula based on the overall height of the Fence (Fence!LenZ).

29. Press the "Tab" key to accept the formula. The value of TopRail's Z is constrained to 9 inches below the length of Fence (Fence!LenZ). The following image shows the changes made in steps 9 through 29:

![Tip - Move the cursor over a field and click the mouse button to create a reference to the content in that field in your formulas. For example, clicking on the LenZ field of Fence would place "Fence!LenZ" in the currently edited formula.]

30. Double-click in the field next to the LenX attribute. The field is opened for editing.
31. Erase the current value.

32. Type ",=Fence!LenX-Post!LenX\" in TopRail\'s LenX field. The length of the TopRail will be constrained to the length of Fence minus the length of the post (4\").

33. Press "Tab" to accept the formula.

34. Double-click in the field next to the LenY attribute. The field is opened for editing.

35. Erase the current value.

36. Type ",=1.5\" in TopRail\'s LenY field. The thickness of TopRail is set to 1.5 \".

37. Press the "Tab" key to accept the formula.

38. Double-click in the field next to the LenZ attribute. The field is opened for editing.

39. Erase the current value.

40. Type ",=3.5\" in TopRail\'s LenZ field. The height of TopRail is set to 3.5\".

41. Press the "Tab" key to accept the formula. All of TopRail\'s default attributes are now constrained so that the component will not change its position and size when scaled. The following image shows the changes made in steps 30 through 41:

![TopRail Attribute Table]

42. Continue constraining all of the default attributes (X,Y,Z, LenZ, LenY, and LenZ) for each of Fence\'s sub-components. Hint: you will want to constrain the LenZ of the picket to some value that is relative to the Fence\'s LenZ so the picket resizes proportionally to the fence in the Z (blue) direction.

43. Click on the "Close" button.

44. Use the Scale Tool to scale your component. The component should only scale in the directions that are unconstrained (the X and Z directions). Sub-components should retain their dimensions (such as post and picket width and depth).
Creating a Dynamic Component

Creating a dynamic component consists of the following high-level steps:

1. Create a new component that is comprised entirely from groups or sub-component instances, each with a unique name. You will only create components with sub-components in this getting started portion of the documentation.

2. Context-click on the component. The component's context menu is displayed.

3. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed. The Component Attributes dialog box is a two-column spreadsheet of attribute and attribute value pairs. This spreadsheet follows general spreadsheet rules:
   1. Use the Tab key to tab between fields or to accept a value.
   2. Use the equals sign (=) to assign a value or formula to a variable
   3. Use an exclamation point (!) to refer to a value outside of the current sub-component. For example, Fence!spacing refers to the value of the spacing variable in the Fence component.

4. Add variables and values to your component to make it dynamic.

5. Test your component to ensure it works correctly.

6. Save your component to a component file.
Adding an Attribute

There are three ways to add attributes to your dynamic components: You can add attributes from a menu of predefined attributes, you can add your own custom attribute, or you can add a group of attributes.

Adding a Pre-Defined Attribute

The Component Attributes dialog box contains several pre-defined attributes you can add to your components. To add a predefined attribute:

1. Click on the add attribute button in the Component Attributes dialog box. A list of predefined attributes appears. A field, with the phrase "Enter Name" also appears.
2. Click on a predefined attribute. The name appears in the first column of the Component Attributes dialog box.

Adding a Custom Attribute

You can add any number of custom attributes to your dynamic components to embed special functionality into the component. To add a custom attribute:

1. Click on the add attribute button in the Component Attributes dialog box. A list of predefined attributes appears. A field, with the phrase "Enter Name" also appears.
2. Enter the name of the custom attribute in the "Enter Name" field.
3. Press the Tab key. The custom attribute is accepted and you are prompted to enter a value for the attribute.

Note - Attribute names cannot have spaces and must start with a letter.

Adding an Attribute Group

The Attribute Manager contains several pre-defined attributes you can add to your components. To add a group of predefined attributes:

1. Click on the add attribute button in the Component Attributes dialog box. A list of predefined attributes appears. A field with the phrase "Enter Name" also appears.
2. Click on the title (in gray) of the group of predefined attributes. All of the predefined attributes in the group appear in the first column of the Component Attributes dialog box.
Repeating a Sub-Component Within a Dynamic Component (1 Dimension)

A repetitive dynamic component is a component containing a sub-component that repeat, such as the pickets of a fence component, or the steps of a stair component.

Following is an image of the fence component. This component contains 4 sub-components: a top rail, a bottom rail, a picket, and a post. You are going to replicate the picket sub-component as the component is scaled in the X direction. The main issue when creating a replicating sub-component is the spacing between each replicated part and how the part is replicated (linearly for a fence, diagonally for stairs, circular for circular stairs, and so on).

Note - The components in this example must be constrained before you can perform these steps. Refer to Constraining Attributes of a Dynamic Component for further information.

1. Create the component with one of the replicating subcomponents, such as the fence with one picket.
2. Context-click on the component. The component's context menu is displayed.
3. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed.
4. Click the plus (+) button next to the Fence component. A list of attributes appears for the component.

⚠️ **Note** - A list of attributes will only appear if you have constrained the component before trying these steps. Refer to Constraining Attributes of a Dynamic Component for further information.

5. Click on the "Add attribute" button in the last row of the Fence component. A list of predefined attributes is displayed. The field is opened for editing.

6. Type "spacing" and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key. An attribute named "spacing" is placed in a list of attributes called "Custom." The field next to the spacing attribute is opened for editing.

7. Type "2"
8. Press the "Tab" key to accept the value. You have established a spacing value of 2" between pickets. The following image shows the results of steps 5 through 8.

9. Click the plus (+) button next to the Picket component. A list of attributes appears for the component.

10. Click on the "add attribute" button in the last row of the Picket component. A list of predefined attributes is displayed. The field is opened for editing.

11. Click on the "Copies" attribute in the list. The field is populated with the word "Copies" and the field next to the Copies attribute is opened for editing. You need to create a formula that will yield a number of copies given the length of TopRail (or BottomRail) component.

12. Type "=(TopRail!LenX)/(Picket!LenX+Fence!spacing)-1"

13. Press the "Tab" key to accept the value. The first part of this formula, TopRail!LenX is the length of the TopRail component in the X direction. This number is then divided by the width of a picket plus the spacing (Picket!LenX+Fence!spacing). A value of 1 is then subtracted from the total. As mentioned, this formula yields the number of pickets that are created given the length of TopRail. These copies are placed at the same X, and, Z coordinate as the original Picket component (so all your pickets are exactly at the same spot). Next, we will use a formula to position, in the X direction, each copy of Picket.

   Note - Open the Outliner to see the copies being made as the component is scaled. The copies of the original picket will display as Picket copy 1, Picket copy 2, Picket copy 3, and so on.

14. Double-click on the value in the value field for the X attribute.

15. Press the "Backspace" (Microsoft Windows) or Delete (Mac OS X) key to delete the current value for the X attribute.

16. Type "]=5+COPY*(Fence!spacing+LenX)"
17. Press the "Tab" key to accept the value. This formula uses a predefined attribute called Copy to determine X positioning for each picket. The Copy attribute is simply a counter that begins at 0 (for the original Picket) and adds one for each additional copy. So, Copy is equal to 1 for the first copy, equal to 2 for the second copy, equal to 3 for the third copy, and so on. However, you will only ever see the X value for the original Picket component in the Component Attributes dialog box. The following image shows the results of steps 9 through 17.

![Picket Attributes](image)

**Note** - Multiplication takes place before addition.

18. Click on the close button.
19. Use the Scale Tool to scale your component in the X direction. The component should add pickets as you scale. The following image shows the Fence component after scaling along the X axis.

You might consider hiding the scale handles so that only the handles in the X direction are visible when using the Scale Tool. Refer to Hiding Scale Handles for further information.
Repeating a Sub-Component Within a Dynamic Component (2 Dimensions)

A repetitive dynamic component is a component containing a sub-component that replicate, such as the tiles within a floor component. In the case of a floor and tiles, the component scales in 2 dimensions, X, and Y.

Note - You should create a component whose subcomponent replicates in one direction prior to creating a component whose subcomponent replicates in two directions. This document assumes you are familiar with 1 dimensional replication. Refer to Repeating a Sub-Component Within a Dynamic Component (1 Dimension).

Following is an image of the Floor component containing 1 Tile sub-component (it simply looks like one tile). The Tile sub-component replicates as the Floor component is scaled in the X and Y directions (using the Scale Tool).

Following is an image of the Floor component after it has been scaled. Now the Floor has 8 copies of the replicating Tile subcomponent.

To replicate a subcomponent within a parent component (in two dimensions):
1. Create your component with one subcomponent, such as a floor with one tile.
2. Context-click on the component. The component's context menu is displayed.
3. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed.

4. Ensure that the attributes for all components are visible.

5. Create a Columns attribute in the Floor component to hold the number of rows in your dynamic component.

6. Create a Rows attribute in the Floor component to hold the number of rows in your dynamic component.

7. Create an attribute, in the Floor component, that represents the size of the replicating subcomponent. For example, this example contains a TileSize attribute.

8. Set TileSize to some value, such as 12.

9. Set the LenX and LenY of the Tile subcomponent to the size in the parent component. For example, set LenX to equal Floor!TileSize and LenY to equal Floor!TileSize (for the Floor Tile subcomponent).

10. Use a formula in the field next to the Floor component's Columns attribute to determine the number of columns in the parent component. This formula will be based on the size of the replicating subcomponent (Tile) and overall size of the parent component (Floor). For example:

\[ \text{=CEILING}(\text{LenX}/\text{TileSize}) \]

Note - The ceiling function, with only one argument, rounds the result of LenX/TileSize to the nearest bigger whole number.

11. Use a formula in the field next to the Floor's Rows attribute to determine the number of rows in the parent component. This formula will be based on the tile size of the replicating subcomponent (Tile) and overall size of the parent component (Floor). For example:

\[ \text{=CEILING}(\text{LenY}/\text{TileSize}) \]

12. Add the Copies attribute to the Tile subcomponent.

13. Use a formula in the field next to the Copies attribute to calculate the number of copies of the replicating subcomponent. The copies are calculated by multiplying the rows by columns and subtracting one (for the original). For example:

\[ \text{=Floor!rows*Floor!columns-1} \]

14. Establish the position of each replicating subcomponent (the exact column and row). Position is determined by establishing a multiplier that represents the row or column and then multiplying the multiplier by the size of the subcomponent to establish its X and Y location.

a. Create an attribute to hold the row multiplier, such as myRow, in the Tile subcomponent.

b. Use a formula in the field next to the myRow attribute that iterates through each copy and determines the row where the copy will be placed. For example:

\[ \text{=Floor}(\text{COPY}/\text{Floor!columns}) \]

If Copy equals 7, and there are 3 columns in the object, then myRow will be equal to 2. Note that rows start at 0, so 2 represents the 3rd row.

Note - The floor function, with one argument, rounds the result down to the nearest whole number.
c. Create an attribute to hold the column multiplier, such as myColumn, in the Tile subcomponent.

d. Use a formula in the field next to the myColumn attribute that iterates through each copy and determines the column where the copy will be placed. For example:

\[ \text{COPY} - (\text{myRow} \times \text{Floor!columns}) \]

If copy equals 7, myRow equals 2 (calculated previously) and there are 3 columns in the object, then myColumn will be equal to 1. Note that columns start at 0, so 1 represents the 2nd row.

\[ \text{Note} \] - The floor function, with one argument, rounds the result down to the nearest whole number.

e. Use a formula in the field next to the Tile subcomponent's X attribute to calculate the location of the sub-component. For example:

\[ \text{X} = \text{myColumn} \times \text{Floor!tilesize} \]

f. Use a formula in the field next to the Tile sub-component's Y attribute to calculate the location of the sub-component. For example:

\[ \text{Y} = \text{myRow} \times \text{Floor!tilesize} \]

The following is an image of the Component Attributes dialog box with all Floor and Title attributes:
Note - The Tile replicating subcomponent is copy 0 and only the values for copy 0 are displayed in the Component Attributes dialog box.
Making Attribute Values End-User Configurable

You might want to allow the users of your dynamic component to configure some values of your dynamic component, such as the spacing between pickets in a fence or the width of your stairs. Values that are configurable will appear in a Component Options dialog box accessible from the component's context menu. To make a value configurable:

1. Context-click on the component. The component's context menu is displayed.

2. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed. Notice that the top-level component is listed.

3. Click the plus (+) button next to the component's name. A list of attributes appears for the component.

4. Click on the "Details" button to the right of the attribute you want to make end-user configurable. A drop-down list of display rules appears. There are two display rules allowing you to configure the attribute: "Users can edit as textbox" and "Users can select from a list." This article explains how to configure the more complex display rule: "Users can select from a list."

5. Select "Users can select from a list." The Display label and a table appear. The following image shows the Display rule drop-down list, Display label field, and table.

![Component Attributes](image)

6. Type a label in the in the "Display label" field. This field contains the user-friendly name you want to appear in the configuration box for this attribute.

7. Click the "add option" icon in the "List Option" column of the table. A row is created with the field in the List Option column open for edit.

8. Type "Small" in the "List Option" field. This text will appear in a drop-down list in the Configure Options dialog box.

9. Press the "Tab" key.

10. Type "1" in the Value field.

11. Press the "Tab" key to accept the value.
12. Repeat steps 7 through 11 using the option and value pairs of:

- Medium, 2"
- Large, 3
- Extra Large, 4

The following image shows the attribute details panel with all completed fields:

14. Click on the "Apply" button. The attribute details panel closes.

15. Click on the "Close" button. The Component Attributes dialog box closes. The user of this component can now configure the component's Slat Spacing attribute using the Configure Options dialog box. Refer to Configuring a Dynamic Component for further information.
Making a Dynamic Gluing Component

The process of creating a component using the create component dialog box is the same for both dynamic and regular components (dynamic components are different in that you have visibility into their internal attributes). As a dynamic component creator you will notice that the blue and green axes (LenY and LenZ) are swapped when you edit the attributes of a component that has a specific gluing orientation (such as a component that glues only to vertical surfaces). LenZ will have a value for length along the green axis and the LenY will have a value for the length along the blue axis. This is an important aspect of gluing components because it affects the variables you use in your formulas. For example, if you want to constrain a gluing component that glues to vertical surfaces, such as window, to a specific height, you're formula will have to constrain LenY, not LenZ.
Hiding Scale Handles

Add the ScaleTool attribute to your Dynamic Component to toggle display of scale handles on the component (limiting how users can scale the component). To hide scale handles using the ScaleTool attribute:

1. Context-click on the component. The component's context menu is displayed.
2. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed. Notice that the top-level component is listed.
3. Click the plus (+) button next to the component's name. An empty list of attributes appears for the component.
4. Click on the "add attribute" button in the last row of the attributes list. A list of predefined attributes is displayed. The field is opened for editing.
5. Click on the "ScaleTool" attribute in the list. The field is populated with the word "ScaleTool.
6. Click on the "Details" button to the right of the ScaleTool attribute. The attribute details panel is displayed. The following image shows the attribute details panel:

![Attribute Details Panel]

6. Uncheck the checkboxes next to the scale handles you want to toggle off. Or, alternatively, check the checkboxes next to the scale handles you want to toggle on.
7. Click on the "Save" button. The attribute details panel closes.
8. Click on the "Close" button. The Component Attributes dialog box closes.
9. Select the "Scale Tool" ( ). The cursor will change to a box within another box.
10. Click on the Dynamic Component. The scaling grips that are toggled on will appear around the Dynamic Component.
Implementing Dynamic Pricing

You can create a component whose pricing changes based on the type of material or size of component the user chooses. To implement dynamic pricing in your dynamic component:

1. Create a component, such as a cabinet door.

2. Context-click on the component. The component's context menu is displayed.

3. Select the "Dynamic Components > Component Attributes" menu item. The Component Attributes dialog box is displayed. Notice that the top-level component is listed.

4. Click on the "add attribute" button in the last row of the component. A drop-down list of attributes appears.

5. Click on the "Material" attribute in the list. The field is populated with the word "Material" and the field next to the Material attribute is opened for editing.

6. Click on the "Details" button to the right of the Material value. A drop-down list of display rules appears.
7. Select "Users can select from a list" from the Display rule drop-down list. The Display label and a table appear. The following image shows the Display rule drop-down list, Display label field, and table.

![Component Attributes dialog box](image)

8. Replace the word "Material" with "Wood Type" in the "Display label" field.

9. Click the "Add option" icon in the "List Option" column of the table. A row is created with the field in the List Option column open for edit.

10. Type "Cherry" in the "List Option" field. This text will appear in a drop-down list in the Configure Options dialog box.

11. Press the "Tab" key.

12. Type "Wood_Cherry_Original" in the Value field. This is the name of a specific material in the Materials Browser.

13. Press the "Tab" key to accept the value.
14. Repeat steps 9 through 13 using the option and value pairs of:
   - Cork, Wood.Board_Cork
   - Plywood, Wood_Plywood_Knots

The following image shows the attribute details panel with all completed fields:

14. Press the "Apply" button. The attribute details panel closes.
15. Click on the "Add attribute" button in the last row of the component. A drop-down list of attributes appears.
16. Type "Cost" and press the Tab key. An attribute named "Cost" is placed in a list of attributes called "Custom." The field next to the Cost attribute is opened for editing.
17. Type 
   
   \[
   =\text{if}(\text{MATERIAL}="\text{Wood.Board.Cork"}, 40.00, \\
   \text{if}(\text{MATERIAL}="\text{Wood.Cherry.Original"}, 60.50, 15.25)) \\
   \]
   
18. Press the Tab key to accept the formula. This formula assigns a cost for the door based on the material (wood) that is selected by the user.
19. Click on the "Close" button.
20. Context-click on the component. The component's context menu is displayed.
21. Select the "Component Options" menu item. The Component Options dialog box is displayed. The following is an image of the Component Options dialog box for the Television dynamic component:
Choosing different Wood Types from the drop-down list not only changes the SketchUp material applied to the component (to reflect the wood type), but changes the MSRP of the door to reflect the wood type.

💡 Tip - You can also use the `CHOOSE` and `OPTIONINDEX` functions in place of nested if statements (as in step 17). For example:

```
MSRP = CHOOSE (OPTIONINDEX("MATERIAL"), 40, 60.50, 15.25)
```

In the previous example, if the first choice in a drop-down list of materials is chosen (Cork), the price $40. If the second choice in a drop-down list of materials is chosen (Cherry), the price is $60.50. And, if the third choice in a drop-down list of materials is chosen (Plywood), the price is $15.25.
Creating a Dynamic Component That Snaps to a Specific Size

You can constrain a component to a series of predefined sizes by placing specific formulas in the LenX, LenY, or LenZ fields of the parent component.

Snapping to the Nearest Rounded Value

Place the following formula in the LenX field for a component to snap the component's LenX to the nearest width within 2 inches after scaling:

\[ \text{LenX} = \text{ROUND}\left(\frac{\text{CURRENT("LenX")}}{2}\right) \times 2 \]

This formula is useful for components that represent items that only come in whole number sizes.

Snapping to One of a Series of Specific Values

Place the following formula in the LenX field for a component to snap the component's LenX to the nearest value (24, 36, or 48 inches) in a list after scaling:

\[ \text{LenX} = \text{NEAREST}\left(\text{CURRENT("LenX")}, 24, 36, 48\right) \]

This formula is useful for components that represent items that come in a pre-defined series of sizes, such as kitchen cabinets.

Snapping to a Smallest or Largest Size

Place the following formula in the LenX field for a component to snap the component's LenX to 20 inches wide when a scale operation scales the component beyond 20 inches:

\[ \text{LenX} = \text{SMALLEST}\left(\text{CURRENT("LenX")}, 20\right) \]

Place the following formula in the LenX field for a component to snap the component's LenX to 10 inches wide when a scale operation scales the component below 10 inches:

\[ \text{LenX} = \text{LARGEST}\left(\text{CURRENT("LenX")}, 10\right) \]

These formulas are useful for components that represent items that must not be smaller than or larger than a specific size.
Using Unique Textures in Dynamic Components

Dynamic Components that use unique textures (textures that do not ship with SketchUp, such as photographic textures of a specific material), must be embedded in the Dynamic Component to be accessible when that component is used on different computers. To embed a texture in a Dynamic Component:

1. Create your Dynamic Component.
2. Create a small face (it can be as small as a few millimeters) on the component that is not visible to the user. For example, create a face on the bottom of a couch component.
3. Apply the unique texture to the face. The texture is now embedded in the component and will be available to all users of the component.
Deleting an Attribute

Click on the minus icon to the right of an attribute's value field to delete the attribute.
Renaming an Attribute or Component Name

Double-click on an attribute name or component name in the Component Attributes dialog box to rename the attribute or component.

Note - You can only change the name of a custom attribute, not a predefined attribute.
Swapping Multiple Dynamic Components

Use the Swap Component menu item to swap the currently selected component with another component. For example, use this option to swap all windows of a specific type or manufacturer with windows of another type or manufacturer.

To swap out a series of components:

1. Select the dynamic components you want to replace. The components are highlighted in the drawing window.
2. Context-click on one component. The context menu is displayed.
3. Select "Dynamic Components > Swap Component." The Select a SKP dialog box is displayed.
4. Select the SketchUp file containing the Dynamic Component to replace the currently selected components.
5. Click the "Open" button. The new Dynamic Component replaces the previously selected Dynamic Components.
**Generating an Attribute Report**

An Attribute Report is a comma separated value file containing all attributes and values in a dynamic component. To generate an Attribute Report:

1. Use the "Select Tool" to select one or more dynamic components. Each components' bounding box is highlighted.
2. Context-click on the component. The component's context menu is displayed.
4. Click the "All model attributes" button to save a report with all attributes in your model or click the "Current selection attributes" to save a report with the attributes in your current selection.
5. Click on the "Generate xml file" button or "Generate csv file" button to generate either an XML or CSV file.
6. Click the "Save" button. The Attribute Report is saved. A dialog box displays.
7. Click the "Yes" button to display the Attribute Report. The report is displayed in Microsoft Excel (or any program that can display .csv files).

**Note** - You can select all components, such as all cabinets, in a scene that have costs attributes. Then, use the SUM formula in Microsoft Excel (after creating an Attribute Report) to calculate the total cost of all items in the selection set. This same method can be used to calculate total board feet for wood used in a project, and so on.
Configuring a Dynamic Component

Some dynamic components have the ability for the values of certain geometry to be end-user configurable using a Component Options dialog box. To configure a component:

1. Context-click on the component. The component's context menu is displayed.
2. Select the "Dynamic Components > Component Options" menu item. The Component Options dialog box is displayed. The following is an image of the Component Options dialog box for the Fencedynamic component:

![Component Options Dialog Box](image)

3. Type values in fields or select options from drop-down menus as applicable. The Fence component has two fields and three drop-down lists.
4. Click the "Apply" button to apply your configuration changes to the component. The component's geometry should reflect changes in the Component Options dialog box.
Identifying Dynamic Components

A component is considered dynamic when one of the following conditions is met:

- The component contains the onClick, ScaleTool or Copies attributes.
- The component contains a formula assigned to one of its attributes. Setting an attribute to some value using the equal sign (=), such as "=123" is sufficient.
- The component contains sub-component of the component is dynamic.

The component will have a badge ( располагается ) on its thumbnail in the Component Browser or in the Google 3D Warehouse indicating that it is dynamic when it meets one of the previous conditions.

Note - A file can only contain one Dynamic Component (without any additional geometry) to be identified as a Dynamic Component.
Common Tasks

This section of the user's guide addresses common tasks that new users ask about as they are learning SketchUp. These tasks are covered within other topics in the user's guide, but are addressed as high-level topics here to facilitate the search capabilities of the online user's guide (so these issues are listed when a search is performed).
Adding a Background to Your Model

SketchUp allows you add image files to your model and position those images such that they act as a background. For example, you can have a single image placed vertically behind a house so that you can study what will be seen from certain angles within the house.
Ensuring Edge Alignment to Axes

There are two methods to ensure your edges align to axes: change the cursor to the axes colors or change your edges to the axes colors.

Changing Cursor to Axes Colors

One method for ensuring your edges are aligned to axes is to change the cursor so that it displays cross hairs that are the colors of the axes while drawing. To change the cursor to axes colors:

1. Select "Window > Preferences" (Microsoft Windows) or "SketchUp > Preferences" (Mac OS X). The Preferences dialog box is displayed.
2. Select the "In Drawing" item on the left-hand side of the Preferences dialog box. The Drawing panel is displayed.
3. Click the "Display cross hairs" checkbox.
4. Click the "OK" button to close the Preferences dialog box. The cursor will display cross hairs that are the color of the axes.

Changing Edges to Axes Colors

A second method for ensuring your edges are aligned to axes is to temporarily change the colors of your edges to reflect their alignment to one of the axis. To change edge colors to reflect axes colors:

1. Select "Window > Styles." The Styles Browser is displayed.
2. Select "In Model" from the drop-down list of styles libraries. The styles in your model appear.
3. Click on the "Edit" tab. One of the edit panels appears.
4. Click on the "Edge Settings" icon. The Edge Setting panel appears.
5. Select "By axis" from the Color drop-down list. The colors of the edges in your model change to reflect their alignment to the axes.
Claiming Credit on a Model

SketchUp allows you to claim credit on the models you create and make available to others to use using the 3D Google Warehouse. To claim credit on a model:

1. Create your model in SketchUp. Your model can be composed of other models, such as models found in the 3D Google Warehouse.

2. Open the Credits panel of "Window > Model Info." The Credits panel displays author and contributor information. The list of contributors will have component and contributor names if you are using pre-made components in your model.

3. Click on the Google Login button on the Status Bar. The Sign In dialog box appears.

   **Note** - Alternatively, click on the "Claim Credit" button in the Credits panel of the Model Info dialog box to sign in.

4. Type in your Username in the Username field.

5. Press the "Tab" key. The cursor moves to the Password field.

6. Type in your Password in the Password field.

7. (optional) Check the "Keep me signed in on this computer" checkbox.

8. Click the Sign In button. The Google Login button is now highlighted to indicated you are signed in. Your username appears in the Author section of the Model Info Credits panel. Your nickname will appear in the Modeled by field in the Contributors section of the Model Info Credits panel.

9. Save and, optionally, upload your model to the 3D Google Warehouse. Your username stays with the model as it is reused in other models. Your nickname will appear as the first contributor if your model is included in someone else's model.

   **Note** - You must sign in every time you run SketchUp.

   **Note** - You can also click on the credits button on the status bar to display the Credits Model Info dialog box.
Copying Geometry

There are two ways to copy geometry in SketchUp:

1. Use the Copy and Paste commands to copy geometry.

2. Use the Move Tool if you want to create one or more copies of a piece of geometry at specified distance intervals from the original piece of geometry.
Creating a 2-Point Perspective

Select "Camera > Two-Point Perspective" to achieve a 2-point perspective view of your model. You will be placed in the Pan Tool to pan around your model.

Caution - Orbiting will move a model out of 2-point perspective.
Dividing Lines or Arcs Into Equal Segments

To divide a line or arc into equal segments:

1. Context-click on the entity to invoke the entity's context menu
2. Select "Divide." A string of red dots appears along the line segment.
3. Drag the cursor back and forth along the length of the entity to increase or decrease the number of divisions. A tooltip displays the number and length of segments that will be created if you pause briefly on the entity.

Note - The number of divisions is also displayed in the Measurements Toolbar. Type in the number of desired segments followed by pressing the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key to manually divide the entity.

4. Click again to divide the entity. The entity will be broken into separate segments.

This menu item is available for the 3D Polyline, Circle, Line, and Polygon entities.
Drawing Accurate Angled Lines

Drawing accurate angled lines is a two-step process. To draw accurate angled lines:

1. Use the "Protractor Tool" to create a Guide Line entity at some angle.
2. Use the "Line Tool" to trace over the Guide Line entity and create the line.
Drawing a Bowl

Advanced tasks, such as drawing a bowl or sphere, require experience with several SketchUp tools and features. You should be competent with the following tools and features before attempting to draw a bowl:

- The Circle Tool
- The Follow-Me Tool
- The Offset Tool
- The Line Tool
- The Eraser Tool
- Inference

One common way to draw a bowl is:

1. Draw a circle on the ground plane at the origin. This circle will be used as a path used to draw the side of the bowl. The size of this circle does not matter.

2. Move the cursor to the origin. The cursor should snap to the origin.
3. Move the cursor up the blue axis (above the circle on the ground plane). The cursor should turn green or red.

4. Press and hold the "Shift" key to lock the Circle Tool in the green or red inference direction.

5. Draw a circle perpendicular to the circle on the ground plane whose radius represents the radius of the outside of your bowl.
6. Use the "Offset Tool" to create an offset of this second circle. The offset distance represents the bowl thickness.

7. Use the "Line Tool" to divide the second circle in half.
8. Use the "Eraser Tool" to erase the top half of the second circle. You are creating the profile of the bowl.

9. Use the "Eraser Tool" to erase the face that represents the inside of the bowl. The profile of the bowl is complete.

10. Select the edge of the circle on the ground plane. This is your path.

11. Select the "Follow-Me Tool."
12. Click on the profile of the bowl. A bowl is created.

13. Remove the circle on the ground plane.
## Drawing a Cone

Advanced tasks, such as drawing a cone or sphere, require experience with several SketchUp tools and features. You should be competent with the following tools and features before attempting to draw a cone:

- The Circle Tool
- The Move Tool
- The Push/Pull Tool
- The Follow-Me Tool
- The Line Tool
- Inference

### Drawing a Cone by Resizing a Cylinder Face

One common way to draw a cone is:

1. Draw a circle on the ground plane at the origin. This circle will represent the base of the cone.
2. Use the "Push/Pull" Tool to create a cylinder at the height of your cone.

3. Select the "Move Tool."

4. Place the cursor at the edge of the top of the cylinder.

5. Move the cursor around the edge until you find one of the cardinal points (a point that is aligned with the red or green axis). The edge of the circle will not highlight when the cursor is on a cardinal point. Cardinal points act as resize handles.

6. Click the mouse button when the cursor is over a cardinal point on the edge of the top of the cylinder.

7. Move the cursor toward the center of the cylinder. A cone begins to take shape.
Drawing a Cone Using The Follow-Me Tool

One common way to draw a cone is:

1. **Draw a circle on the ground plane at the origin. This circle will represent the base of the cone.**

2. **Use the "Orbit Tool" to orbit so that your view is looking over the top of the circle (not directly down on the circle).**

3. **Use the "Line Tool" to draw a line up the blue axis from middle of the circle to the height of your cone.**

4. **Use the "Line Tool" to draw a line from the top of the previous line to the edge of the circle. This line will form the second line of a triangle.**

5. **Use the "Line Tool" to join the last line to the bottom of the first line, creating a solid triangular face.**
6. Select the edge of the circle on the ground plane. This is your path.

7. Select the "Follow-Me Tool."

8. Click on the solid triangular face. A cone is created.

**Note** - The bottom face of the cone is eliminated when you use the Follow Me Tool to create a cone. Draw a line from endpoint to endpoint of any segment along the circumference of the cone's base to recreate the bottom face.
Drawing an Ellipse

There are multiple ways to draw things in SketchUp. One common way to draw an ellipse is:

1. Draw a circle with the Circle tool.
2. Select the "Scale Tool." The cursor will change to a box within another box.
3. Click on the circle. Scaling grips will appear around the circle.
4. Click and hold one of the grips in the middle of one of the bounding box edges (not one of the corner grips).
5. Move the cursor away from the center of the circle. The circle will form an ellipse.
**Drawing Engraved Text**

To draw text that appears engraved:

1. Draw a large rectangular surface.
3. Enter the desired text in the text field.
4. Check the "Extruded" check box.
5. Type a negative value in the Extruded field.
6. Click the "Place" button. A cursor appears with the text.
7. Click on the rectangular surface. The text is placed on the surface as a group.
8. Select the 3D text.
9. Context click on the 3D text. The context menu for the group is displayed.
10. Select the "Explode" menu item. The 3D text explodes into its individual geometry.
11. Select the face of each letter and press the Delete key on your keyboard. The face is removed and the letter appears to be engraved.
Drawing an Inner Tube

Advanced tasks, such as drawing a cone or inner tube, require experience with several SketchUp tools and features. You should be competent with the following tools and features before attempting to draw an inner tube:

- The Circle Tool
- The Select Tool
- The Follow-Me Tool
- Inference

One common way to draw an inner tube is:

1. Draw a circle on the ground plane at the origin. This circle will be used as a path used to draw the sphere. The size of this circle does not matter.

2. Use the "Select Tool" to select the face of the circle and press the "Delete." The face is deleted.

3. Select the "Circle Tool."

4. Move the cursor to the origin. The cursor should snap to the origin.
5. Move the cursor up the blue axis (above the circle on the ground plane). The cursor should turn green or red.

4. Hold the "Shift" key to lock the Circle Tool to lock the inference direction.

5. While holding the "Shift" key, draw a circle, whose diameter will be the diameter of your inner tube, perpendicular to the first circle. This circle is the profile of the inner tube.

6. Select the edge of the circle on the ground plane. This is your path.

7. Select the "Follow-Me Tool."
8. Click on the profile of the inner tube. An inner tube is created.
Drawing a Pyramid (Creating a Pyramidal Hipped Roof)

Advanced tasks, such as drawing a cone or pyramid, require experience with several SketchUp tools and features. You should be competent with the following tools and features before attempting to draw a pyramid:

- The Rectangle Tool
- The Move Tool
- The Line Tool
- Inference

One common way to draw a pyramid is:

1. Use the "Rectangle Tool" to draw a square. SketchUp's inference engine displays a dashed diagonal line and the word "square" when your rectangle is a square. This square will be the base of your pyramid.

2. Use the "Line Tool" to draw two diagonal lines across the square (from corner to the opposite corner).

3. Select the "Move Tool."
4. Hover the cursor over the mid point of the diagonal line. The tooltip should say "endpoint."

5. Click the mouse button.
6. Move the cursor up in the blue direction to the desired height.
Drawing a Sphere

Advanced tasks, such as drawing a cone or sphere, require experience with several SketchUp tools and features. You should be competent with the following tools and features before attempting to draw a sphere:

- The Circle Tool
- The Select Tool
- The Follow-Me Tool
- The Eraser Tool
- Inference

One way to draw a sphere is:

1. Draw a circle on the ground plane at the origin. This circle will be used as a path used to draw the sphere. The size of this circle does not matter.

2. Move the cursor to the origin. The cursor should snap to the origin.
3. Move the cursor up the blue axis (above the circle on the ground plane). The cursor should turn green or red.

4. Press and hold the "Shift" key to lock the Circle Tool in the green or red inference direction.

5. Draw a circle, smaller than the first, perpendicular to the circle on the ground plane (this represents the profile of the sphere).

6. Select the edge of the circle on the ground plane. This is your path.

7. Select the "Follow-Me Tool."
8. Click on the profile of the sphere. A sphere is created.

9. Remove the circle on the ground plane.
Ensuring Edge Alignment to Axes

There are two methods to ensure your edges align to axes: change the cursor to the axes colors or change your edges to the axes colors.

Changing Cursor to Axes Colors

One method for ensuring your edges are aligned to axes is to change the cursor so that it displays cross hairs that are the colors of the axes while drawing. To change the cursor to axes colors:

1. Select "Window > Preferences" (Microsoft Windows) or "SketchUp > Preferences" (Mac OS X). The Preferences dialog box is displayed.
2. Select the "In Drawing" item on the left-hand side of the Preferences dialog box. The Drawing panel is displayed.
3. Click the "Display cross hairs" checkbox.
4. Click the "OK" button to close the Preferences dialog box. The cursor will display cross hairs that are the color of the axes.

Changing Edges to Axes Colors

A second method for ensuring your edges are aligned to axes is to temporarily change the colors of your edges to reflect their alignment to one of the axis. To change edge colors to reflect axes colors:

1. Select "Window > Styles." The Styles Browser is displayed.
2. Select "In Model" from the drop-down list of styles libraries. The styles in your model appear.
3. Click on the "Edit" tab. One of the edit panels appears.
4. Click on the "Edge Settings" icon. The Edge Setting panel appears.
5. Select "By axis" from the Color drop-down list. The colors of the edges in your model change to reflect their alignment to the axes.
Flipping or Mirroring Geometry

A flip operation refers to making a mirror of your geometry. A mirror is creating a mirrored copy of your geometry.

Flipping Geometry

Flipping is useful when you want to create an exact mirror of your geometry. You can flip geometry by:

1. Selecting the geometry to be flip.
2. Context-clicking on the geometry. The context menu is displayed.
3. Selecting the "Flip Along" context menu item.
4. Choosing the direction or axis for the flip. The following image shows the geometry before the flip operation.

The following image shows the geometry after the flip operation.
Note - You can also use the Scale Tool to flip or mirror geometry.

Mirroring Geometry
The process for mirroring geometry is essentially the same process as for flipping, but you are creating an additional copy. Mirroring allows you to create one half of a model and then duplicate and mirror that half to create the rest of the model. For example, you could create the left-side of a model of a car and then duplicate and mirror that side to create the right-side of the car. The process to mirror geometry follows:

1. Select the geometry to be mirrored. The following image shows the left-side of a car.

2. Make a copy of the geometry
3. Paste the copy.
4. Context-click on the geometry. The context menu is displayed.
5. Select the "Flip Along" context menu item.
6. Choose the direction or axis for the flip. The following image shows the left-side of the car and copy of the left-side of the car that has been flipped.

>Note - You can also use the Scale Tool to flip or mirror geometry.
Installing Ruby Scripts

Place Ruby scripts into the Plugins folder to execute them when you restart SketchUp. The Plugins folder on Microsoft Windows is at:

C:\Program Files\Google\Google SketchUp 6\Plugins

The Plugins folder on Mac OS X is at:

<username>/Library/Application Support/Google SketchUp 6/SketchUp/Plugins
Remapping Mouse Buttons (Microsoft Windows)

You can only control the directory you roll the scroll wheel to zoom in and out in SketchUp. By default, you roll the scroll wheel up to zoom in and down to zoom out. To change scroll wheel mapping:

1. Select "Window > Preferences." The Preferences dialog box is displayed.
2. Select the "Compatibility" item in the left-hand side of the Preferences dialog box. The Compatibility panel is displayed.
3. Check the "Invert" checkbox.

Some mouse drivers or configuration utilities make it possible to map mouse buttons to various functions or keystroke assignments. You should make these kinds of changes carefully because SketchUp makes extensive use of the mouse buttons in combination with various modifier keys (Ctrl, Alt, Shift), and you could easily lose functionality by remapping the mouse buttons.
Welcome to the SketchUp Reference Guide

The SketchUp Reference Guide contains explanations of all reference material pertaining to SketchUp. The content in this guide answers the "What is the...feature" questions of end-users.
The SketchUp User Interface

This section of the reference guide covers the SketchUp user interface, including menus, toolbars, dialog boxes, and the drawing area.
Application Window

The SketchUp user interface is designed to be simple and easy to use. The main parts of the SketchUp user interface are the title bar, menus, Toolbars and tool palettes, drawing area, status bar, and the Measurements Toolbar.

Mac OS X

Following is an image of the SketchUp user interface on Mac OS X:

Microsoft Windows

Following is an image of the SketchUp user interface on Microsoft Windows:
Drawing Area

The *drawing area* is where you create your model. The 3D space of the drawing area is identified visually by the drawing axes.
Menus

Menus appear below the title bar. The majority of SketchUp tools, commands, and settings are available within these menus. The menus that appear by default are: SketchUp (Mac OS X-only), File, Edit, View, Camera, Draw, Tools, Window, and Help.
Status Bar

The status bar is the long gray rectangular area at the bottom of the drawing area.

Microsoft Windows

Following is an image of the status bar on Microsoft Windows:

Geolocation Button
Hover over the Geolocation button to display location information for the current model.

Click the Geolocation button to display the Location panel of the Model Info dialog box. The Georeferencing portion of the Location panel allows you to manually establish the geographic location for the current model. A model can have three states, as indicated by the icon next to the Use georeferencing checkbox: Not georeferenced (faded exclamation point), Manually georeferenced using location in SketchUp (bright exclamation point), and georeferenced with data from Google Earth (Google Earth logo with exclamation point).

Note - Altering the fields in the Location panel of the Model Info dialog box while using georeferenced data from Google Earth yields a warning that Google Earth terrain and layers were be erased.

Attribution Button
Click the Attribution button to display the Credits panel of the Model Info dialog box. The Credits panel allows you to view contributors toward the current model. This panel also allows the current users to claim credit toward the current model.

Google Login Button
Click the Google Login button to log in to your Google account.

Instructor Button
Click on the Instructor button to display the Instructor dialog box.

Measurements Toolbar
The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate currently selected entities, such as creating elements of a specific dimension.

Mac OS X

Following is an image of the status bar on Mac OS X:

Geolocation Button
Hover over the Geolocation button to display location information for the current model.

Click the Geolocation button to display the Location panel of the Model Info dialog box. The Georeferencing portion of the Location panel allows you to manually establish the geographic location for the current model. A model can have three states, as indicated by the icon next to the Use georeferencing checkbox: Not georeferenced, Manually georeferenced (using location in SketchUp), and georeferenced with data from Google Earth.
**Attribution Button**
Click the Attribution button to display the Credits panel of the Model Info dialog box. The Credits panel allows you to view contributors toward the current model. This panel also allows the current users to claim credit toward the current model.

**Google Login Button**
Click the Google Login button to log in to your Google account.

**Instructor Button**
Click on the Instructor button to display the Instructor dialog box.

**Measurements Toolbar**
The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate currently selected entities, such as creating elements of a specific dimension.

⚠️ **Note** - Use the resize handle to make the drawing area larger so you can see the entire message in the status bar.
Toolbars and Tool Palettes (Mac OS X)

The Toolbar, appearing below the menus, contains a set of user-defined controls. By default, the Toolbar contains the basic set of SketchUp tools, referred to as the \textit{getting started} tools.

Additional tool palettes are found in the View \textgreater{} Tool Palettes submenu.
Toolbars (Microsoft Windows)

The Toolbars, appearing below the menus and along the left side of the application contain a user-defined set of tools and controls. By default, SketchUp displays one Toolbar, referred to as the *getting started Toolbar*, below the menus. Additional Toolbars are found in the View >Toolbars submenu.
Title Bar (Mac OS X)

The title bar (at the top of SketchUp) contains the standard Macintosh OS X window controls (close, minimize, and maximize) on the left, and a title bar collapse/expand button on the right. In the middle of the title bar is the name of the currently opened file. A blank drawing area appears when you start SketchUp and the name of the currently opened file is "Untitled" in the title bar, indicating that you have not yet saved your work.
Title Bar (Microsoft Windows)

The title bar (at the top of SketchUp) contains the standard Microsoft Windows controls (close, minimize, and maximize) on the right, and the name of the currently opened file. A blank drawing area appears when you start SketchUp and the name of the currently opened file is "Untitled" in the title bar, indicating that you have not yet saved your work.
Measurements Toolbar

By default, the Measurements Toolbar is located on the right side of the status bar. The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate currently selected entities, such as creating elements of a specific dimension. Other behaviors of the Measurements Toolbar are as follows:

- You can type a value in the Measurements Toolbar before or after an operation is complete as long as the value is entered prior to the start of a new operation. Detailed information on the Measurements Toolbar values accepted for each tool appears in the Drawing Tools and Modification Tools sections of this user's guide.

- You must press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key to accept a typed value.

- You can change the value of the geometry as many times as you like before you start a new operation.

- The Measurements Toolbar cannot be used again to enter values for a tool once you have exited the tool.

- SketchUp will display a tilde (~) before the number to indicate that a number is not precise (not within precision settings as set in the Units panel of the Model Info dialog box).

- It is not necessary to click in the Measurements Toolbar before typing. The Measurements Toolbar is always awaiting input from your keyboard.

- You can type values in the Measurements Toolbar using an alternate measuring system than the default system. SketchUp will convert the value to the default system. For example, you can type in 3' 6" even if you are using metric system as your default. Units are set within the Units panel of the Model Info dialog box.
Scene Tabs

Scene tabs are created when a scene is created using the Scene Manager. Click on a scene tab to switch between the scenes in your file.

Note - Scene tabs are not part of the default application user interface. Scene tabs are only displayed when you create a scene using the Scene Manager.

Microsoft Windows

Following is an image of the scene tabs on Microsoft Windows:

![Scene tabs on Microsoft Windows](image)

Mac OS X

Following is an image of the scene tabs on Mac OS X:

![Scene tabs on Mac OS X](image)
Scene Tab Context Menu Items

Scene Tabs contain their own context menus. Context-click on a scene tab to access its context menu.

Move Left/Move Right
The Move Left and Move Right menu items are used to reposition a scene in the series of scenes.

Add
The Add menu item is used to add a new scene to the current file.

Update
The Update menu item is used to update a scene if you have made changes to the scene.

Delete
The Delete menu item is used to delete the currently selected scene.

Play Animation (Microsoft Windows-Only)
The Play Animation menu item starts an animation.

Scene Manager
The Scene Manager menu item invokes the Scene Manager dialog box.
SketchUp Menu (Mac OS X)

The SketchUp menu contains menu items that control the SketchUp application, including items to show and hide SketchUp, application preferences, and the SketchUp license manager.

About SketchUp

The About SketchUp menu item activates the About SketchUp dialog box, containing the SketchUp version number, technical support contact information, and a link to the SketchUp web site.

About Plugins

The About Plugins submenu contains information about each SketchUp plugin, such as the 3DS exporter.

Preferences

The Preferences menu item opens SketchUp's application preferences for setting various global settings for the program.

Mac OS X Keyboard Shortcut: Command+

License

The License menu item displays SketchUp's licensing dialog box used to enter a new license, determine which licenses are currently in use, and view a list of all available licenses. Directions for entering a new license should accompany any new license.

Check for Update

The Check for Update menu item checks to see if you have the most current version of SketchUp. You will be prompted to download the current version if your version is out-of-date. An Internet connection is required to use this feature.

Services

The Services menu item provides access to Mac OS X's system-wide services, which might vary on different computers depending on additional functionality of your other applications.

Hide SketchUp

The Hide SketchUp menu item hides SketchUp and all of its open drawing windows, allowing you access to other programs running in Mac OS X. Clicking on the SketchUp icon in your Dock returns SketchUp to view.

Mac OS X Keyboard Shortcut: Command+H

Hide Others

The Hide Others menu item hides all visible applications except SketchUp allowing you to focus on SketchUp alone. Clicking on any icon in the doc will return that application to view.

Show All

The Show All menu item unhides all running programs in Mac OS X.
Quit SketchUp

The Quit SketchUp menu item quits SketchUp and closes all open documents. You will be prompted to save any unsaved work before SketchUp exits.

**Mac OS X Keyboard Shortcut: Command+Q**

= Functionality only available in Google SketchUp Pro 7
File Menu (Microsoft Windows)

The File menu contains items that relate to SketchUp model files, including commands to create, open, save, print, import, and export model files.

New

The New menu item is used to close the current document and create a blank drawing area to begin a new SketchUp model. You will be prompted to save your changes if you have not saved changes to the current model before selecting the New menu item. SketchUp will use the settings in the template file to define the initial model state if you have selected a template file in the template panel under Window > Preferences.

**Keyboard Shortcut: Ctrl+N**

Open

Use the Open menu item to launch the Open dialog box, allowing you to open a previously saved SketchUp file. You will be prompted to save your changes if an unsaved model is already open because only one file can be open at a time.

**Keyboard Shortcut: Ctrl+O**

Problem Detection

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the open, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.
Save

Use the Save menu item to save the currently active SketchUp model to your file system. When you close an unsaved document, or attempt to quit SketchUp with unsaved open documents, SketchUp will prompt you to save your work before continuing.

Keyboard Shortcut: Ctrl+S

Tip - If Create Backup is enabled within the General panel of the preferences dialog box, the existing file will be converted to a backup file (.skb), and the new drawing will be saved in place of that currently existing file (.skp). The Create Backup option can help preserve your data in the event of an accidental removal of a .skp file. Backup files are saved in the My Documents (Microsoft Windows) or Library/Application Support/Google SketchUp 6/SketchUp/Autosave (Mac OS X) folder, by default.

Tip - It is good to save often. You can have SketchUp automatically save for you at a specific time increment by enabling the Auto-save option within the General panel of the Preferences dialog box.

Problem Detection

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the save, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

Save As

Use the Save As menu item to open the Save As dialog box which defaults to the current document's folder. You can use this dialog box to save the current drawing as a new document. This file can be assigned a new name, a new location, and a previous version of SketchUp. The new file will become the current file in the drawing window.

Problem Detection

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.
SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the save as, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

**Save A Copy As**

Use the Save A Copy As menu item to save a new file based on your current model. This menu item does not overwrite or close the current file and is useful for saving incremental copies or tentative schemes of your work.

**Problem Detection**

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the save copy as, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

**Save As Template**

Use the Save As Template menu item to save the current SketchUp file as a template. This menu item launches a dialog box where you can name the template and set the template as the default template (to be loaded every time you launch SketchUp).

**Revert**

Use the Revert menu item to revert your current document to its last saved state.

**Send to LayOut**

Use the Send to LayOut menu item to send the current model to LayOut.
3D Warehouse
The 3D Warehouse submenu contains menu items for accessing the 3D Warehouse repository of models.

Get Models
Use the Get Models menu item to download a model from the Google 3D Warehouse.

Share Model
Use the Share Model menu item to post your SketchUp model file and corresponding KML file to the Google 3D Warehouse. The Google 3D Warehouse is a repository where models can be shared with other Google Earth or SketchUp users.

Export
Use the Export submenu to access SketchUp's export functionality, which is useful for sharing your work with other people or exporting your drawings for use in other applications. You can export your SketchUp model as a 3D model, a 2D graphic, section slice, or animation.

3D Model
Use the 3D Model menu item to export your SketchUp file to 3D formats, such as KMZ files.

Fix Additional file formats are available for export using Google SketchUp Pro.

2D Graphic
Use the 2D Graphic menu item to export 2D bitmap and dimensionally accurate, resolution independent, 2D vector drawings. Pixel-based images can be exported in JPEG, PNG, Epix, BMP, TGA, and TIFF file formats.

Vector images can be exported in PDF, EPS, DWG, and DXF file formats. This option makes it easy to send your SketchUp files to a plotter, quickly integrate them into construction documentation, or further modify your models using vector-based illustration software. Note that vector output formats may not support certain display options, such as shadows, transparency, and textures.

Section Slice
Use the Export 2D Section Slice menu item to output dimensionally accurate 2D section slices in standard vector formats.

Animation
Use the Animation menu item to export a pre-rendered animation file containing the scene sequence you have created. This option makes it easy to archive your animations to CD or DVD and to create smooth animations of complex models.

Import
Use the Import menu to import information from other files into your SketchUp drawings.

Print Setup
Use the Print Setup menu item to access to the print setup dialog box. This dialog box is used to select and configure printer and scene properties for printing.
Print Preview
Use the Print Preview menu item to preview your model as it will appear on paper (using the print setup settings).

Print
The Print menu item opens the standard Print dialog box. This dialog box enables you to print the current model in SketchUp's drawing area to the currently selected printer.

**Keyboard Shortcut: Ctrl+P**

(Recently Opened File List)
The (Recently Opened File List) menu item lists recently opened SketchUp files. Select a file from this list to open the file.

Exit
The Exit menu item closes the current file and the SketchUp application window. SketchUp will notify you to save your file if it has not been saved since the last change.

= Functionality only available in Google SketchUp Pro 7
File Menu (Mac OS X)

The File menu contains items that relate to SketchUp model files, including commands to create, open, save, print, import, and export model files.

New

The New menu item is used to create a blank drawing area and begin a new SketchUp model. SketchUp will use the settings in the template file to define the initial model state if you have selected a template file in template panel under SketchUp > Preferences.

Tip - Open another instance of SketchUp if you want multiple drawing areas open simultaneously.

Keyboard Shortcut: Command+N

Open

Use the Open menu item to launch the Open dialog box, allowing you to open a previously saved SketchUp file.

Keyboard Shortcut: Command+O

Problem Detection

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the open, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

Open Recent

Use the Open Recent submenu to quickly access recently opened SketchUp files. You can clear the list of recent files by selecting the Clear menu item from the end of the recent files list.

Close

The Close menu item closes the active drawing window. This action is the same as clicking on the close button in your drawing's title bar. You will be prompted to save your changes if the model in the active drawing window has not been saved recently.

Keyboard Shortcut: Command+W
Save

Use the Save menu item to save the currently active SketchUp model to your file system. When you close an unsaved document, or attempt to quit SketchUp with unsaved open documents, SketchUp will prompt you to save your work before continuing.

**Keyboard Shortcut: Command+S**

💡 **Tip** - If Create Backup is enabled within the General panel of the preferences dialog box, the existing file will be converted to a backup file (.skb), and the new drawing will be saved in place of that currently existing file (.skp). The Create Backup option can help preserve your data in the event of an accidental removal of a .skp file.

💡 **Tip** - It is good to save often. You can have SketchUp automatically save for you at a specific time increment by enabling the Auto-save option within the General panel of the Preferences dialog box.

**Problem Detection**

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the save, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

Save As

Use the Save As menu item to open the Save As dialog box which defaults to the current document's folder. You can use this dialog box to save the current drawing as a new document. This file can be assigned a new name, a new location, and a previous version of SketchUp. The new file will become the current file in the drawing window.

**Keyboard Shortcut: Shift+Command+S**

**Problem Detection**

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.
SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the save as, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

Save A Copy As

Use the Save A Copy As menu item to save a new file based on your current model. This menu item does not overwrite or close the current file and is useful for saving incremental copies or tentative schemes of your work.

Problem Detection

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my models, Fix it now, and Fix it later. Google recommends you click on the Always fix my models button in this dialog box to fix the problem. This button also checks the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during the save a copy as, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

Save As Template

Use the Save As Template menu item to save the current SketchUp file as a template. This menu item launches a dialog box where you can name the template and set the template as the default template (to be loaded every time you launch SketchUp).

Revert

Use the Revert menu item to revert your current document to its last saved state.

Send to LayOut

Use the Send to LayOut menu item to send the current model to LayOut.
3D Warehouse

The 3D Warehouse submenu contains menu items for accessing the 3D Warehouse repository of models.

**Get Models**

Use the Get Models menu item to download a model from the Google 3D Warehouse.

**Share Model**

Use the Share Model menu item to post your SketchUp model file and corresponding KML file to the Google 3D Warehouse. The Google 3D Warehouse is a repository where models can be shared with other Google Earth or SketchUp users.

Export

Use the Export submenu to access SketchUp's export functionality, which is useful for sharing your work with other people or exporting your drawings for use in other applications. You can export your SketchUp model as a 3D model, a 2D graphic, a section slice, or an animation.

**3D Model**

Use the 3D Model menu item to export your SketchUp file to 3D formats, such as KMZ files.

*Additional file formats are available for export using Google SketchUp Pro.*

**2D Graphic**

Use the 2D Graphic menu item to export 2D bitmap and dimensionally accurate, resolution independent, 2D vector drawings. Pixel-based images can be exported in JPEG, PNG, Epix, and TIFF file formats.

*Vector images can be exported in PDF, EPS, DWG, and DXF file formats. This option makes it easy to send your SketchUp files to a plotter, quickly integrate them into construction documentation, or further modify your models using vector-based illustration software. Note that vector output formats may not support certain display options, such as shadows, transparency, and textures.*

**Get Pro Exporters**

The Get Pro Exporters menu item launches the Google SketchUp Pro exports web site.

**Animation**

Use the Animation menu item to export a pre-rendered animation file containing the scene sequence you have created. This option makes it easy to archive your animations to CD or DVD and to create smooth animations of complex models.

Import

Use the Import menu to import information from other files into your SketchUp drawings.

Page Setup

Use the Page Setup menu item to access the Mac OS X page setup dialog box. This dialog box is used to select and configure printer and page properties to use for printing. Consult the Mac OS X system help for more information about Page Setup.

*Keyboard Shortcut: Shift+Command+P*
Document Setup
Use the Document Setup menu item to access to the Document Setup dialog box. This dialog box is used to configure the document properties prior to printing.

Print
The Print menu item opens the standard Print dialog box. This dialog box enables you to print the current model in SketchUp's drawing area to the currently selected printer. Consult the Mac OS X system help for more information about printing.

Keyboard Shortcut: Command+P

= Functionality only available in Google SketchUp Pro 7
Edit Menu (Microsoft Windows)

The Edit menu contains items allowing you to perform editing functions on SketchUp geometry. These menu items include those for creating and editing groups and components, visibility operations, and standard cut, copy, paste commands.

Undo

Use the Undo menu item to undo the last drawing or editing commands performed. SketchUp allows you to undo all operations you have performed, one at a time, to the state at which you saved your file. The number of possible sequential Undo commands is limited to 100 steps.

**Keyboard Shortcut:** Alt+Backspace or Ctrl+Z

*Note* - Undo will undo any operation that creates or modifies geometry, but it does not undo changes to your point of view. Use the Previous menu item under the Camera menu to undo a point of view change.

Redo

The Redo menu item returns the last undo to its previous state.

**Keyboard Shortcut:** Ctrl+Y

Cut

The Cut menu item removes the selected elements from your model and places them in the clipboard. The contents of the clipboard can then be inserted back into any open SketchUp document by using the Paste menu item.

Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy command.

**Keyboard Shortcut:** Shift+Delete or Ctrl+X

Copy

The Copy menu item copies the selected items to the clipboard without deleting the items from the model. The contents of the clipboard can then be inserted back into any open SketchUp document by using the Paste menu item.

Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy operation.

**Keyboard Shortcut:** Ctrl+C or Ctrl+Insert

Paste

Use the Paste menu item to paste the contents of the clipboard into the current SketchUp document. The pasted geometry will be attached to and placed by the point of the cursor, allowing you to position the new geometry when it is pasted.

Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy operation.

**Keyboard Shortcut:** Ctrl+V or Shift+Insert
Paste in Place
Use the Paste in Place menu item to paste an item at the same location where it was cut or copied.

Delete
Use the Delete menu item to remove the currently selected entities from your model.

**Keyboard Shortcut: Delete**

Delete Guides
Use the Delete Guides menu item to delete all of the guides that are in the drawing area.

Select All
Use the Select All menu item to select all selectable entities in the model. Hidden entities, any items on a hidden layer, or geometry that is clipped away using a section plane cannot be selected with the Select All menu item.

**Keyboard Shortcut: Ctrl+A**

Select None
The Select None menu item clears the selection set, deselecting any currently selected items in the model.

**Keyboard Shortcut: Ctrl+T**

Hide
Use the Hide menu item to hide any selected object. Hiding geometry can help simplify your current view, or enable viewing and working inside tight areas.

Unhide
The Unhide submenu contains options for unhiding hidden entities.

**Selected**
The Selected menu item unhides any selected hidden object. Ensure Show Hidden Geometry is enabled under the View menu to view and select hidden geometry.

**Last**
The Last menu item unhides the last entities hidden with the Hide command.

**All**
The All menu item unhides all hidden entities in your current document.

Lock
The Lock menu item is used to lock any component or group that you do not want to be able to be moved or edited.
Unlock
The Unlock submenu contains options for unlocking components and groups.

**Selected**
Use the Selected menu item to unlock all components and groups in a selection set.

**All**
Use the All menu item to unlock all components and groups in your drawing area.

Make Component
Use the Make Component menu item to create a component entity from the selected entities.

*Keyboard Shortcut: Ctrl+C*

Make Group
The Make Group menu item creates a Group entity from the selected entities.

*Keyboard Shortcut: G*

Close Group/Component
Use the Close Group/Component menu item to exit from a group or component's context or editing session.

Intersect
The Intersect sub-menu contains menu items for intersecting geometry with other geometry.

**Intersect With Model**
Complex geometry in SketchUp can be easily created using the Intersect With Model menu item (also called the *Intersector*). Use the Intersect with Model menu item to intersect all entities overlapping with the currently selected entity (such as a box component and a tube component).

*Keyboard Shortcut: I*

**Intersect Selected Only**
Select the Intersect Selected Only to intersect only those items that are selected.

**Intersect With Context**
Select the Intersect With Context menu item to intersect two entities within the current context (excluding all entities outside of the context).

Entity Commands Sub-Menu
The Entity Commands sub-menu contains all of the commands available to manipulate the currently selected entity (which are the same as the commands found in the entity's context menu). The sub-menu's name and contents will change depending on the entity that you have selected.
Edit Menu (Mac OS X)

The Edit menu contains items allowing you to perform editing functions on SketchUp geometry. These menu items include those for creating and editing groups and components, visibility operations, and standard cut, copy, paste commands.

Undo

Use the Undo menu item to undo the last drawing or editing commands performed. SketchUp allows you to undo all operations you have performed, one at a time, to the state at which you saved your file. The number of possible sequential Undo commands is limited to 100 steps.

**Keyboard Shortcut: Command+Z**

**Note** - Undo will undo any operation that creates or modifies geometry, but it does not undo changes to your point of view. Use the Previous menu item under the Camera menu to undo a point of view change.

Redo

The Redo menu item returns the last undo to its previous state.

**Keyboard Shortcut: Shift+Command+Z**

Cut

The Cut menu item removes the selected elements from your model and places them in the clipboard. The contents of the clipboard can then be inserted back into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy command.

**Keyboard Shortcut: Command+X**

Copy

The Copy menu item copies the selected items to the clipboard without deleting the items from the model. The contents of the clipboard can then be inserted back into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy operation.

**Keyboard Shortcut: Command+C**

Paste

Use the Paste menu item to paste the contents of the clipboard into the current SketchUp document. The pasted geometry will be attached to and placed by the point of the cursor, allowing you to position the new geometry when it is pasted.
You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with other content using an additional Cut or a Copy operation.

**Keyboard Shortcut: Command+V**

**Paste in Place**
Use the Paste in Place menu item to paste an item at the same location where it was cut or copied.

**Delete**
Use the Delete menu item to remove the currently selected entities from your model.

**Delete Guides**
Use the Delete Guides menu item to delete all of the guides that are in the drawing area.

**Select All**
Use the Select All menu item to select all selectable entities in the model. Hidden entities, any items on a hidden layer, or geometry that is clipped away using a section plane cannot be selected with the Select All menu item.

**Keyboard Shortcut: Command+A**

**Select None**
The Select None menu item clears the selection set, deselecting any currently selected items in the model.

**Keyboard Shortcut: Shift+Command+A**

**Hide**
Use the Hide menu item to hide any selected object. Hiding geometry can help simplify your current view, or enable viewing and working inside tight areas.

**Keyboard Shortcut: Command+E**

**Unhide**
The Unhide submenu contains options for unhiding hidden entities.

**Selected**
The Selected menu item unhides any selected hidden object. Ensure Show Hidden Geometry is enabled under the View menu to view and select hidden geometry.

**Last**
The Last menu item unhides the last entities hidden with the Hide command.

**All**
The All menu item unhides all hidden entities in your current document.

**Keyboard Shortcut: Shift+Command+E**

**Lock**
The Lock menu item is used to lock any component or group that you do not want to be able to be moved or edited.
Unlock
The Unlock submenu contains options for unlocking components and groups.

**Selected**
Use the Selected menu item to unlock all components and groups in a selection set.

**All**
Use the All menu item to unlock all components and groups in your drawing area.

Make Component
Use the Make Component menu item to create a component entity from the selected entities.

*Keyboard Shortcut: Shift+Command+G*

Make Group
The Make Group menu item creates a Group entity from the selected entities.

*Keyboard Shortcut: Command+G*

Close Group/Component
Use the Close Group/Component menu item to exit from a group or component's context or editing session.

*Keyboard Shortcut: Control-Shift+Command+G*

Intersect
The Intersect sub-menu contains menu items for intersecting geometry with other geometry.

**Intersect With Model**
Complex geometry in SketchUp can be easily created using the Intersect With Model menu item (also called the *Intersector*). Use the Intersect with Model menu item to intersect all entities overlapping with the currently selected entity (such as a box component and a tube component).

**Intersect Selected Only**
Select the Intersect Selected Only to intersect only those items that are selected.

**Intersect With Context**
Select the Intersect With Context menu item to intersect two entities within the current context (excluding all entities outside of the context).

Entity Commands Sub-Menu
The Entity Commands sub-menu contains all of the commands available to manipulate the currently selected entity (which are the same as the commands found in the entity's context menu). The sub-menu's name and contents will change depending on the entity that you have selected.

Special Characters (Mac OS X)
The Special Characters menu item opens the Mac OS X Character Palette allowing you to insert special characters, such as mathematical symbols, letters with accent marks, arrows, and other "dingbats," into your model. The Mac OS X help system contains additional help on this feature.
View Menu (Microsoft Windows)

The View menu contains menu items that alter the display of entities within your model.

Note - Items in the View menu alter the display of entities. Items in the Camera menu alter your point of view.

Toolbars
The Toolbars submenu contains all of the Toolbars. These Toolbars are: Getting Started, Large Tool Set, Camera, Guide, Drawing, Face Style, Google, Layers, Measurements, Modification, Principal, Sections, Shadows, Standard, Views, Walkthrough, Dynamic Components, and Sandbox.

The Large Buttons menu item toggles large Toolbar buttons on and off. This option can enhance usability on tablets or low-resolution displays.

Scene Tabs
The Scene Tabs command toggles the display of scene tabs. See the Scene Manager topic for further information.

Hidden Geometry
Use the Hidden Geometry menu item to display hidden geometry or entities that have been hidden using the Hide menu item or context command. The Hidden Geometry menu item displays hidden faces with a light cross-hatch pattern (edges are displayed dashed), enabling you to select the geometry. Once selected, hidden geometry can be made visible with the Unhide and Unhide All menu items.

Section Planes
The Section Planes menu item toggles the display section plane entities.

Section Cuts
The Section Cuts menu item toggles the display of any section cut effects.

Axes
The Axes menu item toggles the display of the drawing axes.

Guides
The Guides menu item toggles the display of Guide line entities and Guide point entities.

Shadows
The Shadows menu item activates shadows.

Fog
The Fog menu item activates fog. Refer to the Fog dialog box for information on configuring fog settings.
Edge Style
The Edge Style submenu contains options to activate edge styles. The edge styles are Profiles, Depth Cue, and Extension. Refer to the Styles topic for further information.

Face Style
The Face Style submenu contains options to activate face styles. The face styles are X-ray, Wireframe, Hidden Line, Shaded, Shaded with Textures, and Monochrome. See the Styles topic for further information.

Component Edit
The Component Edit submenu contains commands to alter the display of other entities when editing components.

Hide Rest of Model
Use the Hide Rest of Model menu item to toggle the display of the model when editing a component.

Hide Similar Components
Use the Hide Similar Components menu item to toggle the display of similar components when editing a component.

Animation
The Animation submenu contains several menu items related to scenes and animations. See the Scenes and Animations topic for further information.

Add Scene
Use the Add Scene menu item to add a new scene to the current file.

Update Scene
Use the Update Scene menu item to update a scene if you have made changes to the scene

Delete Scene
Use the Delete Scene menu item to delete a scene from the current model.

Previous Scene
Use the Previous Scene menu item to transition to the previous scene.

Next Scene
The Next Scene menu item is used to transition to the next scene.

Play
The Play menu item starts an animation. See the Scenes and Animations topic for further information.

Settings
The Settings item invokes the Animation panel of the Model Info dialog box.
View Menu (Mac OS X)

The View menu contains menu items that alter the display of entities within your model.

Note - Items in the View menu alter the display of entities. Items in the Camera menu alter your point of view.

Tool Palettes

The Tool Palettes submenu contains all of the tool palettes. There are three tool palettes: Large Tool Set, Google, and Dynamic Components. The Large Tool Set palette contains all tools needed by advanced SketchUp users. The Google palette has tools for using SketchUp with Google Earth and the Google 3D Warehouse. The Dynamic Components palette has one tool for activating animated dynamic components.

Scene Tabs

The Scene Tabs command toggles the display of scene tabs. See the Scene Manager topic for further information.

Hidden Geometry

Use the Hidden Geometry menu item to display hidden geometry or entities that have been hidden using the Hide menu item or context command. The Hidden Geometry menu item displays hidden faces with a light cross-hatch pattern (edges are displayed dashed), enabling you to select the geometry. Once selected, hidden geometry can be made visible with the Unhide and Unhide All menu items.

Section Planes

The Section Planes menu item toggles the display section plane entities.

Section Cuts

The Section Cuts menu item toggles the display of any section cut effects.

Axes

The Axes menu item toggles the display of the drawing axes.

Guides

The Guides menu item toggles the display of Guide Line entities and Guide Point entities.

Shadows

The Shadows menu item activates shadows.

Fog

The Fog menu item activates fog. Refer to the Fog dialog box for information on configuring fog settings.

Edge Style

The Edge Style submenu contains options to activate edge styles. The edge styles are Profiles, Depth Cue, and Extension. Refer to the Styles topic for further information.
Face Style
The Face Style submenu contains options to activate face styles. The face styles are X-ray, Wireframe, Hidden Line, Shaded, Shaded with Textures, and Monochrome. See the Styles topic for further information.

Component Edit
The Component Edit submenu contains commands to alter the display of other entities when editing components.

Hide Rest of Model
Use the Hide Rest of Model menu item to toggle the display of the model when editing a component.

Hide Similar Components
Use the Hide Similar Components menu item to toggle the display of similar components when editing a component.

Animation
The Animation submenu contains several menu items related to scenes and animations. See the Scenes and Animations topic for further information.

Add Scene
Use the Add Scene menu item to add a new scene to the current file.

Update Scene
Use the Update Scene menu item to update a scene if you have made changes to the scene.

Delete Scene
Use the Delete Scene menu item to delete a scene from the current model.

Previous Scene
Use the Previous Scene menu item to transition to the previous scene.

Next Scene
The Next Scene menu item is used to transition to the next scene.

Play
The Play menu item starts an animation. See the Scenes and Animations topic for further information.

Settings
The Settings item invokes the Animation panel of the Model Info dialog box.

Hide/Show Toolbar
The Hide/Show Toolbar menu item controls the visibility of the Toolbar. You can also modify the visibility of the Toolbar by clicking on the Toolbar collapse/expand button at the top right corner of the title bar.

Customize Toolbar
The Customize Toolbar menu item launches the Customize Toolbar dialog box allowing you to place command buttons on the Toolbar.
Camera Menu (Microsoft Windows)

The Camera menu contains items for altering your point of view of the model.

**Previous**

Use the Previous menu item to back up to the previous saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.

**Next**

Use the Next menu item to advance to the next saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.

**Standard Views**

The Standard Views submenu provides access to standard views: Top, Bottom, Front, Right, Back, Left, and Isometric. Selecting any of these model views will immediately set your active drawing window to that view.

**Parallel Projection**

Select the Parallel Projection menu item to enter a paraline projection.

*Note - SketchUp must be in paraline mode to print to scale. Be aware that faces and edges that are parallel to the view plane will be measurable.*

**Perspective**

Select the Perspective menu item to enter a perspective projection.

**Two-Point Perspective**

A two-point perspective is a common drawing technique in which all verticals lines in the model will appear straight. Use the Two-Point Perspective menu item to achieve a 2-point perspective view of your model. You will be placed in the Pan Tool to pan around your model.

*Caution - Orbiting will move a model out of 2-point perspective.*

**Match New Photo**

Select the Match New Photo menu item to start a match new photo session.

**Edit Matched Photo**

Select the Edit Matched Photo menu item to edit a previously matched photo.

**Orbit**

The Orbit menu item invokes the Orbit Tool.

*Keyboard Shortcut: O*
Pan
The Pan menu item invokes the Pan Tool.

**Keyboard Shortcut: H**

Zoom
The Zoom menu item launches the Zoom Tool.

**Keyboard Shortcut: Z**

Field of View
Use the Field of View menu item to invoke the Zoom Tool in Field of View mode allowing you to widen or narrow your field of view.

Zoom Window
The Zoom Window menu item launches the Zoom Window Tool.

**Note** - The Zoom Window Tool is not in the Google SketchUp Toolbar, but is available to use from the Camera menu.

Zoom Extents
The Zoom Extents menu item launches the Zoom Extents Tool.

**Keyboard Shortcut: Shift+Z**

Zoom to Photo
Select the Zoom to Photo menu item, while using matching, to zoom such that the photo fills the entire drawing area.

Position Camera
The Position Camera menu item launches the Position Camera Tool allowing you to investigate fixed views of your model (such as an eye-level view of a house). This option is often used with the Walk Tool to take an eye-level tour of a structure.

Walk
The Walk menu item invokes the Walk Tool for maneuvering through your SketchUp model as though you taking a virtual tour of the model.

Look Around
The Look Around menu item invokes the Look Around Tool which pivots the camera around a stationary point at the point of view.
Camera Menu (Mac OS X)

The Camera menu contains items for altering your point of view of the model.

Previous
Use the Previous menu item to back up to the previous saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.

Next
Use the Next menu item to advance to the next saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.

Standard Views
The Standard Views submenu provides access to standard views: Top, Bottom, Front, Right, Back, Left, and Isometric. Selecting any of these model views will immediately set your active drawing window to that view.

Parallel Projection
Select the Parallel Projection menu item to enter a paraline projection.

Note - SketchUp must be in paraline mode to print to scale. Be aware that faces and edges that are parallel to the view plane will be measurable.

Perspective
Select the Perspective menu item to enter a perspective projection.

Two-Point Perspective
A two-point perspective is a common drawing technique in which all verticals lines in the model will appear straight. Use the Two-Point Perspective menu item to achieve a 2-point perspective of your model. You will be placed in the Pan Tool to pan around your model.

Caution - Orbiting will move a model out of 2-point perspective.

Match New Photo
Select the Match New Photo menu item to start a match new photo session.

Edit Matched Photo
Select the Edit Matched Photo menu item to edit a previously matched photo.

Orbit
The Orbit menu item invokes the Orbit Tool.

Pan
The Pan menu item invokes the Pan Tool.
Zoom
The Zoom menu item launches the Zoom Tool.

Field of View
Use the Field of View menu item to invoke the Zoom Tool in Field of View mode allowing you to widen or narrow your field of view.

Zoom Window
The Zoom Window menu item launches the Zoom Window Tool.

Note - The Zoom Window Tool is not in the Google SketchUp Toolbar, but is available to use from the Camera menu.

Zoom Extents
The Zoom Extents menu item launches the Zoom Extents Tool.

Zoom to Photo
Select the Zoom to Photo menu item, while using matching, to zoom such that the photo fills the entire drawing area.

Position Camera
The Position Camera menu item launches the Position Camera Tool allowing you to investigate fixed views of your model (such as an eye-level view of a house). This option is often used with the Walk Tool to take an eye-level tour of a structure.

Walk
The Walk menu item invokes the Walk Tool for maneuvering through your SketchUp model as though you taking a virtual tour of the model.

Look Around
The Look Around menu item invokes the Look Around Tool which pivots the camera around a stationary point at the point of view.
Draw Menu (Microsoft Windows)

The Draw menu contains all of the SketchUp drawing tools and provides an alternative to using the Toolbars or keyboard shortcuts.

Line
The Line menu item invokes a Line Tool used to draw Line entities, or edges, within the drawing area.

Keyboard Shortcut: L

Arc
The Arc menu item invokes an Arc Tool used to draw Arc entities, comprised of multiple connected straight line segments (editable as a single curve).

Keyboard Shortcut: A

Freehand
Use the Freehand menu item to invoke a Freehand Tool used to draw irregular, coplanar connected lines in the form of Curve entities.

Rectangle
The Rectangle menu item invokes a Rectangle Tool used to draw four coplanar intersecting edges and a subsequent Face entity.

Keyboard Shortcut: R

Circle
The Circle menu item invokes a Circle Tool used to draw Circle entities.

Keyboard Shortcut: C

Polygon
The Polygon menu item invokes a Polygon Tool used to draw regular Polygon entities, inscribed within a circle, consisting of 3 to 100 sides.
Draw Menu (Mac OS X)

The Draw menu contains all of the SketchUp drawing tools and provides an alternative to using the tool palette or keyboard shortcuts.

Line
The Line menu item invokes a Line Tool used to draw Line entities, or edges, within the drawing area.

**Keyboard Shortcut: Apple+L**

Arc
The Arc menu item invokes an Arc Tool used to draw Arc entities, comprised of multiple connected straight line segments (editable as a single curve).

**Keyboard Shortcut: Apple+J**

Freehand
Use the Freehand menu item to invoke a Freehand Tool used to draw irregular, coplanar connected lines in the form of Curve entities.

**Keyboard Shortcut: Apple+F**

Rectangle
The Rectangle menu item invokes a Rectangle Tool used to draw four coplanar intersecting edges and a subsequent Face entity.

**Keyboard Shortcut: Apple+K**

Circle
The Circle menu item invokes a Circle Tool used to draw Circle entities.

Polygon
The Polygon menu item invokes a Polygon Tool used to draw regular Polygon entities, inscribed within a circle, consisting of 3 to 100 sides.

**Keyboard Shortcut: Apple+;**
Tools Menu (Microsoft Windows)

The Tools menu provides access to all of the modification tools in SketchUp. This menu represents one of three mechanisms for accessing these tools (additional mechanisms are the Toolbars and keyboard shortcuts).

Select
The Select menu item invokes a Select Tool allowing you to select one or more entities to modify.
Keyboard Shortcut: Spacebar

Eraser
Use the Eraser menu item to invoke the Eraser Tool allowing you to erase entities from the drawing area. This tool also allows you to hide and soften edges.
Keyboard Shortcut: E

Paint Bucket
The Paint Bucket menu item invokes the Paint Bucket Tool used to assign materials to entities in your model. Use the Paint Bucket Tool to paint individual elements, fill a number of connected faces, or replace a material in your model.
Keyboard Shortcut: B

Move
The Move menu item invokes the Move Tool allowing you to move, manipulate, and copy geometry. This tool can also be used to rotate Component entities.
Keyboard Shortcut: M

Rotate
Use the Rotate menu item to invoke the Rotate Tool used to rotate drawing elements and single or multiple objects within a single rotation plane. The Rotate Tool can also be used to stretch and distort geometry by selecting only a portion of a model.
Keyboard Shortcut: Q

Scale
The Scale menu item invokes the Scale Tool allowing you to resize and stretch selected geometry relative to other elements in your SketchUp model.
Keyboard Shortcut: S

Push/Pull
The Push/Pull menu item invokes the Push/Pull Tool used to manipulate faces of your model. This tool can be used to displace, extrude, re-attach, or subtract faces, depending on the context of selected geometry.
Keyboard Shortcut: P
Follow Me
Use the Follow Me menu item to invoke the Follow Me Tool used to extrude faces along a path such as an edge or line drawn with the Freehand Tool. This tool is useful when adding details to a model because it allows you to draw the detail at one end of a path on the model and then repeat that detail along the path.

Offset
The Offset menu item invokes the Offset Tool used to create copies of co-planar lines and faces that are a uniform distance from original lines and faces. Lines and faces can be offset either inside or outside the original face. Offsetting a face will always create a new face.

**Keyboard Shortcut: F**

Tape Measure
Use the Tape Measure menu item to invoke the Tape Measure Tool used to perform a number of dimension-related operations. These operations include measuring the distance between two points, creating Guide Line entities, and re-scaling an entire model to an exact dimension.

**Keyboard Shortcut: T**

Protractor
The Protractor menu item invokes the Protractor Tool allowing you to measure angles and create Guide Line entities (usually at some angle).

Axes
The Axes menu item invokes the Axes Tool allowing you to move the drawing axes. This tool is often used when constructing rectangular objects that are skewed relative to one another, or to allow for more accurate scaling of entities that are not oriented along the default coordinate planes.

Dimensions
Use the Dimensions menu item to invoke a Dimension Tool used to place Dimension entities in your model.

Text
The Text menu item launches a Text Tool used to insert Text entities into your model.

3D Text
The 3D Text menu item launches a 3D Text Tool used to create modeled 3 dimensional text.

Section Plane
The Section Plane menu item invokes a Section plane Tool used to make section cuts in your model.
Google Earth
The Google Earth submenu contains menu items for interacting with Google Earth.

Get Current View
Use the Get Current View menu item to capture 2D and 3D snapshot images of the current view in Google Earth.

Toggle Terrain
Use the Toggle Terrain menu item to toggle the Google Earth snapshot image between a 2D and 3D image.

Place Model
Use the Place Model menu item to place your SketchUp models in Google Earth.

Utilities
The Utilities submenu contains various utilities and macros created using the SketchUp Ruby API. This menu item only appears after enabling the utilities tools using the Extensions panel of the Preferences dialog box.

Note - Ruby scripts are contained in the Plugins directory under the installation directory.

Create Face
The Create Face menu item invokes the Create Face utility allowing you to troubleshoot face creation and, in most cases, create a face for three or more intersecting edges. Specifically, the Create Face utility is useful when:

- A model has two edges that have a common end point geometrically (the coordinates of the end point are the same), but the edges are not connected topologically. In this case, the Create Face utility will properly connect edges and create a face.
- A face cannot be created because edges are not exactly planer, or appear to be connected when there is actually a small gap between the ends of the edges. In these instances, Create Face will not create a face, but displays a message indicating why SketchUp cannot create a face. This message can be used to troubleshoot face creation.

Query Tool
The Query Tool menu item invokes a Query Tool utility that displays the current mouse position in the Measurements Toolbar.

Dynamic Components
The Dynamic Components submenu contains menu items for configuring and creating dynamic components. This menu item only appears after enabling Dynamic Components using the Extensions panel of the Preferences dialog box.

Component Options
Use the Component Options menu item to display the Component Options dialog box used to configure a dynamic component.

Interact Tool
Use the Interact Tool menu item to interact with a dynamic component that has click regions, such as a door that, when clicked, animates.
Generate Report
Use the Generate Report menu item to display the Generate Report dialog box used to generate various dynamic components reports.

Component Attributes
Use the Component Attributes menu item to display the Component Attributes dialog box used to develop a dynamic component.

Sandbox
The Sandbox submenu contains options for modifying terrain. This menu item only appears after enabling the terrain modeling tools using the Extensions panel of the Preferences dialog box. See the Sandbox Tools topic for further information.
Tools Menu (Mac OS X)

The Tools menu provides access to all of the modification tools in SketchUp. This menu represents one of three mechanisms for accessing these tools (additional mechanisms are the tool palette and keyboard shortcuts).

Select
The Select menu item invokes a Select Tool allowing you to select one or more entities to modify.

*Keyboard Shortcut: Spacebar*

Eraser
Use the Eraser menu item to invoke the Eraser Tool allowing you to erase entities from the drawing area. This tool also allows you to hide and soften edges.

*Keyboard Shortcut: E*

Paint Bucket
The Paint Bucket menu item invokes the Paint Bucket Tool used to assign materials to entities in your model. Use the Paint Bucket Tool to paint individual elements, fill a number of connected faces, or replace a material in your model.

*Note - The Paint Bucket Tool is different than the Apple Color Picker used to select colors and materials.*

*Keyboard Shortcut: B*

Move
The Move menu item invokes the Move Tool allowing you to move, manipulate, and copy geometry. This tool can also be used to rotate Component entities.

*Keyboard Shortcut: M*

Rotate
Use the Rotate menu item to invoke the Rotate Tool used to rotate drawing elements and single or multiple objects within a single rotation plane. The Rotate Tool can also be used to stretch and distort geometry by selecting only a portion of a model.

*Keyboard Shortcut: Q*

Scale
The Scale menu item invokes the Scale Tool allowing you to resize and stretch selected geometry relative to other elements in your SketchUp model.

*Keyboard Shortcut: S*
Push/Pull
The Push/Pull menu item invokes the Push/Pull Tool used to manipulate faces of your model. This tool can be used to displace, extrude, re-attach, or subtract faces, depending on the context of selected geometry.

**Keyboard Shortcut: P**

Follow Me
Use the Follow Me menu item to invoke the Follow Me Tool used to extrude faces along a path such as an edge or line drawn with the Freerhand Tool. This tool is useful when adding details to a model because it allows you to draw the detail at one end of a path on the model and then repeat that detail along the path.

Offset
The Offset menu item invokes the Offset Tool used to create copies of co-planar lines and faces that are a uniform distance from original lines and faces. Lines and faces can be offset either inside or outside the original face. Offsetting a face will always create a new face.

**Keyboard Shortcut: F**

Tape Measure
Use the Tape Measure menu item to invoke the Tape Measure Tool used to perform a number of dimension-related operations. These operations include measuring the distance between two points, creating Guide Line entities, and re-scaling an entire model to an exact dimension.

**Keyboard Shortcut: T**

Protractor
The Protractor menu item invokes the Protractor Tool allowing you to measure angles and create Guide Line entities (usually at some angle).

Axes
The Axes menu item invokes the Axes Tool allowing you to move the drawing axes. This tool is often used when constructing rectangular objects that are skewed relative to one another, or to allow for more accurate scaling of entities that are not oriented along the default coordinate planes.

Dimensions
Use the Dimensions menu item to invoke a Dimension Tool used to place Dimension entities in your model.

Text
The Text menu item launches a Text Tool used to insert Text entities into your model.

3D Text
The 3D Text menu item launches a 3D Text Tool used to create modeled 3 dimensional text.
Section Plane
The Section Plane menu item invokes a Section plane Tool used to make section cuts in your model.

Google Earth
The Google Earth submenu contains menu items for interacting with Google Earth.

Get Current View
Use the Get Current View menu item to capture 2D and 3D snapshot images of the current view in Google Earth.

Toggle Terrain
Use the Toggle Terrain menu item to toggle the Google Earth snapshot image between a 2D and 3D image.

Place Model
Use the Place Model menu item to place your SketchUp models in Google Earth.

Dynamic Components
The Dynamic Components submenu contains menu items for configuring and creating dynamic components. This menu item only appears after enabling Dynamic Components using the Extensions panel of the Preferences dialog box.

Component Options
Use the Component Options menu item to display the Component Options dialog box used to configure a dynamic component.

Interact Tool
Use the Interact Tool menu item to interact with a dynamic component that has click regions, such as a door that, when clicked, animates.

Generate Report
Use the Generate Report menu item to display the Generate Report dialog box used to generate various dynamic components reports.

Component Attributes
Use the Component Attributes menu item to display the Component Attributes dialog box used to develop a dynamic component.

Utilities
The Utilities submenu contains various utilities and macros created using the SketchUp Ruby API. This menu item only appears after enabling the utilities tools using the Extensions panel of the Preferences dialog box.

Note - Ruby scripts are contained in the Plugins directory under the installation directory.

Create Face
The Create Face menu item invokes the Create Face utility allowing you to troubleshoot face creation and, in most cases, create a face for three or more intersecting edges. Specifically, the Create Face utility is useful when:
• A model has two edges that have a common end point geometrically (the coordinates of the end point are the same), but the edges are not connected topologically. In this case, the Create Face utility will properly connect edges and create a face.

• A face cannot be created because edges are not exactly planer, or appear to be connected when there is actually a small gap between the ends of the edges. In these instances, Create Face will not create a face, but displays a message indicating why SketchUp cannot create a face. This message can be used to troubleshoot face creation.

**Query Tool**
The Query Tool menu item invokes a Query Tool utility that displays the current mouse position in the Measurements Toolbar.

**Sandbox**
The Sandbox submenu contains options for modifying terrain. This menu item only appears after enabling the terrain modeling tools using the Extensions panel of the Preferences dialog box. See the Sandbox Tools topic for further information.
Window Menu (Microsoft Windows)

The Window menu contains model settings and managers for your models. Model settings are dialog boxes with settings that affect the model, such as shadows, display settings, and model information. Managers are dialog boxes that manage certain aspects of your model such as scenes, layers, materials, and components.

Model Info
Use the Model Info menu item to display the Model Info dialog box used to set settings for your entire model.

Entity Info
The Entity Info menu item displays the Entity Info dialog box used to view and set settings for the currently selected entity (or entities).

Materials
The Materials menu item invokes Material Browser and Editor used for managing your materials.

Components
The Components menu item displays Components Browser used for managing your components.

Styles
The Styles menu item invokes the Styles dialog box containing options related to styles, such as edge and face rendering styles.

Layers
Use the Layers menu item to display the Layers Manager used to manage your SketchUp layers.

Outliner
The Outliner menu item invokes the Component Outliner used to display components and groups in a hierarchy.

Scenes
The Scenes menu item invokes the Scene Manager used to manage scenes for an animation. The Scene Manager will display with the current scene highlighted.

Shadows
The Shadows menu item invokes Shadow Settings dialog box for manipulating shadows in your model.

Fog
The Fog menu item invokes the Fog dialog box used to add a fog effect to your model.
Match Photo
The Match Photo menu item invokes the Match Photo dialog box used to help you create accurate 3D models from photos and to accurately place models in a photo’s context.

Soften Edges
The Soften Edges menu item invokes the Soften Edges dialog box used to soften and smooth edges in your model.

Instructor
The Instructor menu item invokes the Instructor used to display information about the currently activated tool.

Preferences
The Preferences menu item invokes the Application Preferences dialog box where you can set various global settings for the program.

Welcome
The Welcome menu item invokes the Welcome to SketchUp dialog box.

Hide/Show Dialogs
Use the Hide/Show Dialog menu item to hide and show all currently active dialog boxes.

Ruby Console
The Ruby Console menu item displays the Ruby Console where you can type Ruby script.

Component Options
The Component Options menu item is used to display the Component Options dialog box used to configure a dynamic component.

Component Attributes
The Component Attributes menu item is used to display the Component Attributes dialog box used to develop a dynamic component.
Window Menu (Mac OS X)

The Window menu contains model settings and managers for your models. Model settings are dialog boxes with settings that affect the model, such as shadows, display settings, and model information. Managers are dialog boxes that manage certain aspects of your model such as scenes, layers, materials, and components.

Minimize

The Minimize menu item minimizes the current document window and places it in the dock. Click on the minimized view in the doc to re-activate a minimized window.

**Keyboard Shortcut: Command+M**

Zoom

The Zoom menu item toggles between shrinking and expanding the main document window. This item works similarly to clicking the plus icon at the top of the document window.

Model Info

Use the Model Info menu item to display the Model Info dialog box used to set settings for your entire model.

**Keyboard Shortcut: Shift+Command+I**

Entity Info

The Entity Info menu item displays the Entity Info dialog box used to view and set settings for the currently selected entity (or entities).

**Keyboard Shortcut: Command+I**

Materials

The Materials menu item invokes the Color Picker used for selecting and applying colors and materials to your models.

**Keyboard Shortcut: Shift+Command+C**

Components

The Components menu item displays the Component Browser used for managing your components.

Styles

The Styles menu item invokes the Styles dialog box containing options related to styles, such as edge and face rendering styles.

Layers

Use the Layers menu item to display the Layers Manager used to manage your SketchUp layers.

Outliner

The Outliner menu item invokes the Component Outliner used to display components and groups in a hierarchy.
Scenes
The Scenes menu item invokes the Scene Manager used to manage scenes for an animation. The Scene Manager will display with the current scene highlighted.

Show Fonts
The Show Fonts sub-menu includes options for toggling the display of the Fonts Panel allowing you to choose a font face and type. The Font Panel also allows you to select bold and italic versions of your fonts.

*Keyboard Shortcut: Command+T*

Shadows
The Shadows menu item invokes Shadow Settings dialog box for manipulating shadows in your model.

Fog
The Fog menu item invokes the Fog dialog box used to add a fog effect to your model.

Match Photo
The Match Photo menu item invokes the Match Photo dialog box used to help you create accurate 3D models from photos and to accurately place models in a photo’s context.

Soften Edges
The Soften Edges menu item invokes the Soften Edges dialog box used to soften and smooth edges in your model.

Instructor
The Instructor menu item invokes the Instructor used to display information about the currently activated tool.

Hide/Show Dialogs
Use the Hide/Show Dialogs menu item to hide and show all currently active dialog boxes.

Ruby Console
The Ruby Console menu item displays the Ruby Console where you can type Ruby script.

Component Options
The Component Options menu item is used to display the Component Options dialog box used to configure a dynamic component.

*Component Attributes*
The Component Attributes menu item is used to display the Component Attributes dialog box used to develop a dynamic component.

Bring All To Front
Use the Bring All To Front menu item to bring all of your open SketchUp windows to the foreground of Mac OS X. All open document windows and active panels and palettes are brought to front.
Arrange in Front

Use the Arrange in Front menu item to bring all of your open SketchUp windows to the foreground of Mac OS X and arrange them from the center outward toward the edge of the screen.

(Open Documents)

The (Open Documents) menu items represent a dynamically generated list of all your open SketchUp files. Select the file you want to activate from this menu to switch between files.
Help Menu (Microsoft Windows)

The Help menu contains items relating to receiving help with the product. These items include the SketchUp on-line user's guide, a quick reference card, and video tutorials.

Welcome to SketchUp

The Welcome to SketchUp menu item launches the Welcome to SketchUp dialog box.

Help Center

The Online Help Center menu item launches the Google SketchUp Help Center in your default web browser. This web site contains a list of Frequently Asked Questions (FAQs) and a knowledge base of technical support issues and solutions.

Contact Us

Select the Contact Us menu to contact Google SketchUp technical support.

License

The License submenu includes several options allowing you to view and manage your SketchUp license.

License Info

The License Info menu item displays information about your SketchUp license, including the type of license and serial number.

Authorize

Use the Authorize menu item to authorize your SketchUp licence to extend the use of SketchUp beyond the 8 hour trial period. Click on this menu item to display the SketchUp Authorization Screen. Type in the authorization number, provided by Google when you buy SketchUp, to authorize SketchUp.

Unauthorize

Use the UnAuthorize menu item to unauthorize your SketchUp licence. This menu item is used primarily when switching from a single-user license to a multiuser network license.

Caution - SketchUp will not run after you unauthorize your license. You must authorize a new single-user or network license to use SketchUp again.

Set Network License File

Use the Set Network License File menu item to relocate the network license file on the network.

Unset Network License File

Use the Unset Network License File menu item to delete the location of the network license file on the network.

Lan License Monitor

The Lan License Monitor menu item displays the LAN License Monitor dialog box. This dialog box displays single user licenses on the network.
Check for Update...

The Check For Update menu item checks to see if you have the most current version of SketchUp. You will be prompted to download the current version if your version is out-of-date. An Internet connection is required to use this feature.

About SketchUp...

The About Google SketchUp menu item activates the About Google SketchUp dialog box. This dialog box provides information about your SketchUp version and license.
Help Menu (Mac OS X)

The Help menu contains items relating to receiving help with the product. These items include the SketchUp on-line user's guide, a quick reference card, and video tutorials.

Welcome to SketchUp

The Welcome to SketchUp menu item launches the Welcome to SketchUp dialog box.

Online Help Center

The Online Help Center menu item launches the Google SketchUp Help Center in your default web browser. This web site contains a list of Frequently Asked Questions (FAQs) and a knowledge base of technical support issues and solutions.

Contact Us

Select the Contact Us menu to contact Google SketchUp technical support.
Toolbars (Microsoft Windows)

The Toolbars appear below the menus and along the left side of the application contain a user-defined set of tools and controls. Toolbar visibility is toggled under the View > Toolbars menu item.

Note - Only the Getting Started and Google Toolbars appear when you first run SketchUp. You can turn on other Toolbars using the Toolbars submenu in the View menu.

Getting Started

The Getting Started Toolbar contains all of the tools and menu items necessary for a new user to become acquainted with SketchUp. These tools and menu items are: Select Tool, Line Tool, Rectangle Tool, Circle Tool, Arc Tool, Make Component, Eraser Tool, Tape Measure Tool, Paint Bucket Tool, Push/Pull Tool, Move Tool, Rotate Tool, Offset Tool, Orbit Tool, Pan Tool, Zoom Tool, Zoom Extents Tool, Get Current View button, Toggle Terrain button, Place Model button, Get Models button, and Share Models button.

Large Tool Set

The Large Tool Set contains the most-used tools and menu items for experienced users. These tools and menu items are:


Camera Tool Bar

The buttons on the Camera Toolbar activate the Orbit Tool, Pan Tool, Zoom Tool, Zoom Window Tool, Previous, Next, and Zoom Extents Tool camera tools.

Guide Toolbar

The buttons on the Guide Toolbar activate the Tape Measure Tool, Dimensions Tool, Protractor Tool, Text Tool, Axes Tool, and 3D Text Tool.
**Drawing Toolbar**

The buttons on the Drawing Toolbar activate the Rectangle Tool, Line Tool, Circle Tool, Arc Tool, Polygon Tool, and Freehand Tool.

![Drawing Toolbar](image)

**Face Style Toolbar**

The buttons on the FaceStyle Toolbar activate SketchUp's face rendering styles (x-ray transparency, wireframe, hidden line, shaded, shaded with textures, and monochrome).

![Face Style Toolbar](image)

**Google Toolbar**

The buttons on the Google Toolbar are used to collaborate between SketchUp and other Google products. The Toolbar contains the Get Current View, Toggle Terrain, Place Model, Get Models, and Share Model buttons.

![Google Toolbar](image)

**Layers Toolbar**

The Layers Toolbar provides quick access to several often used layer operations.

![Layers Toolbar](image)

**Measurements Toolbar**

The Measurements Toolbar contains a field where you can type values corresponding to the currently activated tool. For example, you can type in the specific length of a line while you are in the Line Tool. The Measurement Toolbar is used to create accurate geometry.

![Measurements Toolbar](image)

**Modification Toolbar**

The Modification Toolbar contains geometry modification tools. The tools on this Toolbar are the Move Tool, Push/Pull Tool, Rotate Tool, Follow Me Tool, Scale Tool, and Offset Tool.

![Modification Toolbar](image)

**Principal Toolbar**

The buttons on the Principal Toolbar activate the Select Tool, Make Component, Paint Bucket Tool, and Eraser Tool.

![Principal Toolbar](image)
Sections Toolbar
The Sections Toolbar allows you to conveniently execute common section operations. The controls on this Toolbar include buttons for toggling the section cut effect and toggling the display of section planes.

Shadows Toolbar
The Shadows Toolbar is used to control shadows. This Toolbar contains buttons to launch the Shadow Settings dialog box (left-most icon) and enable/disable shadows (second icon). This Toolbar also contains slider bars to control settings related to the time of year (left-most slider bar) and time of day (right-most slider bar).

Standard Toolbar
The Standard Toolbar contains a variety of menu items which help with file and drawing management and shortcuts to printing and help operations. These menu items are New, Open, Save, Cut, Copy, Paste, Erase, Undo, Redo, Print, and Model Info.

Walkthrough Toolbar
The buttons on the Walkthrough Toolbar activate the Position Camera Tool, Walk Tool, and Look Around Tool.

Views Toolbar
The buttons on the Views Toolbar activate SketchUp's standard views (iso, top, front, right, back, and left). The bottom view is not included, but is available from the Camera menu.

Dynamic Components Toolbar
The buttons on the Dynamic Components toolbar activate the Interaction tool, Component Options dialog box, and Component Attributes dialog box (PRO).

Sandbox Toolbar
The buttons on the Sandbox Toolbar activate SketchUp's Sandbox Tools (Sandbox From Contours, Sandbox From Scratch, Smoove Tool, Stamp Tool, Drape Tool, Add Detail Tool, and Flip Edge Tool).
Large Buttons

The Toolbar can be displayed using large and small tool buttons. Check the Use Large Tool Buttons checkbox in the General panel of the Preferences dialog box to switch between large and small tool buttons.
Large Tool Palette (Mac OS X)

SketchUp contains a large tool palette containing all of the tools in the program. Display the large tool palette by clicking on the View > Tool Palettes > Large Tool Set menu item. The tools in the large tool palette are split into seven categories: Principal Tools, Drawing Tools, Modification Tools, Guide Tools, Camera Tools, and Walkthrough Tools.

Principal Tools
The buttons on the principal tools section of the tool palette activate the Select Tool, Make Component, Paint Bucket Tool, and Eraser Tool.

Drawing Tools
The buttons on the drawing tools section of the tool palette activate the Rectangle Tool, Line Tool, Circle Tool, Arc Tool, Polygon Tool, and Freehand Tool.

Modification Tools
The modification tools section of the tool palette contains geometry modification tools. The tools on this Toolbar are the Move Tool, Push/Pull Tool, Rotate Tool, Follow Me Tool, Scale Tool, and Offset Tool.

Guide Tools
The buttons on the construction tools section of the tool palette activate the Tape Measure Tool, Dimensions Tool, Protractor Tool, Text Tool, Axes Tool, and 3D Text Tool.

Camera Tools
The buttons on the camera tools section of the tool palette activate the Orbit Tool, Pan Tool, Zoom Tool, Zoom Window Tool, Previous, Next, and the Zoom Extents Tool.

Walkthrough Tools
The buttons on the walkthrough tools section of the tool palette activate the Position Camera Tool, Walk Tool, and Look Around Tool.
Google Tool Palette (Mac OS X)

SketchUp contains a Google tool palette containing all of the options to interact with other Google applications. Display the Google tool palette by clicking on the View > Tool Palettes > Google menu item.

The buttons on the Google Toolbar are used to collaborate between SketchUp and other Google products. The Toolbar contains the Get Current View, Toggle Terrain, Place Model, Get Models, and Share Model buttons.
Sandbox Tool Palette (Mac OS X)

The buttons on the Sandbox Toolbar activate SketchUp's Sandbox Tools (Sandbox From Contours, Sandbox From Scratch, Smoove Tool, Stamp Tool, Drape Tool, Add Detail Tool, Flip Edge Tool.)
Dynamic Components Tool Palette (Mac OS X)

The buttons on the Dynamic Components toolbar activate the Interaction tool, Component Options dialog box, and Component Attributes dialog box (PRO).
Toolbar Context Menu (Mac OS X)

The Toolbar context menu is activated by context-clicking on the Toolbar. This menu contains options for manipulating the appearance of your Toolbar.

Icon & Text
The Icon & Text option allow you to display both icons and names of controls in the Toolbar. The Toolbar shows both controls and their labels as a default.

Icon Only
The Icon Only option allows you to only display icons for controls in the Toolbar.

Text Only
The Text Only option allows you to only display the names of controls in the Toolbar.

Use Small Size
The Use Small Size option provides additional space in the Toolbar by shrinking the size of individual icons. This option does not change the size of textual names or icon groups, such as the Display Style group of controls.

Remove Item
The Remove Item option removes the control that you have selected.

Keep Item Visible
The Keep Item Visible option keeps the toolbar item always visible when the window is resized.

Customize Toolbar...
The Customize Toolbar... menu item displays the Customize Toolbar dialog box containing all of the controls that can be placed in the Toolbar.
Toolbar Control Types (Mac OS X)

SketchUp contains a variety of controls you can place into your Toolbar for easy access. The following section covers each of these controls.

Note - Many of the controls on the Customize Toolbar dialog box are tools listed in the Large Tool Palette section of the documentation.

Standard Views
The Standard Views control gives you quick access to SketchUp's Standard Views (not including a bottom view).

Face Style
The Face Style control allows you to quickly switch between SketchUp's Face Rendering Styles. You can also use the View menu or the Styles dialog box to switch between these styles.

Undo/Redo
The Undo command will undo the last drawing or editing command performed. The Redo Command cancels Undo operations, stepping forward in the modification history.

Shadows (sliders)
The Shadows sliders give you quick access to the most frequently used shadow settings. You can turn shadow casting on and off with the checkbox, and adjust date and time with the sliders.

You can also use the Shadow Settings dialog box to access more detailed shadow settings.

Shadows (icon)
The Shadows icon control toggles shadows on and off.

Layers
The Layers Toolbar provides quick access to several often used layer operations.

Display the Current Layer: The Layers Toolbar displays the current layer name. Any new entities you draw will be assigned to the current layer.

Add a Layer: Click in the text field of the drop-down list and type a new layer name to add a new layer to the model.
Slideshow
The Slideshow control is used to start and stop slide shows.

Model Info
The Model Info control is used to display the Model Info dialog box.

Section Display
The Section Display control toggles the display of Section Planes.

Section Cuts
The Section Cuts control toggles the display of the Section Cut Effect.

X-Ray Mode
The X-Ray Mode control toggles the X-Ray display mode.

Component Maker
The Component Maker creates a Component entity from the selected geometry. You will be prompted to set a few characteristics for the Component entity upon clicking this Toolbar control.

Separator
The Separator is used to add a vertical line to separate controls in your Toolbar.

Space
The Space is used to add a space between controls.

Flexible Space
The Flexible Space is used to add an adjustable space between controls. A Flexible Space automatically adjusts spacing between Toolbar controls depending on the number and size of controls in the Toolbar.
Print
The Print control activates the Print dialog box, enabling you to print the current view of your model.

Colors
The Colors control launches the Color Picker.

Fonts
The Fonts control launches the Font dialog box.

Customize
The Customize control invokes the Customize Toolbar dialog box.

Measurements
The Measurements control contains a field where you can type values corresponding to the currently activated tool. For example, you can type in the specific length of a line while you are in the Line Tool. The Measurement Toolbar is used to create accurate geometry.
**Drawing Axes**

SketchUp's drawing axes consist of three colored lines (red, green, blue), perpendicular to each other, displayed in the drawing area. These axes are helpful in providing a sense of direction in 3D space while you work.

The plane where the red and green axes lines lie is called the ground *plane*. The term origin, is used to define the place where all of axes lines start or originate.

*Note* - The Drawing Axes will be automatically hidden in any images exposed from SketchUp.
The Drawing Axes Context Menu

All of the context menu items for the drawing axes context menu follow.

Place
Use the Place menu item to move the drawing axes.

Move
Select the Move menu item to move and rotate the drawing axes relative to their current position.

Reset

Align View
Select the Align View menu item to align SketchUp's point of view with the current view.

Hide
Select the Hide menu item to hide the drawing axes.
Inference

SketchUp features a geometric analysis engine, called the inference engine, allowing you to work in 3D space using a 2D screen and input device. This engine helps you draw very accurately by inferring points from other points as you draw while also providing you with visual cues.

Inference Cues

The inference engine uses visual cues, appearing automatically while working on the model, to identify significant points or geometric conditions. These cues make complex inference combinations clear to you as you draw.

Additionally, the inference engine uses specific colors to indicate its type of inference (covered further in Inference Types).
Inference Types

There are three main types of inferences: point, linear, and planar. SketchUp often combines inferences together to form a complex inference.

Point Inference

A point inference is based on the exact point of your cursor in your model. Following is a list of point inference types.

**Endpoint**

The Endpoint inference indicates the end of a Line or Arc entity. The Endpoint inference is represented by a green circle. Following is an image of an Endpoint inference:

![Endpoint](image)

**Midpoint**

The Midpoint inference indicates the middle point on a line or edge. The Midpoint inference is represented by a cyan circle. Following is an image of a Midpoint inference:

![Midpoint](image)

**Intersection**

The Intersection inference indicates an exact point where a line intersects another line or face. The Intersection inference is represented by a red x. Following is an image of an Intersection inference:

![Intersection](image)

**On Face**

The On Face inference indicates a point which lies on a Face entity. The On Face inference is represented by a blue diamond.

![On Face](image)
On Edge
The On Edge inference indicates a point that lies along an edge. The On Edge inference is represented by a red square. Following is an image of an On Edge inference.

Linear Inference
A linear inference snaps along a line or direction in space. In addition to a tooltip, a linear inference sometimes displays a temporary dotted line while you draw.

On Red Axis
The On Red Axis inference indicates a linear alignment to the red drawing axis. The On Red Axis inference is represented by a red line. Following is an image of an On Red Axis inference:

On Green Axis
The On Green Axis inference indicates a linear alignment to green drawing axis. The On Green Axis inference is represented by a green line. Following is an image of an On Green Axis inference:

On Blue Axis
The On Blue Axis inference indicates a linear alignment to the blue drawing axis. The On Blue Axis inference is represented by a blue line. Following is an image of an On Blue Axis inference:
**From Point**
The From Point inference indicates a linear alignment from a point along the drawing axes directions. The From Point inference is represented by a dotted line whose color corresponds to the axis direction (red, green, or blue). Following is an image of an From Point inference:

![From Point Image](image1)

**Perpendicular**
The Perpendicular inference indicates perpendicular alignment to an edge. The Perpendicular inference is represented by a magenta line. Following is an image of an Perpendicular inference:

![Perpendicular Image](image2)

**Parallel**
The Parallel inference indicates a parallel alignment to an edge. The Parallel inference is represented by a magenta line. Following is an image of an Parallel inference:

![Parallel Image](image3)

**Tangent at Vertex**
The Tangent at Vertex inference indicates an arc whose vertex is tangent to a previously drawn arc’s vertex. The Tangent at Vertex inference is represented by a cyan arc. Following is an image of a Tangent at Vertex inference (the right arc’s vertex is tangent the left arc’s vertex):

![Tangent at Vertex Image](image4)
Shape Inferences

SketchUp indicates half circles, squares, and golden sections, using unique inference indicators. These indicators follow.

**Half Circle**
The Half Circle inference indicates an arc that is exactly one half of a circle. Following is an image of a Half Circle inference:

![Half Circle Inference](image1)

**Square**
The Square inference indicates a rectangle whose sides are all the same size. Following is an image of a Square inference:

![Square Inference](image2)

**Golden Section**
The Golden Section inference indicates a rectangle whose properties match the Golden Ratio as found in mathematics and the arts. Following is an image of a Golden Section inference:

![Golden Section Inference](image3)

**Drawing Plane Inference**
SketchUp will snap to the planes defined by the Drawing Axes or your view when it cannot snap to geometry in the drawing area. For example, SketchUp will draw on the ground plane when the point of view is that of the ground plane.

**Component and Group Inferences**
All inferences apply on geometry inside Component entities or Group entities. Group and Component inference indicators are the same shape, but are magenta color. Group and component tooltips also indicate that the inference is in a Group or Component entity by appending the phrase "in group" or "in component" to the end of an inference tooltip.
Dialog Boxes

Most dialog boxes in SketchUp are *modeless*, meaning they do not limit your interaction with the rest of the application by requiring user input before continuing with your work. Instead, these dialog boxes can be displayed while you work allowing you to make dynamic settings changes to your model while you are sketching. Dialog boxes in SketchUp can be snapped to other user interface components on your screen, resized, and minimized (with some exceptions).
Context Menu Items for Entities

All of the context menu items for all entities in SketchUp follow.

Active Cut

The Active Cut menu item is used to activate and de-activate the Section Plane Object, as indicated by the check mark. Activating a Section Plane will automatically de-activate all other planes in that context.

This menu item is available for the Section Plane entity.

Align View

The Align View menu item is used to align the SketchUp Camera to the currently selected face.

This menu item is available for Face, Section Plane, and Surface entities.

Align Axes

The Align Axes menu item is used to align the Drawing Axes to the currently selected face.

This menu item is available for the Face and Surface entities.

Area

The Area sub-menu of the Face context menu is used to calculate the surface area in your SketchUp model. The results of the calculation are displayed in a Area dialog box.

This menu item is available for the Face and Surface entities.

Selection

The Selection menu item is used to calculate the total surface area of the currently selected face.

Layer

The Layer menu item is used to calculate the total area for all faces in the layer of the currently selected face.

Materials

The Materials menu item is used to calculate the total area of the faces in the entire model, hidden or unhidden, with the material of the currently selected face.

This menu item is available for the Face and Surface entities.

Arrow

Click on the Arrow sub-menu menu to select the end point type for the leader line. Choose between None, Dot, Closed Arrow, and Open Arrow

Change Axes

The Change Axes menu item is used to redefine the origin axes of the selected component. This option is similar to changing the local coordinate system in other 3D applications.

This menu item is available for the Component entity.
Close Component
The Close Component menu item is used to end an editing session and close the component. You can also click outside of the component with the Select Tool, or press the Esc key to close the component.
This menu item is available for the Component entity.

Close Group
The Close Group menu item is used to end an editing session and close the group. You can also click outside of the group with the Select Tool, or press the Esc key to close the group.
This menu item is available for the Group entity.

Combine Textures
The Combine Textures menu item is used to create a texture which is unique to the set of parallel Face entities. This menu item is primarily used to stitch together photographs.
This menu item is available for a selection set of parallel Face entities (where at least one face has a texture).

Convert to Polygon
The Convert to Polygon menu item is used to convert the entity into a polygon arc, which will remain editable yet generate standard facets when extruded.
This menu item is available for the 3D Polyline, Circle, and Curve entities.

Create Group from Slice
Generates new edges, encapsulated within a Group, wherever the section intersects with a face.
This menu item is available for the Section Plane entity.

Dynamic Components
The Dynamic Components submenu contains several options for working with Dynamic Components.

Component Options
The Configure menu item is used to display a dynamic component's Component Options dialog box.

Component Attributes
The Component Attributes menu item is used to display the component's Component Attributes dialog box.

Generate Report
The Generate Report menu item is used to generate a report of all attributes contained in a dynamic component.

Swap Component
The Swap Component menu item is used to swap the currently selected component with another component.
Divide
The Divide menu item is used to divide an entity into any number of equal segments. This menu item is not available when an arc bounds a curved surface.

Dynamic Components
The Dynamic Components submenu contains menu items for configuring and creating dynamic components.

Component Options
The Component Options menu item is used to display the Component Options dialog box used to configure a dynamic component.

Component Attributes
The Component Attributes menu item is used to display the Component Attributes dialog box used to develop a dynamic component. This menu item is available for any Component entity.

Swap Component
Use the Swap Component menu item to swap the currently selected component with another component. For example, use this option to swap all windows of a specific type or manufacturer with windows of another type or manufacturer.

Note - Components that have attributes with the same name and value will retain their settings when swapped. For example, a window with a color attribute set to green will remain green when swapped with another component containing a color attribute set to green.

This menu item is available for any Component entity.

Generate Report
The Generate Report menu item is used to display the Generate Report dialog box used to generate various dynamic components reports.

Edit Component
The Edit Component menu item is used to edit the currently selected component. You can also use the Select Tool to double-click on the component, or select the component and press "Enter" (Microsoft Windows) or Return (Mac OS X) key to edit a component.

This menu item is available for the Component entity.

Edit Group
The Edit Group menu item is used to edit the currently selected group. You can also use the Select Tool to double-click on the group, or select the group and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key to edit a group.

This menu item is available for the Group entity.

Edit Text
The Edit Text menu item is used to edit the dimension text. Type in the new text and press the "Enter" (Microsoft Windows) or "Return" (Mac OS X) key to accept your changes.

This menu item is available for the Dimension and Text entities.
Entity Info
The Entity Info menu item is used to display the Entity Info dialog box for viewing and changing the entity's attributes.
This menu item is available for all entities.

Erase
The Erase menu item is used to delete the selected entity from your model.
This menu item is available for all entities.

Export
The Export menu item is used to save the image entity to a file that can be edited in an image editor.
This menu item is available for the Image entity.

Explode
The Explode menu item is used to break the entity into the separate entities. An exploded entity will appear the same, but it can no longer be edited, and will no longer respond to tool operations as a single entity.
This menu item is available for the 3D Polyline, Component, Group, and Image entities.

Explode Curve
The Explode Curve menu item is used to break the entity into regular edges. An exploded entity will appear the same, but it can no longer be edited, and will no longer respond to tool operations as a single entity.
This menu item is available for the 3D Polyline, Circle, Curve, and Polygon entities.

Flip Along
The Flip Along menu item is used to mirror the selected geometry along an axis. You can use the Axis Tool to reposition the drawing axes, allowing you to flip in virtually any direction.
This menu item is available for the Component and Group entities.

Group
This creates a Group entity out of the selected geometry.

Hide/Unhide
The Hide/Unhide menu item hides or unhides the select entity. All hidden entities are displayed in a ghosted pattern, allowing you to select them, if View > Show Hidden Geometry is enabled. This menu item changes to Unhide when selected geometry is hidden. Select Unhide to restore visibility for the entity.
This menu item is available for all entities.

Intersect With Model
The Intersect With Model menu item is used to intersect two elements, such as a box and a tube, and automatically create new faces where the elements intersect. These faces can then be pushed, pulled or deleted to create new geometry.
This menu item is available for the Component, Face, Group, and Surface entities.

**Leader**

Click on the Leader sub-menu to select between View Based, Pushpin, and Hidden leader types. A View Based leader will always retain its 2D screen orientation. A Pushpin leader is aligned in 3D space, and rotates with your model as you change your view.

**Lock/Unlock**

The Lock menu item is used to lock the component so that it cannot be moved or edited. Additional copies of the component can be dragged into the work area from the Components Browser, however.

The Unlock menu item is used to unlock the component so it can be edited.

**Make Component**

The Make Component menu item converts the entities into a new Component entity (component definition).

This menu item is available for the Group entity.

**Make Unique**

The Make Unique menu item converts the currently selected component into a unique component, with a new definition. The original component definition and all other instances will not be affected when you edit the component after using the Make Unique menu item.

This menu item is available for the Component entity.

**Make Unique Texture**

The Make Unique Texture menu item is used to create a texture which is unique to that face. This menu item is not available if SketchUp already considers the texture to be "unique" and applies to the side of the face which is visible at the time you select the menu.

The Make Unique Texture menu item is also available for a face which doesn't already have a texture applied. The Texture Size dialog box is displayed when you select a face without a texture and then select the Make Unique Texture menu item. This dialog box prompts you to enter a texture size.

This menu item is available for the Face entity.

*Note* - The Make Unique Texture menu item will not be available again for a face unless you change the size of the face, edit the material size, or reposition the texture on the face.

**Orient Faces**

The Orient Faces menu item is used to automatically orient all the connected faces of your model to the orientation of the currently selected face. This option could lead to unexpected results when an edge of a face bounds three or more other faces.

This menu item is available for the Face and Surface entities.
Point at Center
The Point at Center menu item is used to place a point at the center of your arc or circle entity. This menu item is generated by a Ruby script.
This menu item is available for the 3D Polyline, Circle, and Polygon entities.

Reload
The Reload menu item is used to update the currently selected component with a new revision from the file system.
This menu item is available for Component and Image entities.

Reverse
The Reverse menu item is used to reverse the direction of a Section Plane entity.
This menu item is available for the Section Plane entity.

Reverse Faces
The Reverse Faces menu item is used to flip the front and back sides of the currently selected face. However, when exporting SketchUp geometry to a file format that only supports single-sided faced polygons (like DXF, DWG, and 3DS), it becomes important to know which side of the face will be exported.
This menu item is available for the Face, Section, and Surface entities.

Reset Scale
The Reset Scale menu item is used to remove any scaling operations applied to the component.
This menu item is available for the Component and Group entities.

Reset Skew
The Reset Skew menu item is used to remove any skewing applied to the component.
This menu item is available for the Component and Group entities.

Save As
The Save As menu item is used to save the selected component to a separate SketchUp file, with a new name and location in your file system. This menu item is commonly used to create component files that can be included in the component collection or reused in other models.
This menu item is available for the Component entity.

Scale Definition
The Scale Definition menu item applies any scaling operation, to the currently selected component, to the component definition in the Components Browser.
This menu item is available for the Component entity.
Select
The Select submenu contains several options for selecting geometry related to the entity.

Bounding Edges
The Bounding Edges menu item is used to select all of the edges currently bounding the selected entity.

Connected Faces
The Connected Faces menu item is used to select all of the faces currently connected to the selected entity.

All Connected
The All Connected menu item is used to select all of the elements currently connected to the selected entity.

All on same Layer
The All on same Layer menu item is used to select all of the elements on the current layer.

This menu item is available for the 3D Polyline, Circle, Curve, Face, Line, Polygon, and Surface entities.

Shadows
The Shadows submenu contains cast and receive shadow options for the Image entity.

Cast
The Cast Shadows menu item allows the face of the entity to cast a shadow.

Receive
The Receive Shadows menu item allows the face of the entity to receive a shadows cast by other entities.

This menu item is available for the Image entity.

Soften
The Soften menu item is used to soften a faceted surface. Softened edges are not visible unless displayed in profile.

This menu item is available for the 3D Polyline, Circle, Curve, Line, and Polygon entities.

Texture
The Texture submenu contains several options for repositioning textures on a face. This menu item only appears when a texture is painted on the face. See Position Texture Tool for additional information.

Position
The Position menu item is used to manipulate textures (reposition, stretch, skew, and so on) directly on a face.

Reset Position
The Reset Position menu item is used to reset the texture to its previous state.
Projected
The Projected menu item is used to wrap images and textures over forms as though projected onto the form.

This menu item is available for the Face and Surface entities.

Edit Texture Image
Select Edit Texture Image to launch your default image editor, as defined in the Applications panel of the Preferences dialog box, to edit the currently selected texture. If you have not identified an editor in the Applications panel of the Preferences dialog box, SketchUp launches the default editor or image display application.

Text Position
The Text Position menu item is used to position text either at the start of the dimension line (Outside Start), center (Centered), our end of the dimension line (Outside End).

This menu item is available for the Dimension entity.

Zoom Extents
The Zoom Extents menu item is used to zoom your view to a distance where the whole entity is visible and centered in the drawing window.

This menu item is available for the 3D Polyline, Circle, Component, Curve, Face, Group, Image, Line, Polygon, and Surface entities.

Unglue
The Unglue menu item is used to free a component from a face (if you've attached a hole-cutting component to a face).

This menu item is available for the Component, Group, and Image entities.

Use As Material (Microsoft Windows)
The Use As Material menu item is used to create a material, in the In Model section of the Material Browser, from the image.

This menu item is available for the Image entity.

Use As Material (Mac OS X)
The Use As Material menu item is used to create a material, in the Colors In Model section of the Material Browser, from the image.

This menu item is available for the Image entity.
Context Menus

Menu items also appear in special context menu: menus whose contents vary depending on the context in which they are invoked (usually on one or more entities in the drawing area or on a user interface component, such as a dialog box). The following image shows a context menu for a Face entity.
Welcome to SketchUp Dialog Box

The Welcome to SketchUp dialog box appears when you first run SketchUp. This dialog box is primarily used to choose a template for use in SketchUp (templates have predefined settings, such as units of measurement), license a copy of Google SketchUp Pro, and learn more about SketchUp.

**Licensing Status Field**

The Licensing Status field displays current information about your license status. SketchUp can either be Licensed, Not Licensed (during an 8-hour evaluation of Google SketchUp Pro), or Not Licensed - Expired (the 8-hour evaluation period is over).

**Default Template Field**

The Default Template field displays the name of the currently used template. You must choose a template to use SketchUp.

**Add License Button**

Click the Add License button to add a license. The Add License dialog box appears.

**Choose Template Button**

Click the Choose Template button to select a default template. Refer to Selecting a Template for more information.

**Learn Tab**

Click on the arrow next to the Learn tab to display several options for learning SketchUp.

**License Tab**

Click on the arrow next to the License tab to display the currently active licenses.

**Template Tab**

Click on the arrow next to the Template tab to display a list of available templates.

**Always Show on Startup Checkbox**

Check the Always Show on Startup button to display the Welcome to SketchUp dialog box when you launch SketchUp. Uncheck the Always Show on Startup button to never show the Welcome to SketchUp dialog box when you launch SketchUp. Use the Welcome to SketchUp menu item on the Help menu to display the Welcome to SketchUp dialog box.

**Start Using SketchUp Button**

Click the Start using SketchUp button to close the Welcome to SketchUp dialog box and start using SketchUp.
Principal Tools

This section of the user's guide covers the principal tools within SketchUp. Principal tools are those tools that tend to be used most often in SketchUp.

Tools in this section are covered in the order they appear within the Tools menu.
Select Tool

Use the Select Tool to specify the entities you will modify when using other tools or commands. The entities that are included in a selection are referred to as the selection set. Activate the Select Tool from the Principal Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or from the Tools menu.

Keyboard Shortcut: Spacebar
Eraser Tool

Use the Eraser Tool to delete entities. The Eraser Tool can also be used to hide and soften edges. Activate the Eraser Tool from the Principal Toolbar (Microsoft Windows), the Tool Palette (Mac OS X), or by selecting Eraser from the Tools menu.

Keyboard Shortcut: E
Paint Bucket Tool

Use the Paint Bucket Tool to assign materials and colors to entities in your model. You can use it to paint individual entities, fill a number of connected faces, or replace a material with another throughout your model. Activate the Paint Bucket Tool from the Principal Toolbar (Microsoft Windows), the Tool Palette (Mac OS X), or by choosing Paint Bucket from the Tools menu.

The Paint Bucket Tool is separate from the Apple Color Picker used to select colors and materials (Mac OS X).

**Keyboard Shortcut: B**
Fill Options

The Paint Bucket Tool can be used with one or more keyboard modifiers to perform various painting operations.

Element Fill

The Paint Bucket Tool normally operates by filling in faces as you click on them. As mentioned previously, entities selected with the Select Tool can be painted with a single click of the Paint Bucket Tool.

Adjacent Fill

Press and hold the "Ctrl" (Microsoft Windows) or the "Option" (Mac OS X) key while clicking on a face with the Paint Bucket Tool to fill that face and any adjacent (connected) face with the same material. The face you click on and the adjacent face must have the same material prior to performing this operation.

Note - Selecting a number of entities with the Select Tool and painting using the Ctrl (Microsoft Windows) or the Option (Mac OS X) modifier key causes just the entities within the selection set to be painted.

Replace

Press and hold the "Shift" key prior to clicking on a face with the Paint Bucket Tool to apply a material to every face, with the same material in the current context, with the new material.

Note - Selecting a number of entities with the Select Tool and painting using the Shift modifier key causes just the entities within the selection set to be painted.
Adjacent Replace

Press and hold both the "Shift" and the "Ctrl" (Microsoft Windows) or the "Option" (Mac OS X) keys simultaneously while painting to only replace the material on the face within the confines of geometry that is physically connected to that face.

Note - Selecting a number of entities with the Select Tool and painting using the Ctrl (Microsoft Windows) or the Option (Mac OS X) modifier key causes just the entities within the selection set to be painted.
Face Painting Rules

There are several face painting rules that apply when painting multiple faces or edges at the same time. These rules follow:

- The side of the faces that will be painted depends on the side initially painted when more than one face is selected. For example, if all faces are selected and you paint the front of one face, the front of all faces will be painted. Conversely, if all faces are selected and you paint the back of one face, all back faces will be painted.

- All selected edges will be painted when you select a face and all edges and paint the front of the face. No edges are painted when you select a face and all edges and paint the back of one face. Ensure you have the color set to the "By material" style setting to see the painted effect applied to edges.
Drawing Tools

This section of the user's guide covers the drawing tools within SketchUp. Drawing tools are those tools used to create new geometry. These tools include the Line Tool, Rectangle Tool, and Freehand Tool.

Tools in this section are covered in the order they appear within the Draw menu.
Line Tool

Use the Line Tool to draw edges or Line entities. Line entities can be joined to form a face. The Line Tool can also be used to divide faces or heal deleted faces. Activate the Line Tool from the Drawing Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Draw menu.

Keyboard Shortcut: L
Line Entities

Lines, also referred to as edges, form the structural foundation of all models. Draw lines with the Line Tool.
Arc Tool

Use the Arc Tool to draw Arc entities: arcs comprised of multiple connected line segments (which can be edited as a single arc). Activate the Arc Tool from the Tool Palette (Mac OS X), Drawing Toolbar (Microsoft Windows), or from the Draw menu.

Keyboard Shortcut: A
Arc Entities

Arc entities are a combination of multiple line segments connected together to approximate the curvature of the arc. These entities act as a single line in that they can define the edge of a face and also divide a face. Additionally, selecting one segment of the arc selects the entire Arc entity. However, all inference techniques will operate on the Arc as though it were comprised of segments. For example, every point on the arc is inferred as an endpoint of the segment. Draw Arcs with the Arc Tool.

Note - You can explode a arc into regular edge segments using the Explode Curve context menu item (see the Arc Context Menu Items section later in this topic).

Arc entities are comprised of a length (also called the base chord), bulge, radius, and number of segments. The following image shows an Arc entity.

Note - Arc and Circle entities are special in that they automatically produce softened edges when extruded using the Push/Pull Tool.

Arc Segmentation

Arcs with more line segments appear to have smoother curvature than arcs with fewer line segments. However, more line segments increases the size of your model and degrades performance. You can often achieve acceptable results by indicating small segmentation and using smoothing and edge softening to create the impression of smoothness.

Arc Deformation

If an Arc is deformed in a way that destroys its radial definition, such as with a non-uniform scale operation, it will become a non-parametric Curve entity. Polyline Curves can no longer be edited as arcs.
Freehand Tool

Use the Freehand Tool to draw irregular hand-drawn lines in the form of Curve entities and 3D Polyline entities. Curve entities are comprised of multiple line segments that are connected together. These curves behave as a single line in that they can define and divide faces. They are also connected such that selecting one segment selects the entire entity. Curve entities can be useful for representing contours in a contour map or other organic shapes. Activate the Freehand Tool from the Draw menu, from the Drawing Toolbar (Microsoft Windows), or the Tool Palette (Mac OS X).
3D Polyline Entities

SketchUp’s 3D Polyline entities are curve-like entities that do not generate inference snaps or affect geometry in any way. Freehand sketches are usually used for tracing imported drawings, 2D sketching, or for decorating your model.

Draw 3D Polyline entities with the Freehand Tool.

- **Note** - You can explode a freehand sketch into regular edge segments using the Explode context menu item (see the 3D Polyline Context Menu Items section later in this topic).

- **Note** - A 3D Polyline looks just like a Curve entity, but is thinner.
Curve Entities

SketchUp's Curve entities are a combination of multiple line segments that are connected together. These entities act as a single line in that they can define the edge of a face and also divide a face. Additionally, selecting one segment of the curve selects the entire Curve entity.

Draw curves with the Freehand Tool.

Note - You can explode a curve into regular edge segments using the Explode Curve context menu item (see the Curve Context Menu Items section later in this topic).

The following image contains a Curve entity. Curves can begin and end at the same point (as in the following image) or start and end at different points.

Note - The model in the previous image contains two entities: a Face entity (in the middle) surrounded by a Curve entity (the continuous edge).
Rectangle Tool

Use the Rectangle Tool to draw rectangular Face entities, specified by clicking at two opposite corners of the desired shape. Activate the Rectangle Tool from either the Drawing Toolbar (Microsoft Windows), the Tool Palette (Mac OS X), or the Draw menu.

Keyboard Shortcut: R
Face Entities

Face entities are flat plane-like entities that combine to form the 3D geometry in a SketchUp model. Faces are automatically created when any three or more intersecting lines or edges are in the same plane (an infinite flat 2D space), or coplanar.

The edges that bound a face remain when you delete a face. However, a face is erased automatically when you delete one of its bounding edges. SketchUp will create new edges and faces using the Auto-fold feature if you alter one of the edges of a face so that it is no longer co-planar with that face.

Draw faces with the Line Tool, Arc Tool, Freehand Tool, Rectangle Tool, Circle Tool, or Polygon Tool. The following image was created simply by joining arcs and lines to form the edges and subsequent faces.
Circle Tool

Use the Circle Tool to draw Circle entities. Activate the Circle Tool from the Drawing Toolbar (Microsoft Windows), Tool Palette (Mac OS X), or the Draw menu.

Keyboard Shortcut: C
Circle Entities

Circle entities are a combination of multiple line segments that are connected together to form a circle. These entities act as a single line in that they can define the edge of a face and also divide a face. Additionally, selecting one segment of the arc selects the entire Circle entity. However, all inference techniques will operate on the Circle as though it were comprised of segments. For example, every point on the circle is inferred as an endpoint of the segment. Draw circles with the Circle Tool.

Note - You can explode an Circle into regular edge segments using the Explode Curve context menu item (see the Circle Context Menu Items section later in this topic).

Circle entities are comprised of a radius and number of segments. The following image shows a Circle entity with 24 segments.

Note - The model in the previous image contains two entities: a Face entity (in the middle) surrounded by a Circle entity (the circular edge).

Note - Arc and Circle entities are special in that they automatically produce softened edges when extruded using the Push/Pull Tool.
Polygon Tool

Use the Polygon Tool to draw regular Polygon entities. Activate the Polygon Tool from either the Drawing Toolbar (Microsoft Windows), the Tool Palette (Mac OS X), or by selecting Polygon from the Draw menu.
Polygon Entities

SketchUp's Polygon entities are similar to Faces entities, but can have 3 or more sides. These entities act as a single line in that they can define the edge of a face and also divide a face. Additionally, selecting one segment of the polygon selects the entire Polygon entity. However, all inference techniques will operate on the Polygon as though it were comprised of segments. Draw polygons with the Polygon Tool.

**Note** - You can explode a polygon into regular edge segments using the Explode Curve context menu item (see the Polygon Context Menu Items section later in this topic).

Polygon entities are comprised of a radius and number of segments. The following image shows a six-sided polygon.

**Note** - The model in the previous image contains two entities: a Face entity (in the middle) surrounded by a Polygon entity (the six-sided edge).
Modification Tools

This section of the user's guide covers the modification tools within SketchUp. Modification tools are those tools used to modify existing geometry. These tools include the Push/Pull Tool, Eraser Tool, and Select Tool.

Tools in this section are covered in the order they appear within the Tools menu.
Move Tool

Use the Move Tool to move, stretch and copy geometry. This tool can also be used to rotate components and groups. Activate the Move Tool using the Modification Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.

Keyboard Shortcut: M
Rotate Tool

Use the Rotate Tool to rotate, stretch, distort, or copy entities along a rounded path. Activate the Rotate Tool from the Modification Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.

Keyboard Shortcut: Q
Scale Tool

Use the Scale Tool to resize and stretch portions of geometry relative to other entities in your model. Activate the Scale Tool from the Modification Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.

**Keyboard Shortcut:** S

**Note** - A Global Scale is an operation whereby the entire model is scaled simultaneously by applying a desired dimension to the distance between two points. The Scale Tool is only intended to perform scaling operations on portions of your model (not the entire model). Use the Tape Measure Tool’s global re-scale functionality to perform global scaling operations.
Scale Grip Types

Upon activation, the Scale Tool displays all the grips you may use. Any grips hidden behind geometry will become visible whenever touched by the mouse cursor, and remain fully operable. Turn on X-ray Transparency mode to reveal any hidden grips.

The Scale Tool allows you to perform both uniform scaling and non-uniform scaling (stretching operations). The scaling grip that is used dictates the type of scaling you perform.

**Corner Grips**

Corner grips scale the selected geometry from the opposite corner. The default behavior is a uniform scale such that the proportions remain intact and a single scale factor or dimension is displayed in the Measurements Toolbar.

**Edge Grips**

Edge grips scale the selected geometry from the opposite edge by two dimensions simultaneously. The default behavior is a non-uniform scale, meaning that the proportions of the object will change. The Measurements Toolbar displays two values separated by a comma.

**Face Grips**

Face grips scale the selected geometry from the opposite face in only one dimension. The default behavior is a non-uniform scale, meaning that the proportions of the object will change. The Measurements Toolbar displays and accepts a single value.
Push/Pull Tool

Use the Push/Pull Tool to push and pull Face entities to add volume to or subtract volume from your models. You can use push/pull to create volume out of any face type, including circular, rectangular, and abstract faces. Activate the Push/Pull Tool from the Tool Palette (Mac OS X), the Modification Toolbar (Microsoft Windows) or the Tools menu.

**Keyboard Shortcut: P**

**Note** - Push/Pull works only on faces, and therefore does not work when SketchUp is set to a Wireframe rendering style.
Offset Tool

Use the Offset Tool to create copies of lines and faces at a uniform distance from the originals. You can offset edges of faces either inside or outside of the original face. Offsetting a face will always create a new face. Activate the Offset Tool from the Tool Palette (Mac OS X), the Modification Toolbar (Microsoft Windows) or from the Tools menu.

Keyboard Shortcut: F
Follow Me Tool

Use the Follow Me Tool to duplicate the profile of a face along a path. This tool is especially useful when trying to add details to a model, such as a crown molding, because you can draw the profile of the molding at one end of a path on the model and using the Follow Me Tool continue that detail along the path. You can manually and automatically extrude a face along a path using the Follow Me Tool. Activate the Follow Me Tool from the Tools menu, the Modification Toolbar (Microsoft Windows), or the Tool Palette (Mac OS X).

Note - The path and the face must be in the same context.
Intersect With Model Tool

Use the Intersect With Model Tool to create complex geometry. This tool allows you to intersect two elements, such as a box and a tube, to automatically create new edges and faces where the elements intersect. These faces can then be pushed, pulled or deleted to create new geometry. Activate the Intersect With Model Tool from either context menu or the Edit menu.
Position Texture Tool

Materials within SketchUp are applied as tiled images meaning that the pattern or image will repeat both vertically and horizontally across any entities you paint. Use the Position Texture Tool to adjust a material on a surface in a number of ways, including repositioning, resizing, and distorting. Additionally, this tool allows you to perform unique actions on images such as painting a picture around a corner or projecting it on a model. Activate the Position Texture Tool from the context menu for a Face entity.

Note - The Position Texture Tool can only be used to modify textures applied to flat surfaces. You cannot edit a texture applied to a curved surface as a whole though you can use the "View > Hidden Geometry" menu item view and edit the texture on the individual faces that make up the curve's face set.

Note - Normally a texture is a subset of a material. However, the terms material and texture are used interchangeably in this topic.
Material Positioning Pins

The Position Texture Tool uses pins to manipulate a material. Pins can be moved or dragged. A move operation simply moves the pin to another location on the material. A drag operation performs some manipulation of the material, such as a resize or skew.

The Position Texture Tool has two modes: Fixed Pin Mode and Free Pin Mode.
Fixed Pin and Free Pin Mode Context Commands

Context-click while using the Position Texture Tool to display the position texture context menu.

Done
The Done menu item is used to exit the Position Texture Tool and save the current texture position.

Reset
The Reset menu item is used to reset the position of the texture to the position prior to using the Position Texture Tool.

Flip
The Flip menu item is used to flip the texture horizontally (Left/Right) or vertically (Up/Down).

Rotate
The Rotate menu item is used to rotate the texture one of three predefined increments: 90, 180, and 270 degrees.

Fixed Pins
The Fixed Pins menu item is used to toggle between Fixed Pin and Free Pin modes.

Undo
The Undo menu item will undo the last position texture command. Unlike the Undo command in the Edit menu, this undo command will only keep track of a single operation at a time.

Redo
The Redo menu item cancels Undo operations, returning you to the texture positioning state previous to using the Undo command.

⚠️ Caution - The Edit > Undo command and Undo button will Undo everything you did during your texture positioning session. The Edit > Redo operation cancels the Undo Edit > Undo operation, returning you to the last texture positioning command that you performed.
Construction Tools

This section of the user's guide covers the construction tools within SketchUp. Guide tools are those tools used to create construction geometry and prepare physical documentation. These tools include the Measure Tool, Text Tool, and Dimension Tool.

Tools in this section are covered in the order they appear within the Tools menu.
Tape Measure Tool

Use the Tape Measure Tool to measure distances, create guide lines or points, or scale a model. Activate the Tape Measure Tool from the Guide Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.

Keyboard Shortcut: T
Guide Line Entities

Guide Line entities are infinite dashed lines used as guides to draw precisely. Guide Lines do not interfere with regular geometry. Guide lines can also be hidden and erased independent of regular geometry. Draw guide lines with the Tape Measure Tool.

You can use the Move, Rotate, and Erase Tools to reorient a guide line. But, you cannot resize a guide line because guide lines are infinite in length.

Hiding/Erasing All Guide Lines

Guide lines are usually created as a temporary means to build a portion of your model. Keeping too many guide lines in your model can decrease SketchUp's inference accuracy and display performance, so you might want to hide guide lines as you work or delete all guide lines at once when you have finished your model.

Use "Edit > Hide" to hide the currently selected guide line. Use "Edit > Erase" Guides to erase all guides in the current context.
Guide Point Entities

Guide Point entities are finite dashed lines with end points as guides to draw precisely. Guide points do not interfere with regular geometry. Guide points can also be hidden and erased independent of regular geometry. Draw guide points with the Tape Measure Tool.

You can use the Move, Rotate, and Erase Tools to reorient a guide point.

Hiding/Erasing All Guide Points

Guide points are usually created as a temporary means to build a portion of your model. Keeping too many guide points in your model can decrease SketchUp's inference accuracy and display performance, so you might want to hide guide points as you work or delete all guide points at once when you have finished your model.

Use "Edit > Hide" to hide the currently selected guide line. Use "Edit > Erase Guides" to erase all guides in the current context.
Protractor Tool

Use the Protractor Tool to measure angles and create angled guide lines. Activate the Protractor Tool from the Guide Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.
Axes Tool

Use the Axes Tool to move, or reorient, the drawing axes within your model. For example, you might want to move the axes when you are constructing rectangular objects that are skewed relative to one another. Or, you might use this tool to allow for more accurate scaling of objects that are not oriented along the default coordinate planes. Activate the Axes Tool from the Guide Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.
Dimension Tool

Use the Dimension Tool to place Dimension entities in your model. Activate the Dimensions Tool from the Guide Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.
Dimension Entities

Dimension entities are finite lines with length information allowing you to quickly and effectively communicate key dimensions of your model. Dimensions can move and update automatically as you make changes to your model. Draw dimensions with the Dimension Tool.

Each Dimension Object lies in its own plane, which is determined by the entity from which it is drawn and the direction used when it was created.

Dimension display properties, for all dimension entities in your model, can be adjusted using the Dimension panel of the Model Info dialog box.

Changing Dimension Text

A Dimension entities text displays the dimension by default. You can, however, change the dimension text to include additional information, such as text. Include the symbols <> anywhere in your text to insert the dimension. For example, "The length of this line is <>."  

⚠️ Caution - Dimensions that have lost their direct link to geometry or that have had their text edited might not show accurate measurements. Select the Highlight non-associated dimensions option in the Dimension panel of the Model Info dialog box to highlight these dimensions in a specified color.
Text Tool

Use the Text Tool to insert Text entities into your model. Activate the Text Tool from the Guide Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Draw menu.

There are two types of text in SketchUp: Leader Text and Screen Text.
Text Entities

Text entities allow you to annotate your SketchUp model in several ways. There are two types of Text entities: Leader Text, which has leader lines and can be attached to a face, or Screen Text, which remains fixed to a point on your screen.

Text entities can have their own font, color, and size settings. Use the Text Tool to place Text Objects in your model.

Text Leaders

Text Objects can have one of four leader arrow styles: None, Dot, Closed arrow, and Open arrow. This can be changed using the context menu or its Entity Info dialog box.

Text leaders are tied to the model, so as you rotate the model, the text information continues to be valid. As you move and adjust surfaces, the notes attached to those surfaces adjust with them. Once a leader arrow is obscured the text will be hidden.

All text interacts with the model in three dimensions, but there are two ways for it to look on the screen. Thus, there are two main styles of leaders: View Based and Pushpin. A View Based leader will always retain its 2D screen orientation. A Pushpin leader is aligned in 3D space, and rotates with your model as you change your view.

View Based

2D View Based leaders do not change as the model view is changed. Their appearance remains the same based on the screen layout and viewing direction present when they were placed. As you rotate the model, the actual text tries to stay oriented on the screen the same way, and the entire entity will follow whatever it is attached to. When the leader arrow becomes obscured, the whole text entity disappears. This method works well for presentation of still images from a particular vantage point.

Pushpin

3D Pushpin leaders do change appearance as your view changes because they are drawn in 3D space just like model geometry. As you rotate the model, the leader foreshortens, rotates and hides just like any edge geometry. 3D text can be repositioned in 3D space just like any other edge entity. This method works well for planning studies and models that will be examined using fly-bys.
3D Text Tool

Use the 3D Text Tool to create 3 dimensional geometry from text. Activate the 3D Text Tool from the Guide Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu. The following image shows the Place 3D Text dialog box on Mac OS X:

The following image shows the Place 3D Text dialog box on Microsoft Windows:
Section Plane Tool

Use the Section Plane Tool to create section cuts enabling you to view geometry within your model. Activate the Section Plane Tool from the Guide Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.
Section Plane Entities

Section Planes are special entities that control the SketchUp section cutting effect. Their position in space and in relation to groups and components determine the nature of the section cut effect. The following image shows a rectangular section plane creating a section cut effect in a model of a cup.
Camera Tools

This section of the user's guide covers the camera tools within SketchUp. Camera tools are those tools used to manipulate your point of view of the model. These tools include the Orbit Tool, Pan Tool, and Zoom Tool.

Tools in this section are covered in the order they appear within the Camera menu.

Camera Tools Context Menu

Context-clicking while using any camera tool launches the camera tools context menu. This menu enables you to switch between camera tools.
Use the Next option to advance to the next view of your model. Next can be used after using the Orbit Tool, Pan Tool, Position Camera Tool, Look Around Tool, or any of the Zoom tools. Activate the Next option from the Camera menu.
Previous

Use the Previous option to return to the last view of your model. Previous can be used after using the Orbit Tool, Pan Tool, Position Camera Tool, Look Around Tool, or any of the Zoom tools. Activate the Previous option from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X), or the Camera menu.
Standard Views

SketchUp provides several pre-defined standard point of views for your convenience. These point of views are (from left-to-right in the image below): Top (Shift+2), Front (Shift+4), Right (Shift+6), Left (Shift+7), Back (Shift+5), Isometric (Shift+1), and Bottom (Shift + 3). Select a Standard View from Views Toolbar (Microsoft Windows), Standard Views Toolbar (Mac OS X) or the Camera menu.

💡 Tip - The standard views can be used with a paraline projection to produce elevation, plan, and section drawings.
**Match New Photo**

Use the Match New Photo and Edit Matched Photo menu items to create a 3D model to match a photo or to match an existing 3D model to a photo's context. Activate the Match New Photo and Edit Matched Photo menu items from the Camera menu.

SketchUp is commonly used to create designs of buildings or structures. SketchUp allows you to create these designs using the actual real-world scale (a scale of 1:1 where a unit of measurement in SketchUp represents that actual unit of measurement in the real world). However, digital pictures are not at a 1:1 scale. Therefore, to create a 3D model that matches a photo (or to match an existing SketchUp model to a scale in a photo), you must calibrate SketchUp's camera to match the position and focal length of the digital camera used to take the picture.

**High-Level Steps for Using Photo Match**

Photo matching consists of 4 high-level steps:


2. Start matching. Matching involves loading a digital picture and calibrating SketchUp's camera to the position and focal length of the camera used to take the actual photo (you are setting up the exact criteria used to take your picture so you can draw on the picture). You can also set the scale of the actual building or structure while matching, or just resize the entire model after it has been drawn.

3. Start sketching. Once you have duplicated the position and focal length of the camera used to take the picture, you can draw over the image in SketchUp. SketchUp moves into a 2D sketching mode from matching (it is 2D because you are drawing on a 2D photo that needs to be oriented at a specific camera angle to you).

4. Repeat Step 2 and 3 with any other photos that make up the building or structure.
Match Controls and Context-Menu Items

There are three sets of controls that are accessible from the matching mode. These controls are: The matching controls, Match Photo dialog box controls, and the matching context-menu items.

Matching Controls

Use the matching controls to adjust the axis such that you can draw a model to match a photo or match a model to a photo.

**Origin**
The origin represents the point where all axes in SketchUp originate. Click and hold on the origin to select the origin. Move the cursor to reposition the origin.

**Red and Green Axes bars**
The red and green axes bars are used to align the camera to a photo. Click and hold the axes bar grips to reposition the axes bars.

**Axes lines**
The axes lines represent the 3 dimensional axes and help to establish the vanishing points. Click and hold on the axis line to select the axis line. Move the cursor along the axis line to resize a model.

**Vanishing points**
There are three vanishing points in the matching mode (red, green and blue). The vanishing point is a place along the horizon of a perspective photo where all the parallel lines seem to converge. Click and hold on a vanishing point to select the vanishing point. Move the cursor to reposition the vanishing point.

Match Photo Dialog Box

The Match Photo dialog box controls are used to help you create accurate 3D models from photos and to accurately place models in a photo’s context.

**New Matched Photo**
Click on the New Matched Photo button to start a new matching.

**Edit Matched Photo**
Click on the Edit Matched Photo button to reenter the matching mode. This button is only active in a Sketch-Over-Image mode.

**Photo**
Check the Photo checkbox to display the photo. Uncheck the Photo checkbox to hide the photo. This option is also available in sketch-over-image mode.

**Opacity**
Move the Opacity slider to the left to make the photo more transparent. Move the Opacity slider to the right to make the photo more opaque. This option is also available in sketch-over-image mode.

**Model**
Check the Model checkbox to display the model. Uncheck the Model checkbox to hide the model. This option is also available in sketch-over-image mode.
**Project Textures From Photo**
Click on the Project textures from photo button to automatically project the photo as a texture onto your model.

**Grid**
Check the On radio button to continuously display the axes grid. Check the Auto radio button to only show the grid when manipulating one of the matching controls.

**Style**
Click on the Style icons to change the style of the grid. Grid styles are used to set the grid to best complement a specific type of photo. The left-most style is used for photos usually taken indoors where walls, ceiling, and floor of a room meet at a corner (the origin is usually at the bottom corner where the walls, ceiling, and floor meet). The middle style is used for photos taken from a vantage point where you are looking down on the building or structure (the origin would be at the top corner of the building where roof and walls meet). Finally, the right-most style is used for photos taken from a vantage point where you are standing on the ground (the origin would be the bottom corner where the walls and ground meet).

**Planes**
Click on the planes buttons to toggle the display of grid lines on a particular plane. The Red/Green button toggles grid lines in the red and green planes. The Red and Blue button toggles grid lines in the red and blue planes. Finally, the Green/Blue button toggles grid lines in the green and blue planes.

**Spacing**
The spacing field is used to set the scale of your model before you start sketching over the image. Enter a value in the spacing text-entry box to change the size of grid spacing to represent some multiple of the overall structure size. Then, drag the axes lines to line grid squares up with your image.

**Matching Context-Menu Items**
Context-click during matching to display the matching context-menu.

**Done**
Select the done menu item to end your matching.

**Start over**
Select the Start Over menu item to restart matching.

**Cancel match**
Select the Cancel Match menu item to cancel and exit your matching.

**Zoom matched photo**
Select the Zoom matched photo menu item to fit the entire drawing area.

**Zoom vanishing points**
Select the Zoom vanishing points menu item to zoom to fit all vanishing points in the drawing area.

**Rotate 90 left**
Select the Rotate 90 left menu item to rotate the red and green axes 90 degrees left. Use this menu item primarily when creating a model to match several photos (to rotate the model as you draw the model's sides to match the different sides of the structure in different photos).
**Rotate 90 right**
Select the Rotate 90 right menu item to rotate the red and green axes 90 degrees right. Use this menu item primarily when creating a model to match several photos (to rotate the model as you draw the model's sides to match the different sides of the structure in different photos).

**Undo**
Use the Undo menu item to undo the last matching command.

**Redo**
Use the Redo menu item return the last undo to its previous state.

**Sketch-Over-Image Controls and Context-Menu Items**
There are three sets of controls that are accessible from a Sketch-Over-Image mode. These controls are: The SketchUp tools, Sketch Over dialog box controls, and the Sketch-Over-Image context-menu items.

**Sketch-Over-Image Context-Menu Items**
Context-click during a Sketch-Over-Image to display the Sketch-Over-Image context-menu.

- **Edit Matched Photo:** Select the Edit Matched Photo menu item to resume matching.
- **Project Photo:** Select the Project Photo menu item to project the photo's texture on your model.
- **Zoom Matched Photo:** Select the Zoom Matched Photo menu item to fit the entire drawing area.

**Sketch-Over-Image Dialog Box Controls**
The Sketch Over dialog box controls are used to help you create accurate 3D models from photos and to accurately place models in a photo's context.

- **Photo:** Check the Photo checkbox to display the photo. Uncheck the Photo checkbox to hide the photo. This option is also available during matching.

- **Opacity:** Move the Opacity slider to the left to make the photo more transparent. Move the Opacity slider to the right to make the photo more opaque. This option is also available during matching.

- **Model:** Check the Model checkbox to display the model. Uncheck the Model checkbox to hide the model. This option is also available during matching.
Sketch-Over-Image Session Controls and Context-Menu Items

There are three sets of controls that are accessible from a Sketch-Over-Image Session. These controls are: The SketchUp tools, Sketch Over dialog box controls, and the Sketch-Over-Image session context-menu items.

Sketch-Over-Image Session Context-Menu Items

Context-click during a Sketch-Over-Image session to display the Sketch-Over-Image session context-menu.

**Edit Photo Match**
Select the Edit Photo Match menu item to resume the Photo Match session.

**Project Photo**
Select the Project Photo menu item to project the photo's texture on your model.

**Zoom Matched Photo**
Select the Zoom matched photo menu item to fit the entire drawing area.

Sketch Over Dialog Box Controls

The Sketch Over dialog box controls are used to help you create accurate 3D models from photos and to accurately place models in a photo's context.

**Photo**
Check the Photo checkbox to display the photo. Uncheck the Photo checkbox to hide the photo. This option is also available during a Photo Match session.

**Opacity**
Move the Opacity slider to the left to make the photo more transparent. Move the Opacity slider to the right to make the photo more opaque. This option is also available during a Photo Match session.

**Model**
Check the Model checkbox to display the model. Uncheck the Model check box to hide the model. This option is also available during a Photo Match session.
Orbit Tool

Use the Orbit Tool to rotate the camera about the model. The Orbit Tool is useful when viewing geometry from the outside. Activate the Orbit Tool from either the Camera Toolbar (Microsoft Windows), Tool Palette (Mac OS X) or the Camera menu.

Keyboard Shortcut: O
Pan Tool

Use the Pan Tool to move the camera (your view) vertically and horizontally. Activate the Pan Tool from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X) or the Camera menu.

Keyboard Shortcut: H
Zoom Tool

Use the Zoom Tool to move the camera (your view) in or out. Activate the Zoom Tool from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X), or the Camera menu

Keyboard Shortcut: Z
Zoom Window Tool

Use the Zoom Window Tool to zoom in on a specific portion of your model. Activate the Zoom Window Tool from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X) or the Camera menu.
Zoom Extents Tool

Use the Zoom Extents Tool to zoom your view to a distance which makes the whole model visible and centered in the drawing area. Activate the Zoom Extents Tool from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X) or, the Camera menu.

Keyboard Shortcut: Shift+Z
Zoom to Photo Tool

Use the Zoom to Photo Tool to move the camera (your view) in such that the entire photo fills the drawing area. This menu item is active while matching photos. Activate the Zoom to Photo Tool from either the Camera Toolbar (Microsoft Windows, or Tool Palette (Mac OS X), or the Camera menu.
Walkthrough Tools

This section of the user's guide covers the walkthrough tools within SketchUp. Walkthrough tools are those tools used to view your model as through walking around and in your model. These tools are the Position Camera Tool, Look Around Tool, and Walk Tool.

Tools in this section are covered in the order they appear within the Camera menu.
Position Camera Tool

Use the Position Camera Tool to position the camera (your view) at a specific eye height so that you can check the line of sight of a model or walk through a model. Activate the Position Camera Tool from either the Walkthrough Toolbar (Microsoft Windows), Tool Palette (Mac OS X) or the Camera menu.
Walk Tool

Use the Walk Tool to maneuver through your SketchUp model as though you were walking through your model. Specifically, the Walk Tool fixes the camera to a particular height, and then allows you to maneuver the camera around your model. The Walk Tool is available only in Perspective mode. Activate The Walk Tool from the Walkthrough Toolbar (Microsoft Windows), Tool Palette (Mac OS X) or the Camera menu.
Look Around Tool

Use the Look Around Tool to pivot the camera (your view) around a stationary point. The Look Around Tool behaves similarly to a person standing still while turning their head to up, down (tilt), and side to side (pan). The Look Around Tool is particularly useful for viewing the inside of spaces, or to evaluate visibility after using the Position Camera Tool. Activate the Look Around Tool from either the Walkthrough Toolbar (Microsoft Windows, Tool Palette (Mac OS X) or the Camera menu.
Sandbox Tools

This section of the user's guide covers the sandbox tools within SketchUp. Sandbox tools are those tools used to create and manipulate large surfaces (TINs) in your models. These tools include the Sandbox From Scratch Tool, Sandbox From Contours Tool, Smoove Tool, Stamp Tool, and Drape Tool.

Sandbox tools are not just for modeling terrain; they can also be used to model other organic shapes such as the curved portions of a hand-built wooden chair or a wooden bowl. Organic shapes are those that have a hand-made or custom appearance.

Tools in this section are covered in the order they appear within the Draw > Sandbox and Tools > Sandbox sub-menus.
**Sandbox From Contours Tool**

Use the Sandbox from Contours Tool to create a TIN from contour lines. You must create or import contour lines that are offset in their height prior to using this tool. Activate the Sandbox from Contours Tool from the Draw menu.

*Note -* You must enable the sandbox tools before you can use them. See Enabling the Sandbox Tools for further information.

The following image shows several contour lines offset in height from the ground plane.

The following image shows the resulting terrain created when the Sandbox From Contours Tool is used on the selected contours.

*Note -* In some cases the Sandbox From Contour Line Tool might create triangulations in the TIN that result in flat spots or plateaus. These plateaus can be retriangulated (to create a slope) using the Flip Edge Tool.
Sandbox From Scratch Tool

Use the Sandbox From Scratch Tool to generate a flat triangulated TIN that can be sculpted into other forms using other sandbox tools. The Sandbox From Scratch Tool generates the TIN in the red/green or ground plane. This tool is useful in creating terrain when no other terrain model or data is available. Activate the Sandbox From Scratch Tool from the Draw menu.

Note - You must enable the sandbox tools before you can use them. See Enabling the Sandbox Tools for further information.
Smoove Tool

Use the Smoove Tool to sculpt an existing TIN by allowing vertical movement of a selection of points, edges, or faces and their immediately adjacent geometry. The result is a smooth deformation of a triangulated surface. Activate the Smoove Tool from the Tools menu.

Note - You must enable the sandbox tools before you can use them. See Enabling the Sandbox Tools for further information.
Stamp Tool

Use the Stamp Tool to create impressions in a TIN by pushing a duplicate of the base of geometry, such as a house, into a TIN. Activate the Stamp Tool from the Tools menu.

Note - You must enable the sandbox tools before you can use them. See Enabling the Sandbox Tools for further information.
Drape Tool

Use the Drape Tool to project edges, such as the edges in a road, onto a terrain. Activate the Drape Tool from the Tools menu.

Note - You must enable the sandbox tools before you can use them. See Enabling the Sandbox Tools for further information.
Add Detail Tool

TINs do not have to consist of triangles of the same size. Use the Add Detail Tool to split triangles into additional, smaller triangles, and make small detailed modifications to your TIN. Any click on your TIN creates new triangles centered around a new vertex that you can manipulate. Activate the Add Detail Tool from the Tools menu.

Note - You must enable the sandbox tools before you can use them. See Enabling the Sandbox Tools for further information.

Smaller triangles equate to a smoother final TIN. However, having an abundance of small triangles in your TIN can also decrease performance. The Add Detail Tool can help strike a balance between detail and performance by allowing you to add detail only to areas of the TIN where it is needed.
Flip Edge Tool

Use the Flip Edge Tool to manually adjust the triangulation for any pair of adjacent triangles in a TIN. This tool is useful in removing flat spots or plateaus in a terrain generated from contour lines. Activate the Flip Edge Tool from the Tools menu.

Note - You must enable the sandbox tools before you can use them. See Enabling the Sandbox Tools for further information.

The following image contains a terrain with several opposing triangulations (triangles that point opposite to each other).
Triangulations whose sides run north and south create plateaus in the TIN. The Flip Edge Tool can be used to flip these triangulations and remove these plateaus (creating slopes). The following image shows terrain with the triangulations flipped.

Tip - You can easily see triangles with opposing triangulation by displaying hidden geometry. Turn on hidden geometry (View > Hidden Geometry) to view the triangles in the TIN.
Google Toolbar

This section of the user's guide covers the Google Toolbar within SketchUp. Buttons on the Google Toolbar are used to interact with other Google technologies, such as Google Earth.

Items in this section are covered in the order they appear within the Google menu.
Google Earth and SketchUp Workflow

SketchUp can be used to create three-dimensional models for Google Earth. The workflow for creating and placing SketchUp models in Google Earth follows:

1. (Google Earth) Navigate to the location where you want your model to appear.
2. (SketchUp) Click on the "Get Current View" button to get an image of the current view from Google Earth. This image contains the location information needed to properly place the model at the correct location in Google Earth.
3. (SketchUp) Create your model on top of the 2D image.
4. (SketchUp) Click on the "Toggle Terrain button" to toggle to the 3D image.
5. (SketchUp) Reposition the model to conform to the terrain in the 3D image.
6. (SketchUp) Click on the "Place Model button" to place the model in Google Earth.
7. (SketchUp) Export the final model for use in Google Earth using the KMZ export option found in File > Export > 3D Model.
8. (SketchUp/Optional) Click on the Share Model button to post the model to the Google 3D Warehouse.
Get Current View Button

Use the Get Current View button to capture 2D and 3D snapshot images of the current view in Google Earth. These images are used as the context for your 3D SketchUp models.
**Toggle Terrain Button**

Use the Toggle Terrain button to toggle the Google Earth snapshot image between a 2D and 3D image.
Place Model Button

Use the Place Model button to place your SketchUp models in Google Earth. This button is used as a quick mechanism for viewing your model in Google Earth as you are working on your model.
Get Models Button

Use the Get Models button to download models from the 3D Warehouse. Refer to the 3D Warehouse documentation for further information.
**Share Model Button**

Use the Share Model button to post your model to the 3D Warehouse. Refer to the 3D Warehouse documentation for further information.

*Note* - The thumbnail of your model appearing in the 3D Warehouse will represent the view of the model in SketchUp at the time the model was shared.
Model Settings and Managers

This section of the user's guide covers the various model settings and manager dialog boxes within SketchUp. These dialog boxes include the Components Browser, Application Preferences, Material Browser, and Styles Browser dialog boxes.

Each dialog box in this section is covered in the order they appear within the Window (Microsoft Windows) and SketchUp (Mac OS X) menus.
Model Info Dialog Box

The Model Info dialog box allows you to configure a number of different settings specific to your current SketchUp model. Activate the Model Info dialog box from the Window menu.

The Model Info dialog box contains several panels, including the Dimensions panel for setting global dimensions and the Units panel for setting units to be used in your model.

Animation

The Animation panel allows you to set properties for animations. The following image shows the Animation panel of the Model Info dialog box on Microsoft Windows:

![Animation panel on Windows](image)

The following image shows the Animation panel of the Model Info dialog box on Mac OS X:

![Animation panel on Mac OS X](image)

**Scene Transitions**

The Scene Transitions section of the Animation panel allows you to determine the amount of time it takes to transition from one scene in the animation to another scene.

- **Enable scene transitions**: Click on the Enable Scene Transitions checkbox to enable scene transitions.
- **Seconds**: Enter the number of seconds that should transpire before the next scene appears.

**Scene**

The Scene section of the Animation panel allows you to determine the amount of time an animation will spend on each scene before transition to another scene.

- **Seconds**: Enter the number of seconds that will transpire before the transition changes to another scene.

**Components**

The Components panel allows you to modify the visual appearance of your model while editing groups and components. SketchUp allows you to fade or hide other similar components or fade or hide the rest of the model to make it easier to concentrate on
modifications to the edited component. The following image shows the Components panel of the Model Info dialog box on Microsoft Windows:

![Components panel on Windows](image)

The following image shows the Components panel of the Model Info dialog box on Mac OS X:

![Components panel on Mac](image)

**Component/Group Editing**
The Component/Group Editing portion of the Components panel allows you to define how geometry outside a component appears when editing a component.

**Fade Similar Components:** Slide the Fade similar components slider to control the degree of fading of other visible instances of the component you are editing. Click the Hide checkbox to toggle the display of components similar to the one you are editing.

**Fade Rest of Model:** Slide the Fade rest of model slider to control the fading of geometry unrelated to the group or component you are editing. Click on the Hide check box to toggle the display of the rest of the model while editing a component or group.

**Component Axes:** Components contain their own axes. Click the Component Axes checkbox to display component axes.
Credits
The Credits panel allows you to view contributors toward the current model. This panel also allows the current users to claim credit toward the current model.

Author
The Author portion of the Credits panel displays the currently logged in user. User's must log in using their Google Account (GAIA account) to claim credit toward a model.

Claim credit button: Click the Claim Credit button to claim credit on the currently selected model.

Contributors
The Contributors portion of the Credits panel displays the list of contributors toward the current model.

Dimensions
The Dimensions panel allows you to change the appearance and behavior of Dimension entities in your model. The following image shows the Dimensions panel of the Model Info dialog box on Microsoft Windows:

![Dimensions panel screenshot](image_url)
The following image shows the Dimensions panel of the Model Info dialog box on Mac OS X:

**Text**
The Text portion of the Dimensions panel allows you to select the font used by Dimension entities in the drawing area.

**Fonts:** Click on the Fonts button to select the font to be used for all Dimension entities in SketchUp. Click on the font color button to choose a font color for Dimension entities.

**Leader Lines**
The Leader Lines portion of the Dimensions panel allows you to choose an end point style for your leader lines.

**Endpoints:** Select the end point style for all of your end points from the Endpoints dropdown list. These styles are None, Slash, Dot, Closed Arrow and Open Arrow.

**Dimension**
The Dimension portion of the Dimensions panel contains default display options for Dimension entities.

**Align to screen:** Click on the Align to screen radio button to allow Dimension entities to rotate as you orbit the model (always face the camera).

**Align to dimension line:** Click on the Align to dimension line radio button to allow Dimension entities to align to the dimension line instead of the camera. As you orbit your model, the text will remain aligned with the dimension lines.

Select all dimensions: Click on the Select all dimensions button to select all dimension entities in the model.

Update selected dimensions: Click on Update selected dimensions to update the currently selected entities with the currently selected dimension settings.
**Expert Dimension Settings**
Click on the Expert dimension settings button to display the Expert Dimension Settings dialog box.

**Hide when foreshortened:** Click the Hide when foreshortened checkbox to allow Dimension entities to hide when they become foreshortened. Slide the slider to set the threshold angle that will cause Dimension entities to become hidden.

**Hide when too small:** As your view moves further away from your model, dimensions appear smaller and text remains the same size. This behavior can result in an unclear Dimension text. Click on the Hide when too small checkbox to automatically hide dimensions when they are hard to read. Slide the slider to set the size that will cause Dimension entities to be hidden.

**Highlight Non-Associated Dimensions:** Click on the Highlight non-associated dimensions checkbox to assign a color to dimensions that are not associated with entities in your model. Non-associated dimensions are usually the result of erasing an entity that was used to calculate a dimension, such as an edge.

**File**
The File panel allows you to configure settings related to your SketchUp model's file, including the location of the file (on your file system), size, date of last modification, and version of SketchUp used for last modification. The following image shows the File panel of the Model Info dialog box on Microsoft Windows:
The following image shows the File panel of the Model Info dialog box on Mac OS X:

**General**
The General portion of the File panel contains default file options for the current model. The Description field is the only field that is editable within the General section.

**Location:** The Location field contains the location of the model's file on the file system (if it has been saved).

**Version:** The Version field contains the version of SketchUp last used to modify the model.

**Size:** The Size field contains the Size, in kilobytes, of the current SketchUp model's file.

**Description:** Click in the Description field to enter a description for your model.

**Redefine Thumbnail on Save:** Click the Redefine Thumbnail on Save checkbox to save the current view of the model as the thumbnail representation of the model. This thumbnail is shown when browsing through models when locating a file to open (Microsoft Windows).

**Alignment**
The Alignment portion of the File panel allows you to determine the alignment of the model when loaded and used as a component.

**Glue to:** Select a menu item from the Glue to menu to identify the surfaces where your file can be placed. For example, a model of a door would only be glued to surfaces in the horizontal planes.
**Cut Opening:** Click the Cut Opening checkbox to cause your model to able to penetrate a face, thus creating an opening, when used as a component. The model will cut the face to which it is attached at the model's perimeter.

**Always face camera:** Click the Always face camera checkbox to treat the model as though it were a 2D component by forcing the model to always face forward when loaded as a component. This option increases performance by eliminating the need to render the component as a 3D form.

**Shadows face sun:** This option is only available when the Always face camera option is enabled. Click the Shadows face sun checkbox to cause shadows to be cast from the components' current position as though the components were facing the sun. The shadow shape does not change as the component rotates to face the camera. This option works best with components that have narrow bases (such as trees). This option does not work well with components that have wide bases (such as people in mid stride).

**Note** - Ensure the component's axis is positioned at the bottom center of the component for best results.

Uncheck this option to cause the shadow to be cast from the component's current position. The size of the shadow changes based on view point.

**Location**

The Location panel allows you to specify a location for your model based on the nearest major city. This option is useful to determine accurate shading of architectural and geographical models.

**Note** - There is a different process for specifying a location for your model using Google SketchUp. Refer to Specifying a Model's Location in the World for more information.

**Note** - Click the Geolocation button on the status bar to display the Location panel of the Model Info dialog box.
The following image shows the Location panel of the Model Info dialog box on Microsoft Windows:

![Georeferencing panel on Microsoft Windows](image)

The Georeferencing portion of the Location panel allows you to manually establish the geographic location for the current model. A model can have three states, as indicated by the icon next to the Use georeferencing checkbox: Not georeferenced, Manually georeferenced (using location in SketchUp), and georeferenced with data from Google Earth.

The following image shows the Location panel of the Model Info dialog box on Mac OS X:

![Georeferencing panel on Mac OS X](image)
**Use georeferencing:** Check the Use georeferencing checkbox to manually set the location of the current model to the location in the Location panel. The georeferencing button on the Status Bar turns solid to indicate that georeferencing has been set manually.

- **Note** - All models have a location (as indicated in the Location panel of the Model Info dialog box). However, not all models are georeferenced to a location (meaning that location information is embedded in the model so that it can be properly placed in Google Earth.

- **Note** - The Use georeferencing checkbox is automatically checked when you import georeferenced data from Google Earth. If you uncheck this box and then make changes to the location information, it will not affect the georeferenced data.

**Geographic Location**
The Geographic Location portion of the Location panel allows you to assign a geographic location to your model.

- **Country:** Select a country from the Country list box to assign a country of origin for your model.

- **Location:** Select a city from the Location list box to assign a city of origin for your model.

- **Custom Location:** Click on the Custom location button to display the Custom Location dialog box. This dialog box allows you to manually enter Country, Location, Latitude, Longitude, and Timezone for any geographic location that is not already in the Country or Location drop-down list boxes.

**Solar Orientation**
The Solar Orientation portion of the Location panel allows you to set the path of the Sun in relation to the axes.

- **North Angle Button:** Click the North Angle Button to change the path of the Sun.

- **Show in Model:** Click the Show in Model checkbox to highlight the North angle in orange.
Statistics

The Statistics panel allows you to troubleshoot performance issues in SketchUp. This panel displays information about the type and number of drawing elements in your model and allows you to perform verifications on your model. The following image shows the Statistics panel of the Model Info dialog box on Microsoft Windows:

![Statistics panel on Windows](image)

The following image shows the Statistics panel of the Model Info dialog box on Mac OS X:

![Statistics panel on Mac](image)

**Entire Model and Components**

The Entire Model and Components options in the drop-down list box allow you to toggle between displaying statistics for your entire model and displaying statistics related only to components. The Components option is useful for generating a tally of the number of certain components used in your model (such as the number of a particular part in an assembly).
**Show Nested Components**
Click the Show nested components checkbox to include individual elements within placed components in the statistics totals.

**Purge Unused**
Click the Purge Unused button to remove any unused components, materials, image objects, layers, and other extraneous information from your file.

**Fix Problems**
Click the Fix Problems button to find minor issues with your SketchUp model due to the infinite flexibility that SketchUp provides when designing in 3D. Click the Fix Problems button to scan your model, and report and fix any problems. This option checks for several cases, including:

- Faces bounded by properly connected edges.
- Vertices of faces are on the same plane.
- Edges bounding a face are in the same component.
- Faces do not have zero area size.
- Start and end points of an edge are not the same.

*Note - Problem checking is also performed automatically (if turned on within the General panel of the Application Preferences dialog box) when a file is loaded, manually saved, or automatically saved (using the SketchUp auto-save feature). Refer to the Save menu item in the File menu or the auto-save feature in the General panel of the Application Preferences dialog box for further information.*

**Text**
The Text panel allows you to change the appearance and behavior of Text entities in your model. The following image shows the Text panel of the Model Info dialog box on Microsoft Windows:
The following image shows the Text panel of the Model Info dialog box on Mac OS X:

**Screen Text**
Screen text is text that is not attached, using a leader line and arrow, to a specific piece of geometry. The Screen Text portion of the Text panel allows you to select the font used by screen text in the drawing area.

**Fonts:** Click on the Fonts button to define the font to be used for all screen text in SketchUp. The Font dialog box, containing the font, font style, and size for your dimensions font, is invoked.

**Text Color Swatch:** Click on the text color swatch to select the default display color for any unpainted screen text (those painted with the default material).

**Select all screen text:** Click the Select all screen text to select all screen text in the drawing area.

**Leader Text**
Leader text is text that is attached, using a leader line and arrow, to a specific piece of geometry. The Leader Text portion of the Text panel allows you to select the font used by leader text in the drawing area.

**Fonts:** Click on the Fonts button to define the font to be used for all leader text in SketchUp. The Font dialog box, containing the font, font style, and size for your dimensions font, is invoked.

**Leader Text Color Swatch:** Click on the leader text color swatch to select the default display color for any unpainted leader text (those painted with the default material).

**Select all leader text:** Click the Select all leader text to select leader text in the drawing area.

**Leader Lines**
The Leader Lines options allow you to identify the type of leader line used with Text. Text might or might not have leader lines.
**End Point:** Click on the End Point drop-down menu to select the end point type for the leader line. Choose between None, Dot, Closed Arrow, and Open Arrow.

![End Point Examples](image)

**Leader:** Click on the Leader drop-down menu to select between View Based and Pushpin leader types. A View Based leader will always retain its 2D screen orientation. A Pushpin leader is aligned in 3D space, and rotates with your model as you change your view.

![Leader Examples](image)

**Update Selected Text:** Click the Update selected text button to apply the current settings to any selected Text entities.

**Units**

The Units panel is allows you to set defaults for linear and angular unit measurements.

![Units Panel](image)

**Note** - You can override the default units using the Measurements Toolbar to work in different units simultaneously.

The following image shows the Units panel of the Model Info dialog box on Microsoft Windows:
The following image shows the Units panel of the Model Info dialog box on Mac OS X:

![Units panel](image)

**Length Units**
The Length Units section of the Units panel allows you to set the default units for your model.

**Format**: Click on the Format drop-down menu to set the type of units displayed for measurements, dimensions, and within the Measurements Toolbar. Architectural displays as feet and inches. Decimal displays decimal units, including inches, feet, millimeters, centimeters, and meters. Engineering displays feet and decimal units of feet, and fractional units display only fractional inches.

*Note - Fractional units are primarily used by wood workers in the United States.*

**Precision**: Click on the Precision drop-down menu to set the precision for displaying units. Architectural unit precision can be set from 1" to 1/64". Decimal unit precision can be set in numbers of decimal places beyond zero for any of these units. SketchUp users working in Metric should use the decimal unit setting. Engineering unit precision can be set in decimal places beyond zero.

**Enable length snapping**: Click the Enable length snapping checkbox to snap lines and other entities to the specified sized increments. Length snaps can be overridden by entering exact values into the Measurements Toolbar. Type the snap length in the text field to have SketchUp snap to specific increments when drawing.

*Note - SketchUp does not have a grid snap option similar to other CAD applications.*

**Display units format**: Click the Display units format checkbox to display unit markers, such as the double quotes (") for inches. This option is only available when the format is set to Decimal.

**Force Display of 0"**: Click on the Force Display of 0" checkbox to display 0" in architectural units when there are no inches in the measurement. Ordinarily, inches would be suppressed in this case. For example, a measurement of three feet in length would read as 3'0" with this setting enabled.
**Angle Units**

The Angle Units portion of the Units panel allow you to define how units are displayed for angled measurements.

**Precision:** Click on the Precision drop-down list to set the use of decimal degree units to either a level of precision of 0 (no decimal places) or 0.0 (one decimal place) for greater accuracy.

**Enable angle snapping:** Click on the Enable angle snapping checkbox to enable snapping to the specified increment while using the Protractor or Rotate Tool. Move your cursor inside the protractor to snap to the specified increment while using these tools. You will see tick marks corresponding to your snap angle on the Protractor.

**Snap Angle:** Click on the Snap Angle drop-down list to choose the snap increment for angular measurements and rotations.
Entity Info

Select an entity and either context-click on the entity or select Window > Entity Info to view and change the entities attributes. All of the Entity Info dialog box fields for all entities in SketchUp follow.

Note - Some of these items are only visible when the details arrow in the upper right-hand corner is pointing up.

Align to Screen

The Align to screen radio button allows Dimension entities to rotate as you orbit the model (always face the camera).

Align to Dimension

The Align to dimension radio button allows dimension text to align vertically to the dimension line instead of the camera. As you orbit your model, the text will remain vertically aligned with the dimension lines.

This Entity Info dialog box item is available for the Dimension entity.

Above

The Above menu item places the dimension text above the dimension line.

Centered

The Centered menu item places the dimension text in the center of the dimension line.

Outside

The Outside menu places the dimension text on the opposite side of the dimension line from the dimensioned points.

Text Position

The Text position options allow dimension text to horizontally to the dimension line.

This Entity Info dialog box item is available for the Dimension entity.

Outside Start

The Outside Start menu item places the dimension text at the start of the dimension line.

Centered

The Outside Start menu item places the dimension text at the center of the dimension line.

Outside End

The Outside End menu item places the dimension text at the end of the dimension line.

Endpoints

Select the end point style for all of your end points from the Endpoints drop-down list. These styles are None, Slash, Dot, Closed and Open.

This Entity Info dialog box item is available for the Dimension entity.
Area
The Area field displays the area of the selected entity. Use the Area > Selection context menu item to calculate the area of multiple selected entities.
This dialog box item is available for the Face entity.

Arrow
The Arrow drop-down list contains a list of arrowheads permitted for the selected Text entity.
This Entity Info dialog box item is available for the Text and Dimension entities.

Cast Shadows
The Cast Shadows menu item allows the entity to cast a shadow.
This Entity Info dialog box item is available for the Arc, Circle, Component, Curve, Face, Group, Image, Line, Polygon, and Surface entities.

Definition Name
The Name field can contain the name of the component definition.
This Entity Info dialog box item is available for the Component entity.

Expand
Click on Expand to see components and groups nested within the currently selected component or group.
This Entity Info dialog box item is available for the Component and Group entities.

Font
The Font button is used to select a new font for the selected Text or Dimension entity.
This Entity Info dialog box item is available for the Text and Dimension entities.

Hidden
The Hidden check box is used to hide or unhide the entity. Hidden entities are displayed in a ghosted pattern, allowing you to select them, if View > Show Hidden Geometry is enabled.
This Entity Info dialog box item is available for all entities.

Layer
The Layer field displays the layer of the currently selected entity. Select a new layer to move the entity to that layer.
This Entity Info dialog box item is available for the all entities.

Leader
The Leader drop-down list contains a list of leader-types permitted for the selected Text entity.
This Entity Info dialog box item is available for the Text entity.
Length
The Length field displays the length of the currently selected entity.
This Entity Info dialog box item is available for the Arc, Circle, Curve, Line, and Polygon entities.

Locked
The Locked check box is used to lock the component so that it cannot be moved or edited. However, additional copies of the component can be dragged into the work area from the Components Browser.
Uncheck the Locked check box to unlock the component so it can be edited.
This Entity Info dialog box item is available for the Component and Group entities.

Material
The Material swatch displays the material used on the currently selected entity. The default material for an entity is represented by a gray/blue box. There are two default material swatches for faces and surfaces because faces and surfaces have both a front and a back side. The left swatch represents the front-side material. The right swatch represents the back-side material.
This Entity Info dialog box item is available for the 3D Polyline, Arc, Circle, Component, Curve, Dimension, Face, Group, Line, Polygon, Surface, and Text entities.

Name
The Name displays the name of the currently selected component instance or group. Image entities also have an un-editable name field in the dialog box.
This Entity Info dialog box item is available for the Component, Group, and Image entities.

Radius
This Radius field displays the radius of the selected entity. Type a new value in this field to change the radius of the entity.
This Entity Info dialog box item is available for the Arc, Circle, and Polygon entities.

Receive Shadows
The Receive Shadows menu item allows the component to receive a shadows cast by other entities.
This Entity Info dialog box item is available for the Component, Face, Group, Image, and Surface entities.

Segments
The Segments field displays the number of segments in the selected entity. Type a new value in this field to change the number of segments for the entity.

Note - Arc segmentation can only be changed when the Arc entity is part of 2 dimensional geometry (not part of a curved surface).
This Entity Info dialog box item is available for the Arc, Circle, Curve, and Polygon entities.
Size in pixels (Microsoft Windows) or Size (Mac OS X)
The Size in pixels (Microsoft Windows) or Size (Mac OS X) field displays the pixel dimensions of the currently selected image.
This Entity Info dialog box item is available for the Image entity.

Soft
The Soft option is used to render the edge as a soft edge.
This Entity Info dialog box item is available for the Line entity.

Smooth
The Smooth option is used to render the faces connected to the edge with a varying tonal value.
This Entity Info dialog box item is available for the Line entity.

Text
The Text field contains the text string for the selected Text entity. Click in this field to modify the text. Click in the drawing area to update your changes.
This Entity Info dialog box item is available for Text and Dimension entities.

Width and Height
The Width and Height fields display the dimensions of the currently selected image. Type in a new width or height to proportionally rescale the Image entity. Or, click on the lock icon to rescale the Image entity's width and height independently (non-proportional scale).
This Entity Info dialog box item is available for the Image entity.
Entity Info Dialog Box

The Entity Info dialog box displays information about selected entities, and allows you to view and change their properties. This dialog box is context-sensitive, and will contain different options as you select different entities in your model. Activate the Entity Info dialog box from either the Window menu or through a context menu. The following image shows the Entity Info dialog box on Microsoft Windows:

![Entity Info dialog box on Windows]

The following image shows the Entity Info dialog box on Mac OS X:

![Entity Info dialog box on Mac OS X]
Details Arrow

Click on the arrow in the upper-right portion of the Entity Info dialog box to show or hide additional details.
Materials Browser

SketchUp contains a library of predefined materials that you can apply to faces and edges in your model. The Materials Browser is used to organize materials and colors into libraries and to select and to apply materials to your model.

Activate the Materials Browser either by clicking on the Paint Bucket Tool or by selecting Material Browser from the Window menu.
Materials Browser Controls

Use Materials Browser controls to navigate among materials in your materials libraries.

Material Thumbnail
The material thumbnail displays the currently selected material.

Material Name Field
The material name field displays the name of the currently selected material.

Display Secondary Selection Pane Button
The Display Secondary Selection Pane button displays a second select panel below the primary select panel. This feature allows you to display both your materials libraries and the in model library at the same time. This feature is useful when you want to drag materials between libraries and the in model library.

Create Material
Click on the Create Material button to create a copy of the currently active material in the In Model library.

Set Material To Paint With To Default
Click the Set Material To Paint With To Default to set the material to the default front and back face colors. Refer to the Face Panel section of the Styles Browser topic for further information on setting the default front and back face colors.

Sample Paint Button
Use the Sample Paint button, appearing as an eye dropper, to sample and repaint materials appearing in your model. See the Paint Bucket Tool for additional information.

Select Tab
Click on the Select tab to display the select panel. Use the select tab to navigate between material libraries.

Back Arrow
Click the Back arrow to navigate to the previous location in the hierarchy of libraries.

Forward Arrow
Click the Forward arrow to navigate to the next location in the hierarchy of libraries.

In Model Button
Click on the In Model button to navigate to the In Model style library. The In Model style library contains all of the styles currently included with your model file.

Edit Tab
The Edit tab contains a panel of options for editing materials.
Material Browser Context Menu Items (Mac OS X)

A number of useful Materials Browser-related commands are accessible using context menus. Context-click on any material's icon or name to access the Materials Browser's context menus. The following options appear depending on whether you are clicking on icons in an established styles library or in the In Model library:

**Duplicate...**
Click the Duplicate menu item to duplicate the material. The Color name dialog box appears. Enter a new name for the duplicated material in the Color Name field. Click OK.

**Edit...**
Click the Edit menu item to place the current material in the Edit Panel.

**Remove**
Click the Remove menu item to remove a material from the In Model library.
Material Browser Context Menu Items (Microsoft Windows)

A number of useful Materials Browser-related commands are accessible using context menus. Context-click on any material's icon or name to access the Materials Browser's context menus. The following options appear depending on whether you are clicking on icons in an established styles library or in the In Model library:

Add to Model
Select the Add to model menu item to add the currently selected material to the In Model library.

Area
Select the Area menu item to calculate the amount of surface area, in current units, painted with the currently selected material. The material is not applied to any faces when the Area menu item is grey.

Delete
Select the Delete menu item to delete a single material from a materials library.

Edit Texture Image
Click the Edit Texture Image to launch your default image editor, as defined in the Applications panel of the Preferences dialog box, to edit the currently selected texture. If you have not identified an editor in the Applications panel of the Preferences dialog box, SketchUp launches the default editor or image display application.

Export Texture Image
Click the Export Texture Image menu item to save the texture-portion of the material as an image file

Save As
Select the Save As menu item to save the selected material to a separate file (.skm), with a new name and location. You can use this menu item to save materials that have been modified or created during a drawing session.

Select
Select the Select menu item to select all faces in your model painted with the currently selected material.
Materials Browser Details Menu

Click on the right arrow next to the styles library drop-down list to open the details pop-up menu. This menu allows you to perform additional material-related functions.

Open or Create a Library
Select the Open or create a library menu item to open an existing library (or file) or create a new styles library (folder).

Note - The open or create a library menu item displays a Browse for Folder dialog box. This dialog box does not display files, only folders. Select the folder or location containing the file and click the OK button.

Save Library As
Select the Save Library As menu item to save a copy of a library with a new name.

Add Library to Favorites
Select the Add Library to Favorites menu item to add an existing library to the list of favorite libraries (appearing at the bottom of the libraries drop-down list).

Remove Library From Favorites
Select the Remove Library from Favorites menu item to remove a library from your list of favorites (appearing at the bottom of the libraries drop-down list).

Purge Unused
Select the Purge Unused menu item to remove all materials in the In Model library that are not actually used in your model.

Small Images, Medium Images, Large Images, Extra Large Images
Select the Small Images, Medium Images, Large Images, or Extra Large Images menu item to change the size of the thumbnails in the Select panel.

List View
Select the List View menu item to display the styles in list form.

Refresh
Select the Refresh menu item to update the styles appearing in the styles browser.

Get More
Select the Get More menu item to get more styles from the SketchUp web site.
Materials Browser Edit Panel

Use the edit panel to edit the currently selected material.

Color Pickers Drop-Down List
Use the Color Pickers drop-down list to select between the HLS, (Hue, Light, Saturation), HSB (Hue, Saturation, and Brightness), RGB, (Red-Green-Blue), and Color Wheel color pickers. See Color Pickers (Microsoft Windows) or Color Picker (Mac OS X) for more information.

Undo Color Changes Button
Click the Undo Color Changes button to drop all changes to the material during an edit session.

Match Color of Object in Model Button
Click on the match color of object in model button and click on an entity in the model to sample the color from that entity and apply it to the currently selected material.

Note - The Match color of object in model tool matches the color of a specific entity’s material. This color can be disguised a bit when it is combined with a texture. Use the Match color on screen button if you want to sample a specific, on-screen, color.

Match Color On Screen Button
Click on the Match color on screen button and click anywhere on the screen to sample a color of a pixel and apply it to the currently selected material.

Use Texture Image Checkbox
Check the Use texture image checkbox to include an image file, representing a texture, as part of the current material. The Choose Image dialog box appears. Locate and select the image file you want to use and click the Open button. The image file appears in the texture file field below the Use texture image checkbox.

Uncheck the Use texture image checkbox to indicate that you no longer want to use an image file in your material (the texture file is removed).

Note - Re-checking the use texture checkbox will not restore a previous image file setting. Instead, you will be promoted to select a new image file.

Texture File Field
The texture file field contains the name of a image file (representing a texture), if any, associated with the current material. Drag image files into this field on click on the file open icon to the right to locate and open a image file.

Browse Button
Click on the Browse button to display the Choose Image dialog box and browse for an image file.
Edit Texture Image in External Editor Button
Click on the Edit texture image in external editor button to launch your default image editor, as defined in the Applications panel of the Preferences dialog box, to edit the currently selected texture. If you have not identified an editor in the Applications panel of the Preferences dialog box, SketchUp launches the default editor or image display application.

Colorize Checkbox
Check the Colorize checkbox to lock all colors throughout the image to the same hue. This option is useful for files that are not displaying proper colors.

Reset Color Button
Click the Reset Color button to reset the color of the material to the original color in the image file.

Dimensions Fields
Textures repeat themselves similar to tiles when they are painted on surfaces. The Dimensions options allow you to specify the dimensions of each texture tile. These options do not affect the original image file itself. Type a value in the height or width box to change the size of the texture tile. The corresponding dimension will adjust automatically to maintain aspect ratio. For example, if you type 2 in the top dimension box (width), 2 will appear in the bottom box (height).

Click on the chain icon if you do not want aspect ratio to be maintained.

Click the horizontal and vertical arrow buttons to revert to the previous width and height settings.

Opacity Slider
Slide the opacity slider to the right to increase the opacity of the texture. Slide the opacity slider to the left to increase the transparency of the texture. Alternatively, type a number from 0 to 100 (0 being fully transparent and 100 being fully opaque) in the opacity field.
Components Browser

The Components Browser contains both user-created and pre-built Component entities that you can use in your models. Activate the Components Browser from the Window menu.

⚠️ **Note** - See component definitions and instances for further information.

The following image contains a screenshot of the Components Browser on Microsoft Windows.
The following image contains a screenshot of the Components Browser on Mac OS X.
Component Definitions and Instances

A Component Definition and a Component Instance are created when a component is created using the Create Component dialog box. Components Definitions define or provide a blueprint for how all components of a specific type, called instances, appear and behave within the drawing area (whether they can be glued to faces, where insertion points appear, and so on). Component Definitions are represented by thumbnail images in the Components Browser.

Component Instances are components definitions that have been inserted in the drawing area (called instancing). Component Instances all look like and have the same default behavior as the Component Definition, but, once brought into the drawing area, can be rotated, scaled, and painted independently of other instances.
The Create Component Dialog Box

The Create Component dialog box is displayed when you attempt to create a component using the Make Component menu item.

General

Name
The Name field can contain the name of the component definition. All component definitions must have a name.

Description
The Description field can contain a description of the component.

Alignment

Glue to
The Glue to drop-down list is used to identify the faces where your component can be placed when initially placed from the Components Browser. For example, a standard door might only be glued to faces in the vertical (blue) plane. A grey gluing plane guide will appear when a specific gluing plane is selected. This plane represents exactly where the component will orient to a face and cut into a face. The following image shows a window component during component creation. Notice that the gluing plane (the grey plane) is parallel to the red/green plane and bottom of the window. This window component was also set to glue to vertical surfaces.
The following image shows what occurs when the previously mentioned window component is placed, from the Components Browser, against a vertical surface. Notice that the window meets the vertical face at the window's bottom because it was created with a gluing plane that is parallel to the bottom of the window.

![Image of window component against a vertical surface]

Usually you want windows and doors to have a gluing plane that is parallel to the front or back of the window or door (not the bottom). You might need to reorient the component's axes at creation, using the Set Plane button, to properly set the gluing or cutting plane.

**Set Component Axis**

The component axis defines how the component inserts and aligns to other geometry or to the camera. The component axis also defines the cutting plane by the orientation of the red/green plane. The Set component axis button is used to specify a different origin for the component and to modify the orientation of the component when it is placed.

**Cut Opening**

The Cut Opening option allows the Component to create openings in the face onto which it is placed. For example, a door or window component might be set to cut an opening in any wall where instances of the component are placed.

- **Note** - There must be edges along the cutting plane of the component to cut a hole in a face.

**Always face camera**

The Always face camera option allows the component to take on billboard behavior by drawing the component as a 2D form. This option increases performance by eliminating the need to render the component as a 3D model.

- **Note** - Components with the Always face camera option enabled cannot have gluing behavior.
Shadows face sun
This option is only available when the Always face camera option is enabled. The shadows face sun option causes the shadow to be cast from the component's current position as though the component were facing the sun. The shadow shape does not change as the component rotates to face the camera. This option works best with components that have short bases (such as trees). This option does not work well with components that have wide bases (such as people in mid stride).

Note - Ensure the component's axis is positioned at the bottom center of the component for best results.

Uncheck this option to cause the shadow to be cast from the component's current position. The size of the shadow changes based on view point.

Replace selection with component
The Replace selection with component option causes the currently selected entities to be turned into a Component instance. Uncheck this option to create a component definition in the Components Browser without creating a component instance from selection set.
Component Entities

Components are entities that can hold other entities. Components are similar to Group entities, but they are commonly used to combine several entities as a single entity for the purposes of reuse in multiple models. Use the Make Component menu item from the Edit menu to create a component from the currently selected entities.
**Components Browser Context Menus**

A number of useful Components Browser-related commands are accessible using context menus. Context-click on any component's icon or name to access the Components Browser's context menus. The following options appear depending on whether you are clicking on icons in an established component collection or in the In Model components:

**Delete**
Select the Delete menu item to delete a single component from a component collection.

**Properties**
Select the Properties menu item to display the Properties dialog box. This dialog box contains the location for the component file, when the file was last opened, the name of the component, and the number of component instances in the model.

**Reload**
Select the Reload menu item to reload a component from its original file in the event that the component's file has changed since being used in your model.

**Replace Selected**
Select the Replace Selected menu item to replace the currently selected components in the drawing area with the currently selected component in the Components Browser.

**Reset Insertion Point**
Select the Reset Insertion Point menu item to reset any changes made to a component definition's insertion point.

**Save As**
Select the Save As menu item to save the selected component to a separate SketchUp file with a new name and location. You can use this menu item to save components that have been modified or created during a drawing session.

**Select Instances**
Select the Select Instance menu item to select all of the instances of a specific component in your model.
Components Browser Controls

Use Components Browser controls to navigate among components in your component libraries.

Component Thumbnail
The component thumbnail displays the currently selected component.

Component Name Field
The component name field displays the name of the currently selected component.

Component Description Field
The component description field displays a description of the currently selected component.

Display Secondary Selection Pane Button
The Display Secondary Selection Pane button displays a second select panel below the primary select panel. This feature allows you to display both your component collections and the In Model components at the same time. This feature is useful when you want to drag components between collections and the In Model components.

Select Tab
Click on the Select tab to display the select panel. Use the select panel to navigate between component libraries, components in your model, and components in the 3D Warehouse.

View Options Drop-Down List
Click on the View Options drop-down list to list several options for viewing your components in Components Browser.

Small Thumbnails: Click the Small Thumbnails menu item to display small thumbnail representations of your components.

Large Thumbnails: Click the Large Thumbnails menu item to display large thumbnail representations of your components.

Details: Click on the Details menu item to display large thumbnails representations of your components along with the component name, author, and description.

List: Click on the List menu item to display a list of all component names.

Refresh: Click on the Refresh menu item to refresh the current list of components.

In Model Button
Click on the In Model button to navigate to the In Model components. The In Model components contain all of the components currently included with your model file.

Note - You can have components in your In Model components that are not being used by your model.
Collections and Searches Drop-Down List
Click on the Collections and Searches drop-down list to list all of the component collections in SketchUp. Click on a collection to select the collection. The Collections and Searches drop-down list is divided into three sections: Collections at the top, a list of the user's favorite collections or searches (local or in the Google 3D Warehouse), and a list of the five most-recently viewed local collections and Google 3D Warehouse searches.

Search Field
Type the name of any components you want to find in the search field. For example, to search for all plane components, type "plane."

Search Button (Microsoft Windows)
Click the Search button to initiate a search of a component whose name you have typed in the Search field.

Search Button (Mac OS X)
Click the Search button to view a list of recent searches. Select the Clear menu item to clear the list.

Note - SketchUp lists all individual models and collections with the search term.

Details Menu
Click on the Details arrow to display the Details Menu. The following lists all options found on the details menu in both Microsoft Windows and Mac OS X versions of SketchUp.

Add to favorites: Select the Add to favorites menu item to add the current collection to a list of favorite collections in the Collections and Searches drop-down list.

Create a local collection (Mac OS X): Select the Create a local collection menu item to create a new collection folder.

Expand: Select the Expand menu item to see all sub-components.

Open a local collection: Select the Open a local collection menu item to open all the components in a collection folder.

Open or create a local collection (Microsoft Windows): Select the Open or create a local collection menu item to open all the components in a collection folder or create a new collection folder.

Purge unused (In Model only): Select the Purge unused to remove all components in the In Model collection that are not currently used in your model.

Remove from favorites: Select the Remove from favorites menu item to remove the current collection from the list of favorite collections in the Collections and Searches drop-down list.

Save as a local collection: Select the Save as a local collection menu item to save all components in the In Model collection as a collection on your local hard drive.

View in 3D Google Warehouse: Select the View in 3D Google Warehouse menu item to view the search results in the 3D Warehouse.

Component List
The component list contains a listing of all components in the model, in a favorite, resulting from a search, and so on. Individual Components are indicated by a single box around the component thumbnail. Collections are identified by a stack of 3 overlapping boxes around a component thumbnail.
**Previous Button**
Click on the Previous button (displayed after performing a search) to view the previous twelve Google 3D Warehouse search results.

**Next Button**
Click on the Next button (displayed after performing a search) to view the next twelve Google 3D Warehouse search results.

**Edit Tab**
The Edit tab contains properties specific to the currently selected component. These properties can only be edited for components that are selected in the In Model components. These are the same properties whose values you define when a component is created, for the exception of the Loaded From field. See the Create Component Dialog Box for further information on these properties.

**Loaded From**
The Loaded From field displays the location of the component on the file system.

**Statistics Tab**
The Statistics tab reports quantities of various elements, such as faces, edges, construction lines, within the component. Select All geometry from the drop-down list to see statistics for all geometry in the component or group. Alternatively, select Components from the drop-down list to see statistics for all components in the component. Finally, click on Expand to see components and groups nested within the currently selected component or group.
Styles Browser

The Styles Browser contains options used to alter how your model and the drawing area is rendered (its edge type face type, background colors, watermarks, and so on). Activate the Styles Browser from the Window menu. The following image contains a screen shot of the Styles Browser on Microsoft Windows:
The following image contains a screen shot of the Styles Browser on Mac OS X:
The Styles Browser Background Panel

Styles also contain options for configuring the drawing area background, sky, and ground colors.

**Background**
Click on the Background button to select a background color for SketchUp's drawing area.

**Sky**
Check on the Sky checkbox to have a sky color that is different from the background color. Click on the Sky button to select a sky color.

**Ground**
Check on the Ground checkbox to select a ground color that is different from the background color.

**Transparency**
Slide the Transparency slider to adjust the level of transparency for the ground plane. Place the slider toward the left-most position to minimize below-ground visibility. Place the slider toward the right-most position to maximize below-ground visibility.

**Show Ground from Below**
Check the Show ground from below checkbox to toggle the display of the ground plane from viewpoints below the horizon.
**Styles Browser Controls**
Use the Styles Browser controls to navigate among styles in your styles libraries.

**Style Thumbnail**
The style thumbnail displays the style currently applied to your model.

**Style Name Field**
The style name field displays the name of the currently active style.

**Style Description Field**
The style description field displays a description of the currently active style.

**Display Secondary Selection Pane Button**
The Display Secondary Selection Pane button displays a second select panel below the primary select panel. This feature allows you to display both your styles libraries and the in model library at the same time. This feature is useful when you want to drag styles between libraries and the in model library.

![Note] - You can only apply one style at a time, but you might want multiple styles in the In Model library. For example, you might have one style that you apply when you are working on the model (because performance is better when you use the style) and another style you use for presenting the model. Styles in the In Model library are also saved with your SketchUp file.

**Create New Style Button**
Click on the Create new style button to create a copy of the currently active style in the In Model library.

**Update Style Button**
Click on the Update style button to update the copy of the currently active style in the In Model library.

**Select Tab**
Click on the Select tab to display the select panel. Use the select panel to navigate between style libraries.

**Back Arrow**
Click the Back arrow to navigate to the previous location in the hierarchy of libraries.

**Forward Arrow**
Click the Forward arrow to navigate to the next location in the hierarchy of libraries.

**In Model Button**
Click on the In Model button to navigate to the In Model styles library. The In Model styles library contains all of the styles currently included with your model file.

![Note] - You can have styles in your In Model style library that are not being used by your model.
Libraries Drop-Down List
Click on the libraries drop-down list to list all of the styles libraries in SketchUp. Click on a library to select the library.

Details Menu
Click on the Details arrow to display the Details Menu. See Details Menu for further information.

Edit Tab
The Edit tab contains five separate panels: The edge rendering panel, face rendering panel, drawing area styles panel, watermark panel, and other styles panel.

Mix Tab
The Mix tab contains five wells corresponding to the five categories of styles in the styles browser (edge, face, background, watermark, and modeling styles). Click on this tab to display the five wells and a secondary style pane. Select a style from the secondary style pane and click on one or more wells to sample the corresponding settings from that style. For example, click on a style in the secondary style pane and click on the Edge Settings well to sample the edge settings from that style. The style in the style thumbnail changes to reflect the newly sampled settings.
Styles Browser Details Menu

Click on the right arrow next to the styles library drop-down list to open the details pop-up menu. This menu allows you to perform additional styles-related functions.

Create Style
Select the Create style menu item to create a copy of the currently active style in the In Model library.

Open or Create a Library
Select the Open or create a library menu item to open an existing library (or file) or create a new styles library (folder).

Note - The open or create a library menu item displays a Browse for Folder dialog box. This dialog box does not display files, only folders. Select the folder or location containing the file and click the OK button.

Save Library As
Select the Save Library As menu item to save a copy of a library with a new name.

Add Library to Favorites
Select the Add Library to Favorites menu item to add an existing library to the list of favorite libraries (appearing at the bottom of the libraries drop-down list).

Remove Library From Favorites
Select the Remove Library from Favorites menu item to remove a library from your list of favorites (appearing at the bottom of the libraries drop-down list).

Purge Unused
Select the Purge Unused menu item to remove all styles in the In Model library that are not actually used in your model.

Small Images, Medium Images, Large Images, Extra Large Images
Select the Small Images, Medium Images, Large Images, or Extra Large Images menu item to change the size of the thumbnails in the Select panel.

List View
Select the List View menu item to display the styles in list form.

Refresh
Select the Refresh menu item to update the styles appearing in the styles browser.

Get More
Select the Get More menu item to get more styles from the SketchUp web site.
The Styles Browser Edge Panel

SketchUp contains a variety of edge rendering styles allowing you to manipulate the edge appearance on the screen.

Note - Endpoints and Jitter edge rendering styles are not available for NPR Edges.

Tip - Models with perfectly straight digitally drawn lines are often perceived to be in a finished state. Edge Rendering Styles are useful in conveying that a model is still in conceptual state and, therefore, is open for feedback.

Display Edges

Check the Display Edges checkbox to activate the display of edges in your model. The following images shows a series of cubes without and then with edges.
Profiles
Check the Profiles checkbox to emphasize the outlines or profiles of major shapes in your model. This style is particularly useful in ensuring the 3D nature of geometry is emphasized and borrows from a proven traditional media drawing technique. Enter a thickness, in pixels, for the profile lines in the pixels field. The following image shows a series of cubes with edges and profile edges.

Depth Cue
Check the Depth Cue checkbox to emphasize the lines of geometry in the foreground over the lines of geometry in the background. The following image shows a series of cubes with edges and depth cue edges on. Notice that the foreground edges on each cube get progressively thinner from front to back and top to bottom. Enter a thickness, in pixels, for the depth cue lines in the pixels field. This thickness determines the thickness of the forward-most lines (such as for the bottom middle cube in the following image) of your model.
Extension
Check the Extension checkbox to extend each line slightly past its endpoint, giving your model hand-drawn sketched appearance. This edge rendering style does not affect inference behavior. Enter a length, in pixels, for the extension lines in the pixels field. The following image shows a series of cubes with edges and extension edges.

Endpoints
Check the Endpoints checkbox to place additional line thickness at the endpoints of lines. Enter a length, in pixels, for the length of the emphasized endpoints in the pixels field. The following image shows a series of cubes with edges and endpoints edges.
Jitter

Check the Jitter checkbox to render each line multiple times at a slight offset, giving your model hand-drawn sketched appearance. This edge rendering style does not affect inference behavior. The following image shows a series of cubes with edges and jitter edges.

![Image of cubes with jitter edges]

Halo

Check the Halo checkbox to create a halo affect where lines overlap in your model by ending lines, that would normally overlap, a certain distance away from the overlap point. Type a number in the halo text field representing the distance away from the intersection where lines will end. This option is only available for styles that have a Sketchy Edge.

Level of Detail

Move the Level of Detail slider to the right increase the number of displayed edges. Move the Level of Detail slider to the left to decrease the number of displayed edges. This option is only available for styles that have a Sketchy Edge.

💡 Tip - Experiment with combinations of edge renderings to see how they appeal to you.

Color

SketchUp also allows you to manipulate the edge color on the screen.

📝 Note - Edge Colors are only available when using Shaded and Shaded with Textures Face Rendering Styles. Inference alignments to edges are not available when edges are hidden.
**All Same**
Select the All Same drop-down list item to display all edges using the Edges color as defined in color swatch. This option does not actually change any edge color assignments you may have made, but preserves them if you choose to view them again.

**By Material**
Select the By Material drop-down list item to display edges using an assigned material color. The following image contains edges painted with a grey material.

**By Axis**
Select the By Axis drop-down list item to display edges in colors corresponding to the color of the drawing axes to which they are parallel. This option is helpful in determining when edges are not aligned to an axis. The following image has lines colored red, green, and blue corresponding to the axes to which they are aligned.
The Styles Browser Face Panel

SketchUp contains a variety of face rendering styles allowing you to manipulate the amount of material and textures displayed on the screen.

Front Color
Click on the Front color button to set the default color for all front sides of faces. Materials assigned to faces override this setting.

Back color
Click on the Back color button to set the default color for the back sides of faces. Materials assigned to faces override this setting.

Wireframe
Click on the Wireframe face rendering style button to display the model as a collection of lines. Faces are not displayed in Wireframe mode.

Note - You cannot use face modification tools, such as the Push/Pull Tool, on a wireframe rendered model

Hidden Line
Click on the Hidden Line button to display faces in the model without any shading or textures.

Tip - Use this face rendering style when creating black and white printouts which you might want to modify further with traditional media, or which you might use as an underlay for hand drawings.
Monochrome
Click on the Monochrome button to display the model as an assembly of edges and faces, just as with the Hidden Line face rendering style. However, Monochrome mode provides default shading and is useful for shadow studies whereby you turn the face front and face back to white and then display shadows.

Shaded
Click on the Shaded button to display faces in the model as shaded to reflect a light source. Any color that had been applied to a face will be displayed. Remember that both sides of faces can have different colors. The default colors for front and back face are displayed when no color has been applied to a face.

Shaded with Textures
Click on the Shaded with Textures button to display the faces in model with the texture images that have been applied to a face.

Tip - Textures can slow down SketchUp's performance. Use other face rendering styles, such as the Shaded face renderings style, when performance slows dramatically. Switch back to the Shaded with Textures face rendering mode to create your final output.
Monochrome
Click the Monochrome button to display the faces with the default front and back face color.

X-Ray
Click on the X-Ray button to display all faces in SketchUp with a global transparency. This option allows you to see through the model's faces and edit edges behind faces and can be combined with any of the above face rendering styles.

You can easily visualize, select, and snap to points and edges that would otherwise be hidden behind faces when modeling with X-ray mode. Remember, however, that it is not possible to select and infer faces that would otherwise be hidden.

Faces can not cast Shadows when using X-ray mode. Shadow display will default to ground plane shadows only when X-ray mode is enabled. X-ray mode is different than material transparency.

Enable Transparency
Click on the Enable transparency checkbox to enable or disable global material transparency.

Transparency Quality
The Transparency Quality options allow you to select the quality of transparency display between faster, medium, and nicer. Each option differs in its speed and quality of transparency sorting. The Faster display sacrifices sorting accuracy to provide a faster rendering update rate. Conversely, the Nicer display performs additional calculations to correctly sort transparent surfaces.

Because SketchUp's transparency system is designed for real-time feedback and display, it may sometimes display transparent faces in an unrealistic way: Faces may appear as if they were in front of other surfaces when they are really behind, and vice-versa.
The Styles Browser Modeling Panel

The Modeling panel contains styles for how a variety of entities are displayed on the screen.

Selected
Click on the Selected button to set the color of the highlight used to indicate a selection. Use a color that will contrast well with the other colors in your model when selecting a selected color.

Locked
Click the Locked button to set the color of any locked component.

Guides
Click on the Guides button to set the color of any Guide Line entities in your model.

Inactive Section
Click on the Inactive Section button to define the color for the currently inactive (not highlighted) Section Plane entities in your model.

Active Section
Click on the Active Section button to define the color for the currently active (highlighted) Section Plane entity.

Section Cuts
Click on the Section Cuts button to define the color for the active section plane’s section slice line.

Section Cut Width
Enter a Section Cut Width to define the thickness (in pixels) of all cut lines in the active section plane.

Hidden Geometry
Check the Hidden Geometry checkbox to display hidden geometry or entities that have been hidden using the Hide menu item or context command. The Hidden Geometry checkbox displays hidden faces with a light cross-hatch pattern (edges are displayed dashed), enabling you to select the geometry. Once selected, hidden geometry can be made visible with the Unhide > Selected, UnHide > Last, and Unhide > All menu items.

Color by Layer
Check the Color by Layer checkbox to apply materials to geometry on a per layer basis using the color associated with the layer. Ensure shaded or shaded with Textures display is turned on to view materials.

Guides
Check the Guides checkbox to display guide line entities and guide point entities.

Section Planes
Check the Section Planes checkbox to display Section Plane entities.
Section Cuts
Check the Section Cuts checkbox to display section cut effects.

Model Axes
Check the Axes checkbox to display the drawing axes.
The Styles Browser Watermark Panel

Refer to the Watermark section of this reference guide for additional information on the watermark feature.
Watermark

Watermark is part of the Styles Browser. This feature allows you to add a watermark-like image to foreground or background of the drawing area.
Watermark Panel

The watermark panel contains settings for all of the watermarks in a style.

Display Watermarks

Check the Display watermarks checkbox to display all active watermarks (all watermarks whose Active checkbox is checked). Uncheck the Display Watermarks checkbox to hide all watermarks.
Watermark Settings

There are several settings that you can make when creating or editing a watermark. These settings follow.

Create Mask

The Create Mask option uses brightness of the color to create a vignette-like mask. The white portion of the graphic will become transparent and the black portions of the graphic will use the background color.

Blend

Move the Blend slider to the right to increase the presence of the watermark while decreasing the presence of the model. Move the Blend slider to the left to increase the presence of the model while decreasing the presence of the watermark.

Position

There are three options for positioning your watermark. The positioning options are:

Stretched

Select the Stretched option to stretch the watermark across the drawing area. Check the Lock Aspect Ratio checkbox if you want the aspect ratio (height of image to width of image) to remain consistent such that the image is not distorted (the image might not fill the entire drawing area when aspect ratio is locked).

Tiled

Select the Tiled option to create copies, or tiles, of the watermark and tile them across the drawing area. Move the Scale slider to the left to create progressively more, smaller, watermarks. Move the Scale slider to the right to create progressively fewer, larger, watermarks.

Positioned

Select the Positioned option to position the watermark at one of nine pre-defined screen locations. Check the radio button in the Position matrix that best represents the location on the screen where you want your watermark. Move the Scale slider to the left to create decrease the size of the watermark. Move the Scale slider to the right to increase the size of the watermark.
Layers Manager

The Layers Manager is used to apply and manage layers in your model. Activate the Layers Manager from the Window menu. The following image shows the Layers Manager on Microsoft Windows:

The following image shows the Layers Manager on Mac OS X:

The Layers Manager displays all the layers and their associated visibility in the model. Every model has one layer, called Layer0, which will be visible the first time you activate the Layers dialog box.

Note - You cannot delete Layer0. Entities that reside on Layer0 always inherit their visibility from the layer of the components/groups that contain them. This makes layer 0 work like the default drawing layer. If you use any other layer as a drawing layer, all the entities that were created on that layer will become invisible when you hide that layer. This is not the case when hiding layer 0. Any entities that are on layer 0, but inside a group or component that is on another layer, will remain visible when you hide layer 0.

Caution - Remember, layers in SketchUp do not work exactly like layers in 2 dimensional programs. Namely, entities drawn with one layer appear in all layers in SketchUp.
Details Menu

Click on the right arrow next to the Delete button to open the details pop-up menu. This menu allows you to perform additional Layers Manager-related functions.

Select All
Select the Select All menu item to select all layers in the list of layers.

Purge
Select the Purge option to delete all unused layers (layers without any geometry).

Color by Layer
Select the Color by Layer menu item to apply materials to geometry on a per layer basis using the color associated with the layer. Ensure shaded or shaded with Textures display is turned on to view materials.
Layers Manager Options

Add
Click on the Add button to create additional layers. Enter the layer name (or press "Enter" on Microsoft Windows or "Return" on Mac OS X to accept the default name). Each new layer has a different color to help you distinguish layers.

Delete
Select a layer and click on the Delete button to delete a layer. You will be prompted to move entities on the deleted layer to another layer (the default or current layer) if there are entities unique to that layer.

Name
The Name column lists all the layers, by name, in the drawing. The current layer has a check next to its name. Check the box next to a layer name to make it the current layer. Click on the name of a layer to edit the name of the layer.

Click on the Name column header to sort the layer alphabetically. Click on the Name column again will reverse the order. You can select a multiple layers by dragging. You can also press the Ctrl key and click on layer names to selectively pick layers or press the Shift key and click to select a series of contiguous layers.

Visible
Click on the Visible checkbox to toggle the visibility of a layer. Click on the Visible column header to sort layers by visibility. Click again on the Visible column header to reverse the order. A hidden layer becomes automatically visible when you select the layer.

Color
The color column displays a color associated with each layer. Click on a layer and select a new color to change the color of the layer. Click on the Color column header to sort layers by color. Click again on the Color column heading to reverse the order.
Outliner

The Outliner is used to view your Group and Component hierarchies as a hierarchical tree. This feature is great for navigating through large models, restructuring the model hierarchy, locating instances of a particular component, or renaming groups and components. Activate the Outliner dialog box from the Window menu. The following image shows a screenshot of the Outliner on Microsoft Windows:

The following image shows a screenshot of the Outliner on Mac OS X:
Details Menu
Click on the right arrow next to the Filter field to open the details pop-up menu. This menu allows you perform additional Outliner-related functions.

Expand All
Select the Expand All menu item to expand (open all branches) the entire hierarchical view in the Outliner.

Collapse All
Select the Collapse All menu item to collapse (close all branches) the entire hierarchical view in the Outliner.

Sort by Name
Select the Sort by name menu item to toggle the sorting of the groups and components alphabetically.
Scenes Manager

The Scenes Manager is used to control the various features of SketchUp scenes. Activate the Scenes dialog box from the Window menu or from the scene tabs.

The Scenes Manager contains a list of all of the scenes for the model. Scenes in this list are displayed in the order in which they will be displayed when running an animation. The following image shows the Scenes Manager on Microsoft Windows:
The following image shows the Scenes Manager on Mac OS X:

⚠️ **Caution** - Each scene has a series of properties that you can store with that scene (Properties to save). Additionally, when you update a scene, you can choose those properties, of the properties that are stored with the scene, to update (the dialog box that appears when the Update button is clicked). If you choose to update a property that you are not storing with a scene (using Properties to save), the property will not be updated. Therefore, it is important to ensure you have all of the properties you want to store with a scene checked prior to updating a scene.
Details Arrow

Click on the arrow in the upper-right portion of the Scene Manager dialog box to show or hide additional Entity Info details.
Scenes Manager Options

Add Scene
The Add Scene button allows you to add a new scene to the current file. To add a scene:
1. Click on the Add Scene button. A new scene, with a default scene name, is added to the list of scenes and a scene tab appears above the drawing area.
2. (optional) Rename the default scene name to something that represents the view of the model that will appear in the scene. For example, if your scene contains a top-down view of the model, call the scene "Top."
3. (optional) Provide a description of the scene.
4. (optional) Unselect any properties you do not want to save with the scene.

Delete Scene
The Delete Scene button allows you to delete a scene from the current file. Select the scene in the list of scenes and click the Delete Scene button to delete the scene.

Update Scene
Use the Update Scene button to update a scene if you have made changes to the scene. To update a scene:
1. Select the scene you want to update.
2. Click on the properties, within Properties to save, to store with the scene.
3. Click on the Update Scene button. A Properties to Update dialog box appears.
4. Click on the properties you want to update. Remember, you can only update those properties that you have previously selected to be stored with the scene.
5. Click on the Update button.

Include in Animation
Use the Include in Animation option to indicate whether a scene should be used in the animation. Select a scene and check the Include in Animation option to include the scene in animation. Disable this option for scenes you want to work on but do not want in an animation.

Name
Click in the Name field to name the currently active scene.
Description
Click in the Description field to provide a short description or note for the currently active scene.

Properties to Save
The Properties to Save options are used to control the different properties that can be stored with each scene. Properties that are not checked in the Properties to save section cannot be updated with the Update button.

Camera Location
Click on the Camera Location checkbox to store the point of view, including the zoom distance and field of view, with the scene.

Hidden Geometry: Click on the Hidden Geometry checkbox to store the hidden geometry visibility with the scene.

Visible Layers
Click on the Visible Layers checkbox to store the visible layers with the scene.

Active Section Planes
Click on the Active Section Planes checkbox to store the active section planes with a scene.

Tip - Use different section cuts in successive scenes to create exciting animations with different cross sections of your model.

Drawing Style
Click on the Drawing Style checkbox to store the drawing style settings, such as edge rendering, with the scene.

Shadows Settings
Click on the Shadows Settings checkbox to store all shadow-related information, including type, time, date, and so on, with the scene.

Axes Location
Click on the Axes checkbox to store display and position of SketchUp's drawing axes with the scene.
Shadows Settings Dialog Box

The Shadows dialog box is used to control SketchUp's Shadows feature, including display, time and date, and site location and orientation. You can also use the Shadows Toolbar control to control shadows. Activate the Shadow Settings dialog box from the Window menu. The following image contains a screen shot of the Shadows Settings dialog box on Microsoft Windows:

![Shadows Settings on Windows](image)

The following image contains a screen shot of the Shadows Settings dialog box on Mac OS X:

![Shadows Settings on Mac](image)

**Note** - Ensure you have set the proper location for your model set through the Location panel of the Model Info dialog box for accurate shadow casting.

**Note** - Daylight savings time is not factored into shadow calculations.
Details Arrow

Click on the arrow in the upper-right portion of the Scene Manager dialog box to show or hide additional Entity Info details.
Shadow Options

SketchUp contains a variety Shadow setting options allowing you to manipulate the use of shadows within your model.

Display Shadows
Click on the Display Shadows checkbox to toggle between displaying and not displaying shadows within your model.

Time
Use Time slider to adjust the time of day used by SketchUp to determine the location of the sun for shadow casting. The slider adjusts the time from sunrise to sunset, with 12:00 noon in the middle of the slider. Type a time into the time text field to set a precise time.

Date
Use the Date slider to adjust the day of the year used by SketchUp to determine the location of the sun for shadow casting. The slider adjusts the date from January 1st to December 31st. Type a date into the date text field to set a precise day. You can specify the date in numerical form (11/8).

Light
Use the Light slider to control the intensity of the light in the model. (it lightens or darkens light). This option effectively lightens and darkens illuminated surfaces.

Dark
Use the Dark slider to control the intensity of light in the model. This option (it lightens or darkens shadows). This option effectively lightens and darkens the areas under shade and shadows.

On Faces
Click on the Faces checkbox to enable casting of Face shadows. This feature makes intensive use of your 3D graphics hardware and can cause performance degradation.

On Ground
Click the On Ground checkbox to enable the casting of shadows on the ground plane (the red/green plane).

From Edges
Click the From Edges checkbox to enable the casting of shadows from edges that are not associated with a face.
Fog Dialog Box

Fog is primarily used as a special effect during presentations. Click on the Fog menu item within the Window menu to display the Fog dialog box. The following image shows a screenshot of the Fog dialog box on Microsoft Windows:

The following image shows a screenshot of the Fog dialog box on Mac OS X:
Fog Options

There are a few options in the Fog dialog box for configuring fog.

Display Fog

Check the Display Fog checkbox to display fog in the drawing area. Uncheck the Display Fog checkbox to hide fog.

Fog Sliders

The left-most fog slider determines where you want the fog to start relative to the camera (your view). Fog can begin right in front of the camera which is zero on the scale or further away from the camera. Move the left-most slider to the right to start fog somewhere beyond the camera.

The right-most slider determines where you want the fog to be at 100% strength (known as zero visibility). Move the right-most slider to the left to establish 100 percent strength closer to the camera (your view). Move the right-most slider all the way to the left to have zero visibility right in front of the camera and extending out to infinity (you won't actually be able to see your model at all and at any distance).

Use Background Color

Check the Use background color checkbox to use the currently configured background color as the fog color. Refer to the Background Panel section of the Styles Browser topic for further information on setting the background color.

Uncheck the Use background color and click on the color swatch to select a different color to be used as the fog color.

Note - Use the OpenGL panel in the Application Preferences dialog box to set hardware acceleration before using fog.
**Match Photo Dialog Box**

The Match Photo dialog box controls are used to help you create accurate 3D models from photos and to accurately place models in a photo's context. This dialog box is only relevant during matching. Activate the Match Photo dialog box from the Window menu. Refer to the Match Photo dialog box section of the Matching Photos and Models topic for further information. The following image contains a screen shot of the Match Photo dialog box on Microsoft Windows:

![Match Photo Dialog Box](image)

The following image contains a screen shot of the Match Photo dialog box on Mac OS X:

![Match Photo Dialog Box](image)
Soften Edges Dialog Box

SketchUp's edges can be softened and smoothed to achieve a real-world appearance. Edges are automatically hidden when softened. Softened edges can also be smoothed rendering the adjoining faces with a smooth tonal gradient. The following series of images contains a column (lower part of each image) that is first softened (middle column) and then smoothed (right-most column).

Note - Softened edges are hidden automatically (but still exist in your model). Edges that are currently not visible will be displayed, along with any explicitly hidden geometry, when you enable the Hidden Geometry menu item on the View menu.

Tip - Triple-click on geometry to ensure you have hidden and unhidden geometry selected before performing a soften or smooth operation.

The Soften Edges dialog box allows you to automatically apply or remove softness and smoothing effects to the edges in your model. Activate the Soften Edges dialog box from the Window menu. The following image contains a screen shot of the Soften/Smooth Edge dialog box on Microsoft Windows:
The following image contains a screen shot of the Soften/Smooth Edge dialog box on Mac OS X:

![Soften/Smooth Edges Dialog Box]

**Tip** - There are several components to achieving a desired result using soften and smoothing effects. Namely, detailed geometry require additional facets (such as a column having many small sides) to achieve a clean soften or smooth effect. However, additional detail can affect the computer's performance. Conversely, adding detail to portions of a model that will be seen at a distance is likely a waste of the computer's resources. A good strategy for creating useful models is to try to use the least amount of geometry in conjunction with soften or smoothing effect to achieve the desired result (whether it be a detailed close-up or a panoramic).
**Soften Edges Options**

SketchUp contains a few Soften Edges options allowing you to manipulate the use of softening within your model.

**Note** - Edges that are shared by three or more faces cannot be softened. The following image shows an edge shared by three faces.

**Angle Between Normals**

Use Angle Between Normals slider to set the maximum size of all angles that will be smoothed or softened. The higher the setting, the more angles you are likely to smooth or soften with a smooth or soften command. Consequently, the higher the setting the more performance might degrade.

**Smooth Normals**

Click on the Smooth Normals checkbox to smooth any edges, essentially spreading color and texture over edges, to make the edges appear smooth.

**Soften Coplanar**

Click on the Soften Coplanar checkbox to soften edges, essentially deleting edges, between coplanar surfaces.

**Tip** - Create a three dimensional multi-sided polygon (with more than 5 sides) and experiment with these options to become familiar with softening and smoothing models. For example, create a 6-sided polygon, expand the polygon using the Push/Pull Tool, select the entire 3D polygon, click on Smooth Normals, and move the Angle Between Normals to 61 degrees. Notice that each edge of the polygon looks smooth because the angle between each normal is 60 degrees and, therefore, can be smoothed. Now move the slider to 59 degrees. Notice that the sides no longer look smoothed because the Angle Between Normals only operates on angles below or equal to 59 degrees. Experiment further by turning on the Soften Coplanar option to see edges appear and disappear.
Instructor

The Instructor dialog box displays information related to the currently selected tool. Click on a tool in the Toolbar or menu to view information about that tool in the instructor. Click on links in the instructor to navigate to sections in the online SketchUp User's Guide.
Application Preferences Dialog Box (Microsoft Windows)

SketchUp's application preferences are used to set various global behaviors for SketchUp. Activate the Preferences from the Window menu.

Applications

Use the Applications preferences panel to identify the application used to open an application for editing image files.

Default Image Editor

Click on the “Choose” button to display the Image Editor Browser. Use the browser to locate an image editor for your image files.

Compatibility

Use the Compatibility preferences panel to identify component and group highlighting and mouse wheel settings.

Component/Group Highlighting

Bounding box only: Click the Bounding box only checkbox to toggle between displaying only one bounding box or displaying a bounding box for each component and its corresponding edges when selected.

Mouse Wheel Style

Click the Invert checkbox to change SketchUp scroll wheel behavior to match Google Earth scroll wheel behavior (rolling forward zooms out, rolling backward zooms in).

Drawing

Use the Drawing preferences panel to define global mouse (or other input device) behavior.

Click Style

The Click Style options allows you to define how your input device reacts to clicks.

Click-drag-release: Click the Click-drag-release radio button to force the Line Tool to draw by click and holding the mouse button to define the start point of the line, dragging the mouse to extend the line, and releasing the mouse to establish the end point of the line.

Auto Detect: Click the Auto Detect radio button to use either Click-drag-release and Click-move-click as necessary.

Click-move-click: Click the Click-move-click radio button to force the Line Tool to draw by clicking and releasing the mouse button to define the start point of the line, moving the mouse to extend the line, and clicking again to establish the end point of the line.

Continue Line Drawing: Click the Continue line drawing checkbox to force the Line Tool to treat an end point as the start point of a new line, saving you one extra click required establish a new start point for the second line.

Miscellaneous

The Miscellaneous options define other global mouse behaviors.

Display crosshairs: Click the Display crosshairs checkbox to display a set of colored crosshairs (corresponding to axes colors) when drawing.
Extensions
Use the Extensions preferences panel to add or remove SketchUp extensions from the user interface. An extension can be an add-on tool or feature created by Google that is not necessarily a part of core SketchUp functionality.

Click in the check box next to the extension that you want to enable in SketchUp. The extension will be available (menu items and optional Toolbar) the next time you run SketchUp.

Files
The Files preferences panel defines various locations for files used by SketchUp (such as the default location for Components and Materials).

Models
Use the Models field to define the default location for all of your models. SketchUp uses this location as the starting point for all open and save file operations.

Components
Use the Components field to define the default location used when you open or create a collection using the Components Browser.

Materials
Use the Materials field to define the default location used when you open or create a library using the Materials Browser.

Styles
Use the Styles field to define the default location used when you open or create a library using the Styles Browser.

Texture Images
Use the Texture Images field to define the default location for all images that can be used as a texture. SketchUp uses this location as the starting point for all File > Insert > Image as Texture operations.

Watermark Images
Use the Watermark Images field to define the default location for all images that can be used as a watermark.

Export Models
Use the Export Models field to define the default location for all models that are exported. SketchUp uses this location as the starting point for all File > Export > 3D Model operations.

General
Use the General preferences panel to define global save and user interface settings.

Saving
Create Backup: Click on the Create Backup checkbox to automatically create a backup file whenever you save a drawing. The backup file is the previously saved version of the file. This file will be saved to the same folder as the drawing file. For example, if your drawing is hotel.skp, the backup will be called hotel.skb.

Auto-Save: Click the Auto-Save checkbox to automatically save changes to your drawing into a temporary file at a specific time interval. This temporary file is available on the file system should SketchUp abnormally exit. Type the auto-save interval, in minutes, into the minutes field.
The temporary file's name will be a combination of the word "AutoSave" with the original filename, such as AutoSave_hotel.skp. This file is saved in the directory where the original .skp file exists.

⚠️ **Caution** - Google strongly recommends you keep the Auto-Save option checked to ensure that your valuable work is retained.

SketchUp checks your model for unrecoverable errors during the auto-save, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

**Tool Palette**
SketchUp has two differently sized toolbars. The large tool buttons are easier for some users to see and use (they provide larger areas to click with your mouse) and are easier to use with a pen and tablet. Smaller buttons save screen space, allowing a larger drawing area.

Use Large Tool Buttons: Click on the Use large tool buttons checkbox to toggle between large and small tool buttons.

**Check Model For Problems**
The Check Model for Problems options allow you to enable problem checking for your SketchUp models.

Automatically check models for problems: Check the Automatically check model for problems checkbox to check for minor problems with your model. These problems can occur given the infinite flexibility that SketchUp provides when designing in 3D. Your model is assessed for problems when it is loaded or saved. Google strongly recommends checking this box to ensure that problems are corrected proactively, allowing your model to perform optimally. You must manually check for problems using the Fix Problems button in the Statistics panel of the Model Info dialog box if you leave this checkbox unchecked.

Automatically fix problems when they are found: Check the Automatically fix problems when they are found checkbox to have SketchUp fix problems found in your model automatically (without having to display a dialog box). Leave this checkbox unchecked if you want SketchUp to display a dialog box (with the Always fix my models, Fix it now, and Fix it later options) when a problem is found.

**Scenes and Styles**
The Scenes and Styles options allow you to enable warnings for style changes.

Warn of style changes when creating scenes: Click the Warn of style changes when creating scenes if you want to be notified when a style has changed when adding scenes to your file.
OpenGL

Use the OpenGL preferences panel to define how the OpenGL standard should be applied within SketchUp.

- **Note** - You might notice intermittent streaks or small spots of light within face shadows. A minimal amount of these artifacts is to be expected on most systems, and can vary greatly with the quality of your OpenGL driver.

- **Caution** - Certain OpenGL drivers do not fully support casting shadows on faces.

- **Caution** - SketchUp's Shadow feature can have a severe performance impact on slower computers or those using software rendering.

OpenGL Settings
The OpenGL Settings allow you to speed up OpenGL drawing.

**Use hardware acceleration:** Click on the Use Hardware acceleration checkbox to use the hardware acceleration features of a video card. Unfortunately, only a small percentage of 3D drivers in the consumer video card market are 100% OpenGL compatible and can use this feature (though many cards claim to be 100% OpenGL compatible). Most 3d drivers are designed for games, and are rarely tested using other 3D programs. Consequently, numerous incompatibility problems can occur requiring a fix from the video card manufacturer. Disable this option if you are having problems with the 3D rendering of your models or if your video card is not 100% OpenGL compatible and does not support hardware acceleration.

- **Note** - Hardware Acceleration might only be available on your system for certain resolutions and color depths. Check the system settings for your graphics card to see if it supports hardware acceleration (using the Control Panel on Microsoft Windows).

Google cannot control the quality of the OpenGL driver on your computer system. Video card device drivers are proprietary and are maintained solely by the manufacturer of the video card in your system. Therefore, Google cannot guarantee that SketchUp will work with hardware acceleration on your system. Refer to the OpenGL topic for further information.

**Use maximum texture size:** Check the Use maximum texture size checkbox to use the maximum texture size supported by your graphics card. This option might result in a slowing of SketchUp unless your graphics card and computer can handle what is advertised.

**Use fast feedback:** Check the Use fast feedback checkbox to increase performance when editing large models. SketchUp runs a test to assess whether your video card can support this option on startup. SketchUp will activate (check) this option if fast feedback is supported. You can also attempt to use this feature by checking the Use Fast Feedback checkbox manually; however you will be warned by SketchUp that enabling this option could cause problems on your system if fast feedback is not supported.

Google strongly recommends that you set your driver's anti-aliasing setting to application controlled (which is normally the default setting for most graphic card drivers) to ensure that fast feedback functions properly. It is possible that you will see rendering anomalies, such as blurring of the model, when using fast feedback under a non-application controlled setting.
Correct reversed picking driver bug: Check the Correct reversed picking driver bug checkbox to correct an issue whereby some video card device drivers cause SketchUp to select the reverse of faces with the Select Tool. This setting provides a solution to this problem.

Capabilities
The capabilities table lists one or more different graphic card settings combinations that might work well within SketchUp. These combinations were selected by SketchUp, on execution, from a large list of settings combinations supported by your graphics card. SketchUp defaults to the most basic of these combinations to ensure your models will be rendered properly. Choose a different combination if you want to alter your graphics capabilities within SketchUp.

Anti-Alias: SketchUp generally defaults to a combination with a zero anti-alias value. Higher anti-alias values, such as 2x or 4x, can create smoother looking lines in SketchUp. However, you might experience some flickering and reduced rendering performance if a higher anti-alias value is selected.

Details: Click on the Details button to view details about your video card.

Shortcuts
Use the Shortcuts preferences panel to define keyboard shortcuts for most SketchUp commands.

Filter Field
Type a phrase in the Filter to list shortcuts of a specific type.

Function List
The Function list contains all of the functions that can be assigned a keyboard shortcut.

Add Shortcut Field
Type a keyboard shortcut, to be assigned to the currently selected function, in the Add Shortcut field.

Add Shortcut Button
Click the add shortcut button to add the keyboard shortcut in the Add Shortcut field to the currently selected function.

Assigned Field
The Assigned field contains a list of keyboard shortcuts assigned to the currently selected function.

Assigned Button
Click the assigned button to remove the currently selected keyboard shortcut (in the Assigned field) from the list of shortcuts assigned to a function.

Reset All Button
Click the Reset All button to reset all keyboard shortcuts to their factory defaults.

Import Button
Click the Import button to import a keyboard shortcuts file. Refer to Importing Preferences, Including Keyboard Shortcuts for more information.

Export Button
Click the Export button to export current keyboard shortcuts as a keyboard shortcuts file. Refer to Exporting Preferences, Including Keyboard Shortcuts for more information.
Template

Use the Template preferences panel to designate a SketchUp file that you would want to use as a template for all of your subsequent models.

Drawing Template Drop-Down List

The Drawing Template drop-down list contains a list of all of the templates available in SketchUp.

Browse Button

Click the "Browse" button to browse for a template. The Browse for Template dialog box is displayed. Locate and select a template using this dialog box.
Application Preferences Dialog Box (Mac OS X)

SketchUp’s application preferences are used to set various global behaviors for SketchUp. Activate the Preferences from the SketchUp menu.

Applications

Use the Applications preferences panel to identify the application used to open an application for editing image files.

Default Image Editor

Click on the “Choose” button to display the Image Editor Browser. Use the browser to locate an image editor for your image files.

Drawing

Use the Drawing preferences panel to define global mouse (or other input device) behavior.

Click Style

The Click Style options allow you to define how your input device reacts to clicks.

Click-drag-release: Click the Click-drag-release radio button to force the Line Tool to draw by click and holding the mouse button to define the start point of the line, dragging the mouse to extend the line, and releasing the mouse to establish the end point of the line.

Auto Detect: Click the Auto Detect radio button to use either Click-drag-release and Click-move-click as necessary.

Click-move-click: Click the Click-move-click radio button to force the Line Tool to draw by clicking and releasing the mouse button to define the start point of the line, moving the mouse to extend the line, and clicking again to establish the end point of the line.

Continue Line Drawing: Click the Continue line drawing checkbox to force the Line Tool to treat an end point as the start point of a new line, saving you the one extra click required establish a new start point for the second line.

Miscellaneous

The Miscellaneous options define other global mouse behaviors.

Display crosshairs: Click the Display crosshairs checkbox to display a set of colored crosshairs (corresponding to axes colors) when drawing.

Auto-activate paint tool: Click the Auto-activate paint tool checkbox to automatically activate the Paint Bucket Tool after you select a color swatch.

Extensions

Use the Extensions preferences panel to add or remove SketchUp extensions from the user interface. An extension can be an add-on tool or feature created by Google that is not necessarily a part of core SketchUp functionality.

Click in the check box next to the extension that you want to enable in SketchUp. The extension will be available (menu items and optional Toolbar) the next time your run SketchUp.
General

Use the General preferences panel to define global save and user interface settings.

Create Backup
Click on the Create Backup checkbox to automatically create a backup file whenever you save a drawing. The backup file is the previously saved version of the file. This file will be saved to the same folder as the drawing file. For example, if your drawing is hotel.skp, the backup will be called hotel.skb.

Auto-Save
Click the Auto-Save checkbox to automatically save changes to your drawing into a temporary file at specific time interval. This temporary file is available on the file system should SketchUp abnormally exit. Type the auto-save interval, in minutes, into the minutes field.

The temporary file’s name will be a combination of the word "AutoSave" with the original filename, such as AutoSave_hotel.skp. This file is saved in the Autosave folder under <user>/Library/Application Support/SketchUp/Autosave if the model has never been saved. SketchUp puts the auto save file in the same directory as the model file.

⚠️ Caution - Google strongly recommends you keep the Auto-Save option checked to ensure that your valuable work is retained.

SketchUp checks your model for unrecoverable errors during the auto-save, preventing the overwriting of a good auto-save file. SketchUp will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. Google recommends you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable information regarding the unrecoverable errors.

Tool Palette
SketchUp has two differently sized tool pallets. The large tool buttons are easier for some users to see and use (they provide larger areas to click with your mouse) and are easier to use with a pen and tablet. Smaller buttons save screen space, allowing a larger drawing area.

Use Large Tool Buttons: Click on the Use large tool buttons checkbox to toggle between large and small tool buttons.

Main Window
The Main Window options allow you to set the behavior for the main SketchUp window.

Cascade main windows: Click on the Cascade main windows checkbox to place newly created drawing windows lightly below and to the right (cascaded) of the previous drawing window. This feature is useful if you want to see all of your drawing window title bars. Newly created drawing windows will appear directly on top of each other when this option is not enabled.

Save current window size: Click on the Save current window size button to save the window size for the currently active drawing window as the default size for SketchUp.

Check Model For Problems
The Check Model for Problems options allow you to enable problem checking for your SketchUp models.
Automatically check models for problems: Check the Automatically check model for problems checkbox to check for minor problems with your model. These problems can occur given the infinite flexibility that SketchUp provides when designing in 3D. Your model is assessed for problems when it is loaded or saved. Google strongly recommends checking this box to ensure that problems are corrected proactively, allowing your model to perform optimally. You must manually check for problems using the Fix Problems button in the Statistics panel of the Model Info dialog box if you leave this checkbox unchecked.

Automatically fix problems when they are found: Check the Automatically fix problems when they are found checkbox to have SketchUp fix problems found in your model automatically (without having to display a dialog box). Leave this checkbox unchecked if you want SketchUp to display a dialog box (with the Always fix my models, Fix it now, and Fix it later options) when a problem is found.

Scenes and Styles
The Scenes and Styles options allow you to enable warnings for style changes.

Warn of Style Changes When Creating Scenes: Click the Warn of style changes when creating scenes if you want to be notified when a style has changed when adding scenes to your file.

OpenGL
Use the OpenGL preferences panel to define how the OpenGL standard should be applied within SketchUp.

- **Note** - You might notice intermittent streaks or small spots of light within face shadows. A minimal amount of these artifacts is to be expected on most systems, and can vary greatly with the quality of your OpenGL driver.

- **Caution** - Certain OpenGL drivers do not fully support casting shadows on faces.

- **Caution** - SketchUp's Shadow feature can have a severe performance impact on slower computers or those using software rendering.

OpenGL Settings
The OpenGL Settings allow you to speed up OpenGL drawing.

Use Hardware Acceleration: Click on the Use Hardware acceleration checkbox to use the hardware acceleration features of a video card. Unfortunately, only a small percentage of 3D drivers in the consumer video card market are 100% OpenGL compatible and can use this feature (though many cards claim to be 100% OpenGL compatible). Most 3d drivers are designed for games, and are rarely tested using other 3D programs. Consequently, numerous incompatibility problems can occur requiring a fix from the video card manufacturer. Disable this option if you are having problems with the 3D rendering of your models or if your video card is not 100% OpenGL compatible and does not support hardware acceleration.

- **Note** - Hardware Acceleration might only be available on your system for certain resolutions and color depths. Check the system settings for your graphics card to see if it supports hardware acceleration (using the System Preferences on Macintosh OS X).
Google cannot control the quality of the OpenGL driver on your computer system. Video card device drivers are proprietary and are maintained solely by the manufacturer of the video card in your system. Therefore, Google cannot guarantee that SketchUp will work with hardware acceleration on your system. Refer to the OpenGL topic for further information.

**Use maximum texture size:** Check the Use maximum texture size checkbox to use the maximum texture size supported by your graphics card. This option might result in a slowing of SketchUp unless your graphics card and computer can handle what is advertised.

**Use Fast Feedback:** Check the Use fast feedback checkbox to increase performance when editing large models. SketchUp runs a test to assess whether your video card can support this option on startup. SketchUp will activate (check) this option if fast feedback is supported. You can also attempt to use this feature by checking the Use Fast Feedback checkbox manually; however you will be warned by SketchUp that enabling this option could cause problems on your system if fast feedback is not supported.

**Shortcuts**

Use the Shortcuts preferences panel to define keyboard shortcuts for most SketchUp commands.

**Assigning Keyboard Shortcuts**

Keyboard shortcuts can dramatically speed up your drawing by allowing you to change tools while keeping the mouse cursor near the drawing area. To assign a keyboard shortcut:

1. Select the command to which you will assign a keyboard shortcut (within the Function list). Existing keyboard shortcuts for this command will display in the Key column.

   ![Note] - The list of commands available in the Shortcuts panel is dynamically generated and includes all menu items and active context menu items. Some context menu items become active only after performing another task. For example, select a face to activate the Reverse Faces command and then open Preferences > Shortcuts to set a keyboard shortcut for Reverse Faces.

2. Type the keyboard shortcut key sequence in the text field at the bottom of the panel. Shortcut keys can consist of any keyboard key, except number keys, with a few exceptions. Any key that can be used as a shortcut can also be assigned a modifier key like Shift, Control, or Option. SketchUp will indicate when a key or key combination cannot be used or is already assigned.

   SketchUp will prompt you before allowing you to assign a keyboard shortcut that is already assigned to another command. Some keys are reserved for use by Mac OS X and can not be assigned as a keyboard shortcut.

   ![Note] - Keyboard shortcuts are saved to Home/Library/Application Support/SketchUp/Shortcuts.plist. You can copy this file to other users or computers.
The Measurements Toolbar and Keyboard Shortcuts
Temporary focus is given to the Measurements Toolbar when you type a number while in the drawing area. Therefore, numbers cannot be used as shortcut keys. The letters S, R, X, and the symbols / and * can be used within keyboard shortcuts and as you enter values in the Measurements Toolbar. Add a prefix to any of these letters with a number in the Measurements Toolbar to ensure that a command with a corresponding keyboard shortcut letter is not invoked. For example, 7s would be the correct entry to redefine a segmentation in the Measurements Toolbar. However, s7 will activate whatever command is invoked with the letter S as a keyboard shortcut.

Tip - Do not use the spacebar or backspace keys as keyboard shortcuts to avoid conflict with values entered in the Measurements Toolbar.

Template
Use the Template preferences panel to designate a SketchUp file that you would want to use as a template for all of your subsequent models.
Color Pickers (OS X)

SketchUp on OS X uses the Apple System Color Picker, with some enhancements for SketchUp, for all operations in which you create, modify and apply color. However, SketchUp's Color Picker has been enhanced.

Activate the Color Picker by clicking on any color well in SketchUp's interface (such as in the Material Browser), by clicking on the Colors control in the Toolbar, or by selecting the Paint Bucket Tool.

Note - SketchUp supports the new system-wide Color Picker in OS X 10.2 (called "Jaguar").

The Color Picker Dialog Box

The Color Picker dialog box contains a variety of different material and color controls providing several options for experimenting with color and materials in your SketchUp models.

Toolbar

The Toolbar at the top of the Color Picker dialog box contains icons representing each of the available color pickers. Switch between these color pickers by clicking one of these icons.

Active Color Well

The Active Color Well, below the Toolbar, contains the current color selection. You can drag and drop color swatches from this color well into your model or into any other visible color well.

The contents of the Active Color Well are maintained as you switch between color pickers, allowing you to use different pickers to create your colors.

Note - Ensure that the Shaded or Shaded with Textures display style is selected to ensure applied colors and materials are displayed.
**Screen Picker**
The Screen Picker, represented as a magnifying glass, is used to choose a color from any element currently visible on your Apple Macintosh screen.

**Color Picker Controls**
The Color Picker Controls, below the Active Color Well, differ for each Color Picker. See the Color Pickers section of this topic for additional information.

**Opacity Slider**
SketchUp supports adjustable (by material) transparency. The Opacity slider, below the Color Picker Controls, is used to adjust the opacity level. Type an opacity value in the text field to the right of the slider if you prefer to set opacity levels more precisely.

Be sure to activate SketchUp’s material transparency within the Edit tab of the Styles Browser before experimenting with the Opacity Slider.

**User Palette**
The User Palette, at the bottom of the Color Pickers, is an expandable palette of small color wells. To use the User Palette:

- Drag and drop a color or texture swatch from any visible color well, including the Active Color Well, and drop it over a User Palette well to add a color to the User Palette.
- Drag and drop a new swatch in the place of another color swatch to replace a swatch in the User Palette.
- Drag and drop an empty swatch onto a color to remove a color from the User Palette.
- Click and drag down on the size handle (a small circle) in the middle of the bottom edge of the palette to see more wells.

**Note** - The colors and materials in the User Palette are saved in SketchUp and can be used between multiple modeling sessions.

**Note** - Ensure that the Shaded or Shaded with Textures display style is selected to see the colors that you have applied to entities.

**Color Picker Types**
SketchUp contains four color picker types used to select materials that do not have texture (just color), and a materials picker (containing color/texture combinations that mimic real-world construction materials).

**Note** - Ensure that the Shaded or Shaded with Textures display style is selected to see the colors that you have applied to entities.

**Color Wheel Picker**
The Color Wheel picker allows you to select a color by Hue, Saturation, and Brightness.

Select the color you want by clicking your mouse over that color in the Color Wheel. You can also click and drag the cursor around the Color Wheel to quickly browse through many different colors. You will see a dynamic preview of the selected color in the Active Color Well at the top of the Color Picker.
The Color Wheel arranges color hue radially around the wheel, with the highest saturation at the outer edge of the wheel. Slide the value slider, to the right of the wheel, up or down, to change the brightness of the color.

The Color Wheel Color Picker is the simplest and most versatile of the standard Apple Color Pickers, though it is also the least precise. You might want to use the Color Wheel picker to make a rough color choice, and then use one of the Color Slider pickers to fine tune your choice.

### Color Slider Picker

The Color Slider Picker contains four pickers: Gray Scale Slider, RGB Sliders, CMYK Sliders, and HSB Sliders. These color pickers differ only in the components they use to mix colors. Select the Color Slider picker from the pop-up menu at the top of the Picker control area to choose one of the Color Slider pickers.

**Gray Scale Slider:** The Gray Scale slider allows you to select colors from the grayscale color range (shades of gray).

Adjust the slider until you see the color you want in the Active Color Well. Alternatively, you can select a color by typing a percent gray value directly in the text box to the right of the slider. Or, choose from one of the five preset gray values below the slider.

**RGB (Red, Green & Blue) Sliders:** The RGB sliders allow you to select colors from the RGB (Red, Green and Blue) color range. RGB colors are traditionally used when modeling color on a computer screen and represent the closest approximation of the actual range of colors recognizable by the human eye. RGB has a wide color gamut and is one of the most effective color spaces to use in SketchUp.

Drag the sliders left and right for each of the component colors (red, green and blue) to create the color that you want to use. The background color of each slider changes as you modify values to help you predict how adjustments will change your color mix.

Alternatively, you can type in exact numerical values for red, green or blue in the value boxes to the right of the sliders to precisely match a color that you have specified elsewhere.

**CMYK (Cyan, Magenta, Yellow & Black) Sliders:** The CMYK sliders allow you to select colors from the CMYK (Cyan, Magenta, Yellow and Black) color range. CMYK is traditionally used to select colors intended for professional printing, where colors are usually specified in percentages of these four basic ink colors. RGB or HSB color pickers are generally sufficient for most work in SketchUp.

Drag the sliders left and right for each of the component colors (cyan, magenta, yellow and black) until you have the color you want to use. To help you find an exact color, the background color of each slider will change as you modify values to help you predict how adjustments will change your color mix.

**HSB (Hue, Saturation & Brightness) Sliders:** The HSB Color sliders allow you to pick colors from the HSB (Hue Saturation and Brightness) color range. HSB often gives you a more intuitive color model for selecting desaturated colors.

Adjust the sliders for Hue, Saturation and Brightness until you see the color you want in the Active Color Well.

Sometimes it is easier to mix de-saturated colors using the HSB Color Picker in conjunction with one of the other color pickers. Switch to another color picker to make your rough color selection, then switch back to the HSB Color Picker to fine tune or mix desaturated colors.
**Image Palettes**
The Image Palettes Picker allows you to load an image file into the Color Picker and select colors from anywhere in that image. The Image Palettes Picker has a spectrum image loaded as a default.

**Texture Palette Picker**
The Texture Palette Picker is unique to SketchUp and is the picker that you use to create, modify and manage SketchUp-specific materials.

**Swatch Browser:** The middle of the Texture Palettes Picker contains a Swatch Browser, in which thumbnail images for all available materials from the currently selected materials List are displayed. To use the Swatch Browser:

- Drag your mouse over a swatch to see a tool tip with the texture's name.
- Click on a swatch to load it in the Active Color Well for use in your model.
- Double-click on a swatch to open the material for editing. See the "Editing Materials" section for more information.
- Drag and drop materials within the Swatch Browser to re-sort the materials.
- Drag and drop image files directly from the finder into the Swatch Browser. You will be prompted to supply a name and dimensions for the material when you drag and drop an image file into the Swatch Browser.

The Color and List drop-down menu are below the Swatch Browser. Use the Color menu to manage and create new materials and the List menu to manage and create new material lists. See Material Libraries for additional information.

**Crayons Picker**
The Crayons Picker displays a graphic representation of a box of crayons with a small range of standard Apple colors. The Crayon Picker is the simplest picker to use and is fairly limited in the range of colors available.

Click on the crayon whose color you want to use to select a color with the Crayon Picker. The crayon's color will be transferred to the Active Color Well.

**Texture Pallet Picker Options**
SketchUp contains a library of predefined materials. These materials are grouped into categories, within the Texture Palette Picker, in the pop-up menu below the Active Color Well. Select the category of material you want to use to see several related materials. Or, use the forward and backward arrows next to this pop-up to quickly step forward and backward through your previously selected material categories.

**Colors In Model**
The Texture Palettes Picker includes a special material library called Colors In Model containing all materials currently used in your model. The contents of this library are generated automatically as you add materials to your SketchUp model.

Select the Colors In Model from the materials library drop-down menu, or simply click on the icon shaped like a house, to view all of the materials in your model.
Color Menu
The Color drop-down menu allows you to manipulate materials within the Colors In Model materials library.

Edit: Click on the Edit menu item to edit the material. See Editing Materials below for further information.

Remove: Click on the Remove menu item to remove the material from the Colors In Model materials library. You will be prompted to replace the material with the default material if the material is currently used within your model.

Duplicate...: Click on the Duplicate... menu item to duplicate a material within the Colors In Model materials library. You will be prompted to provide a new name for the duplicate material.

New Texture...: Click on New Texture... menu item to import an image file containing new material. You will be prompted to select the image file from a file system to import as a new texture. After you have selected the image file to import, type in the name for the new material followed by the dimension, in inches, that comprise the size of the texture swatch that will be repeated when painted on your model.

SketchUp can place any image supported by Apple's QuickTime media layer as a texture. Supported Image file types include JPEG, PNG, PDF, PICT, PSD, EPS, SGI, and TIFF files.

Note: SketchUp for OS X supports the alpha channel in image files that support transparency, such as PNG, PSD and TIFF files.

List Menu
The List drop-down menu allows you to create, duplicate, remove, and purge unused materials libraries.

New...: Click on New... to create a new materials library. You will be prompted to provide a name for the new library.

Duplicate...: Click on Duplicate... to Duplicate the currently selected materials library. You will be prompted to provide a name for the duplicate library.

Remove: Click on Remove to remove a materials library. You will be prompted to click Remove or Cancel to commit this action. Certain standard Apple color libraries, such as the Web Safe Colors library, cannot be removed.

Purge Unused: Click on Purge Unused, from within the Colors In Model library to remove any materials that appear in this library, but are not being used in the model. This option is useful when your Colors In Model library becomes cluttered with materials that are no longer used in your model.

Edit Material Panel
The Edit Material panel allows you to modify the following material properties:

Name: Enter a new name for a material to change the name of the material being edited.

Texture: This drop-down menu allows you to load a materials image file, remove the texture portion of an image file that you are editing, or reset any colorization applied to the material. A flat color approximation of the removed image appears when the texture image is removed.
**Width/Size:** Using the Width and Height text boxes, you can change the actual size of the texture material in your model. To maintain the proportions of the material you are editing, ensure that the chain icon to the right of the fields is unbroken. Click on the chain icon to toggle aspect locking on and off.

⚠️ **Note** - If you have a texture image assigned to the material you are editing, picking a color from any of the Color Pickers will colorize the texture image instead of replacing it with a flat color. This is a great way to quickly and loosely experiment with variations in material color.

**Using SketchUp Material Libraries**

SketchUp stores materials in the cross-platform .SKM file format. Following are some details about materials files:

- .SKM files are also created every time you use the Texture Palette Picker to create a new material library.
- .SKM files are stored in the directory ~/Library/Application Support/SketchUp. Place a .SKM file in this directory to add a new materials library to SketchUp.
- .SKM files created on Mac OS X are identical to those created under Windows and can be shared transparently between platforms.
Color Pickers (Microsoft Windows)

The Choose Color dialog box contains a variety of different color controls that combine to give you a versatile mechanism for experimenting with color in your SketchUp models.

You can activate the Choose Color dialog box by clicking on any color swatch in the SketchUp user interface (such as in the Colors section of the Model Info dialog box).

![Choose Color dialog box](image)

Color Picker Menu

SketchUp allows you to choose between four color pickers: Color Wheel, HLS, HSB, and RGB. Click on the color picker that you want to use in the drop-down menu within the Choose Color dialog box.

Active Color Well

The Active Color Well, which is below the Color Picker menu, contains the current color selection.

The contents of the Active Color Well are maintained as you switch between pickers, allowing you to use different pickers to create your colors.

Color Picker Types

SketchUp contains four color picker types, used to select materials that do not have texture (just color).

Note - Ensure that the Shaded or Shaded with Textures display style is selected to see the colors that you have applied to entities.

Color Wheel

The color wheel arranges color hue radially around the wheel, with the highest saturation at the outer edge of the wheel. To change the brightness of the color, slide the value slider to the right of the wheel up or down.

To use the Color Wheel, select the color you want by clicking your mouse over that color in the wheel. You can also click and drag the cursor around the Color Wheel to quickly browse through many different colors which will dynamically appear in the Active Color Well.

HSB (Hue, Saturation & Brightness) and HLS (Hue, Light, and Saturation)

The HSB and HLS Color Pickers allow you to pick colors from the HSB (Hue Saturation and Brightness) color range. HSB often gives you a more intuitive color model for selecting desaturated colors.
Adjust the sliders for Hue, Saturation and Brightness until you see the color you want in the Active Color Well.

Sometimes it is easier to mix desaturated colors using the HSB or HLS Color Picker in conjunction with one of the other color pickers. Switch to another color picker to make your rough color selection, then switch back to the HSB or HLS Color Picker to fine tune your color.

**RGB (Red, Green & Blue)**

The RGB Color Picker allows you to select colors from the RGB (Red, Green and Blue) color range. RGB colors are traditionally used when modeling color on a computer screen and represent the closest approximation of the actual range of colors recognizable by the human eye. RGB has a wide color gamut and is one of the most effective color spaces to use in SketchUp.

Drag the sliders left and right for each of the component colors (red, green and blue) to create the color that you want to use.

You can type in exact numerical values for red, green or blue in the value boxes to the right of the sliders if you want to precisely match a color that you have specified elsewhere.
Entities

This section of the user's guide covers the various entities used to construct a model in SketchUp. These entities include faces, arcs, dimensions, and lines.

Entities are covered in alphabetical order.
**Group Entities**

Groups are entities that can hold other entities. Groups are commonly used to combine several entities as a single entity for the purposes of performing a quick operation with the combination (such as a copy). Use the Make Group menu item from the Edit menu to create a group from the currently selected entities.
Image Entities

Image entities are essentially special groups consisting of a face with an applied bitmap image material. Image Objects can be moved, rotated and scaled. They can also be stretched horizontally or vertically, but they cannot be made non-rectangular. Import Images using the File > Import > 2D Graphic menu item.

Image Formats

SketchUp supports the following formats for import as an Image Object: JPEG, PNG, PDF (Mac OS X), PICT (Mac OS X), PSD (Mac OS X), EPS, SGI (Mac OS X), TGA (Microsoft Windows), BMP (Microsoft Windows), and TIFF. Some formats may be more appropriate than others for certain types of images and applications.
Image Proportions

By default, Image Objects retain the proportions of the file from which they are derived. While inserting an image, you can hold down the Shift key to de-constrain the proportions. You can also use the Scale Tool to alter the image object's proportions after it is placed.
Surface Entities

Surface entities are a number of faces joined together to give the impression of roundness (using soft edges). Although the individual planar faces that make up a curved face set are still separate entities, they can act like a single group when selected or painted.

There are three types of surfaces, though the Entity Info dialog box will recognize each as just a Surface entity:

• Arc surface. An arc surface is generated when a face with an Arc entity has one or more of its edges extruded (usually with the Push/Pull Tool).

• Cylindrical surface. A cylindrical surface is similar to an arc surface, but is generated when a circular face is extruded to form a cylinder.

• Polyface surface. A polyface surface is generated when a face with a Polyline Curve entity has one or more of its edges extruded (usually with the Push/Pull Tool). You can also create one manually by softening edges with the Erase Tool or using the Soften/Smooth Control. Polyface surfaces do not have special editable properties, but respond to tool operations as a single entity.

The following image contains the three types of surfaces, an arc surface, cylindrical surface, and polyface surface, from left to right.
Input and Output

This section of the user's guide covers the various mechanisms for inputting items, such as graphic images, into your SketchUp file and outputting or presenting your model once it is finished.

The items in this section are divided into the following categories:

- Importers and Exporters
- Presentations
- Printing

The majority of the items in this section are found in the File menu.
3D Model (3DS) Export

The 3DS format is native to the original DOS-based 3D Studio modeling and animation application. Although obsolete in many ways, the 3DS format is still widely used and offers a direct way to export simpler SketchUp models into a wide range of 3D modeling packages. Because 3DS preserves material assignments, texture mapping, and camera position, it can often allow ideas generated in SketchUp to be transferred with greater fidelity than formats designed for CAD.

= Functionality only available in Google SketchUp Pro 7
Known Issues and Limitations

2 Sided Faces
Faces are only visible from the front in some programs while both sides of a face are always visible in SketchUp. These two-sided faces can appear to be missing in other applications if not facing the correct direction. You can manually reorient your faces in SketchUp using the Reverse command or the Orient Faces command to make face directions uniform for a given set of connected geometry.

Additionally, you can use the Export two-sided checkbox to correct this issue.

Flipped Textures
Textures and materials exported with the two-sided/geometry checkbox can appear flipped in certain applications (such as, Maya version 6.0 and 6.5). A 3DS mesh does not store any normal data so normals must be computed by the target system. Some importers might compute the normals incorrectly resulting in the appearance of flipped textures.

Texture Map Names
The 3DS format was designed in an era when DOS-based systems were prevalent. Therefore, 3DS is not capable of storing texture filenames that exceed the 8.3 DOS character limit. This issue can be a limitation to anyone who uses modern OS filename capabilities to manage large, complex projects or file libraries.

SketchUp create unique names for each texture by adding unique suffixes to file names. For example, a file named “corrugated metal.jpg” will be described in the 3DS file as “corrugat.jpg”. Any other files that use the same first six letters is truncated and the suffix "01," 02," and so on, are added.

Visibility
Only entities that are currently visible in SketchUp are output to the 3DS file. Rendering display options are not taken into account, which means that faces are output even if SketchUp is in wireframe mode. Faces are not output, however, if they are hidden or if they reside on a layer that is hidden.

Multiple Cameras
3DS format cannot store an orthographic camera. This format will be simulated through a perspective camera with a very small field of view or a very large lens length. The eye point will be moved as far away as is possible to yield the same width and height of the projection plane. Certain applications might have problems with a small field of view. For example, Maya does not read the field of view at all and only lets it become as small as 2.5.

Layers
The 3DS format does not support layers. Any layers you assign in SketchUp will be lost. The DWG format might be a better solution if you need layers to export. Alternatively, you can export with the “Color by Layer materials” option enabled, which might allow you to easily select and organize geometry in your model based on SketchUp layers once your model is imported into another application.
Units

SketchUp exports 3DS files at the units specified in the 3DS export options dialog box. This setting can affect the way geometry is described within the 3DS file. For example, a 1 meter cube in SketchUp will export to 3DS with sides of length 1 when units are set to meters. If you change the export units to centimeters, the same cube will export to 3DS with a length of 100.

The 3DS format contains extra information that indicates the original units using a scale factor. This information allows an application that reads 3DS to automatically adjust the size of 3DS models to the correct “real world” size.

Unfortunately, many applications ignore this extra unit scale information meaning that the centimeter cube imports as 100 times larger than the 1 meter cube, instead of at the same size. Worse, it is not always clear in which unit 3DS files are saved, resulting in considerable trial and error. In these cases, the best work-around is simply to export files at the units setting expected by the 3DS importing application.

= Functionality only available in Google SketchUp Pro 7
3DS Export Options Dialog Box

The 3DS Export Options dialog box contains options for exporting 3DS files.

Geometry

The Geometry section of the 3DS Export Options dialog box contains options for determining how geometry will be represented in a 3DS file.

Export (Full hierarchy)

The Export (Full hierarchy) option is used to create meshes for each top level nested component and group and, additionally, meshes for non-grouped entities based on the connection of faces. These meshes will be organized based on where they fit in the component and group hierarchy. This option allows you (using a tree view in AutoDesk 3DS Max, for example) to select individual components and groups with all their children and each connected face set as separate meshes. This option preserves the name of the component or group using the following rule for components: if an instance name exists, that name will be used; if an instance name does not exist, the definition name will be used.

Export (By layer)

The Export (By layer) option is used to create separate meshes based on a combination of how faces are connected and what layer (from SketchUp) they are on. All faces that are connected and are on the same layer will be grouped together in separate meshes. These meshes will then be organized based on the layer to which they belong. This option allows you (using a tree view in AutoDesk 3DS Max, for example) to select all objects on a layer using the organization scheme and then to drill down and select individual meshes within that layer. No hierarchy will be created with this option.

Export (By material)

The Export (By material) option is used to create separate meshes based on a combination of how faces are connected and what material they have. All faces that are connected and have the same material will be grouped together in separate meshes. These meshes will then be organized based on their materials. This option allows you (using a tree view in AutoDesk 3DS Max, for example) to select all objects with the same material using the organization scheme and then to drill down and select individual meshes having that material. No hierarchy will be created with this option.

Export (Single Object)

The Export (Single object) item is used to export your SketchUp model as a single 3DS mesh. This single mesh will be simple to select and manipulate once imported into another application. Because there is a limitation in the 3DS format that meshes can only have 65,536 vertices and faces, if this limit is exceeded, more than one mesh will be created with emphasis on keeping the number of meshes to the minimum amount necessary.

Export Only Current Selection

The Export only current selection checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no selection. Additionally, the entire model is exported when this checkbox is not checked.
Export Two-Sided Faces
The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the resulting 3DS file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always render, and materials applied to front and back faces are preserved. When this option is selected, SketchUp will weld the vertices of the front faces together and the vertices of the back faces together according to the logic for texture mapping and welding outlined in the following Export texture maps option.

Export Standalone Edges
Standalone Line entities (lines not connected to any faces) are somewhat unique to SketchUp and not supported by many other 3D programs or the 3DS format. The Export standalone edges check box creates very thin rectangles that appear as standalone lines in the 3DS files. Unfortunately, this option can result in invalid texture coordinates requiring UV mapping to be re-applied before the scene is rendered. Also, certain exported standalone edge geometries can create invalid 3DS files altogether. The VRML format may better suit your needs if you need to export standalone edges.

Materials
Export Texture Maps
The Export texture maps checkbox is used to assign texture maps to 3DS materials whenever the corresponding SketchUp material uses a texture image. The 3DS format allows only one UV mapping coordinate per vertex, meaning you can not have a different UV mapping on two faces that share the same vertex. Given this limitation of the 3DS format, a tradeoff between preserving texture coordinates and welding geometry is sometimes necessary and reflected in the following two sub-options: Favor Preserving texture coordinates and Favor Welding Vertices.

Favor (Preserving Texture Coordinates)
When the Preserving texture coordinates option is selected, and UV mappings are different, the exporter breaks up geometry so that each coplanar group of polygons has its own set of vertices. In this case, vertices will not be welded together and no smoothing of faces will be evident. If UV mappings are identical, vertices will be welded.

Note - Use this option if the preservation of textures is of most importance.

Favor (Welding Vertices)
When the Welding Vertices option is selected, the exporter will weld together vertices which will keep your geometry intact and allow smoothing to be preserved. However, when two faces share the same vertex but have different UV mappings, this option will only allow one of the texture mappings to be preserved.

Note - Use this option if the preservation of smoothing and welding is of most importance.

Use “Color by Layer” Materials
The 3DS file format does not support layers directly. The Use "Color by Layer" Materials checkbox is used to assign 3DS materials based on your model's layer assignments in SketchUp. Check this checkbox to export materials based on layers, such as when exporting to other rendering applications.
Cameras

Generate Cameras From Scenes
The Generate Cameras from Scenes checkbox is used to create a camera for the default view as well as any SketchUp Scenes which have been defined. The current SketchUp view is exported with the name "Default Camera," and other Scene camera definitions are output using their Scene Name.

Scale

Units
The units drop-down list is used to determine the unit size in the 3DS output.

= Functionality only available in Google SketchUp Pro 7
3D Model (DWG/DXF) Export

SketchUp can export 3D geometry to several AutoCAD formats: DWG r12, DWG r13, DWG r14, DWG r2000, DWG r2004, DXF r12, DXF r13, DXF r14, DXF r2000, and DXF r2004. SketchUp uses the industry standard OpenDWG Alliance file import/export model libraries to ensure maximum possible compatibility with AutoCAD. Export a file from the File menu.

= Functionality only available in Google SketchUp Pro 7
3D DWG/DXF Export Details

The 3D DWG and DXF export is used to export SketchUp files for use in other CAD programs such as AutoCAD. The following details apply to this export:

- Faces in SketchUp are exported as a triangulated polyface mesh with interior spliframe hidden lines (if applicable). This conversion helps to simulate the appearance of your native SketchUp file, even when all exported faces are triangular.

- SketchUp uses the current units set in the Units Panel of the Model Info dialog box as a reference for translation to a DWG or DXF file. For example, if the current unit setting is Decimal and Meters, SketchUp will export the DWG file accordingly. AutoCAD must be set to decimal for the units to translate correctly as meters.

- When exporting, duplicate line entities will not be created on top of a p-line entity.

= Functionality only available in Google SketchUp Pro 7
AutoCAD Export Options Dialog Box
(Microsoft Windows)

The AutoCAD Export Options dialog box contains options for exporting AutoCAD files.

AutoCAD Version

The AutoCAD section of the AutoCAD DWG/DXF Export Options dialog box is used to select the version of exported DWG/DXF file.

Export

The Export section of the AutoCAD Export Options dialog box contains the various entities that can be exported into your DWG/DXF file.

SketchUp can export faces, edges (wires), dimensions, text, or guides in any combination.

= Functionality only available in Google SketchUp Pro 7
AutoCAD Export Options Dialog Box (Mac OS X)

The AutoCAD Export Options dialog box contains options for exporting AutoCAD files.

Geometry

The Geometry section of the Export Options dialog box contains the various entities that can be exported into your DWG/DXF file.

SketchUp can export faces, edges (wires), dimensions, text, or guides in any combination.

= Functionality only available in Google SketchUp Pro 7
3D Model (KMZ) Export

The KMZ format is a zipped form of Google Earth's proprietary Keyhole Markup Language (KML). These files can contain location data (latitude and longitude) along with other information (such as SketchUp geometry).
3D Model (DAE) Export

SketchUp allows you to export your models as DAE (Collada) files. Export a DAE file using the Export > 3D Model menu item in the File menu.
The DAE Export Options Dialog Box

The DAE Export Options dialog box contains options for exporting DAE Files.

Geometry
The Geometry section of the DAE Export Options Dialog box is used to identify the geometry that will be exported.

**Export only current selection**
The Export only current selection only checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no selection. Additionally, the entire model is exported when this checkbox is not checked.

**Triangulate all faces**
The Triangulate all faces checkbox is used to break the output into triangles instead of multi-sided faces.

**Export two-sided faces**
The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the resulting DAE file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always render, and materials applied to front and back faces are preserved.

Materials
The Materials section of the DAE Export Options Dialog box is used to identify how materials will be exported.

**Export texture maps**
Check the Export texture maps checkbox to export textures with your DAE file.

Cameras
The Cameras section of the DAE Export Options Dialog box is used to identify how cameras will be exported.

**Generate cameras from scenes**: Check the Generate cameras from scenes checkbox to create a camera object in the DAE file for each default camera position from each scene in your SketchUp file.

Scale
The Scale section of the DAE Export Options Dialog box is used to identify the scale used in the DAE output.

**Units**: The Units drop-down list is used to determine the unit size in the DAE output.
3D Model (FBX) Export

SketchUp allows you to export your models as Kaydara (FBX) files. Export a FBX file using the Export > 3D Model menu item in the File menu.

= Functionality only available in Google SketchUp Pro 7
The FBX Export Options Dialog Box

The XSI Export Options dialog box contains options for exporting XSI Files.

Geometry

The Geometry section of the FBX Export Options Dialog box is used to identify the geometry that will be exported.

Export only current selection

The Export only current selection only checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no selection. Additionally, the entire model is exported when this checkbox is not checked.

Triangulate all faces

The Triangulate all faces checkbox is used to break the output into triangles instead of multi-sided faces.

Export two-sided faces

The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the resulting XSI file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always render, and materials applied to front and back faces are preserved.

Materials

The Materials section of the FBX Export Options Dialog box is used to identify how materials will be exported.

Export texture maps

Check the Export texture maps checkbox to export textures with your FBX file.

Scale

The Scale section of the FBX Export Options Dialog box is used to identify the scale used in the FBX output.

Swap YX coordinates (Y is up)

The Swap YZ coordinates check box is used to output the model with the vertical direction as Y. This orientation is the default orientation for some applications, such as Maya. Do not check this box if you want your model to be output with the Z axis in the vertical direction.

Units

The units drop-down list is used to determine the unit size in the FBX output.

= Functionality only available in Google SketchUp Pro 7
3D Model (OBJ) Export

The OBJ file format is a 3D file format created by Wavefront for use in their Advanced Visualizer™ product. These files are text-based and support free-form and polygonal geometry. An additional .mtl file describes materials defined in the .obj file.

= Functionality only available in Google SketchUp Pro 7
OBJ Export Known Issues and Limitations

OBJ file names
OBJ files do not support spaces in their filenames. SketchUp will replace any space with an underscore (_) when the file is saved.

Triangulation errors
SketchUp will export one face entity as one polygon in an OBJ file. This ratio of faces to polygons can create some problems for some OBJ importers (polygons might appear missing or reversed). Use the Triangulate faces option to create additional polygons for importers that seem to have problems with the OBJ file exported from SketchUp. Additionally, you can import the OBJ file into an application that does not have problems with the SketchUp faces-to-polygons ratio and then export that file as another file type to be used in the less-qualified application.

Flat set hierarchy
The OBJ output supports a flat set membership hierarchy meaning that the format identifies which objects belong to any set. This output does not support a tree hierarchy because it cannot identify if one particular set is actually a component of another set. This limitation is a limitation of the OBJ format.

NURBS
SketchUp does not output nurbs or any of the advanced OBJ entities. SketchUp outputs polygon faces only.

Maya and PNG or JPG files (Mac OS X)
PNG and JPG images included in an OBJ do not always appear in Maya. This issue appears to occur due to a Maya bug on the Macintosh platform.

= Functionality only available in Google SketchUp Pro 7
OBJ Export Options Dialog Box

The OBJ Export Options dialog box contains options for exporting OBJ files.

Geometry

Export only current selection
The Export only current selection checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no selection. Additionally, the entire model is exported when this checkbox is not checked.

Triangulate all faces
The Triangulate all faces checkbox is used to break the output into triangles instead of multi-sided faces.

Export two-sided faces
The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the resulting OBJ file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always render, and materials applied to front and back faces are preserved.

Export edges
The Export edges checkbox is used to write SketchUp line entities as OBJ line entities. Edges are ignored when this checkbox is not checked. Usually this checkbox is not checked because most applications will ignore edges on import.

Materials

Swap YZ coordinates (Y is up)
The Swap YZ coordinates check box is used to output the model with the vertical direction as Y. This orientation is the default orientation for some applications, such as Maya. Do not check this box if you want your model to be output with the Z axis in the vertical direction, such as when using 3D Studio Max.

Units
The units drop-down list is used to determine the unit size in the OBJ output. The Model Units setting is used to select the units that are being used in SketchUp.

= Functionality only available in Google SketchUp Pro 7
3D Model (XSI) Export

SketchUp allows you to export your models as Soft Image (XSI) files. Export a XSI file using the Export > 3D Model menu item in the File menu.

= Functionality only available in Google SketchUp Pro 7
The XSI Export Options Dialog Box

The XSI Export Options dialog box contains options for exporting XSI files.

Geometry
The Geometry section of the FBX Export Options Dialog box is used to identify the geometry that will be exported.

**Export only current selection**
The Export only current selection only checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no selection. Additionally, the entire model is exported when this checkbox is not checked.

**Triangulate all faces**
The Triangulate all faces checkbox is used to break the output into triangles instead of multi-sided faces.

**Export two-sided faces**
The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the resulting XSI file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always render, and materials applied to front and back faces are preserved.

Materials
The Materials section of the XSI Export Options Dialog box is used to identify how materials will be exported.

**Export texture maps**
Check the Export texture maps checkbox to export textures with your XSI file.

Scale
The Scale section XSI Export Options Dialog box is used to identify the scale used in the XSI output.

**Swap YX coordinates (Y is up)**
The Swap YZ coordinates check box is used to output the model with the vertical direction as Y. This orientation is the default orientation for some applications, such as Maya. Do not check this box if you want your model to be output with the Z axis in the vertical direction.

Units
The Units drop-down list is used to determine the unit size in the OBJ output.

= Functionality only available in Google SketchUp Pro 7
2D Graphic (PDF/EPS) Export

SketchUp allows you to export your models as 2D vector drawings, including PDF and EPS. Export a file using the Export > 2D Graphic menu item in the File menu.

= Functionality only available in Google SketchUp Pro 7
2D PDF/EPS Export Details

The PDF and EPS export is used to export vector SketchUp files for use in other vector-based editing programs like Adobe Illustrator.

⚠️ Caution - Some graphic features of SketchUp, including textures, shadows, smooth shading, backgrounds, and transparency, cannot be exported to PDF and EPS.

Text and Dimensions

SketchUp will attempt to output text annotation and notes to your 2D drawing. Please note the following limitations:

- Text and Dimension entities that are obscured (partially or totally) by other geometry in the SketchUp drawing area export on top of the geometry.
- Text and Dimension entities that are partially clipped by the edges of the SketchUp Drawing Area are not exported.
- Certain fonts may not export exactly.

= Functionality only available in Google SketchUp Pro 7
PDF/EPS Hidden Line Options Dialog Box
(Microsoft Windows)

The PDF/EPS Hidden Options dialog box contains options for exporting 2D PDF and EPS Files.

Drawing Size

The Drawing Size section of the PDF/EPS Hidden Options Dialog box contains size and scaling options for your model.

Full Scale (1:1)

Full Scale (1:1) option is used to set your output to a 1:1 (real world) scale.

Width/Height

The width and height fields are used to enter a custom page size for your file.

In Hidden-Line Output/In SketchUp

In Hidden-Line Output/In SketchUp fields are used to scale your model for export. The first measurement, labeled In Hidden-Line Output, is the measurement of the exported geometry. The second measurement, labeled In SketchUp, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1’, simply enter 1 inch In SketchUp equals 4 feet In Hidden Line Output.

Note - It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera > Standard submenu, to enable this scale option.

Profile Lines

The Profile Lines section of the PDF/EPS Hidden Options Dialog box contains options for exporting profile lines.

Show Profiles

The Show profiles option exports any lines that are displayed in profile as thicker lines in the 2D vector file. All lines are output normally, without profile thickness, when this option is disabled (regardless of the screen display).

Match Screen Display (Auto Width)

The Match screen display (auto width) automatically sets the width of profile lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Show profiles is checked.

Width

The Width fields are used to specify an exact width for the profile lines. This option is only available when Show Profiles is checked and Match Screen Display (Auto Width) is unchecked.
Section Lines
The Section Lines section of the DWG/DXF Hidden Options Dialog box contains options for exporting section lines.

Specify Section Line Width
The Specify section line width option is used to adjust settings for Section Slice lines that are output.

Match Screen Display (Auto Width)
The Match screen display (auto width) automatically sets the width of section lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Specify section line width is checked.

Width
The Width fields are used to specify an exact width for the section lines. This option is only available when Specify Section Line Width is checked and Match screen display (auto width) is unchecked.

Extension Lines
The Extension Lines section of the PDF/EPS Hidden Options Dialog box contains options for exporting extension lines.

Extend Edges
Some CAD applications might have problems recognizing endpoints and intersections of lines with SketchUp extension lines. The Extend edges option is used to toggle the export of line extensions.

Match Screen Display (Auto Width)
The Match screen display (auto width) automatically sets the width of extension lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Extend edges is checked.

Width
The Width fields are used to specify an exact width for the extension lines. This option is only available when Extend Edges is checked and Match screen display (auto width) is unchecked.

Always Prompt for Hidden Line Options
The Always prompt for hidden line options is used to automatically display the Hidden Line Options dialog box when you export a 2D PDF or EPS file.

Map Windows fonts to PDF base fonts
This option is used to select PDF fonts that correspond to the Windows fonts used in the model.

Defaults
The Defaults button is used to return the items in the Hidden Line Options dialog box to the default settings.

= Functionality only available in Google SketchUp Pro 7
Export Options Dialog Box (Mac OS X)

The Export Options dialog box contains options for exporting 2D PDF and EPS Files.

Image Size
The Image Size section of the PDF/EPS Hidden Options Dialog box contains size options for your model.

Match View Size
Match View Size option is used to set your output to a 1:1 (real world) scale.

Width/Height
The width and height fields are used to enter a custom page size for your file.

Image Scale
The Image Scale section of the PDF/EPS Hidden Options Dialog box contains scaling options for your model.

In Image/In Model
In Image/In Model fields are used to scale your model for export. The first measurement, labeled In Model, is the measurement of the exported geometry. The second measurement, labeled In Model, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1', simply enter 1 inch In Model equals 4 feet In Image.

Note - It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera > Standard submenu, to enable this scale option.

Line Quality
The Line Quality section contains a setting for exported line weights.

Line Weight
This option is used to apply a weight to all profile lines, or lines that have space behind them as they are displayed.

PRO Functionality only available in Google SketchUp Pro 7
3D Model (VRML) Export

VRML 2.0 (Virtual Reality Modeling Language) is a 3D scene/object description format often used to exchange data between 3D applications and to publish 3D information to the web. VRML files can store SketchUp geometry in the form of edges, faces, groups, materials and textures, transparency, camera views, and lights.

= Functionality only available in Google SketchUp Pro 7
The VRML Export Options Dialog Box
(Microsoft Windows)

The VRML Export Options dialog box contains options for exporting VRML files.

**Appearance**
The Appearance section of the VRML Export Options dialog box contains options to configure the appearance of the exported VRML file.

**Output Texture Maps:** If enabled, SketchUp will export texture information to the VRML file. When disabled, it will export colors only. When publishing VRML files to the web, you may want to edit the files so that textures read from the relative location rather than from your local hard drive. Also, VRML texture and material names cannot have blanks, so SketchUp will use the underscore character instead.

**Ignore Back of Face Materials:** The Ignore Back of Face Materials checkbox is used to export both front and back faces with the front material. SketchUp exports VRML files with double faces so that files will be viewable from any viewpoint.

**Output Edges:** The Output Edges check box exports displayed edges as VRML edge entities.

**Use “Color by Layer” Materials:** The VRML file format does not support layers directly. The Use “Color by Layer” Materials checkbox is used to assign VRML materials based on your model’s layer assignments in SketchUp. Check this checkbox to export materials based on layers, such as when exporting to other rendering applications.

**Use VRML Standard Orientation:** The Use VRML Standard Orientation checkbox is used to export a file that conforms to the VRML standard. The VRML standard considers the XZ plane to be horizontal (the ground plane) whereas SketchUp considers the XY plane to be the ground plane.

**Generate Cameras:** The Generate Cameras checkbox is used to create a camera for the default view as well as any SketchUp Scenes which have been defined. The current SketchUp view is exported with the name “Default Camera”, and other Scene camera definitions are output using their Scene Name.

**Allow Mirrored Components:** The Allow Mirrored Components check box is used to export components that have been mirrored or resized so they are an opposite of the original component.

**Check for Material Overrides:** The Check for Material Overrides check box is used to determine if any of the faces, edges, or components within this component contain references to the default material or default layer.

= Functionality only available in Google SketchUp Pro 7
The VRML Export Options dialog box contains options for exporting VRML files.

Geometry
The Geometry section of the VRML Export Options dialog box contains options to configure the appearance of the exported VRML file.

**Use VRML Standard Orientation**
The Use VRML Standard Orientation checkbox is used to export a file that conforms to the VRML standard. The VRML standard considers the XZ plane to be horizontal (the ground plane) whereas SketchUp considers the XY plane to be the ground plane.

**Allow Mirrored Components**
The Allow Mirrored Components check box is used to export components that have been mirrored or resized so they are an opposite of the original component.

**Output Edges**
The Output Edges check box exports displayed edges as VRML edge entities.

Materials
The Materials section of the VRML Export Options dialog box contains options to configure the appearance of the exported VRML file.

**Ignore Back of Face Materials**
The Ignore Back of Face Materials checkbox is used to export both front and back faces with the front material. SketchUp exports VRML files with double faces so that files will be viewable from any viewpoint.

**Check for Material Overrides**
The Check for Material Overrides check box is used to determine if any of the faces, edges, or components within this component contain references to the default material or default layer.

**Output Texture Maps**
If enabled, SketchUp will export texture information to the VRML file. When disabled, it will export colors only. When publishing VRML files to the web, you may want to edit the files so that textures read from the relative location rather than from your local hard drive. Also, VRML texture and material names cannot have blanks, so SketchUp will use the underscore character instead.

**Use “Color by Layer” Materials**
The VRML file format does not support layers directly. The Use “Color by Layer” Materials checkbox is used to assign VRML materials based on your model's layer assignments in SketchUp. Check this checkbox to export materials based on layers, such as when exporting to other rendering applications.
Cameras

The Caeras section of the VRML Export Options dialog box contains an option to generate cameras for the exported VRML file.

**Generate Cameras from Scenes**

The Generate Cameras from Scenes checkbox is used to create a camera for the default view as well as any SketchUp Scenes which have been defined. The current SketchUp view is exported with the name “Default Camera”, and other Scene camera definitions are output using their Scene Name.

- = Functionality only available in Google SketchUp Pro 7
2D Graphic (Epix) Export

Piranesi is a painting application that enables you to create stunning renderings from your SketchUp models. For more information, please visit the Piranesi Web Site: www.informatix.co.uk/piranesi.htm

SketchUp allows you to export your models as Epix files for use in Piranesi. Export an Epix file using the Export > 2D Graphic menu item in the File menu.

= Functionality only available in Google SketchUp Pro 7
The Export Options Dialog Box

The Export Options dialog box contains options for exporting Epix files.

Image Size
The Image Size section of the Export Options dialog box contains size and scaling options for your model.

Use View Size
The Use View Size option is used to set your output to the exact dimensions of your SketchUp drawing area.

Width/Height
The width and height fields are used to enter a custom page size for your file.

Tip - SketchUp cannot export Epix files with compression enabled. Re-saving your file in Piranesi can reduce file size considerably.

Resolution (Mac OS X)
The Resolution drop-down list is used to select the resolution for the exported image. For viewing images on the screen, 72-96 pixels/inch is adequate. For printing, you might want to increase the resolution to 150-300 pixels/inch. Remember, high resolution images take longer to generate.

EPIX
The EPIX section of the Export Options dialog box contains options for the contents of the exported file.

Export Edges
The Export Edges check box is used to maintain the edge rendering style from the drawing area when saving your drawings as an Epix file.

Note - Edges will not appear in your Epix file if edges are disabled in your style.

Export Textures
The Export Textures check box is used to maintain textures from the drawing area when saving your drawings as an Epix file.

Note - The Export Textures option is only applicable when materials have been assigned to faces and SketchUp is in the Shaded with Textures display setting.

Export Ground Plane
The Export Ground Plane check box is used to create a ground plane in the Epix file without explicitly modeling a ground in SketchUp.

= Functionality only available in Google SketchUp Pro 7
2D Graphic Export (Microsoft Windows)

SketchUp allows you to export 2D raster image files in JPEG, BMP, TIFF, and PNG raster file formats. Export a file using the Export > 2D Graphic menu item in the File menu.

Note - Shadows cannot be saved with a 3D model. None of the 2D vector output formats support rendering features such as shadows, textures, or transparency. The only export formats that will represent shadows as seen on your display are pixel-based raster images and animations.
2D Graphic Export (Mac OS X)

SketchUp allows you to export 2D raster image files in JPEG, TIFF, PNG, and Epix formats. Export a file using the Export > 2D Graphic menu item in the File menu.

Note - Shadows cannot be saved with a 3D model. None of the 2D vector output formats support rendering features such as shadows, textures, or transparency. The only export formats that will represent shadows as seen on your display are pixel-based raster images and animations.
Export Image Options Dialog Box

The Export Image Options dialog box contains options for exporting raster image files.

Image Size

**Use View Size**
The Use view size is used to set your output to a 1:1 (real world) scale.

**Width/Height**
The Width and Height fields are used to control the size of image as measured in pixels or specific units. Click on the chain icon to the right of the text fields to lock the aspect ratio of the export (Mac OS X).

Resolution (Mac OS X)
The Resolution drop-down list is used to select the resolution for the exported image. For viewing images on the screen, 72-96 pixels/inch is adequate. For printing, you might want to increase the resolution to 150-300 pixels/inch. Remember, high resolution images take longer to generate.

Rendering

**Anti-Alias**
When enabled, SketchUp will smooth the exported image. This method can take longer, but it helps to reduce jagged lines and pixilated artifacts in images.

JPEG Compression
The slider bar for a JPEG export is used to define the level of JPEG compression quality. The level of quality becomes lesser and the file size is smaller as the slider is moved to the left. Conversely, the level of quality becomes higher and the file size is larger if the slider is moved to the right.
2D Graphic (DWG/DXF) Export

SketchUp allows you to export your models as 2D vector drawings, including DWG and DXF. Export a file using the Export > 2D Graphic menu item in the File menu.

= Functionality only available in Google SketchUp Pro 7
The DWG/DXF Hidden Line Option dialog box contains options for exporting 2D DWG and DXF Files.

**Drawing Scale & Size**

The Drawing Scale & Size section of the DWG/DXF Hidden Options Dialog box contains scaling options for your model.

**Full Scale (1:1)**
The Full Scale (1:1) option is used to set your output to a 1:1 (real world) scale.

**In Drawing/In Model**
The In Drawing/In Model fields are used to scale your model for export. The first measurement, labeled In the Model, is the measurement of the exported geometry. The second measurement, labeled In Drawing, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1', simply enter 1 inch In Model equals 4 feet In Drawing.

**Note** - It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera > Standard submenu, to enable this scale option.

**Width/Height**
The width and height fields are used to enter a custom page size for your file.

**AutoCAD Version**
The AutoCAD section of the AutoCAD DWG/DXF Export Options dialog box is used to select the version of exported DWG/DXF file.

**Profile Lines**
The Profile Lines section of the DWG/DXF Hidden Option Dialog box contains options for exporting profile lines.

**None**
The None option is used to export profile lines at standard width.

**Polylines with width**
The Polylines with width option is used to export profile lines as AutoCAD polyline entities.

**Wide line entities**
The Wide line entities option is used to export profile lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.
**Separate on a layer**

The Separate on a layer option is used to output profile lines onto their own layer. This option is useful if you would like to plot profile lines using a different pen weight or quickly change the line width of all profile lines in a separate CAD or Illustration program.

*Note -* The Separate on a layer option creates a single additional layer for profile edges. SketchUp Layer assignments do not translate directly when exporting 2D hidden line vectors.

**Width**

The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and Automatic is unchecked.

**Automatic**

The Automatic option is used to set the width of profile lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Polylines with width is checked.

**Section Lines**

The Section Lines section of the DWG/DXF Hidden Options Dialog box contains options for exporting section lines.

**None**

The None option is used to export section slice lines at standard width.

**Polylines with width**

The Polylines with option is used to export section slice lines as AutoCAD polyline entities.

**Wide line entities**

The Wide line entities option is used to export section slice lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.

**Separate on a layer**

The Separate on a layer option is used to output section slice lines onto their own layer. This option is useful if you would like to plot section slice lines using a different pen weight or quickly change the line width of all section slice lines in a separate CAD or Illustration program.

*Note -* The Separate on a layer option creates a single additional layer for section slice edges. SketchUp Layer assignments do not translate directly when exporting 2D hidden line vectors.

**Width**

The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and Automatic is unchecked.

**Automatic**

The Automatic option is used to set the width of section slice lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Polylines with width is checked.
Extension Lines

The Extension Lines section of the DWG/DXF Hidden Options Dialog box contains options for exporting extension lines.

**Show extensions**

Some CAD applications might have problems recognizing endpoints and intersections of lines with SketchUp extensions. The show extensions option is used to toggle the export of line extensions.

**Length**

The Length field is used to specify an exact length for line extensions. This option is only available when Show extensions is checked and Automatic is unchecked.

**Automatic**

The Automatic option is used to set the length of extension lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Show extensions is checked.

**Always Prompt for Hidden Line Options**

The Always Prompt for Hidden Line Options is used to automatically display the Hidden Line Options dialog box when you export a 2D DWG or DXF file.

**Defaults**

The Defaults button is used to return the items in the Hidden Line Options dialog box to the default settings.

= Functionality only available in Google SketchUp Pro 7
The DWG/DXF Export Options dialog box contains options for exporting 2D DWG and DXF Files.

### Drawing Scale & Size

The Drawing Scale & Size section of the DWG/DXF Hidden Options Dialog box contains scaling options for your model.

**Full Scale (1:1)**

The Full Scale (1:1) option is used to set your output to a 1:1 (real world) scale.

**In Drawing/In Model**

The In Drawing/In Model fields are used to scale your model for export. The first measurement, labeled In the Model, is the measurement of the exported geometry. The second measurement, labeled In Drawing, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1’, simply enter 1 inch In Model equals 4 feet In Drawing.

**Note** - It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera > Standard submenu, to enable this scale option.

### Width/Height

The width and height fields are used to enter a custom page size for your file.

### Profile Lines

The Profile Lines section of the DWG/DXF Hidden Options Dialog box contains options for exporting profile lines.

**None**

The None option is used to export profile lines at standard width.

**Polylines with width**

The Polylines with width option is used to export profile lines as AutoCAD polyline entities.

**Wide line entities**

The Wide line entities option is used to export profile lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.

**Separate on a layer**

The Separate on a layer option is used to output profile lines onto their own layer. This option is useful if you would like to plot profile lines using a different pen weight or quickly change the line width of all profile lines in a separate CAD or Illustration program.

**Note** - The Separate on a layer option creates a single additional layer for profile edges. SketchUp Layer assignments do not translate directly when exporting 2D hidden line vectors.
Width
The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and Automatic is unchecked.

Automatic
The Automatic option is used to set the width of profile lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Polylines with width is checked.

Section Lines
The Section Lines section of the Export Options Dialog box contains options for exporting section lines.

None
The None option is used to export section slice lines at standard width.

Polylines with width
The Polylines with option is used to export section slice lines as AutoCAD polyline entities.

Wide line entities
The Wide line entities option is used to export section slice lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.

Separate on a layer
The Separate on a layer option is used to output section slice lines onto their own layer. This option is useful if you would like to plot section slice lines using a different pen weight or quickly change the line width of all section slice lines in a separate CAD or Illustration program.

Note - The Separate on a layer option creates a single additional layer for section slice edges. SketchUp Layer assignments do not translate directly when exporting 2D hidden line vectors.

Width
The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and Automatic is unchecked.

Automatic
The Automatic option is used to set the width of section slice lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Polylines with width is checked.

Edge Extensions
The Edge Extensions section of the Export Options Dialog box contains options for exporting extension lines.

Show extensions
Some CAD applications might have problems recognizing endpoints and intersections of lines with SketchUp extensions. The show extensions option is used to toggle the export of line extensions.

Length
The Length field is used to specify an exact length for line extensions. This option is only available when Show extensions is checked and Automatic is unchecked.
**Automatic**

The Automatic option is used to set the length of extension lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only available when Show extensions is checked.

= Functionality only available in Google SketchUp Pro 7
3D Model (DWG/DXF) Import

SketchUp allows you to import 3D models, such as DWG and DXF CAD files, for placement within your model. Import a file using the Import menu item in the File menu.

Note - Google is a member of the OpenDWG Alliance, allowing SketchUp to offer the most reliable DWG file translation available.
DWG/DXF Supported CAD Elements

SketchUp must translate the elements within a CAD file into SketchUp entities when importing a CAD file. Supported CAD elements include lines, arcs, circles, polylines, faces, entities with thickness, 3D faces, and nested blocks. CAD layers are also supported.

SketchUp does not support AutoCAD regions, XREFs, hatching, dimensions, text, and proprietary ADT or ARX objects. These CAD elements will be ignored on import.

You can change any unsupported elements into primitive CAD drawing elements, within your CAD application, if you need to import these elements into SketchUp. For example, you can explode ADT walls and extrusions in Autodesk Architectural Desktop so they will import as faces in SketchUp. Some elements might need to be exploded multiple times in your CAD package to be translated into SketchUp entities.
The Import AutoCAD DWG/DXF Options Dialog Box

Some CAD files might contain non-standard units, coplanar faces, or inconsistently oriented faces. You can force SketchUp to automatically analyze and repair these issues during the import process.

Geometry

The Geometry section of the AutoCAD DWG/DXF Import Options dialog box contains options to configure the appearance of the exported VRML file.

Merge Coplanar Faces

Planes can import into SketchUp with triangulated lines. Removing these lines manually can be tedious. The Merge coplaner faces option is used to have SketchUp automatically remove these lines.

Orient Faces Consistently

The Orient faces consistently option is used to analyze the direction of imported faces and orient these faces so that they are uniform in direction.

Scale

Some CAD formats, such as DXF, save data in generic units. The Scale section of the AutoCAD DWG/DXF Import Options dialog box contains options to configure the units for the imported file.

Units

Select the unit type used in the original CAD file to import geometry at the correct scale.

Caution - SketchUp only recognizes faces of .001 square inches and larger. It is possible to create very small faces on import if you select millimeters as your SketchUp units but the model was originally intended to be displayed in feet. Therefore, use a large unit type, such as feet or meters, if you do not know the units used in the original file. Resize the model as necessary after it is imported.

Preserve Drawing Origin

The Preserve drawing origin option is used to define where the DWG/DXF file will be placed when it is inserted into a SketchUp file. Check this box if you want to place the DWG/DXF file at the origin, as originally defined in the DWG/DXF file. Do not check this box if you want the DWG/DXF file to be placed near the SketchUp origin.
3D Model (3DS) Import

SketchUp allows you to import 3D Studio (3DS) files. Import a file using the Import menu item in the File menu.
3DS Import Options Dialog Box

Geometry

Merge Coplanar Faces
Planes can import into SketchUp with triangulated lines. Removing these lines manually can be tedious. The Merge coplanar faces option is used to have SketchUp automatically remove these lines.

Scale

Units
The Units drop-down list is used to import 3DS geometry at the correct scale. A 3DS file has a field which indicates its units value. Sometimes this value is explicitly set in the 3DS file (such as millimeters) and sometimes it is missing and set to a generic value. The Model Units list item will import your 3DS file with the unit value it finds in your 3DS file. SketchUp will import your file using inches if a units value is not set in the 3DS file. SketchUp will import your 3DS file at the unit you choose if you pick anything other than Model Units.

For example, a face that is 1cm x 1cm will be imported into SketchUp as 1cm x 1cm if your 3DS file has its units value set to centimeters and you select Model Units in this drop-down list. A 1cm x 1cm face will import into SketchUp with dimensions of 1in x1in if you choose inches in the drop-down list.

⚠️ Caution - SketchUp only recognizes faces of .001 square inches and larger. It is possible to have create very small faces on import if you select millimeters as your SketchUp units but the model was originally intended to be displayed in feet. Therefore, use a large unit type, such as feet or meters, if you do not know the units used in the original file. Resize the model as necessary after it is imported.
3D Model (DEM) Import

SketchUp allows you to import a digital elevation models (DEM) containing point data relating to terrain elevations. Unfortunately, there is not a single standardized file format for digital elevation models. However, SketchUp supports the following two important file formats: USGS DEM and spatial data transfer standard (SDTS).

The USGS DEM file format is an ASCII format for storing geographical information. These files can have an extension of .dem. You will have to add the .dem extension to your USGS DEM files if they do not have this extension.

SDTS is a complex geographical data format. SDTS models usually consist of 20 or more files, all with the extension of .ddf, stored in a single directory. You can select any of the *.ddf files in a SDTS directory to import the entire set of files.

Import a USGS DEM or SDTS file using the Import menu item in the File menu.
DEM Import Options Dialog Box

DEM files can contain thousands of points yielding a very detailed, yet very slow, SketchUp model. The CAD files might contain non-standard units, coplanar faces, or inconsistently oriented faces. You can force SketchUp to automatically analyze and repair these issues during the import process.

Points and Faces

The Points and faces fields are used to identify the number of points, and subsequent faces, that will be created upon import. The fewer the points and subsequent faces, the better the performance in SketchUp. However, the fewer the points and subsequent faces, the lesser the detail of the imported model.

❗ Note - \(2 \times \text{points} + 1 = \text{approximate number of faces created upon import.}\)

Generate Gradient Texture

The Generate gradient texture field is used to apply a gradient texture to the imported DEM model. This texture will be darker in lower areas of the model and lighter in high areas.
3D Model (DAE) Import

SketchUp allows you to import DAE (Collada) files. Import a DAE file using the Import menu item in the File menu.
2D Graphic Import

SketchUp allows you to import 2D raster images, including JPEG and BMP, for placement within your model. Import a file using the Import menu item in the File menu.
Section Slice Export

SketchUp can save the active Section Slice as its own 2D file in the DWG and DXF formats. As with all vector information, section slice export has the advantage of preciseness. Export a section slice using the Export > Section Slice menu item in the File menu.

= Functionality only available in Google SketchUp Pro 7
**2D Section Slice Options Dialog Box**

**(Microsoft Windows)**

The 2D Section Slice Export Options dialog box contains options for exporting 2D section slice files.

**Projection**

The projection section contains options for selecting the type of exported file.

**True Section (Orthographic)**

This option outputs the section slice as a true orthographic drawing. This is useful for creating templates for CD drawings or any other time you want to generate accurate, measurable slices.

**Screen Projection (WYSIWG)**

This projects the section cut as you see it on your SketchUp screen, including any perspective distortion. This is most useful for diagrams that need not be measured.

**Drawing Scale & Size**

The Drawing Scale and Size section of the Section Slide Export Options dialog box contains options to configure the scale and size of the exported section slice.

**Full Scale (1:1)**

Select Full Scale (1:1) to output your section slice to CAD at a true 1:1 scale.

**Width/Height**

These values represent the overall dimensions of the slice output, and will update depending on the slice being exported and its scale.

**In Drawing/In Model**

These controls allow you to specify a certain drawing scale, and follow architectural conventions. The first measurement, labeled 'In Drawing' is the measurement of the exported geometry. The second measurement, labeled 'In Model' is the actual measurement of the object in real scale.

For example, for a scale of 1/4” = 1’, simply enter 1 inch in the output equals 4 feet in SketchUp.

**Note -** You cannot export a perspective screen projection to scale. Also, even if the view is a paraline projection, only faces whose normals are perpendicular to the view angle will be measurable.

**AutoCAD Version**

The AutoCAD section of the AutoCAD DWG/DXF Export Options dialog box is used to select the version of exported DWG/DXF file.

**Section Lines**

The Section Lines section of the Section Slice Export Options dialog box contains options to configure the section cut lines of the exported section slice.

**None**

Outputs section slice lines at normal width.
**Polylines with width**
Select the Polylines with width option to output lines as polyline entities.

**Wide line entities**
Select the Wide line entities to output lines as wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.

**Separate on a layer**
The Separate on a layer option is used to output profile lines onto their own layer. This option is useful if you would like to plot profile lines using a different pen weight or quickly change the line width of all profile lines in a separate CAD or Illustration program.

![Note] - The Separate on a layer option creates a single additional layer for profile edges. SketchUp Layer assignments do not translate directly when exporting 2D hidden line vectors.

**Width/Automatic**
When enabled, this automatically sets the width of profile lines by matching the output to the proportions you see in the SketchUp display. If disabled, you can specify an exact width.

**Always Prompt for Hidden Line Options**
When enabled, the options dialog will come up each time you output a section slice. When disabled, SketchUp will use whatever options were used the last time by default.

= Functionality only available in Google SketchUp Pro 7
2D Section Slice Options Dialog Box (Mac OS X)

The 2D Section Slice Export Options dialog box contains options for exporting 2D section slice files.

Width/Height
These values represent the overall dimensions of the slice output, and will update depending on the slice being exported and its scale.

Drawing Scale
The Drawing Scale section of the Section Slice Export Options dialog box contains options to configure the scale of the exported section slice.

Full Scale (1:1)
Use the Full Scale (1:1) option to output your section slice to CAD at a true 1:1 scale.

In Drawing/In Model
These controls allow you to specify a certain drawing scale, and follow architectural conventions. The first measurement, labeled 'In Drawing' is the measurement of the exported geometry. The second measurement, labeled 'In Model' is the actual measurement of the object in real scale.

For example, for a scale of 1/4" = 1', simply enter 1 inch in the output equals 4 feet in SketchUp.

Note - You can't export a perspective screen projection to scale. Also, even if the view is a paraline projection, only faces whose normals are perpendicular to the view angle will be measurable.

Section Lines
The Section Lines section of the Section Slice Export Options dialog box contains options to configure the section cut lines of the exported section slice.

None
Outputs section slice lines at normal width.

Polylines With Width
Use the Polylines With Width option to output lines as polyline entities.

Wide Line Entities
Use the Wide Line Entities option to output lines as wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.

Automatic/Width
When enabled, this automatically sets the width of profile lines by matching the output to the proportions you see in the SketchUp display. If disabled, you can specify an exact width.
Projection

The projection section contains options for selecting the type of exported file.

**True Section (Orthographic)**
This option outputs the section slice as a true orthographic drawing. This is useful for creating templates for CD drawings or any other time you want to generate accurate, measurable slices.

**Screen Projection (WYSIWYG)**
This projects the section cut as you see it on your SketchUp screen, including any perspective distortion. This is most useful for diagrams that need not be measured.

= Functionality only available in Google SketchUp Pro 7
Animation Export

You can export animations as video animation files or as series of image file, one file for each frame per second of your presentation. Export an animation using the Export > Animation menu item in the File menu.

Tip - Use the Animation Export feature when you need to provide a presentation of your model to a client who does not have SketchUp or the SketchUp viewer. Or, export a video animation for post-processing in another presentation software package. Use SketchUp for simple presentations or when the customer has the SketchUp viewer.

Note = Functionality only available in Google SketchUp Pro 7
The Animation Export Options Dialog Box
(Microsoft Windows)

The Animation Export Options dialog box contains options for exporting Animation files.

**Width/Height**

The Width and Height fields are used to control the frame size of the animation, as measured in pixels. The smaller the width and height values, the smaller the overall size, in kilobytes, the video animation file.

**Tip** - Computer screens can handle resolutions of 1024x768 pixels and above. However, 640x480 pixels is considered a full-size video. Typical videos are created at an even lower frame size. For example, 320x240 is yields acceptable data rates for CD-ROM, and transfers acceptably to videotape while 240x180 is acceptable for Web streaming. Values larger than 640x480 are not recommended unless specifically require such as when creating Full Quality Digital Video similar to that of professional videographers.

**Note** - Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame size, the larger the resulting video animation file. Large video animation files can slow down your computer resulting in skipping.

**Aspect Ratio Lock**

The Aspect Ratio Lock icon is used to maintain a fixed proportion of video at any frame size. Click on this lock to use a nonproportional frame size in your video animation.

**Frame Rate**

The Frame Rate drop-down list is used to select the number of frames of animation per second (fps) of time in the presentation. The more frames per-second, the smoother the video animation. However, doubling the frame rate generally doubles the rendering time as well as the final size of the video. A setting between 8 and 10 is considered the minimum required for to produce smooth movement in your video animation. You might consider using a frame rate of 3 frames per-second while testing video animation export.

**Note** - There are frame rate requirements for certain mediums, such as 29.97 fps for television in the United States, 25 fps for television in Europe, 24 fps for film, and so on.

**Note** - Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame rate, the larger the resulting video animation file. Large video animation files can slow down your computer resulting in skipping.

**Loop to Starting Scene**

The Loop to Starting Scene option is used to generate an additional video segment that animates from the last scene of your presentation to the first (forming a continuous loop of video).
Anti-Alias
The Anti-Alias option is used to smooth the exported image. This option can increase the export time, but helps to reduce jagged lines and pixilated artifacts in images.

Codec
The Codec option is used to specify which codec, or compression plug-in, to apply to your video animation.

Play When Finished
The Play When Finished option is used to start your default video player and play exported video animation file after it has been created.

Always Prompt for Animation Options
The Always Prompt for Animation Options option is used to display the Animation Export Options dialog box every time a video animation is created.

= Functionality only available in Google SketchUp Pro 7
The Animation Export Options Dialog Box (Mac OS X)

The Animation Export Options dialog box contains options for exporting Animation files.

Settings
The settings section of the Animation Export Options dialog box contains options for controlling resolution and frame size for the video animation.

Format
The Format drop-down list is used to select the combination of resolution, frame rate, and codec based on your particular output medium (Web, CD ROM, Email, and so on. For example, the suggested combination of settings for streaming a video over the Web is 160x120 resolution at 10 frames per second using the Sorenson codec.

Select Custom from the Format drop-down list to configure your own custom settings.

Width/Height
The Width and Height fields are used to control the frame size of the animation, as measured in pixels. The smaller the width and height values, the smaller the overall size, in kilobytes, the video animation file.

Tip - Computer screens can handle resolutions of 1024x768 pixels and above. However, 640x480 pixels is considered a full-size video. Typical videos are created at an even lower frame size. For example, 320x240 is yields acceptable data rates for CD-ROM, and transfers acceptably to videotape while 240x180 is acceptable for Web streaming. Values larger than 640x480 are not recommended unless specifically required such as when creating Full Quality Digital Video similar to that of professional videographers.

Note - Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame size, the larger the resulting video animation file. Large video animation files can slow down your computer resulting in skipping.

AspectRatio Lock
The Aspect Ratio Lock icon is used to maintain a fixed proportion of video at any frame size. Click on this lock to use a nonproportional frame size in your video animation.
Frame Rate
The Frame Rate drop-down list is used to select the number of frames of animation per second (fps) of time in the presentation. The more frames per-second, the smoother the video animation. However, doubling the frame rate generally doubles the rendering time as well as the final size of the video. A setting between 8 and 10 is considered the minimum required for to produce smooth movement in your video animation. You might consider using a frame rate of 3 frames per-second while testing video animation export.

Note - There are frame rate requirements for certain mediums, such as 29.97 fps for television in the United States, 25 fps for television in Europe, 24 fps for film, and so on.

Note - Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame rate, the larger the resulting video animation file. Large video animation files can slow down your computer resulting in skipping.

Loop to Starting Scene
The Loop to Starting Scene option is used to generate an additional video segment that animates from the last scene of your presentation to the first (forming a continuous loop of video).

Expert
Click the Expert button to launch the Compression Settings dialog box. This dialog box allows you to modify the settings used by a specific codec.

Rendering
The rendering section of the Animation Export Options dialog box contains options for rendering your video animation.

Anti-Alias
The Anti-Alias option is used to smooth the exported image. This option can increase the export time, but helps to reduce jagged lines and pixilated artifacts in images.

Transparent Background
The Transparent Background option is used to save the animation with a transparent background to aid in compositing. However, not all codecs are capable of storing transparency. Following is a list of codes that support transparency:

= Functionality only available in Google SketchUp Pro 7
Animation Types

SketchUp supports both single video animation file export (in the form of a Audio Video Interleave or AVI on Microsoft Windows and QuickTime on Mac OS X) and multiple image file export.

Single Video File Animations

SketchUp allows you to export animation as a single video animation file (Audio Video Interleave or AVI on Microsoft Windows and QuickTime on Mac OS X). These files can be played using any compatible software video player or incorporated into a professional presentation using additional software presentation tools. SketchUp utilizes special third-party software called codecs (compressor/decompressor) to create these files. The following image shows the process of video compression on Microsoft Windows:

![Video Compression on Microsoft Windows](image)

The following image shows the process of video compression on Mac OS X:

![Video Compression on Mac OS X](image)

Each codec included with SketchUp implements a compression technique designed for a specific medium such as Web video, Email, or CD-ROM.

Multiple Image File Animations

SketchUp also allows you to export an animation as a series of progressive image files. The number of files exported depends on the frame rate for the presentation. For example, a 5 minute presentation exported at 10 frames per-second will yield 3000 files (60 seconds x 5 minutes x 10 frames per-second). Multiple image file animations are typically generated to use as input into video animation software products for post-processing.

= Functionality only available in Google SketchUp Pro 7
The Print Setup Dialog Box (Microsoft Windows)

The Print Setup dialog box is used to select and configure your printer and final output orientation. Select File > Print Setup to invoke the Print Setup dialog box.

Printer

The Printer section of the Print Setup dialog box is used to select a specific printer and printer settings. Select the printer to use from the Name drop-down list. Click on the Properties button to configure the printer for printing (the properties dialog box is different for each printer-type).

Paper

The Paper section of the Print Setup dialog box is used to select the paper size used for your output.

Size

The Size drop-down list contains different paper sizes that are supported by your printer. Select the paper size that you want to use from this list.

Location

The Location drop-down list contains different trays in your printer. Select the tray that contains the paper you want to use.

Orientation

The Orientation section is used to select the orientation (landscape or portrait) for your output.
The Print Preview and Print Dialog Boxes (Microsoft Windows)

The Print Preview and Print dialog boxes contain the same series of options. The only difference is that the Print Preview dialog box outputs your model to the screen instead of to a printer. Items configured in one of these dialog boxes automatically appear in the other dialog box. Select File > Print Preview or File > Print to invoke the Print Preview and Print dialog boxes.

![Print Preview and Print dialog boxes](image)

The Print Preview and Print dialog boxes contain several printing options to consider when printing a SketchUp model.

**Printer**

The Printer section of the Print dialog box is used to select a specific printer and printer settings. Select the printer to use from the Name drop-down list. Click on the Properties button to configure the printer for printing (the properties dialog box is different for each printer-type).

**Tabbed Page Print Range**

The Tabbed Print Range section of the Print dialog box is used to choose between printing the model in the current Draw Area, or printing all models on all scenes in the file.

**Copies**

The Copies section of the Print dialog box is used to select the number of copies to print. Click the collate button if you want each copy to be collate (instead of printing several page ones, then several page twos, and so on).
The Print Size section of the Print dialog box is used to adjust the physical size of your output.

**Fit to Page**
The Fit to Page option is used to size the model to fit on a single sheet of paper. This option must be disabled to specify a different size or scale.

**Page Size**
The Page size fields are used to enter a custom page size for your output.

**Scale**
The Scale fields are used to scale your model for printing. The first measurement, labeled In the Model, is the measurement of the exported geometry. The second measurement, labeled In SketchUp, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1’, simply enter 1 inch In the Printout equals 4 feet In SketchUp.

**Note** - It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera > Standard submenu, to enable the scale option.

**Note** - Even though paraline projection is used to get an output that is to scale, not all angles will be measurable to a scale. This issue is the result of SketchUp using foreshortening, or a technique of shortening lines to create a 3D effect on a 2D medium such as paper.

**Use Model Extents**
The Use Model Extents option is used to print only the model as viewed using the Zoom Extents Tool. This option might discard any surrounding empty background.

**Tiled Sheet Print Range**
If the current Scale is larger than the paper size of your printer or plotter, the entire model can be printed by printing on several pieces of paper. These pieces of paper can then be taped together to create the final scaled model. For example, tiling lets you print proofs of a large model, such as a B size (11" x 17"), on a printer that uses a smaller paper size, such as an A size (8.5" x 11"). Tiling also lets you print banners that are made up of multiple pages.

Tiling is available when you use the Scale fields to scale a model to be larger than the current paper size available in your printer.

You can also print selected page tiles within the set by entering a page number range in the Pages from fields. Page tiles are numbered top to bottom beginning at the top left of the drawing page.

You can display a preview of tile Pages using Print Preview in the File menu.

Printing large tiled output can be taxing on your computers resources.
Print Quality

You can expedite the printing of print jobs and rough drafts by selecting the appropriate print quality.

**Draft**
The Draft setting is used to produce quick images (usually output has jagged lines).

**Standard**
The Standard setting is used to produce output with the optimum balance of speed and quality.

**High Definition**
The High Definition setting is used to produce high-quality output.

**Ultrahigh Definition**
The Ultrahigh Definition setting is used to produce the highest-quality output. This setting can slow down your system, but is best for measured drawings or ultra-fine prints.

**Large Format**
The Large Format setting produces images that are optimized for large format output or that are meant to be viewed from several feet away. Resolution and line weights are set accordingly. This setting is useful for plotters and tiled sheets.

**2D Section Slice Only**
The 2D Section Slice Only option is used to output only the section slice outlines in your model (if present).

**Use High Accuracy HLR**
The Use High Accuracy HLR option is used to send the model information to the printer as vector information.

= Functionality only available in Google SketchUp Pro 7
The Document Setup Dialog Box (Mac OS X)

The Document Setup dialog box is used to configure settings specific to the current SketchUp model. Use Document Setup to set the print size, print scale and to preview the number of pages required to print your drawing. Select File > Document Setup to invoke the Page Setup dialog box.

Print Size
The Print Size section of the Document Setup dialog box is used to determine the size of the page size for your output.

Fit View to Page
The Fit View to Page option is used to size the model to fit on a single sheet of paper. This option must be disabled in to specify a different size or scale.

Width/Height
The width and height fields are used to enter a custom page size for your output. If you define a size larger than the page size you selected in Page Setup, SketchUp will print your drawing on multiple pages (tiles) that you can affix together manually after printing.

SketchUp will calculate the number of pages required to print your drawing at that size automatically, and display it below.

Print Scale
The Scale section of the of the Page Setup dialog box is used to override any SketchUp-specific scale settings.

In Drawing/In Model
The In Drawing/In Model fields are used to scale your model for printing. The first measurement, labeled In the Model, is the measurement of the exported geometry. The second measurement, labeled In SketchUp, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1', simply enter 1 inch In Drawing equals 4 feet In Model.

Note - It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera > Standard submenu, to enable the scale option.

Note - Even though paraline projection is used to get an output that is to scale, not all angles will be measurable to a scale. This issue is the result of SketchUp using foreshortening, or a technique of shortening lines to create a 3D effect on a 2D medium such as paper.

Pages Required (Section Tiling)
If the current Scale is larger than the paper size of your printer or plotter, the entire model can be printed by printing on several pieces of paper. These pieces of paper can then be taped together to create the final scaled model. For example, tiling lets you print proofs of a large model, such as a B size (11" x 17"), on a printer that uses a smaller paper size, such as an A size (8.5" x 11"). Tiling also lets you print banners that are made up of multiple pages.

Tiling is available when you use the Scale fields to scale a model to be larger than the current paper size available in your printer.
You can display a preview of tile pages by clicking on the Preview button at the bottom of the Print dialog box.

= Functionality only available in Google SketchUp Pro 7
The Page Setup Dialog Box (Mac OS X)

The Page Setup dialog box is used to set paper size and orientation specific to your printer. This dialog box is the same as all standard Page Setup dialog boxes found in OS X applications. Select File > Page Setup to invoke the Page Setup dialog box.

Settings

The Settings drop-down list of the Page Setup dialog box contains a list of settings panels to appear in the Page Setup dialog box.

Page Attributes

The Page Attributes panel contains primary configuration settings for the Page Setup dialog box. Its settings are defined below in detail.

Custom Paper Size

The Custom Paper Size panel allows you to define custom paper sizes not currently configured for your selected printer.

Caution - You can define a paper size that your printer is not capable of using.

Summary

The Summary panel contains a summary of all current page attributes. You can use this panel to troubleshoot difficult print jobs, or to verify all the current page attributes in one quick view.

Format for

The Format For drop-down list of the Page Setup dialog box is used to select a specific printer and printer settings. Select the printer to use from the Name drop-down list.

Note - The Any Printer setting is a generic printer description that should set up a print job for any printer available. Use this setting if you are preparing a PDF file for printing on a printer that is not configured on your system.

Paper Size

The Paper Size section of the Page Setup dialog box is used to select the paper size used for your output.

Orientation

The Orientation section of the Page Setup dialog box is used to select the orientation (landscape or portrait) for your output.

Scale

The Scale section of the Page Setup dialog box is used to override any SketchUp-specific scale settings.
The Print Dialog Box (Mac OS X)

The Print dialog box is used to send your output to a printer, PDF file, or Fax. This dialog box is the same as all standard Print dialog boxes found in OS X applications. Select File > Print to invoke the Print dialog box.

The Settings drop-down list displays various settings panels within the Print dialog box. The settings drop-down list is in the middle of the Print dialog box and normally displays the Copies & Pages settings.

The Copies and Pages Print Dialog Box Panel

The Copies and Pages Print dialog box panel is used to control the number of copies and tiled output.

**Copies**

The Copies section of the Print dialog box is used to select the number of copies to print. Click the collate button if you want each copy to be collate (instead of printing several page ones, then several page twos, and so on).

**Pages**

The Pages section of the Print dialog box is used to print selected page tiles within a set of tiled Pages by entering a page number range in the Pages from fields. Page tiles are numbered top to bottom beginning at the top left of the drawing page.

The Layout Print Dialog Box Panel

The Layout Print dialog box panel is used to select the orientation (landscape or portrait) for your output.

The Scheduler Print Dialog Box Panel

The Scheduler Print dialog box panel is used to schedule the printing of your model for a later time.

The Paper Handling Print Dialog Box Panel

The Paper Handling Print dialog box panel is used to alternate between printing odd or even numbered pages.

The Color Sync Print Dialog Box Panel

The Color Sync Print dialog box panel is used to perform color conversion (if supported by your printer) and filters to your output.

The Paper Feed Print Dialog Box Panel

The Paper Feed Print dialog box panel is used to select the tray that contains the paper you want to use.
The SketchUp Print Dialog Box Panel

There are a few SketchUp-specific settings in the Print dialog box that you can access by selecting SketchUp from the settings drop-down list in the middle of the dialog box.

You can expedite the printing of print jobs and rough drafts by selecting the appropriate print quality.

**Draft**
The Draft setting is used to produces quick images (usually output has jagged lines).

**Standard**
The Standard setting is used to produce output with a the optimum balance of speed and quality.

**High Definition**
The High Definition setting is used to produce high-quality output.

**Ultrahigh Definition**
The Ultrahigh Definition setting is used to produce the highest-quality output. This setting can slow down your system, but is best for measured drawings or ultra-fine prints.

**Large Format**
The Large Format setting produces images that are optimized for large format output or that are meant to be viewed from several feet away. Resolution and line weights are set accordingly. This setting is useful for plotters and tiled sheets.

**2D Section Slice Only**
The 2D Section Slice Only option is used to output only the section slice outlines in your model (if present).

**Use High Accuracy HLR**
The Use High Accuracy HLR option is used to send the model information to the printer as vector information.

The Summary Print Dialog Box Panel

The Summary Print dialog box panel contains a summary of all current page attributes. You can use this panel to troubleshoot difficult print jobs, or to verify all the current page attributes in one quick view.
Welcome to the Dynamic Components Reference Guide

The Dynamic Components Reference Guide contains explanations of all reference material pertaining to dynamic components. The content in this guide answers the "What is the...feature" questions of end-users.
Dynamic Component Component Attributes Dialog Box

The Component Attributes dialog box is used to develop a dynamic component. This dialog box contains two tabs (Info and Functions), a configuration panel, and a few buttons.
Info Tab
Click on the Info tab to display information about the currently selected attribute at the top of the Component Attributes window.

Functions Tab
The Functions tab contains a drop-down list of functions. Select a function name to view a brief description of the function.

Refresh Button
Click the Refresh button to refresh values in the Component Attributes dialog box. You will usually use this button if you manipulated a component with a SketchUp tool while the Component Attributes dialog box is open.

Toggle Formula View Button
Click the Toggle formula button to toggle the display of formulas with the resulting values in the Component Attributes dialog box.
Dynamic Component Predefined Attributes

Following is a list of all predefined attributes for use in creating your dynamic components.

X, Y, Z

The X, Y, and Z attributes contain the value for the component's X (red), Y (green), or Z (blue) coordinate.

LenX, LenY, LenZ

The LenX, LenY, and LenZ attributes contain the length of the component in the X (red), Y (green), or Z (blue) direction.

RotX, RotY, RotZ

The RotX, RotY, and RotZ attributes contain the rotation about the X, Y, or Z axis, in degrees.

Hidden

The Hidden attribute contains either a 1 (TRUE) to hide the component or 0 (FALSE) to unhide the component.

Copies

The Copies attribute contains the number of copies of the component to be created by SketchUp. Every copy will be created at the exact X, Y, and Z coordinates of the original. The Copies attribute is usually used in conjunction with the Copy attribute.

Copy

The Copy attribute contains the copy number of a specific copy. So for example, if Copies is equal to 3, Copy can contain 0 through 3 (0 being the original). Copy is generally used within formulas (so it's more of a variable than an attribute) to refer to a specific copy (usually to position that copy to different X, Y, and Z coordinates). For example, you might have a formula that positions copies of pickets on a fence horizontally along the X axis. The formula for X would look like \(=5+\text{Copy} \times (\text{Fence!spacing}+\text{LenX})\)

If Fence!spacing for the picket is 4" and the width (LenX) of the picket is 2.5", this formula resolves to 5" for the X value of the original component (5+0*(4+2.5)). The formula resolves to 11.5 for the first copy (5+1*(4+2.5)), 18 for the second copy (5+2*(4+2.5)), and so on for each copy of the picket.

You can only see copies of a component in the Outliner (Window > Outliner), not in the Component Attributes dialog box. Therefore, you can never look at the attribute/value pairs for a copy.

Name

The Name attribute contains the name of the component as you would like it to appear in the Component Options dialog box.

Summary

The Summary attribute contains a brief, one sentence summary of the component for the Component Options dialog box.
Description
The Description attribute contains a longer description of the component for the Component Options dialog box.

Creator
The Creator attribute contains the name of the developer of the dynamic component.

ItemCode
The ItemCode attribute contains a manufacturer item code for the product represented by the dynamic component.

ImageURL
The ImageURL attribute contains a URL to a GIF, JPG, or PNG file on the Internet that you want to appear in the Component Options dialog box. For example, if ImageURL is equal to "http://mysite.com/myimage.gif", then myimage.gif image would appear, instead of the SketchUp-generated thumbnail, inside the Component Options dialog box.

DialogWidth
The DialogWidth attribute contains the width, in pixels, of the Component Options dialog box.

DialogHeight
The DialogHeight attribute contains the width, in pixels, of the Component Options dialog box.

onClick
The onClick attribute contains a simple script identifying how the component will react to being clicked (using the Interact Tool). For example, if the onClick attribute contained 'alert("Hello World");', an alert box would display when a user clicked on the component. Refer to onClick Functions for further information.

Material
The Material attribute contains the material to apply to the component. The material can be in several formats:

- A named color, such as "Blue" (See ruby api docs for complete list of colors).
- A hexadecimal string, such as "#FFF00" or "3399A0" (the # is optional).
- A three number list of RGB values (between 0 and 255). For example, 255, 128, 0.
- A material name that exists in the "in-model" material list. Your dynamic component needs to have a tiny swatch of the material you want displayed embedded somewhere on the component. The material also needs to have a custom name. For example, "0002_HotPink" won't work unless you rename it to be "0002_MyHotPink")

ScaleTool
The ScaleTool attribute allows you to toggle display of scale handles on the component (limiting how users can scale the component). Refer to Hiding Scale Handles for further information.
Dynamic Component Attribute and Formula Rules and Conventions

Attribute Rules and Conventions
Following is a list of rules for attributes:

• Attribute names cannot have spaces and must start with a letter.

Formula Rules and Conventions
Following is a list of rules for formulas:

• Text must always appear in quotes in a formula.

• You can concatenate a string with the value of an attribute by using the ampersand (&) sign. For example, to display a text string with a calculated value, an attribute's value might be:

  ="I am a table with the cost of" & <variable name>

• The number sign (#) indicates an error in your formula.

• Use the backslash character (\) to keep a quote inside of a text string. For example, to display a text string with quotes in the string, an attribute's value might be:

  ="This is the "\official\" retail price for this item:" & <variable name>

• Formulas that return numbers will return them as floating values, never as integers. So, the formula \text{if}(5=5,1,0) \text{ will return 1.0 instead of 1.}

• All lengths are in inches and angles in degrees.
Dynamic Component Supported Functions

Following is a list of all functions supported within your dynamic components. Many of these functions are identical to functions found in spreadsheet applications such as the spreadsheet application that is a part of Google Docs.

Math Functions
The following functions are for math-related use:

**ABS(number)**
The ABS function returns the absolute value of number.

**CEILING(number, significance)**
The CEILING function rounds a number to the nearest integer or multiple of significance. The significance argument is the value whose multiple of ten is the value to be rounded (.01, .1, 1, 10, etc.).

**DEGREES(number)**
The DEGREES function converts the number (in radians) to degrees.

**EVEN(number)**
The EVEN function rounds the number up to the nearest even integer.

**EXP(number)**
The EXP function returns e raised to the power of number.

**FLOOR(number, significance)**
The FLOOR function rounds the number down to the nearest multiple of significance.

**INT(number)**
The INT function rounds the number down to the nearest integer.

**ISEVEN(number)**
The ISEVEN function returns TRUE if the number is an even integer, or FALSE if the number is odd. If the number is not an integer, the function evaluates only the integer part of the number.

**ISODD(number)**
The ISODD function returns TRUE if the number is an odd integer, or FALSE if the number is even. If value is not a number, the function evaluates only the integer part of the number.

**LN(number)**
THE LN function returns the natural logarithm based on the constant e of the number.

**LOG10(number)**
The LOG10 function returns the base-10 logarithm of the number.

**ODD(number)**
The ODD function rounds the number up to the nearest odd integer.

**PI()**
The PI function returns the value of PI to fourteen decimal places.

**RADIANS(number)**
The RADIUS function converts the number (in degrees) to radians.
RAND()
The RAND function returns a random number between 0 and 1.

RANDBETWEEN(bottom, top)
The RANDBETWEEN function returns a whole number between the bottom and top number.

Example:
=RANDBETWEEN(1,3)
The previous example returns a 1, 2, 3.

ROUND(number, count)
The ROUND function rounds the number to a certain number of decimal places according to valid mathematical criteria. The count argument is optional and represents the number of the places to round the number. If the count argument is negative, only the whole number portion is rounded.

Example:
=ROUND(1.12789,2)
The previous example returns 1.13.

SIGN(number)
The SIGN function returns the sign of the number. The function returns the result 1 for a positive sign, -1 for a negative sign, and 0 for zero.

SQRT(number)
The SQRT function returns the positive square root of the number. The number must be positive.

SketchUp Functions
The following functions are specific to SketchUp dynamic components:

CHOOSE(index,value1,value2, ...valueN)
The CHOOSE function returns a value from a list of parameters at the location of the index value. This function allows you to create a single drop-down list that drives multiple attribute changes at once.

Example:
=CHOOSE(2,"Blue","Red","Green")
The previous example results in "Red."

Use CHOOSE and OPTIONINDEX together as a mechanism to assign different values depending on a user’s choice in the Component Options dialog box. For example, if the Component Options dialog box allows the user to choose different materials to assign to a component (and the price changes depending on material chosen), the formula for MSRP might be:

=CHOOSE (OPTIONINDEX("Material"), 100, 150, 200)
The previous example returns 100, 150, or 200 depending on the material chosen in the Component Options dialog box.
CURRENT("attributeName")
The CURRENT function accepts a string name of an attribute, and returns the size or position attribute that the SketchUp user just applied. This function allows you to do validation of Scale Tool or Move Tool actions.

Example:

=ROUND(CURRENT("LenX")/2)*2

The previous example, when entered into the LenX value field, constrains the component to the nearest width, within 2 inches, after scaling.

EDGES()
The EDGES function returns the number of "ungrouped" edges inside the component or group that this function is called within.

FACEAREA("materialName")
The FACEAREA method returns the area (in square inches) of every "ungrouped" face that is painted with the materialName. The FACEAREA method returns the total area of all ungrouped faces when the materialName is not provided.

Example:

=FACEAREA("Oak")

The previous example returns the square inches of Oak material inside the component or group.

FACES()
The FACES function returns the number of "ungrouped" faces inside the component or group that this function is called within.

LARGEST(value1,value2,...valueN)
The LARGEST function returns the largest of the values in a list.

Example:

=LARGEST(CURRENT("LenX"), 20, 10)

The previous example, when entered into the LenX value field, constrains the component so it cannot be scaled more than the largest of three numbers (either the value of LenX, 20, or 10).

LAT()
The LAT function returns the latitude of the current SketchUp model.

LNG()
The LNG function returns the longitude of the current SketchUp model.

NEAREST(originalValue, value1, value2, ...valueN)
The NEAREST function compares the originalValue with a list of target values, and returns the target value that is closest to the originalValue.

Example:

=NEAREST(CURRENT("LenX"),24,36,48)

The previous example, when entered into the LenX value field, will cause the component to snap to the nearest width of 24,36, or 48 after scaling.
**OPTIONINDEX("attributeName")**
The OPTIONINDEX function returns the currently selected index from its option list given a string name of an attribute. For example, if an attribute can be "red," "blue," or "green," and blue is the current value, this function returns 2. If no match is found, 0 is returned.

**OPTIONLABEL ("attributeName")**
The OPTIONLABEL function returns the currently selected label from its option list given a string name of an attribute. For example, if an attribute can be "Red=red", "Blue=blue", or "Green=green", and blue is the current value, this function returns "Blue". If no match is found, an error is raised.

**SMALLEST(value1,value2,...valueN)**
The SMALLEST function returns the smallest of the values in a list.

**Example:**

```
=SMALLEST(CURRENT("LenX"),20,10)
```

The previous example, when entered into the LenX value field, constrains the component so it cannot be scaled less than the smallest number (the value of LenX, 20, or 10).

**SUNANGLE()**
The SUNANGLE function returns the angle (in degrees) between the sun and the current model's North direction.

**SUNELEVATION()**
The SUNELEVATION function returns the elevation (in degrees) of the sun from the current model's shadow settings. The elevation is defined as the angle between a vector pointing at the sun and the ground plane.

**Text Functions**

**CHAR(number)**
The CHAR function converts a number into a character according to the current code table. The number argument can be a two-digit or three-digit integer number between 1 and 255 (representing the code value for the character).

**CODE(text)**
The CODE function returns a numeric code for the first character in a text string. The text argument is the text for which the code of the first character is to be found.

**CONCATENATE(text1, text2, ...textN)**
The CONCATENATE function combines several text strings into one string. The text1, text2, ...textN arguments are text strings that are combined into one string.

**DOLLAR(value, decimals)**
The DOLLAR function converts a number to an amount in the currency format, rounded to a specified decimal place. The value argument is the number to be converted to currency. The value argument can be a number, a reference to a cell containing a number, or a formula which returns a number. The decimals (optional) argument is the number of decimal places. If no decimals value is specified, all numbers in the currency format will be displayed with two decimal places. The currency format is set in the system settings.

**EXACT(text1, text2)**
The EXACT function compares two text strings and returns TRUE if they are identical. This function is case-sensitive. The text 1 and text 2 arguments are the text strings.
**FIND(findText, text, position)**
The FIND function looks for a string of text within another string. The findText argument is the text to be found. The text argument is the text string to be searched. The position (optional) argument is the position in text where the search starts. The findText argument can be a number or any string of characters. The search is case-sensitive.

**LEFT(text, number)**
The LEFT function returns the first character (or characters) in a text string. The text argument is the text string. The number (optional) argument is the number of characters to be returned. One character is returned if the number is not defined.

**LEN(text)**
The LEN function returns the length of a text string including spaces. The text argument is the string whose length is returned.

**LOWER(text)**
The LOWER function converts all uppercase letters in a text string to lowercase. The text argument is the string to be converted.

**MID(text, start, number)**
The MID function returns a text segment of a text string. The text argument is the text string. The start argument contains the position of the first character in the text to extract. The number argument is the number of characters to return.

**PROPER(text)**
The PROPER function capitalizes the first letter in all words of the provided text string.

**REPLACE(text, position, length, new)**
The REPLACE function replaces part of a text string with a different text string. The text argument is the text string containing the section to be replaced. The position function is the position within the text where the replacement will begin. The length argument is the number of characters in the text to be replaced. The new argument is the replacement text.

This function can be used to replace both characters and numbers (which are automatically converted to text). The result of the function is always displayed as text. To perform further calculations with a number which has been replaced by text, convert it back to a number using the VALUE function. Any text containing numbers must be enclosed in quotation marks so it is not interpreted as a number and automatically converted to text.

**REPT(text, number)**
The REPT function repeats a text string. The text argument is the text to be repeated. The number argument is the number of repetitions. The result can be a maximum of 255 characters.

**RIGHT(text, number)**
The RIGHT function returns the last character or characters in a text string. The text argument is the text string. The number (optional) argument is the number of characters to be returned.

**SUBSTITUTE(text, searchText, newText, occurrence)**
The SUBSTITUTE function substitutes new text for old text in a string. The text is the old text string. The searchText argument is the segment in text to be replaced. The newText argument is the replacement text. The occurrence (optional) argument indicates the number of occurrences of searchText to be replaced. If the occurrence is missing, the search text is replaced throughout.
**TRIM(text)**
The TRIM function removes spaces in front of a text string or aligns cell contents to the left. The argument contains text string or cell whose contents will be left-aligned.

**UPPER(text)**
The UPPER function converts a text string to uppercase. The text argument contains the lower case letters you want to convert to upper case.

**VALUE(text)**
The VALUE function converts a text string into a number. The text argument is the text to be converted to a number.

### Trig Functions

**ACOS(number)**
The ACOS function returns the inverse cosine of the number in degrees.

**ACOSH(number)**
The ACOSH function returns the inverse hyperbolic cosine of the number in degrees.

**ASIN(number)**
The ASIN function returns the inverse sine of the number in degrees.

**ASINH(number)**
Returns the inverse hyperbolic sine of the number in degrees.

**ATAN(number)**
The ATAN function returns the inverse tangent of the number in degrees.

**ATANH(number)**
The ATANH function returns the inverse hyperbolic tangent of the number in degrees.

**COS(number)**
The COS function returns the cosine of the number in degrees.

**COSH(number)**
The COSH function returns the hyperbolic cosine of the number in degrees.

**SIN(number)**
The SIN function returns the sine of the number in degrees.

**SINH(number)**
The SINH function returns the hyperbolic sine of the number in degrees.

**TAN(number)**
The TAN function returns the tangent of the number in degrees.

**TANH(number)**
The TANH function returns the hyperbolic tangent of the number in degrees.

### Logical Functions

The following functions are for math-related use:

**AND(logicalValue1, logicalValue2, ...logicalValueN)**
The AND function returns TRUE if all arguments are TRUE. If any element is FALSE, this function returns the FALSE value. The logicalValue arguments are conditions to be checked. All conditions can be either TRUE or FALSE.
FALSE()
The FALSE function sets the logical value to FALSE. The FALSE function does not require any arguments.

IF(test, thenValue, elseValue)
The IF function identifies a logical test. The test argument is any value or expression that can be TRUE or FALSE. The thenValue (optional) is the value that is returned if the logical test is TRUE. The elseValue (optional) is the value that is returned if the logical test is FALSE.

Example:
=IF (5=5, 1, 0)
The previous example returns a 1 if the test (5=5) is TRUE. Otherwise, the function returns a 0.

NOT(logicalValue)
The NOT function reverses the logicalValue. The logicalValue argument is any value to be reversed.

OR(logicalValue1, logicalValue2, ...logicalValueN)
The OR function returns TRUE if at least one argument is TRUE. This function returns FALSE if all the arguments have the logical value FALSE. The logicalValue arguments are conditions to be checked. All conditions can be either TRUE or FALSE.

TRUE()
The TRUE function turns the logical value to TRUE. The TRUE() function does not require any arguments.

OnClick Functions

ALERT("message")
The ALERT function displays the value of the message in an alert box.

Example:
=ALERT("You Clicked Me!")
The previous example displays an alert box with the phrase "You Clicked Me!," when inside the ONCLICK attribute.

ANIMATE(attribute, state1, state2, ... stateN)
The ANIMATE function starts an animation that will change the value of the attribute to the next value in a list of parameters every half a second. For example, if the ONCLICK attribute contains ANIMATE("X",0,100), and the user clicks on the component, the component would animate the value of the "X" attribute between 0 and 100. A subsequent click would animate back to 0 from 100. If more than two animate states are passed, then the value will toggle between them in order. So, if the ONCLICK attribute equals ANIMATE("ROTZ",0, -130,10,100) the animation would go through each of the 4 values with each click.

This function animates with default easing. Easing is the speed of the animation (on a scale of 0 to 100, 0 being fastest). Easing is represented by two numbers. The first number (easein) identifies the speed at the start of the animation. The second number (easeout) identifies the speed at the end of the animation. Default easing is 0,100 (animation starts fast but slows down at the end).

ANIMATESLOW("attributeName", state1, state2, ... stateN)
The ANIMATESLOW function does the same thing as animate, but slower (one second).
**ANIMATEFAST(“attributeName”, state1, state2, ... stateN)**
The ANIMATEFAST function does the same thing as animate, but faster (a quarter of a second).

**ANIMATECUSTOM(“attributeName”, time, easein, easeout, state1, ...stateN)**
The ANIMATECUSTOM function does the same thing as animate, but with an arbitrary time with easing. Refer to the ANIMATE function for information about easing.

**GOTOSCENE(“sceneName”, time, easein, easeout)**
The GOTOSCENE function moves to a scene identified by a name or number. Refer to the ANIMATE function for information about easing.

**REDRAW()**
The REDRAW function redraws the component that contains this function.

**SET(“attributeName”, state1, state2, ...stateN)**
The SET function sets a given attribute to the next state in a list.
Dynamic Component Supported Operators

Following is a list of all operators supported in dynamic component formulas.

- + (add)
- - (subtract)
- * (multiply)
- / (divide)
- < (less than)
- > (greater than)
- <= (less than or equal to)
- >= (greater than or equal to)
- = (equal)
- () (parentheses)
- <> (not equal to)
Dynamic Components Supported HTML Tags

The following HTML tags are supported within a Dynamic Component's Description and Summary fields:

- `<a>`
- `<b>`
- `<i>`
- `<u>`
- `<strong>`
- `<em>`
- `<p>`
- `<br>`
- `<ol>`
- `<ul>`
- `<li>`
- `<font>`
Technical Info

This section of the documentation contains additional detailed information about various aspects of SketchUp.
Bug Splat (Microsoft Windows)

BugSplat (www.bugsplatsoftware.com) is a third-party software application that is integrated in SketchUp for Microsoft Windows 2000 and XP to help improve the quality of the product. BugSplat helps Google troubleshoot unrecoverable SketchUp errors or crashes. BugSplat provides a mechanism for Microsoft Windows users to send information about all crashes to Google for troubleshooting.

How Does it Work?

In the rare event that SketchUp crashes you will see a dialog, similar to Microsoft Window's crash report dialog. This dialog will give you the option to send us the information regarding the crash. Here is what is collected if you decide to send us the information:

- Your version of the SketchUp executable.
- Your language setting, such as English.
- A "stack trace" of the bug allowing us to see the exact line of code where SketchUp crashed.
- A list of SketchUp code dependencies.
- (optional) Your name and email address.
- (optional) A description of what you were doing before the crash.

Note - If you happen to look at the BugSplat Software website, you will see a security statement that is aimed at assuring clients of BugSplat - in this case Google – that the information on our crashes (e.g., how many we have, and so on) will be protected. The above information is all that we are collecting.
2D Vector File Formats

2D vector file formats have advantages over bitmap image export in that they produce drawings that are resolution independent and can be easily imported and modified in many other programs. These file formats are useful for creating a set of 2D construction documents, plotting a perspective in a large format, or for import into vector illustration software for further refinement.

EPS

Encapsulated PostScript format is based on PostScript, a graphics description language developed by Adobe as a standard way for graphics programs and print devices to communicate. EPS is widely used in the graphic design and publishing industries.

PDF

Adobe® Portable Document Format (PDF) is the open standard for worldwide electronic document distribution. PDF preserves all the fonts, formatting, graphics, and color of the source document, regardless of the application and platform used to create the document. Also, PDF files are compact and can be shared, viewed, navigated, and printed exactly as intended by anyone with free Adobe Acrobat® Reader® software.

⚠️ Caution - Some graphic features of SketchUp, including textures, shadows, smooth shading, backgrounds, and transparency, cannot be exported to PDF and EPS.

DWG (AutoCAD Drawing File)

DWG was created by AutoDesk as the file format for their AutoCAD program. There are many different versions of DWG, including DWG r12, r2000, and r2004.

DXF (Data Exchange File)

DXF is a 2D graphics file format supported by most all Macintosh and PC-based CAD applications. DXF was created by AutoDesk as the method for exchanging CAD data between their AutoCAD application and other CAD applications.

The Anatomy of an Epix File

The native file format of Piranesi is referred to as an Epix (Extended Pixel) file. In addition to storing the actual rendered image, Epix embed additional information from the original 3D model. This information allows Piranesi's paint tools to intelligently render the image. There are three "channels" of an Epix file:

RGB

The first, known as the RGB Channel, contains the color of each pixel. This is the same data typically stored in other raster image formats. (In fact, Epix files are readable in most image editors as TIFF files.)

Depth

The second, known as the Depth Channel, stores the distance of each pixel from the eye point. This information helps Piranesi understand the surface topology under the image and allows it to apply textures, scale objects, lock orientation, and many other capabilities dependant on the 3D surfaces of your model.
Material
The third, a Material Channel stores the material for each pixel. This lets you paint one part of your rendering loosely without having to worry about painting another by mistake.

In General, Piranesi expects a flat shaded, non-textured Epix file. Some of the rendering modes in SketchUp, such as Wireframe and Hidden Line, don't really work well for Piranesi, and are disabled during export in favor of shaded output.

Other features of SketchUp, such as edges and textures, are also different from that which Piranesi expects, yet may be desirable in many cases. While adding support for Epix files in SketchUp, we have tried to adhere to Piranesi's expectations whenever possible while retaining enough flexibility to accommodate the varying needs of different artists and renderers.
Codec Lists

SketchUp's animation export feature uses codecs (COmpressor/DECompressor) to create the appropriately sized video depending on your needs. Codecs differ in their intended use, compression method, and handling pictures and sound. If you plan to edit your video, you might want to choose a codec that provides higher quality at the expense of file size and compatibility. Conversely, if you plan to email your video or play it off a CD, you might want to select a codec that provides lower data rates at the expense of quality. Some codecs are also designed specifically for a certain device, such as a digital video camera.

You can also choose to create uncompressed video by not using a codec. However, a large uncompressed animation file might require a fast system and very large amounts of disk space.

Microsoft Windows Codecs

Following is an explanation of codecs that are included with SketchUp.

**Cinepak Codec by Radius**

This is the default codec for SketchUp. Although not as advanced as modern codecs, videos compressed using Cinepak will work reliably on any platform, play smoothly from CD-ROM, and will provide good file size compression. Cinepak is asymmetrical and lossy.

**Intel Indeo Video R3.2**

This codec was designed for video playback from CD-ROM discs. It is comparable in quality to the Cinepak codec, but Cinepak is preferable due to wider support.

**Microsoft Video 1**

This codec originally shipped with Video for Windows (Windows 3.1) and is low quality and rarely used today.

**Intel Indeo Video 4.5**

This is a lossy codec that provides good compatibility, speed, and flexibility with average image quality. Advanced features include a quick compression option, keyframe control, transparency, and the ability to adapt to the available bandwidth. (Access to some of these requires software available separately from Intel.)

**Intel Indeo Video 5.10**

This is a lossy codec that provides good compatibility, speed, and flexibility with average image quality. Advanced features include a quick compression option, keyframe control, transparency, and the ability to adapt to the available bandwidth. (Access to some of these requires software available separately from Intel.)

**Full Frames Uncompressed**

This option allows you to export your animation without any compression.

Mac OS X Codecs

**Animation**

This codec works well for images that use large areas of solid colors, and is great for SketchUp images that have no textures or background gradients. It is lossy, but a compression setting of 100% is lossless.

**Apple H.263**

H.263 is a QuickTime codec designed for video conferencing at low data rates and may not be suitable for general-purpose video.
Apple Pixlet Video

Apple VC H.263
This codec is a modified version of H.263 for iChat

Cinepak
This is the default codec for SketchUp. Although not as advanced as modern codecs, videos compressed using Cinepack will work reliably on any platform, play smoothly from CD-ROM, and will provide decent file size compression. Cinepak is asymmetrical and lossy.

Component video
This codec provides relatively little compression, which means files can get large. It's useful for archiving, or temporarily storing video.

DV - PAL
Used by PAL digital video hardware such as camcorders.

Graphics
This provides a high quality, 8-bit color image that can work well with SketchUp output. The compression ratio is low, however, which means that it might not be well suited to playback from CD-ROM or the web.

H.261
H.263 is a codec designed for video conferencing at low data rates and may not be suitable for general-purpose video. The H.263 requires half the bandwidth to achieve the same video quality as in the H.261.

JPEG 2000

Motion JPEG A and Motion JPEG B
These codecs are designed for many video-capture cards, which provide hardware acceleration for JPEG compression.

MPEG-4 Video
MPEG-4 is the new worldwide standard for interactive multimedia creation, delivery, and playback for the Internet. The MPEG-4 video codec is designed to provide the highest quality across a wide array of data rates over the Internet.

None
This option allows you to export your animation without any compression.

Photo - JPEG
The Photo JPEG codec is built into QuickTime and implements the Joint Photographic Experts Group ISO version 9R9 algorithm for image compression. This codec is generally used for storage of still images, but can also be used for editing and storage of high-quality video files.

Planar RGB
This is similar to the Animation codec in that it is effective for images that use large areas of solid colors.

PNG
The PNG codec implements the lossless PNG compression - decompression algorithm used by many Web browsers.
**Sorenson Video**
This is a very good codec for general video, and is great for playback from CD-ROM the web. It is similar to Cinepak, but provides better picture quality and smaller file sizes at the cost of lightly longer compression times. It also supports dynamic playback that automatically adjusts to available bandwidth and CPU resources.

**Sorenson Video 3**
Makes improvements over Sorenson Video in the form of higher quality video and better data compression.

**TGA**
The TGA codec implements the lossless TGA compression - decompression algorithm.

**TIFF**
The TIFF codec implements the lossless PNG compression - decompression algorithm.

**Video**
This provides high-quality playback from hard disk and moderate quality playback from CD-ROM. It supports both spatial and temporal compression of 16-bit video. Data can be recompressed or recompiled later for higher compression ratios with minimal or no quality degradation.
SketchUp and OpenGL

3D applications, such as SketchUp, require abundant system resources. Aside from having a fast CPU and large amounts of RAM, your video card and video card drivers must be 100% OpenGL compliant.

What is OpenGL?

OpenGL is the industry-standard, used in numerous software applications and games, to draw 3D geometry. Most Microsoft Windows and Apple OS X operating systems come with a software-based OpenGL driver. However, these drivers rely heavily on the CPU to perform the rendering calculations of OpenGL (a task that is not done efficiently by most CPUs).

Many video card manufacturers have also built cards that support the OpenGL standard. These cards perform the rendering calculations using a specialized chip called the Graphics Processing Unit or GPU (instead of relying on the CPU). These chips significantly enhance OpenGL performance upward of 3000 percent. This performance enhancement is known as Hardware Acceleration.

Hardware Acceleration

SketchUp will can take advantage of hardware acceleration if your computer has a 100% OpenGL compatible video card.

**Tip** - If the Use Hardware Acceleration option is not available in SketchUp, verify that the control panel settings for your video card's device driver has hardware acceleration enabled (Microsoft Windows).

Unfortunately, only some 3D drivers in the consumer video card market are 100% OpenGL compatible and can use this feature (though many cards claim to be 100% OpenGL compatible). Most 3d drivers are designed for games, and are often not tested using other 3D programs. Consequently, incompatibility problems can occur requiring a fix from the video card manufacturer. Disable this option if you are having problems with the 3D rendering of your models or if your video card is not 100% OpenGL compatible and does not support hardware acceleration.

**Note** - Hardware Acceleration might only be available on your system for certain resolutions and color depths. Check the system settings for your video card to see if it supports hardware acceleration (using the Control Panel on Microsoft Windows or System Preferences on Macintosh OS X).

**Note** - Google strongly recommends that you set your display colors to a 32-bit color depth (using Control panel > Display Properties) to assure that your SketchUp model will render accurately when using hardware acceleration (Microsoft Windows).

Google cannot control the quality of the OpenGL driver on your computer system. Video card device drivers are proprietary and are maintained solely by the manufacturer of the video card in your system. Therefore, Google cannot guarantee that SketchUp will work with hardware acceleration on your system.
Compatibility Issues

OpenGL incompatibility is a significant system configuration issue leading to problems with SketchUp. Difficulties with SketchUp tools, performance, and rendering (such as mysterious graphics appearing on your screen) are usually the result of a video card not fully supporting OpenGL (despite claims by the manufacturer), an out-of-date video card driver, or incompatibility with 32-bit color depth. A temporary solution is to disable hardware acceleration in SketchUp while troubleshooting the problem.

Consult the Video Card Compatibility section of the Readme file (in the SketchUp installation directory) for additional details regarding compatibility issues for specific video cards.
**Raster File Formats**

Raster images are made up of individual square colored pixels that, when combined, form some image. SketchUp supports several different raster image formats, each of which has its own particular advantages and should be selected depending on the task you want to perform.

**JPEG (Joint Photographic Experts Group)**

JPEG image files enjoy wide support across many applications, computer platforms, and digital cameras. The most prominent feature of JPEG is its compression scheme, which can reduce file size to a fraction of other formats. This compression scheme makes the JPEG format particularly useful for sending images, such as digital photographs, using email or for viewing on the world wide web.

*Tip* - Consider using JPEG if your image contains lots of textured areas or fine detail.

JPEG compression works so well because it analyzes an image, divides it into blocks, and then discards the information which the human eye does not readily perceive. However, this high-level of compression yields a lower image quality and therefore, sometimes resulting in blocky patterns of color referred to as *artifacts*. JPEG images are referred to as *lossy* because data is actually lost during the compression process and an uncompressed JPEG file will never be identical to the original file.

The previous image shows the artifacts resulting from JPEG compression (in the right-most portion of the image).

Fortunately, you can adjust the amount of JPEG compression to suit your needs using the File > Export > 2D Graphic Options > Image Quality slider bar.

*Tip* - Resaving a JPEG image multiple times can result in compounded artifacts. Work with original raster images in a non-lossy format, such as PNG, before saving to JPEG for final output.

**PNG (Portable Network Graphics)**

The PNG format was developed for transferring images efficiently over the world wide web without data loss. Like JPEG, PNG does use compression, but it is a non-lossy variety that is free from artifacts.
Tip - Consider using PNG for models that have large areas of solid, uniform, colors (such as non-textured SketchUp models).

TIFF (Tagged Image File Format)

The TIFF file format is often used to exchanged files between applications and computer platforms (Mac and Personal Computers). There are a large number of variations to the TIFF format available, and therefore TIFF might not be as universally accessible as other formats such as PNG and JPEG. SketchUp supports as wide a range of TIFF formats as possible, and you should test compatibility with other applications before exporting to TIFF file. 1-bit raster files, or TIFF files with gif encoding, are not compatible with SketchUp.

Also, while formats such as PNG and JPEG are viewable by any web browser and can therefore be sent to virtually any other person with good chance of success, TIFF files may require additional software to be viewed on some systems. TIFF is primarily used for high-resolution printing from desktop publishing applications.

Note - SketchUp does not support TIFF files at 1 bit per pixel. Images compressed using RLE will expand to uncompressed sizes once imported into SketchUp.

BMP (Bitmap)

The BMP file format was created for Microsoft Windows operating systems primarily as the format used for the Microsoft Windows clipboard and for viewing (especially as wallpaper). BMP does not use compression. Therefore, BMP can be useful for creating temporary files to be further modified in other applications. However, BMP tends to create very large files that are not suitable for archive, web, and email use.

Epix

Epix is the native format of Piranesi which is an architectural painting application designed to work with images generated from 3D models. See Piranesi Epix Export for more information.
SketchUp Ruby API and Console

SketchUp contains a Ruby application programming interface (API) for users who are familiar with (or want to learn) Ruby scripting and want to extend the functionality of SketchUp. This interface allows users to create tools, menu items, and other macros, such as automated component generators, to be included in the menus within SketchUp. In addition to the API, SketchUp also includes a Ruby console which is an environment where you can experiment with Ruby commands or methods.

For additional information on the Ruby programming language, visit www.rubycentral.com.

Click on "Help" > "Ruby Help" for additional information on SketchUp Ruby API.

Currently, Google does not offer technical support for the Ruby Application Programmers Interface (API) or for any Ruby scripts created by third parties. We encourage posting Ruby API questions to our SketchUp Ruby API Forum. General Ruby information may be obtained at http://www.ruby-lang.org/en/.

Google reserves the right to change this policy at any time.
Glossary

A

Angular Rotation Value - The value in the Measurements Toolbar that is displayed when measuring an angle with the Protractor Tool.

Autofold - The process of skewing, distorting, or folding geometry by selecting a specific point on an edge or face and moving the points. See also Sticky.

Axonometric - Meaning "measurable from the axes." An axonometric projection is a view of a model in which lines appear parallel in both 3 dimensional and 2 dimensional space, and lines have a length that is to some scale, (for example 1? in SketchUp = 1? in the real world).

B

CAD - See Computer Assisted Design

Camera - A software implementation of the user's point of view. See also Point of View.

Camera Angle - See Point of View.

Camera Tool - A software tool used to alter the user's point of view of a SketchUp model.

Chord Length - The distance between the starting point and the ending point of an Arc entity.

Component entity - An entity that contains other entities. Components are models that are saved as SketchUp files for reuse in other SketchUp files.

Components Browser - The Components Browser is used to instance Component entities from component definitions, including those components that you create and a variety of pre-built Components that you can use in your models.

Component Definition - The blueprint that defines the appearance and behavior of all component instances. Component definitions are created and stored in the Components Browser either as part of a component collection or when you create a component.

Component Instance - An instance of a component definition, such as an a single instance of an office chair component. You can have multiple component instances from the same component definition.

Component Collection - A series of related component definitions, such as a component collection of doors or windows.

Computer Aided Design - Software used for precision design. CAD is traditionally rigid and is often used for creating construction documents from which you would create the actual item you are designing.

Guide Tools - Tools used to create construction geometry and prepare physical documentation.

Context - An isolated realm that separates geometry within from anything outside. When you start a SketchUp model you are working within the model context. When you make a Group or Component you are essentially creating other contexts inside of the model context. When you edit groups or components you are in the group or component context. Certain commands or operations, such as the Unhide All command, scaling using the Measure Tool,
and placing active Section Planes, are limited to a particular context. Additionally, when you create and select other entities, you are essentially in the entity’s context.

Context Menu - A menu of menu items or commands available in a particular context, such as when a line or component is selected.

Cutting Behavior - The ability of component entities to cut holes in faces. The component’s cutting behavior is established when the component is initially created.

Cutting Plane - A plane defining the exact location where the component will cut into a face.

Coplanar - Refers to entities that existing in the same plane.

Curved Face Set - A series of faces joined to make up a curved surface, such as a tube or arch.

D

Dialog Stack - Dialog boxes arranged such that they form a stack.

Distort - Twisting out of natural shape.

Drawing Area - The area within the Drawing Window where you create your model. See also Drawing Window.

Default Material - A material assigned to all newly created faces. The default material is different for the front and back of faces.

Drawing Tool - A software tool used to create entities and geometry from scratch.

Drawing Window - The entire application window for SketchUp. The Drawing Window contains menus, Toolbars, the status bar, and the Drawing Area. See also drawing area.

E

Edge-Based Modeling - A form of modeling in which a surface is automatically created for 3 intersecting coplanar edges.

Edge entity - Edges bound faces within geometry. The term edge and line are used interchangeably.

Entity - The smallest graphical building blocks in SketchUp. Entities are used to create geometry which, in turn, is used to create models.

Extrude - The action of thrusting out or growing a form.

Extrusion - A form that has been extruded. See Extrude.

F

Functional Terrain - Terrain that has no portion of itself bending back upon itself creating overhangs, underhangs or caves.

Face entity - A planer entity bounded by 3 or more intersecting coplanar edges or lines.

Face Shadows - Shadows projected onto horizontal faces by vertical faces based on the sun's angle in the sky.

G

Geometry - The combination of 3 or more entities. Geometry in SketchUp usually refers to a indistinguishable portion of a component or model.
Ground Plane - A flat or level surface representing the ground. In SketchUp, the ground plane is represented by the exact location of the red and green axes.

Group entity - An entity that contains other entities. Groups are commonly used to combine several entities into a single entity for the purposes of performing a quick operation, such as a copy and paste.

Gluing Behavior - The ability of component entities to align to faces in a specific orientation. The component's gluing behavior is established when the component is initially created.

Ground Shadows - Shadows projected onto the ground plane by vertical faces based on the sun's angle in the sky.

Healing - The concept of joining two faces by erasing, or "healing" a line that intersects a face. Creating one face from two.

Inference - The identification of relationships between entities in the drawing area. These relationships are identified and pointed out to the user by the inferencing engine and can be used as references for drawing in 3D space.

Inference Engine - Functionality built into SketchUp to locate or infer points from other points in your model, such as the center of a circle, the midpoint of a line, a line that is perpendicular to the ground plane, a point on a face, a point on an edge, and so on. The Inference Engine notifies you of these points by using both color indicators and on-screen messages indicating the location of the cursor as you draw an entity. For example, SketchUp displays the string **From Point?** when the line you are drawing is in plane with another point.

Insertion Point - The point where the cursor will grab and insert the component into a model from the Components Browser.

Instance - see Component Instance.

Intersection - The concept of splitting faces and edges to create additional independent faces and edges by intersecting the face or edge with a line.

Layer - Layers are used to control the visibility of geometry within large models. A SketchUp layer is an attribute with a name, such as "Layer0," "Layer9," or "Chairs." Elements can be assigned different layers.

Layers Manager - A dialog box used to apply and manage layers in your model

Manager - A dialog box used to store and manipulate a specific aspect of SketchUp functionality such as scenes, components, or materials.
Material - Software-simulated paints that have both color and texture attributes. For example, a brick material might contain the color of red and a rough appearance or texture similar to real brick.

Modal Dialog Box - A dialog box that temporarily prohibits the user's interaction with the application. Modal dialog boxes usually require the user to perform some action prior to returning to normal application use.

Model - The contents of a SketchUp file. See also component.

Modification Tool - A software tool used to modify existing entities or geometry.

Modeless Dialog Box - A dialog box that does not prohibit the user's interaction with the application. See also Modal Dialog Box.

Move Point - The point where you click on the entity with the Move Tool.

One-Point Perspective - In central perspective or one point perspective there is only one vanishing point (vp), which is located straight in front of the viewer: it is the vanishing point for the direction of view. This is not determined by our view, but the flat faces and tunnel walls of all objects within view. All lines drawn in the blue axes are exactly perpendicular to the ground plane and all of the lines drawn in the red and green axes are exactly perpendicular to the blue axes when viewing a 2 or 3 dimensional drawing viewed in one point perspective.

Origin - The point where the Drawing Axes start or originate.

Organic Shape - Geometry or models that have a hand-made or custom appearance.

Pan - A camera movement in which the camera turns side to side.

Paraline - See Axonometric.

Perspective - A distortion of the Camera Angle such that it represents the model as though you were standing at a fixed position and looking at it without moving (certain items appear closer while other items appear to be far away; entities are not to scale).

Plane - A flat or level surface.

Point of View - The user's view of the model.

Polygon Mesh - A surface comprised of polygons, each derived from irregularly spaced points.

POV - see Point of View.

Principal Tools - Tools that tend to be used most often in SketchUp.

Pulling - The process of reshaping your model by shrinking a portion of your model back toward its starting point along a single axis.

Pushing - The process of reshaping a your model by expanding a portion away from its starting point and along a single axis.
Ruby Console - Ruby console which is an environment where you can experiment with Ruby commands or methods.

Ruby Script - A small program, written in the Ruby programming language, that adds functionality to SketchUp.

Ruby Console - Ruby console which is an environment where you can experiment with Ruby commands or methods.

Ruby Programming Language - An object oriented scripting language.

S

Sandbox - Surfaces created with the Sandbox from Scratch and Sandbox from Contours are referred to as sandboxes because like sand in a sandbox, these surfaces can be sculpted using a special set of tools called sandbox tools. Other terms for sandbox are terrain or Triangulated Irregular Network.

Scene - Similar to a slide in presentation software, a scene consists of your model and a series of scene-specific settings, such as a specific point of view, shadow, display setting, and section cut. Scene can be combined to form animations in SketchUp.

Score - A thin slice allowing for folding.

Section Cut Effect - The result of slicing through your model to see inside and optionally modify its inner working.

Section Plane - Special entities that are used to control the selection, placement, orientation, direction, of the section slice.

Section Slice - The edges created by the intersection of geometry at a section plane.

Segment - A segment is a single line that, when combined, form an arc, circle, or polygon. The more segments an entity has, the smoother it appears.

Skew - To place at an angle.

Split - The concept of creating two faces from one by dividing the face with a line.

Stickiness - Entities are said to be "sticky" in that when connected to another entity, moving one entity might move or alter the another, attached, entity. See also Autofold.

Surface - A series of joined faces.

T

Three-Point Perspective - in three-point perspective there are three vanishing points (vp), allowing you to construct a form in any orientation. Three-point perspective is usually used to represent three dimensions in a three-dimensional medium such as SketchUp.

Tilt - A camera movement in which the camera tilts up or down.

TIN - See Triangulated Irregular Network.

Triangulated Irregular Network - A surface comprised of triangles, each derived from irregularly spaced points. This surface is also referred to as a Sandbox and Mesh.

Triangulation - The orientation of triangles in a TIN (horizontal or vertical). See also Triangulated Irregular Network.
Two-Point Perspective - In two-point perspective there are two vanishing points (vp), which are located to the left and right of the viewer. Two-point perspective is usually used to represent three dimensions on a two-dimensional medium. All lines drawn in the blue axes are exactly perpendicular to the ground plane when viewing a 3 dimensional drawing viewed in 2 point perspective.

U

V

Measurements Toolbar - The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate the selected entity.

W

Walkthrough Tools - Tools used to view your model as through walking around and in your model

X

X-Ray Mode - A display setting whereby all faces have an applied global transparency. X-Ray mode is useful for seeing, and sometimes editing, the inner workings of your model

Y

Z